Subject: strace project

From: "David S. Miller" <[email-masked]>
Date: Mon, 17 Jun 1996 13:51:07 -0700

I'm just curious how strace support for IRIX 6.2 is coming along?

It would be _extremely_ useful and make me _extremely_ happy to have
so that I can write all of the IRIX system call compatability code
when I return from my talks in the U.K. on Thursday.

Later,
David S. Miller
[email-masked]

---

From: [email-masked] (William J. Earl)
Date: Mon, 17 Jun 1996 13:58:02 -0700

> when I return from my talks in the U.K. on Thursday.

       If by strace you mean tracing system call arguments and results,
try using par(1).  (It does not help if you want to decode argument structures,
however.)  Here is a sample:

<fir:5> par -s -SS date
Mon Jun 17 13:56:39 PDT 1996
    0mS was sent signal SIGUSR1
    0mS END-pause() errno = 4 (Interrupted system call)
    0mS received signal SIGUSR1
    0mS sigreturn(0x7fff2a00) OK
    1mS execve(/usr/bsd/date, 0x7fff2ea8, 0x7fff2eb0) errno = 2 (No such file or directory)
    1mS execve(/usr/new/date, 0x7fff2ea8, 0x7fff2eb0) errno = 2 (No such file or directory)
    1mS execve(/usr/people/wje/abi-bin/date, 0x7fff2ea8, 0x7fff2eb0) errno = 2 (No such file or directory)
    2mS execve(/usr/people/wje/irix-bin/date, 0x7fff2ea8, 0x7fff2eb0) errno = 2 (No such file or directory)
    2mS execve(/usr/bin/date, 0x7fff2ea8, 0x7fff2eb0) OK
   74mS open(/lib/rld, O_RDONLY, 04) = 3
   74mS read(3, <7f 45 4c 46 01 02 01 00 00 00 00 00 00 00 00 00>..., 52) = 52
   74mS lseek(3, 52, SEEK_SET) = 52
   74mS read(3, <70 00 00 00 00 00 00 a0 0f b6 00 a0 0f b6 00 a0>..., 96) = 96
   74mS elfmap(3, 0x7fff21bc, 2) = 0xfb60000
   75mS close(3) OK
   76mS getpagesize() = 4096
   77mS getpid() = 10390 ppid=10389
   78mS syssgi(SGI_TOSSTSAVE) OK
   78mS getpagesize() = 4096
   78mS brk(0x10002000) OK
   80mS time() = 835044999
   80mS ioctl(1, TCGETA, 0x7fff2cd8) = 0
   81mS write(1, "Mon Jun 17 13:56:39 PDT 1996\n", 29) = 29
   81mS prctl(PR_GETNSHARE) = 0
   81mS exit(0)
exit             : 1 times
read             : 2 times
write            : 1 times
open             : 1 times
close            : 1 times
time             : 1 times
brk              : 1 times
lseek            : 1 times
getpid           : 1 times
syssgi           : 2 times
ioctl            : 1 times
sysmp            : 2 times
execve           : 5 times
sigreturn        : 1 times
prctl            : 1 times