Subject: Re: EFS and XFS file systems support

From: Mike Shaver <[email-masked]>
Date: Tue, 15 Apr 1997 16:26:29 -0400 (EDT)

Thus spake Larry McVoy:
> At this point, since we are moving away from EFS, it is possible
> that we would be willing to donate a version of the EFS code to
> Linux.  I can probably get that cleared.  But someone else would
> have to do the port, I'm too busy.  If you find someone to do the
> port, let me know.

Assuming it's all cleared with everyone, and we get a source
repository somewhere to play with, I might give it a shot.  Does
anyone know if the efslook stuff is GPL'd?

Mike

-- 
#> Mike Shaver ([email-masked]) Ingenia Communications Corporation 
#>                 Ignore the man behind the curtain.                  
#>                                                                     
#> "And then I realized that it never should have worked in the first  
#>  place.  Thus, it would not work again until rewritten." --- Anon.

---

From: [email-masked] (Larry McVoy)
Date: Tue, 15 Apr 1997 14:09:27 -0700

At this point, since we are moving away from EFS, it is possible that we would 
be willing to donate a version of the EFS code to Linux.  I can probably get 
that cleared.  But someone else would have to do the port, I'm too busy.
If you find someone to do the port, let me know.

: On Apr 14,  1:47pm, Larry McVoy wrote:
: > Subject: Re: EFS and XFS file systems support
: > : I thought that there was a program available for Linux that would read EFS
: > : file systems, although I can't for the life of me remember the name.
: >
: > Nope.
: >
: > : >My biggest reason for wanting them supported is to access SGI CD ROMs.
: > :
: > : I think the better question is when will we start distributing CDs in a
: > : standard format...  Yeah, yeah, backward compatibility, I know ;->
: >
: > I agree with Steve.  Switch to iso9660.
: >-- End of excerpt from Larry McVoy
: 
: 
: Hey, I'd love to switch to iso9660.  Unfortunately, how do we read all
: the CDs that have already been generated?  For example all the free
: source code that has been generated on the Developer's Toolbox and
: stuff.  Also, after a linux kernel has been booted, it would be nice
: to mount SGI file systems.
: 
: -- 
: 
: 		Chris Carlson
: 
: 	+------------------------------------------------------+
: 	| Also, [email-masked]                                |
: 	|   Work:       (714) 756-5976     SGI vmail: 678-4530 |
: 	|   FAX:        (714) 833-9503                         |
: 	|                                                      |
: 	| Trivia fact: an electroencephalogram shows that a    |
: 	| human brain and a bowl of quivering lime Jell-O have |
: 	| the same waves.  [Time Magazine, Mar 17, 1997]       |
: 	+------------------------------------------------------+

---

From: "Christopher W. Carlson" <[email-masked]>
Date: Tue, 15 Apr 1997 14:11:22 -0700

On Apr 15,  2:09pm, Larry McVoy wrote:
> Subject: Re: EFS and XFS file systems support
>-- End of excerpt from Larry McVoy

If you can get it cleared, I'll do the port.

Initially, I'll port it to my system at home and create an EFS
filesystem on a Zip drive and see if I can read it here in the office.

If that all works, then I'll pass my source to one of the other guys
who actually has a linux SGI box.

-- 

		Chris Carlson

	+------------------------------------------------------+
	| Also, [email-masked]                                |
	|   Work:       (714) 756-5976     SGI vmail: 678-4530 |
	|   FAX:        (714) 833-9503                         |
	|                                                      |
	| Trivia fact: an electroencephalogram shows that a    |
	| human brain and a bowl of quivering lime Jell-O have |
	| the same waves.  [Time Magazine, Mar 17, 1997]       |
	+------------------------------------------------------+