Subject: The Indy has landed...

From: Mike Shaver <[email-masked]>
Date: Thu, 3 Apr 1997 11:12:26 -0500 (EST)

[shaver@neon shaver]$ telnet bogomips
Trying 205.207.220.72...
Connected to bogomips.ingenia.com.
Escape character is '^]'.

IRIX (bogomips.ingenia.com)

login: root
Password:
IRIX Release 6.2 IP22 bogomips
Copyright 1987-1996 Silicon Graphics, Inc. All Rights Reserved.
Last login: Thu Apr  3 07:18:17 PST 1997 on :0
bogomips 1# w
  8:07am  up 50 mins,  2 users,  load average: 0.38, 0.25, 0.10
User     tty from            login@   idle   JCPU   PCPU  what
demos    q0  :0.0            8:02am      4                -csh
root     q1  205.207.220.57  8:06am                       w
bogomips 2# 

It would seem, ladies and gentlemen, that we're off to the races!
After the conference sessions tonight I'll see about setting up the
tftpboot stuff.  (Tips welcome!)

Mike

-- 
#> Mike Shaver ([email-masked]) Ingenia Communications Corporation 
#> Paranoid for money.                            Sarcastic for kicks. 
#>                                                                     
#> "They already *KNOW* I am a whacko, Karen.                          
#>                  That doesn't mean I am *WRONG*." -- [email-masked]

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 3 Apr 1997 20:10:35 +0200 (MET DST)

Hi,

> IRIX (bogomips.ingenia.com)

(Hope this is R4600 - otherwise BogoMIPS won't be too impressive ...)

> tftpboot stuff.  (Tips welcome!)

Assuming you're using a Linux box as TFTP Server here are old versions of
my config files.  Iff(OS != Linux) while(1){swear();rtfm(damn);swear()} ;-)

--- /etc/bootptab ------------------------------------------------------------

# /etc/net/bootptab: database for bootp server (/usr/net/in.bootpd)
# Last update Mon 11/7/88 18:03
# Blank lines and lines beginning with '#' are ignored.
#
# Legend:
#
#	first field -- hostname
#			(may be full domain name and probably should be)
#
#	hd -- home directory
#	bf -- bootfile
#	cs -- cookie servers
#	ds -- domain name servers
#	gw -- gateways
#	ha -- hardware address
#	ht -- hardware type
#	im -- impress servers
#	ip -- host IP address
#	lg -- log servers
#	lp -- LPR servers
#	ns -- IEN-116 name servers
#	rl -- resource location protocol servers
#	sm -- subnet mask
#	tc -- template host (points to similar host entry)
#	to -- time offset (seconds)
#	ts -- time servers
#
# Be careful about including backslashes where they're needed.  Weird (bad)
# things can happen when a backslash is omitted where one is intended.
#

# First, define a global entry which specifies the stuff every host uses.
# NOTE: THE VALUES BELOW ARE MEANT AS AN EXAMPLE!
#allhost:hd=/tmp:bf=null:\
#	:ds=145.71.35.1 145.71.32.1:\
#	:sm=255.255.254.0:\
#	:gw=145.71.35.1:\
#	:ts=145.71.35.1:\
#	:lp=145.71.35.1:\
#	:to=-7200:

# Define all individual entries.
#hostname:ht=1:ha=ether_addr_in_hex:ip=ip_addr_in_dec:tc=allhost:

#
#
#
.diskless:bf=null:\
	:sm=255.255.255.0:\
	:to=7200:

mipsy:hd=/tftpboot/193.98.169.17/:\
	:rp=/tftpboot/193.98.169.17/:\
	:ht=ethernet:\
	:ha=004095e11dc2:\
	:ip=193.98.169.17:\
	:tc=.diskless:

#mipsy:hd=/tftpboot/194.121.228.22/:\
#	:rp=/tftpboot/194.121.228.22/:\
#	:ht=ethernet:\
#	:ha=004095e11dc2:\
#	:ip=194.121.228.22:\
#	:tc=.diskless:

-- snipet from /etc/inetd.conf -----------------------------------------------

bootps dgram   udp     wait    root    /usr/sbin/tcpd  /usr/sbin/in.bootpd

(My bootpd (probably from Slackware 2.0 or 3.0) had to be replaced; it
wasn't working at all ...)

------------------------------------------------------------------------------

/tftpboot/193.98.169.17/ is Mipsy's NFS root, 004095e11dc2 it's 48 bit
Ethernet hardware address.  Note that the kernel makes some assumptions
about where the NFS root is on the server (/tftpboot/<ip>); if you
change that you need to pass some kernel options.  My setup is such
that I don't need to pass any options at all.

Does that help?

  Ralf

---

From: Mike Shaver <[email-masked]>
Date: Thu, 3 Apr 1997 19:23:08 -0500 (EST)

> (Hope this is R4600 - otherwise BogoMIPS won't be too impressive ...)

bogomips 10# cat /proc/cpuinfo
Cannot open /proc/cpuinfo: No such file or directory
bogomips 11# dmesg | more
dmesg: Command not found.
bogomips 12# man dmesg
No manual entry found for dmesg.
bogomips 13#

Not sure...I _think_ it's an R5K, but the packing bits and the machine
itself are 3 time zones east.

> my config files.  Iff(OS != Linux) while(1){swear();rtfm(damn);swear()} ;-)

Actually (I guess I should have made this clearer...a couple of people
have sent tftp help) I meant tips on what should go in the NFS root
area.  Can I just pull stuff down from davem's private archive and
untar, or have things changed since then?

Mike

-- 
#> Mike Shaver ([email-masked]) Ingenia Communications Corporation 
#>              Commando Developer - Whatever It Takes
#>                                                                     
#> "See, you not only have to be a good coder to create a system like
#>    Linux, you have to be a sneaky bastard too." - Linus Torvalds

---

From: "Alistair Lambie" <[email-masked]>
Date: Fri, 4 Apr 1997 12:57:06 +0000

On Apr 4, 12:24pm, Mike Shaver wrote:
> Subject: Re: The Indy has landed...
> Thus spake Ralf Baechle:

I assume it's got Irix running at the moment.  If so, try 'hinv'.

> untar, or have things changed since then?

Ariel....maybe you should put the tar's on netengr.engr:~/dm/alambie on
ftp://reality.sgi.com/private/dm/ till I get linux.sgi.com sorted out.  There
should be everything you need to get multiuser in there.

Cheers, Alistair

-- 
Alistair Lambie					    [email-masked]
Silicon Graphics New Zealand				  SGI Voicemail: 56791
Level 5, Walsh Wrightson Tower,				    Ph: +64-4-802 1455
94-96 Dixon St, Wellington, NZ			  	   Fax: +64-4-802 1459

---

From: Mike Shaver <[email-masked]>
Date: Tue, 8 Apr 1997 18:23:31 -0400 (EDT)

>> boot -f bootp()neon.ingenia.ca:/vmlinux
Setting $netaddr to 205.207.220.72 (from server neon.ingenia.ca)
Obtaining /vmlinux from server neon.ingenia.ca
PROMLIB: SGI ARCS firmware Version 1 Revision 10
PROMLIB: Total free ram 65208320 bytes (63680K,62MB)
Loading R4000 MMU routines.
CPU REVISION IS: 00002310
Primary ICACHE 32K (linesize 32 bytes)
Primary DCACHE 32K (linesize 32 bytes)
R4600/R5000 SCACHE size 512K linesize 128 bytes
ARCH: SGI-IP22
CPU: MIPS-R5000 FPU<MIPS-R5000FPC> ICACHE DCACHE SCACHE
MC: SGI memory controller Revision 3
calculating r4koff... 000bd678(775800)
zs0: console input
zs0: console I/O
Calibrating delay loop.. ok - 154.83 BogoMIPS
Memory: 60564k/196604k available (792k kernel code, 2988k data)
Swansea University Computer Society NET3.035 for Linux 2.0
NET3: Unix domain sockets 0.12 for Linux NET3.035.
Swansea University Computer Society TCP/IP for NET3.034
IP Protocols: ICMP, UDP, TCP
Checking for 'wait' instruction...  unavailable.
Linux version 2.0.12 (dm@neteng) (gcc version 2.7.2) #2 Mon Aug 12 04:43:30 PDT6
SGI Zilog8530 serial driver version 1.00
tty00 at 0xbfbd9838 (irq = 21) is a Zilog8530
tty01 at 0xbfbd9830 (irq = 21) is a Zilog8530
PS/2 auxiliary pointing device detected -- driver installed.
WD93: Driver version 1.21 compiled on Aug 12 1996 at 04:20:18
wd33c93-0: chip=WD33c93B microcode=0d
scsi0 : SGI WD93
scsi : 1 host.
Started kswapd v 1.3
  Vendor: SGI       Model: IBM DORS-32160    Rev: W80D
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 1, lun 0
  Vendor: CONNER    Model: CFP2107S  2.14GB  Rev: 172B
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdb at scsi0, channel 0, id 6, lun 0
scsi : detected 2 SCSI disks total.
SCSI device sda: hdwr sector= 512 bytes. Sectors= 4197405 [2049 MB] [2.0 GB]
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 4194304 [2048 MB] [2.0 GB]
sgiseeq.c: David S. Miller ([email-masked])
eth0: SGI Seeq8003 08:00:69:0a:2a:9b
Partition check:
 sda: sda1 sda2 sda3 sda4
 sdb: sdb1 sdb2 sdb3 sdb4
Sending BOOTP and RARP requests............

Doesn't seem to want to find the server again for the NFS root thing,
but that's probably a config problem.

_Now_ we're ready to rock...

Mike

-- 
#> Mike Shaver ([email-masked]) Ingenia Communications Corporation 
#>       Chief System Architect -- Head geek -- System exorcist        
#>                                                                     
#>   "Have you considered a life?  I hear they're quite affordable     
#>          these days." --- [email-masked]

---

From: "William J. Earl" <[email-masked]>
Date: Tue, 8 Apr 1997 16:37:49 -0700

> CPU REVISION IS: 00002310
...

    Congratulations -- quick work.

...
 > Checking for 'wait' instruction...  unavailable.
...

     This appears to be a bug.  The R5000 does have the wait instruction.

---

From: Mike Shaver <[email-masked]>
Date: Tue, 8 Apr 1997 19:56:31 -0400 (EDT)

Thus spake Alistair Lambie:
> I used to have that...you probably haven't got a rarp server set up, so it
> can't find its address.  One of the things David was going to add was that
> ability to read it out of NVRAM...but that wasn't high on the priority list!
>  For now, the only way is to have a rarp server.

Actually, you can do it with
boot -f bootp()server:/vmlinux nfsaddrs=my.ip.ad.dr:nfs.ip.ad.dr

It mounts it now (I have the NFS daemon running with debugging on so
that I can watch) but it just stops after it looks at tty[4123 -- in
that order].

I'm going to see how the SPARC guys did it; I think it's just a matter
of getting the device entries correct.

> Did you get my root filesystem etc off http://reality.sgi.com/ariel/alambie.
> This should give you the bits you need to get multiuser (init), set up
> networking and mount disks.

Yeah, and that's what I'm using for my root filesystem.
It mounts everything and checks out stuff like /var/log/utmp (!), but
then hangs after it looks at the ttys.

Curious...

Mike

-- 
#> Mike Shaver ([email-masked]) Ingenia Communications Corporation 
#>           Resident Linux bigot and kernel hacker. (OOPS!)           
#> `If you get bitten by a bug, tough luck...the one thing I won't do  
#> is feel sorry for you.  In fact, I might ask you to do it all over  
#> again, just to get more information.  I'm a heartless bastard.'     
#>                       -- Linus Torvalds (on development kernels)

---

From: "William J. Earl" <[email-masked]>
Date: Tue, 8 Apr 1997 17:00:43 -0700

Alistair Lambie writes:
 > On Apr 9, 10:27am, Mike Shaver wrote:
 > > Subject: It booooooooooots!
 >  For now, the only way is to have a rarp server.  The other way is to have the
 > root file system on hard disk....but to do that you need to boot linux and copy
 > it across.
 > Kind of the chicken and the egg situation!

     Can you pass the information to the kernel via the command line arguments
or the environment variables?  (argc, argv, and environ are passed in $a0, $a1,
and $a2 by the PROM or sash to the kernel on entry, just as they are passed
to a main program in a regular process; you can look for the "netaddr" environment
variable to find your IP address:

	netaddr=192.111.24.24

Set netaddr at the prom this way:

	setenv -p netaddr 192.111.24.24

---

From: "William J. Earl" <[email-masked]>
Date: Tue, 8 Apr 1997 17:02:14 -0700

Alistair Lambie writes:
 > On Apr 9, 11:38am, William J. Earl wrote:
 > > Subject: Re: It booooooooooots!
 > > Mike Shaver writes:
...
 > I don't think David ever worked on an R5000.  The only platforms were R4600 &
 > R4400...soooo, there may be some issues to be resolved.
...

     On an Indy, the R5000 and R4600 are basically equivalent, except
for the MIPS IV extensions and larger caches (32 KB versus 16 KB) on the R5000.
The R5000 does have built-in secondary cache control, which is used on the O2,
but it is not used on the Indy.  On the Indy, the R5000 uses the same off-chip
secondary cache controller as the R4600.  The wait instruction operates the
same on both processors.  The wait instruction is not really essential in any
case, since its main purpose is to save power, and the R5000 and R4600 don't
use much power anyway.

---

From: Mike Shaver <[email-masked]>
Date: Tue, 8 Apr 1997 22:09:49 -0400 (EDT)

Wierd stuff here.
We've got it mountinng the NFS partition and running /bin/sh, but we
can't type anything to it at that point.
It's kinda weird, because we see the `#' prompt, but stuff I type to
it isn't registering.

stdin in /dev/cua1, FWIW.

I'm going to try to get some better diags, I guess.

Mike

---

From: Alex deVries <[email-masked]>
Date: Wed, 9 Apr 1997 00:29:32 -0400 (EDT)

-----BEGIN PGP SIGNED MESSAGE-----

On Wed, 9 Apr 1997, Alistair Lambie wrote:
> On Apr 9,  2:12pm, Mike Shaver wrote:
> Does your Indy not have a 'head' on it....why are you using the serial ports..

The machine we're working on, bogomips, is in Ottawa, Canada.  Mike's on
business in Mountainview, California.  Joshua "boot boy" Lamorie handles
the hardboots, and I offer petty advice from Boston, watching Mike use
minicom in a ytalk session through a serial connection.  Odd, but it
works.

Does anyone know the the status of gcc for sgi-linux?  I understand the
cross compiler between Irix and sgi-linux is operational.  How about a
native compiler?  I'm keen on porting a ton of RPM's...

- - Alex

<()       Alex deVries
 |_\_ System Administrator
  ^^   The EngSoc Project

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 9 Apr 1997 07:25:46 +0200 (MET DST)

>      This appears to be a bug.  The R5000 does have the wait instruction.

Linux doesn't really check; instead it has encoded which CPU types
have a wait instruction.  I add the R500 to that list.

  Ralf

---

From: Martin Knoblauch <[email-masked]>
Date: Wed, 09 Apr 1997 09:06:29 +0200

Alistair Lambie wrote:
> > Subject: init=/bin/sh and serial devices
> > Wierd stuff here.

 this brings up the question: do we already have drivers for
the textport? Not to speak of an X-Server? How are we (SGI)
going to handle this? As far as I know we never published
the hardware dependent parts on the X11 distribution, did we?

Martin 
-- 
+---------------------------------+-----------------------------------+
|Martin Knoblauch                 | Silicon Graphics GmbH             |
|Manager Technical Marketing      | Am Hochacker 3 - Technopark       |
|Silicon Graphics Computer Systems| D-85630 Grasbrunn-Neukeferloh, FRG|
|---------------------------------| Phone: (+int) 89 46108-179 or -0  |
|http://reality.sgi.com/knobi     | Fax:   (+int) 89 46107-179        |
+---------------------------------+-----------------------------------+
|e-mail: <[email-masked]>   | VM: 6-333-8197 | M/S: IDE-3150    |
+---------------------------------------------------------------------+

---

From: "Alistair Lambie" <[email-masked]>
Date: Wed, 9 Apr 1997 11:48:25 +0000

Cheers, Alistair

---

From: "Alistair Lambie" <[email-masked]>
Date: Wed, 9 Apr 1997 12:06:27 +0000

> boot -f bootp()server:/vmlinux nfsaddrs=my.ip.ad.dr:nfs.ip.ad.dr

Forgot that one!!  It all seems so long ago :-)

> that I can watch) but it just stops after it looks at tty[4123 -- in

Have you set up the 'init' environment, or are you just using the plain 'root'
package.  If the later, I seem to remeber that the kernel looks for init, but
doesn't look in the correct place for the shell.  There is a boot argument that
I used to use to get the shell...can't remeber what now, but it was real easy
to find in the kernel source....

Even if you are using init, you might want to just boot the shell first to
track down what is happening!

Cheers

---

From: "Alistair Lambie" <[email-masked]>
Date: Wed, 9 Apr 1997 14:22:45 +0000

> stdin in /dev/cua1, FWIW.

Try 'init=/bin/sh </dev/cua1 >/dev/cua1'.  I seem to remember you need that.
Sorry all this seems to be coming piece meal, but it's been a long time since I
have run it up, and you kind of forget some of the details till you are
reminded!

Cheers, Alistair

---

From: "Alistair Lambie" <[email-masked]>
Date: Wed, 9 Apr 1997 14:24:03 +0000

Cheers, Alistair

---

From: "Alistair Lambie" <[email-masked]>
Date: Wed, 9 Apr 1997 14:29:40 +0000

BTW, if you use the init package it will take care of all this stuff...you
should be able to just lay it over the top of the root package on your nfs
disk.

Cheers, Alistair

On Apr 9,  2:23pm, Alistair Lambie wrote:
> Subject: Re: init=/bin/sh and serial devices
>-- End of excerpt from Alistair Lambie

---

From: "Alistair Lambie" <[email-masked]>
Date: Wed, 9 Apr 1997 14:31:16 +0000

> should be able to just lay it over the top of the root package on your nfs

You will need to edit inittab for the serial devices...it's set up for the vc's
on a 'headed' Indy.

> > Sorry all this seems to be coming piece meal, but it's been a long time
since
> I

---

From: "William J. Earl" <[email-masked]>
Date: Wed, 9 Apr 1997 11:31:04 -0700

Martin Knoblauch writes:
...
...

    With management authorization, I provided the technical details
for the graphics hardware (and all the other Indy hardware) to David
Miller, who I believe got a textport driver working.

---

From: "William J. Earl" <[email-masked]>
Date: Wed, 9 Apr 1997 11:37:30 -0700

> have a wait instruction.  I add the R500 to that list.

     As far as I know, all QED processors have the "wait" instruction.
All the 0x2???  processor ID values are QED processors.  Here are the current
values:

#define C0_IMP_NEVADA	0x28
#define C0_IMP_RM7000	0x27
#define C0_IMP_MAGIC	0x25
#define C0_IMP_SONIC	0x24
#define	C0_IMP_R5000 	0x23
#define	C0_IMP_R4650 	0x22 
#define	C0_IMP_R4700 	0x21
#define	C0_IMP_R4600 	0x20

I don't know which processors are SONIC, MAGIC, or NEVADA, but I think NEVADA
is the new RM5260 (a low-cost R5000).

---

From: [email-masked] (Ariel Faigon)
Date: Wed, 9 Apr 1997 11:40:47 -0700 (PDT)

:
:Martin Knoblauch writes:
:...
: >  this brings up the question: do we already have drivers for
: > the textport? Not to speak of an X-Server? How are we (SGI)
: > going to handle this? As far as I know we never published
: > the hardware dependent parts on the X11 distribution, did we?
:...
:
:    With management authorization, I provided the technical details
:for the graphics hardware (and all the other Indy hardware) to David
:Miller, who I believe got a textport driver working.
:

Also, the agreement we signed with David was that all the Linux work
including those low level drivers will be released under the GPL
i.e. anyone who cares would be able to look at these driver sources.

-- 
Peace, Ariel

---

From: [email-masked] (Ariel Faigon)
Date: Wed, 9 Apr 1997 11:46:07 -0700 (PDT)

:
:-----BEGIN PGP SIGNED MESSAGE-----
:
:
:On Wed, 9 Apr 1997, Alistair Lambie wrote:
:> On Apr 9,  2:12pm, Mike Shaver wrote:
:> > stdin in /dev/cua1, FWIW.
:> >
:> 
:> Does your Indy not have a 'head' on it....why are you using the serial ports..
:
:The machine we're working on, bogomips, is in Ottawa, Canada.  Mike's on
:business in Mountainview, California.  Joshua "boot boy" Lamorie handles
:the hardboots, and I offer petty advice from Boston, watching Mike use
:minicom in a ytalk session through a serial connection.  Odd, but it
:works.
:
:Does anyone know the the status of gcc for sgi-linux?  I understand the
:cross compiler between Irix and sgi-linux is operational.  How about a
:native compiler?  I'm keen on porting a ton of RPM's...
:
:- - Alex
:
:<()       Alex deVries
: |_\_ System Administrator
:  ^^   The EngSoc Project
:
:

This is one of the things that weren't done and we want to get done
by the Linux/SGI developers.  I believe that Miguel is one of the
best people to make this happen.  If we can just get his Indy R5000
out of the bureaucratic mess.  Miguel's Indy was shipped three weeks
ago to Mexico and requires a "special permit for used equipment" by
the Mexican customs to be provided by the SGI Mexico City office)

I hope Miguel will send us some good news soon.
-- 
Peace, Ariel

---

From: "Alistair Lambie" <[email-masked]>
Date: Wed, 9 Apr 1997 19:30:15 +0000

> the hardware dependent parts on the X11 distribution, did we?

We already have drivers for 'textport'....well actually it takes over the whole
screen with a font that allows something like 132x80 from what I remeber.  This
has VC support so you can do the usual Alt-F1 etc like on a PC based linux box.
 No work has been done on the X-Server yet.

Cheers, Alistair

---

From: "David S. Miller" <[email-masked]>
Date: Mon, 14 Apr 1997 04:17:17 -0400

Date: Wed, 09 Apr 1997 09:06:29 +0200
   From: Martin Knoblauch <[email-masked]>

   do we already have drivers for the textport?

I wrote the text console driver for 24-bit Newport INDY frame buffers,
and it is in the SGI/Linux code.  I was never able to get around to
doing the 8-bit frame buffer card driver though, so if you've got one
of those in the INDY you are a out of luck for now.  (hinv -v from the
firmware prompt will tell you if you have the 24-bit or 8-bit card)

---------------------------------------------////
Yow! 11.26 MB/s remote host TCP bandwidth & ////
199 usec remote TCP latency over 100Mb/s   ////
ethernet.  Beat that!                     ////
-----------------------------------------////__________  o
David S. Miller, [email-masked] /_____________/ / // /_/ ><

---

From: "William J. Earl" <[email-masked]>
Date: Mon, 14 Apr 1997 11:05:52 -0700

...

     Does the textport driver run in color-index mode?  If so, it will
probably work on the 8-bit card.  The cards are largely identical, except
for the depth of the frame buffer.

---

From: "David S. Miller" <[email-masked]>
Date: Mon, 14 Apr 1997 22:09:11 -0400

Date: Mon, 14 Apr 1997 11:05:52 -0700
   From: "William J. Earl" <[email-masked]>

	Does the textport driver run in color-index mode?  If so, it
   will probably work on the 8-bit card.  The cards are largely
   identical, except for the depth of the frame buffer.

If memory serves, I left the chip in the exact mode the firmware has
set it to.  So if the firmware sets up the card to use color-index
mode, then I do as well in the driver.  (I think I did this so I did
not have to deal with monitor frequencies, and resolutions, and that
sort of thing)

But my text rendering code may make assumptions about frame buffer
depth, I draw them using the various simpler raster operation commands
the Newport has, so someone who knows would have to look at my code.

---

From: [email-masked] (Alistair Lambie)
Date: Sat, 19 Apr 1997 10:35:30 +1200 (NZT)

> the Newport has, so someone who knows would have to look at my code.
I've been away for a few days, so sorry about the late reply :-)

It definitely works on an 8 bit machine.  That is what I have used in the past.

Cheers, Alistair