Subject: anon-ftp enabled on linus

From: [email-masked] (Ariel Faigon)
Date: Thu, 26 Jun 1997 11:46:22 -0700 (PDT)

FYI:

I just enabled public ftp access to linus.linux.sgi.com
ftpd runs as user/group  ftp/ftp.

The chroot'ed location (~ftp) is /src (where the CVS tree resides)

I made sure that the source tree has no world write permissions
or ftp group write permissions anywhere.

Since IRIX comes only with a dynamically liked '/bin/ls'
I had to add /lib/rld libc.so and /dev/zero rooted at /src
for dir to work.  I made all the permissions secure but
another check would be appreciated.

If anyone feels like building the latest wu-ftpd (with all security
patches) and replace the SGI ftpd - welcome.

A web site is planned too.  I hope we got a volunteer to set it up.

Let's keep the public areas only on the /src partition. I suggest
/src/www (or some such) for the web doc root.

-- 
Peace, Ariel

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 26 Jun 1997 20:55:56 +0200 (MET DST)

Hi,

> for dir to work.

> patches) and replace the SGI ftpd - welcome.

If someone wants do work on this - I've got an modified wu-ftpd 2.4
with a builtin ls command.  Would be nice to have that in linus' ftpd,
too.

> A web site is planned too.  I hope we got a volunteer to set it up.

Alan is already complaining.  I told him that I consider port 80
burned land ;-)

  Ralf

---

From: Miguel de Icaza <[email-masked]>
Date: Thu, 26 Jun 1997 14:44:15 -0500

> /src/www (or some such) for the web doc root.

Heh.  This will be a nice addition.  Alan has been complaining about
www.linux.sgi.com not showing up anything :-)

Miguel.

---

From: "Christopher W. Carlson" <[email-masked]>
Date: Thu, 26 Jun 1997 17:32:30 -0700

On Jun 26, 11:46am, Ariel Faigon wrote:
> Subject: anon-ftp enabled on linus
> FYI:
> 
>-- End of excerpt from Ariel Faigon

BTW, I don't know if anybody cares but...

I have a defkeymap.map which generates all the escape sequences for
the IRIX keyboard.  IOW, it generates all the F1, F2,... escape
sequences to match what IRIX does.

It can be retrieved from
	http://reality.sgi.com/carlson_newport/files/defkeymap.map

Be sure to use the right mouse button and select "Save link as ..."
because Netscape tries to read it as an image file.

-- 

		Chris Carlson

	+------------------------------------------------------+
	| Also, [email-masked]                                |
	|   Work:   (714) 224-4530                             |
	|   Vnet:       6-678-4530     FAX:    (714) 833-9503  |
	|                                                      |
	| Trivia fact: an electroencephalogram shows that a    |
	| human brain and a bowl of quivering lime Jell-O have |
	| the same waves.  [Time Magazine, Mar 17, 1997]       |
	+------------------------------------------------------+