Subject: (Fwd) Re: SGI machine

From: "Christopher W. Carlson" <[email-masked]>
Date: Tue, 17 Jun 1997 13:02:18 -0700

Just thought I'd pass on the response that I received from Richard
Stallman.

--- Forwarded mail from Richard Stallman <[email-masked]>

Date: Tue, 17 Jun 1997 15:17:06 -0400
From: Richard Stallman <[email-masked]>
To: carlson
Subject: Re: SGI machine

We now have free systems running on all our machines, so we could not
accept a machine that runs a non-free system like IRIX.

Once you have a GNU/Linux system running, that problem would be
solved.  But usable machines have become pretty cheap--we could buy a
686 for the cost of paying a programmer for 2 weeks--and we have more
than enough machines now for the people we have.  What we mainly need
nowadays is money to pay programmers.

Is there any chance you could convince some part of SGI to make a
donation?  Or at least buy a Deluxe Distribution?

We can hire a programmer for a year for just $35000 or so.

---End of forwarded mail from Richard Stallman <[email-masked]>

-- 

		Chris Carlson

	+------------------------------------------------------+
	| Also, [email-masked]                                |
	|   Work:   (714) 224-4530                             |
	|   Vnet:       6-678-4530     FAX:    (714) 833-9503  |
	|                                                      |
	| Trivia fact: an electroencephalogram shows that a    |
	| human brain and a bowl of quivering lime Jell-O have |
	| the same waves.  [Time Magazine, Mar 17, 1997]       |
	+------------------------------------------------------+

---

From: [email-masked] (Larry McVoy)
Date: Tue, 17 Jun 1997 23:37:15 -0700

: There are some very serious issues which come up even getting Xfree to a
: moderate level of acceleration.  

How about to a simple level of working?  Without any acceleration?
For most people, just having xterms and netscape working is enough.

I'm not a graphics or X person.  Could someone who knows SGI's gfx
devices tell us how hard it would be to make the basics work?

Thanks.

---

From: Martin Knoblauch <[email-masked]>
Date: Wed, 18 Jun 1997 09:33:02 +0200

Christopher W. Carlson wrote:
> 
> Just thought I'd pass on the response that I received from
> Richard Stallman.
> 
> We now have free systems running on all our machines, so we
> could not accept a machine that runs a non-free system like IRIX.
>

 So, does this mean they are no longer interested in supporting
GNU stuff on non-free systems?
 
> We can hire a programmer for a year for just $35000 or so.

  Besides our GNU effort, any chance that we can get someone
to donate a considerable amount of money to the FSF? Just
to make a point that we are not against free software.

Martin
-- 
+---------------------------------+-----------------------------------+
|Martin Knoblauch                 | Silicon Graphics GmbH             |
|Manager Technical Marketing      | Am Hochacker 3 - Technopark       |
|Silicon Graphics Computer Systems| D-85630 Grasbrunn-Neukeferloh, FRG|
|---------------------------------| Phone: (+int) 89 46108-179 or -0  |
|http://reality.sgi.com/knobi     | Fax:   (+int) 89 46107-179        |
+---------------------------------+-----------------------------------+
|e-mail: <[email-masked]>   | VM: 6-333-8197 | M/S: IDE-3150    |
+---------------------------------------------------------------------+

---

From: Martin Knoblauch <[email-masked]>
Date: Wed, 18 Jun 1997 10:21:29 +0200

[also changeing the subject]

Larry McVoy wrote:
> 
> : There are some very serious issues which come up even getting
> : Xfree to a moderate level of acceleration.
> 

  Probably not that hard if we gave away the documentation
(do we have *documentation*) on the GFX cards low level interfaces.
The major problem to me seems that each different architecture
(XL, XZ/Elan/Extreme, IMPACT, CRM) has different interfaces.
I am not sure that you can find a minimal subset of calls
to make a very simple Xserver work (is Peter Daifuku on this
list ? Mark Kilgard?).

  Personally I think that we don't loose anything if we give away
the stuff for the older boards (Newport, Express). I am not
sure, what we loose if we do the same for IMPACT/IR (OK, IR
is probably not such a big deal :-)

 Questions:

- How much HW dependent stuff is in Xsgi itself?
- Which of the DSOs in /usr/lib/X11/dyDDX are minimally
  needed to bring up an non-GLX Xserver?
- How much efforts would it cost to compile the dyDDX
  stuff for Linux and distribute the binaries only
  (assuming that there is not to much HW stuff in Xsgi itself)?

 And of course, we probably have to provide the microcode and
loader for the different GFX cards.

 I definitely agree with Ariel, that this is the most important
topic once we have Linux running stable.

Martin

---

From: [email-masked] (richard offer)
Date: Wed, 18 Jun 1997 09:23:49 -0700

* $ from [email-masked] at "18-Jun:10:21am" | sed "1,$s/^/* /"
*
*
* [also changeing the subject]
*
* Larry McVoy wrote:
* >
* > : There are some very serious issues which come up even getting
* > : Xfree to a moderate level of acceleration.
* >
* > How about to a simple level of working?  Without any acceleration?
* > For most people, just having xterms and netscape working is enough.
* >
* > I'm not a graphics or X person.  Could someone who knows SGI's gfx
* > devices tell us how hard it would be to make the basics work?
* >
*
*   Probably not that hard if we gave away the documentation
* (do we have *documentation*) on the GFX cards low level interfaces.
* The major problem to me seems that each different architecture
* (XL, XZ/Elan/Extreme, IMPACT, CRM) has different interfaces.
* I am not sure that you can find a minimal subset of calls
* to make a very simple Xserver work (is Peter Daifuku on this
* list ? Mark Kilgard?).

I'm fairly sure Peter isn't, and I haven't heard anything from Mark, so one
would guess not :-)

*
*   Personally I think that we don't loose anything if we give away
* the stuff for the older boards (Newport, Express).

Unfortunetly we don't get to make these sorts of decisions :-(

* I am not
* sure, what we loose if we do the same for IMPACT/IR (OK, IR
* is probably not such a big deal :-)
*
*
*  Questions:
*
* - How much HW dependent stuff is in Xsgi itself?
* - Which of the DSOs in /usr/lib/X11/dyDDX are minimally
*   needed to bring up an non-GLX Xserver?

My guess would be none of them, on my system all I have is glx, speedo, type1
and xdps, all features of which I could live without---whether the server will
work without them is another thing. Although I hope it would, as there is no
way we can have xdps.

* - How much efforts would it cost to compile the dyDDX
*   stuff for Linux and distribute the binaries only
*   (assuming that there is not to much HW stuff in Xsgi itself)?

I can't answer any of these, this requires someone else from Peter's group
(jessb and corriero are the low-level hardware type people). I doubt if they
have much interest/bandwidth.

*
*
*  And of course, we probably have to provide the microcode and
* loader for the different GFX cards.
*
*  I definitely agree with Ariel, that this is the most important
* topic once we have Linux running stable.

Good, so we are all agreed then.

*
* Martin
* --
* +---------------------------------+-----------------------------------+
* |Martin Knoblauch                 | Silicon Graphics GmbH             |
* |Manager Technical Marketing      | Am Hochacker 3 - Technopark       |
* |Silicon Graphics Computer Systems| D-85630 Grasbrunn-Neukeferloh, FRG|
* |---------------------------------| Phone: (+int) 89 46108-179 or -0  |
* |http://reality.sgi.com/knobi     | Fax:   (+int) 89 46107-179        |
* +---------------------------------+-----------------------------------+
* |e-mail: <[email-masked]>   | VM: 6-333-8197 | M/S: IDE-3150    |
* +---------------------------------------------------------------------+
*

richard.

_____________________________________________________________________

 The difference between 'wants' and 'needs' can clearly be expressed 
 as follows:-

         You want the moon on a stick.
         You need a damn good kicking.

                                        Nhi Vanye:after "Fist of Fun"

---

From: "Christopher W. Carlson" <[email-masked]>
Date: Wed, 18 Jun 1997 09:41:11 -0700

On Jun 18,  9:33am, Martin Knoblauch wrote:
>-- End of excerpt from Martin Knoblauch

Yes, that's what I think it means.

Bottom line is that it is up to us (SGI) to provide the support for
IRIX.  There are various people throughout SGI who do testing and
debugging on our systems and feed them back to FSF.  For example, I'm
on the Emacs pretest list.  I usually get early releases of Emacs and
test it on various boxes before it is released.

-- 

		Chris Carlson

---

From: [email-masked] (Ariel Faigon)
Date: Wed, 18 Jun 1997 10:48:56 -0700 (PDT)

:
:Christopher W. Carlson wrote:
:> 
:> Just thought I'd pass on the response that I received from
:> Richard Stallman.
:> 
:> --- Forwarded mail from Richard Stallman <[email-masked]>
:> 
:> Date: Tue, 17 Jun 1997 15:17:06 -0400
:> From: Richard Stallman <[email-masked]>
:> To: carlson
:> Subject: Re: SGI machine
:> 
:> We now have free systems running on all our machines, so we
:> could not accept a machine that runs a non-free system like IRIX.
:>
:
: So, does this mean they are no longer interested in supporting
:GNU stuff on non-free systems?
: 

Hi Linuxies,

As much as I admire rms, his amazing life achievements,
and the free software movement he created, let's not accept it
"as is" when he talks in his strong opinionated style in the
name of others.  I happen to know two major FSF contributors
that would love to get SGI hardware and make GNU stuff work
on IRIX _or_ Linux.   Please keep emailing me leads :-)

-- 
Peace, Ariel

---

From: "William J. Earl" <[email-masked]>
Date: Thu, 19 Jun 1997 12:42:31 -0700

> to make a very simple Xserver work (is Peter Daifuku on this

     The kernel graphics driver is quite complex, although that is in
large part due to the support for direct rendering in GL.  The
hardware, except for Starter, XL, and O2, requires downloaded firmware.
Fortunately, basic firmware is downloaded by the PROM, so that it can
write on the screen.  I believe that an X server can simply do the
same operations as the PROM, in regard to manipulating the frame buffer,
using the firmware interfaces.  I have to investigate this in more
detail, however.

...
 >   (assuming that there is not to much HW stuff in Xsgi itself)?

     The interfaces are very different.  I tried mixing IRIX X server
and XFree86 X server source and did not get very far.