Subject: Interest in SGI/Linux

From: [email-masked] (Ariel Faigon)
Date: Tue, 22 Jul 1997 12:14:53 -0700 (PDT)

The external SGI/Linux site is not yet widely advertised
as we're trying to avoid visibility and a barrage of questions
before we have something stable to show the world and a good HOWTO.

Yet I see pretty impressive interest.
First: we have quite a few ftp connections coming in.
For example in the last two days we got FTP connections
from the following sites:

	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	[email-masked]
	athena.nuclecu.unam.mx
	lager.engsoc.carleton.ca
	portmaster-ppp-slip-term-10.uni-koblenz.de
	portmaster-ppp-slip-term-25.uni-koblenz.de
	portmaster-ppp-slip-term-30.uni-koblenz.de
	sgi.com
	thoma.uni-koblenz.de
	vulcan.ko.bnc.net

Not to mention web hits.  Since our web server (linus) went on air
We got web hits from the following (note the interest from some
interesting .com sites) some IP addresses are unresolved.
uniq'ed sorted visitor sites:

        051.msy4.communique.net
        128.175.116.205
        133.1.127.36
        138.245.179.28
        148.206.32.143
        148.206.32.99
        150.186.92.3
        159.153.51.164
        166.82.237.41
        167.114.28.18
        184.msya.communique.net
        192.100.200.98
        193.77.166.67
        194.122.208.197
        194.140.166.2
        194.140.166.6
        194.177.3.16
        194.233.182.101
        194.74.32.53
        198.68.106.97
        198.68.106.98
        199.78.39.201
        200.23.36.9
        200.247.23.1
        204.101.225.170
        204.101.225.7
        205.179.228.26
        205.205.145.247
        206.102.1.34
        206.16.230.9
        206.210.75.105
        206.228.168.202
        206.228.168.206
        206.235.82.200
        206.6.58.134
        207.103.93.121
        207.219.36.2
        207.227.165.200
        207.66.214.245
        209.21.31.7
        38.168.90.30
        ALEPH0.MIT.EDU
        Bongo.HGS.SE
        Breughel.ufsia.ac.be
        C58.reach.net
        CACHE1.TC.CORNELL.EDU
        CDEMPSEY.PHAR.LSUMC.EDU
        DeathStar.destru.com
        Firenze7-49.tin.it
        Gandalf.HGS.SE
        Gtn2-net0-s9.eci.com
        OPTIC.NEURO.BCM.TMC.EDU
        PG024.hatelecom.or.jp
        S16-cs1-alhambra.datadepot.com
        SGI.COM
        WS-Fra1.win-ip.dfn.de
        WS-Koe1.win-ip.dfn.de
        abyss.kolej.mff.cuni.cz
        admin3.calweb.com
        alan.mobile.cymru.net
        alaska-ext.wise.edt.ericsson.se
        alex2.med.iacnet.com
        amazonas.borak.es
        amor.comwell.se
        arctis-ext.wise.edt.ericsson.se
        athena.nuclecu.unam.mx
        avery.uiah.fi
        bacchus.comwell.se
        bananoid.nuclecu.unam.mx
        bassin.feut.utoronto.ca
        blackstone.cs.brown.edu
        blanc.cisco.com
        blit.nuclecu.unam.mx
        blondie.uni-mb.si
        boojum.cs.brown.edu
        brewmaster.engsoc.carleton.ca
        bugatte.nmt.edu
        cache-1.www.demon.net
        cache-2.www.demon.net
        cagw1.att.com
        cahor.cintibelltv.com
        cajal.ucsd.edu
        calli.matem.unam.mx
        canna.physics.ox.ac.uk
        capatida.whoi.edu
        cassia.hensa.ac.uk
        cave.slip.wg.saar.de
        celt.network1.net
        cerbere.bruyeres.cea.fr
        chaos.wasteland.org
        chico.franken.de
        cinesite1.sohonet.co.uk
        click3west.com
        cosmic.ssc.com
        cust119.max3.dial.tor2.uunet.ca
        cww-proxy1.cww.de
        cyprus.cryst.bbk.ac.uk
        dalet.belnet.be
        darling.cs.ucsb.edu
        dasc12-94.flash.net
        davinci.hut.fi
        dbath-home-pc.cisco.com
        debug.cs.brown.edu
        demdwu19.mediaways.net
        deneb.its.deakin.edu.au
        dhcp-o-44-253.cisco.com
        dial06.c3.hu
        dial10.c3.hu
        dial211.ppp.lrz-muenchen.de
        dialup-17-ascend.athens.net
        dialup90-3-4.swipnet.se
        diamondage.cymru.net
        dj.whoi.edu
        dog.nordnet.fi
        dreamworks.com
        drson.ms.mff.cuni.cz
        du232-7.ppp.algonet.se
        eagle.plsys.co.uk
        eins.siemens.at
        enigma.tec.ufl.edu
        entropy.UCSC.EDU
        evil.aec.at
        extern.adnc.com
        falcon.destru.com
        faui45o.informatik.uni-erlangen.de
        fep3-orange.clear.net.nz
        fire-nyc.viacom.com
        firewall.edstone.com
        firewall.lego.com
        fourier.sva.edu.154.35.199.IN-ADDR.ARPA
        gars.gar.no
        gatekeep.cv.ruu.nl
        gatekeeper.qms.com
        gatekeeper.viewpoint.com
        gateway.cam-ani.co.uk
        gazoo.eecs.wsu.edu
        gimli.elemental.net
        goalkeeper.d2.com
        grmn-105ppp63.epix.net
        gw1.vtr.co.uk
        harvey.cyclic.com
        hcmason.vip.best.com
        heme.chem.wsu.edu
        host38.ocean.u-net.com
        host51.kset.com
        huey.pixar.com
        i115.ztm.euronet.nl
        i120.ztm.euronet.nl
        icon32.iconnet.com
        idnewt.idsoftware.com
        if-home.uk.stratus.com
        ikluft-ss20.cisco.com
        imhotep.uoregon.edu
        indy05.cs.monash.edu.au
        inet-gateway.CO.Santa-Clara.CA.US
        ip197.sjc.primenet.com
        ip57-129.tol.primenet.com
        iriquois.eel.ufl.edu
        jens.metrix.de
        joysun2.office.planet.nl
        jt11-163-1.tky.hut.fi
        kc1-14.kc-primary.net
        kcgw1.att.com
        kcgw2.att.com
        kgb.emn.fr
        kheops.cray.com
        knisdn-105.planetc.com
        knox35.static.usit.net
        korsoft.com
        krpan.uni-mb.si
        krusty.taoslab.com
        kwilson-pc.cisco.com
        laerche-atm.cs.uni-magdeburg.de
        lax-ca18-20.ix.netcom.com
        lax-ca38-59.ix.netcom.com
        lax-ca56-01.ix.netcom.com
        leia.ethz.ch
        liberty.dd.co.za
        lippitt.cs.brown.edu
        lo-pan.ridgecrest.ca.us
        lonsf24317.mle.co.uk
        lrdpf.spacetec.no
        mail.mdli.com
        marmoset.loc201.tandem.com
        max-sf2-7.iway.aimnet.com
        mean.netppl.fi
        metra-rnd.metra.com
        metro16.metro-online.com
        mg131-114.ricochet.net
        millennium.falcon.org
        monitor.mips4.com
        morsan.nrm.se
        mpc2.sohonet.co.uk
        myangup.connect.com.au
        myeah.connect.com.au
        myponga.connect.com.au
        nat-26.avanticorp.com
        neon.ingenia.ca
        neurogen.nimh.nih.gov
        newshost.uni-koblenz.de
        nextstat1.physics.ox.ac.uk
        nic.uakom.sk
        nile.informatik.uni-freiburg.de
        nina.pagesz.net
        njl2.materials.ox.ac.uk
        nmho05u.rohmhaas.com
        noho.demon.co.uk
        nueva.nuclecu.unam.mx
        odin.appliedtheory.com
        oz.cableview-online.com
        panic.lut.ac.uk
        pb.cache.nlanr.net
        pc-9202.on.rogers.wave.ca
        pearl.ge.com
        perplex.eagle.y.se
        persephone.tippett.com
        phaedrus.uchicago.edu
        pir2cache.utc.fr
        pm3-tor-17.passport.ca
        pm55-18.magicnet.net
        pol1.phy.cam.ac.uk
        poplar.cs.brown.edu
        poppy.hensa.ac.uk
        ppp-101.starnet.com.eg
        ppp-18.sierranet.net
        ppp033-sf2.sirius.com
        ppp213.Ins-CoIn.DE
        ppp24.cuug.ab.ca
        ppp31-ts2.pdnt.com
        proxy.camelot.de
        proxy00.TokyoNet.AD.JP
        proxy1.disney.com
        red2.sqla.com
        reddy.rhythm.com
        rira.ucsd.edu
        rorschach.cec.jyu.fi
        rtio-ss20.cisco.com
        rulcmc.LeidenUniv.nl
        s.sh.shr.shro.shroo.shroom.shrooms.com
        s10-pm01.clemson.campus.mci.net
        sammyman.digop.com
        santos.pentacom.co.uk
        schullin.co.at
        sdn-ts-021txfwoRP13.dialsprint.net
        sea-ts4-p32.wolfenet.com
        sentinel.sonalysts.com
        sesmith-ultra.cisco.com
        sextans124.wco.com
        sf-pm5-30-94.dialup.slip.net
        sf-pm8-25-185.dialup.slip.net
        shell3.ba.best.com
        shiva2-n4-ip218-toronto.ica.net
        sierra.sci-park.uunet.pipex.com
        sj-cse112-sun.cisco.com
        sjx-ca13-24.ix.netcom.com
        sjx-ca36-15.ix.netcom.com
        sjx-ca86-13.ix.netcom.com
        skennedy-sun.cisco.com
        skoda2.skoda-auto.cz
        sl05.pc.chemie.th-darmstadt.de
        slave.sci.co.uk
        sn44h64.next.com
        snafu.rutgers.edu
        sp052.cern.ch
        speak.atc.missouri.edu
        sqcisco.squeep.prado.com
        ss9-16.inre.asu.edu
        sunsite.ms.mff.cuni.cz
        sunsrv8.lrz-muenchen.de
        supernova.madcoyote.com
        theskye.uoregon.edu
        tidal.tessier.com
        tide09.microsoft.com
        tide11.microsoft.com
        tide14.microsoft.com
        tide22.microsoft.com
        tide26.microsoft.com
        tide27.microsoft.com
        toaster.cac.psu.edu
        toutatis.xs4all.nl
        ts006d03.cht-ma.concentric.net
        ts015d06.cht-ma.concentric.net
        ts060d05.lax-ca.concentric.net
        ts3310.SLIP.ColoState.EDU
        tvinput.materials.ox.ac.uk
        uc.cache.nlanr.net
        unknown-151-212.segasoft.com
        unknown-151-248.segasoft.com
        unknown-23-144.mattel.com
        urns.kerner.com
        usr21-95.dial.roc.frontiernet.net
        verdi.et.tudelft.nl
        vl22.pi.net
        vl41.pi.net
        vl48.pi.net
        vl57.pi.net
        vl63.pi.net
        vladimir-pc.cisco.com
        vortex.engr.ucdavis.edu
        wahoo.eecs.wsu.edu
        webcache.manawatu.gen.nz
        wi1p.pr.mcs.net
        wot.cisco.com
        www-cache.funet.fi
        www-proxy.ingenia.com
        www-proxy01.germany.eu.net
        www.xlink.net
        www2.rrz.uni-hamburg.de
        wwwdec.cern.ch
        yodo.uam.mx
        zeus.stjohns.co.uk
-- 
Peace, Ariel

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 23 Jul 1997 04:49:10 +0200 (MET DST)

> from the following sites:

I'm also surprised, especially because a search on Altavista found just
one single reference to *.linux.sgi.com in a German newgroup, Dejanews
didn't find any references.

  Ralf

---

From: Mike Shaver <[email-masked]>
Date: Wed, 23 Jul 1997 00:48:45 -0400 (EDT)

>         idnewt.idsoftware.com

Ah, yes.
I was talking to John Carmack about Quake 2, Linux, GL hardware and
such, and while the Indy's not suitable (only gouraud, and Q2 needs
texture mapping), the O2 would be.  If we can get Linux ported to the
O2 as well, we can very likely get a Quake II port.

>         snafu.rutgers.edu

This is suspicious.
Should we be controlling access to linus?

Mike

-- 
#> Mike Shaver ([email-masked]) Ingenia Communications Corporation 
#>       Chief System Architect -- Head geek -- System exorcist        
#>                                                                     
#>   "Have you considered a life?  I hear they're quite affordable     
#>          these days." --- [email-masked]

---

From: Bob Mende Pie <[email-masked]>
Date: Tue, 22 Jul 1997 22:18:04 -0700 (PDT)

> Should we be controlling access to linus?

This is most likely davem ... snafu is a system at the caip center, where
he does most of his work.

                    /Bob...                    mailto:[email-masked]
              http://reality.sgi.com/mende            KF6EID

---

From: Mike Shaver <[email-masked]>
Date: Wed, 23 Jul 1997 01:43:51 -0400 (EDT)

Thus spake Bob Mende Pie:
> This is most likely davem ...

My point exactly.

Mike

-- 
#> Mike Shaver ([email-masked]) Ingenia Communications Corporation 
#>            Chief System Architect and Herder of Bits                
#>                                                                     
#> "Yoda say, `Just slap a little public key crypto into it' does not  
#>      a secure system make." -- Marcus J. Ranum ([email-masked])

---

From: [email-masked] (Alan Cox)
Date: Wed, 23 Jul 1997 20:33:53 +0100 (BST)

> didn't find any references.

Altavista doesnt archive linuxnet:#linux

Alan

---

From: Alex deVries <[email-masked]>
Date: Wed, 23 Jul 1997 22:03:44 -0400 (EDT)

Good news from the east coast of the US!

To begin with, I was happy to see two very large boxes getting dropped off
at my cubicle around 2pm this afternoon from SGI.  Had I not been in the
middle of fighting a million other fires this afternoon (multiple
billings, crashed hard disks, etc) I would have opened it sooner.

I know that Ariel has gone through a lot to get the volunteers hardware,
and it says a lot about his hard work and determination that I have an
Indy on my desk right now. SGI Linux would be very difficult to get
running without the input of him and SGI. This _is_ going to work well. 

A few beers are owed to David Kascht for setting up my system properly,
and for getting the machine out the door in Mountainview.  His efforts are
greatly appreciated.

But, at 7:30pm I started unpacking, and by 8:15 I had Irix functional. 
Setting up bootp, tftpd, nfs, etc was easy (note to self:  remember to
restart inetd, remember to restart inetd...), and the whole thing booted
as of about 9:15. The cleaners are still looking at me funny from my loud
cheers.

I'm using Mike's vmlinux version 2.1.43 (11MB!), and the
root-be-0.0.cpio.gz (thanks, Ralf!) root file system.

I'm now sorting out why I can't write to the fs, I think it's because I
had forgotten to modify it's /etc/mtab or such.  No problem, I expect.

So, all I need is fdisk, and we're really rocking...

I've been documenting more specifically, and I will be creating the HOWTO
installation parts tomorrow night.

The plan for my machine (Red) is to host it here at work (as
alex3.med.iacnet.com) behind a firewall until SGI Linux is a bit further
ahead, or until I get an ISDN line (which I will for certain, once I
move).  Red is an Indy with 2 1GB drives, 64MB and ISDN. 

Again, huge thanks to SGI.  I promise to contribute in order to make it
worth their while.

- Alex

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 24 Jul 1997 04:17:26 +0200 (MET DST)

Hi,

> I'm using Mike's vmlinux version 2.1.43 (11MB!), and the

*Brrr*  why are you using a kernel with debugging info?

  Ralf