Subject: Re: How to get the masses (IRIX<->Linux) (fwd)

From: [email-masked] (Ariel Faigon)
Date: Thu, 10 Jul 1997 15:02:03 -0700 (PDT)

[I'm forwarding this very helpful hint from Christian to the list
 not sure if all our audience, especially those outside SGI are aware
 of all these options.]

Now since after setting nvram it'll always boot Linux ;-)
the question is how to toggle two different (Linux/IRIX)
nvram settings in a friendly trivial way...

Looks like a SILO option after the wakup/reboot would be the best.

	Press 1 to boot IRIX [default]
	Press 2 to boot Linux

----- Forwarded message from Christian Reisch -----

>From [email-masked]  Thu Jul 10 14:52:45 1997
Sender: [email-masked]
Date: Thu, 10 Jul 1997 14:52:39 -0700
From: Christian Reisch <[email-masked]>
To: Ariel Faigon <[email-masked]>
Subject: Re: How to get the masses (IRIX<->Linux)

Ariel Faigon wrote:

>         % su
>         # at 5am July 3
>         /usr/sbin/wakeupat 6pm Thursday
>         /etc/shutdown -y
>         <Ctl-d> (control - d)  This will submit the job.
>         # exit
> 
> If we could rewrite wakeupat or reboot to take some
> extra boot options or alternatively run some Linux loader
> (SILO/MILO) from IRIX then 2) should be easy.
> 
>

	I think irix decides where to boot from from these nvram variable...

SystemPartition=pci(0)scsi(0)disk(1)rdisk(0)partition(8)
OSLoadPartition=pci(0)scsi(0)disk(1)rdisk(0)partition(0)
OSLoader=sash
OSLoadFilename=/unix
OSLoadOptions=auto

You could write a script to fudge them with the nvram command then
shutdown and wake up.  Unfortunately I don't have the disk/time to play
with it at the moment

6

----- End of forwarded message from Christian Reisch -----

-- 
Peace, Ariel

---

From: "Christopher W. Carlson" <[email-masked]>
Date: Fri, 11 Jul 1997 11:02:58 -0700

On Jul 10,  3:02pm, Ariel Faigon wrote:
> Subject: Re: How to get the masses (IRIX<->Linux) (fwd)
>-- End of excerpt from Ariel Faigon

Actually, we frequently have two versions of IRIX that we need to
boot each from a different disk drive.  We have a shell script which
root can run which sets up nvram so that the next time we reboot, it
will come up in the other OS.  Here's the script below:

#!/bin/sh
#
# Usage: switch_os 6.2 switches to 6.2
#        switch_os 6.5 switches to 6.5

if [ $# -lt 1 ] ; then
  echo "Usage: switch_os <6.2|6.5>"
  exit
fi
if [ $1 != "6.2" -a $1 != "6.5" ] ; then
  echo "Usage: switch_os <6.2|6.5>"
  exit
fi
if [ $1 = "6.2" ] ; then
  sys_part="scsi(0)disk(1)rdisk(0)partition(8)"
  os_load="scsi(0)disk(1)rdisk(0)partition(0)"
else
  sys_part="scsi(0)disk(3)rdisk(0)partition(8)"
  os_load="scsi(0)disk(3)rdisk(0)partition(0)"
fi
echo "rebooting venus to use $1 in 5 seconds..."
sleep 5
/sbin/nvram SystemPartition $sys_part
/sbin/nvram OSLoadPartition $os_load
/etc/reboot

-- 

		Chris Carlson

	+------------------------------------------------------+
	| Also, [email-masked]                                |
	|   Work:   (714) 224-4530                             |
	|   Vnet:       6-678-4530     FAX:    (714) 833-9503  |
	|                                                      |
	| Trivia fact: an electroencephalogram shows that a    |
	| human brain and a bowl of quivering lime Jell-O have |
	| the same waves.  [Time Magazine, Mar 17, 1997]       |
	+------------------------------------------------------+