Subject: "unable to handle kernel paging request" at boot

From: Oliver Frommel <[email-masked]>
Date: Thu, 21 Aug 1997 03:13:07 +0200 (MET DST)

hi,

after i was finally able to free and Indy from useless tasks like DNS, mail, www
:) i have now problems booting the machine.
after/at start of the Ethernet driver i get the following message:

eth0 SGI Seeq ....
Unable to handle kernel paging request at 00000008, epc: 880d8a64

what's going wrong ?

oliver

---

From: Eric Kimminau <[email-masked]>
Date: Wed, 20 Aug 1997 23:14:53 -0400

> Unable to handle kernel paging request at 00000008, epc: 880d8a64

Ill put $100.00 US that you have an R4000 or R4400 Indy NOT an R4600.

The only system we have been able to boot is an R4600 with the kernel we
pulled down off ftp.

-- 
Eric Kimminau                             System Engineer
[email-masked]                       Silicon Graphics, Inc
Vox:(810) 848-4455                        39001 West 12mile Road
Fax:(810)848-5600                         Farmington, MI 48331-2903
            "I speak my mind and no one else's."
    http://www.dcs.ex.ac.uk/~aba/rsa/perl-rsa-sig.html

-----END PGP PUBLIC KEY BLOCK-----
http://bs.mit.edu:11371/pks/lookup?op=vindex&search=Eric+A.+Kimminau&fingerprint=on

---

From: Oliver Frommel <[email-masked]>
Date: Thu, 21 Aug 1997 07:12:15 +0200 (MET DST)

> pulled down off ftp.

yeah .. it's a 4400 .. i did all previous sgilinux work on a R5000 though, FYI

o.

---

From: Eric Kimminau <[email-masked]>
Date: Thu, 21 Aug 1997 09:31:15 -0400

> yeah .. it's a 4400 .. i did all previous sgilinux work on a R5000 though, FYI

WHOOHOO!  DOes that mean you owe me $100.00?  :)

Agreed on the R5k working. Dunno why R4400 doesnt. 

-- 
Eric Kimminau                           System Engineer/RSA
[email-masked]                     Silicon Graphics, Inc
Voice: (248) 848-4455                   39001 West 12 Mile Rd.
Fax:   (248) 848-5600                   Farmington, MI 48331-2903

                 VNet Extension - 6-327-4455
              "I speak my mind and no one else's."
       http://www.dcs.ex.ac.uk/~aba/rsa/perl-rsa-sig.html

    When confronted by a difficult problem, solve it by reducing 
    it to the question, "How would the Lone Ranger handle this?"

Windows 95: n.
    32 bit extensions and a graphical shell for a 16 bit patch to an
    8 bit operating system originally coded for a 4 bit microprocessor,
    written by a 2 bit company that can't stand 1 bit of competition.

    Author unknown.

---

From: Miguel de Icaza <[email-masked]>
Date: Thu, 21 Aug 1997 10:58:26 -0500

> Unable to handle kernel paging request at 00000008, epc: 880d8a64

What kernel are you using?

Miguel.

---

From: Miguel de Icaza <[email-masked]>
Date: Thu, 21 Aug 1997 11:05:25 -0500

> The only system we have been able to boot is an R4600 with the kernel we

Can you both guys fetch this kernel:

	ftp://ftp.nuclecu.unam.mx/incoming/vmlinux 

and send me the output of the crash? 

Miguel.

---

From: Eric Kimminau <[email-masked]>
Date: Thu, 21 Aug 1997 13:43:55 -0400

> and send me the output of the crash?

Well, when we got word yesterday that 4600's were working, we swapped
the CPU module on linux.detroit to an R400 and we are working that way
towards getting a bootable system.

We are still having problems getting a boot via nfs to work.

Things would be a whole lot simpler if we could mke2fs on a disk while
booting IRIX, mount it and copy all the stuff over before trying to boot
linux.

Windows 95: n.

    Author unknown.

---

From: Alex deVries <[email-masked]>
Date: Thu, 21 Aug 1997 14:23:44 -0400 (EDT)

> We are still having problems getting a boot via nfs to work.

What problems are you having, exactly?  These should be pretty easy to
solve.  Mind you, just popping vmlinux on Irix's /, and booting with the
boot monitor with:
vmlinux nfsroot=bl.ea.h:/sgi-linux

works very easily, and saves the whole problem of having to setup
tftpboot, etc.

> booting IRIX, mount it and copy all the stuff over before trying to boot

mke2fs does exist for Irix; check out the e2fs tools that are precompiled
and sitting on ftp.linux.sgi.com.  It's in the misc directory.  Actually
copying them over is a problem, though, since Irix can't read ext2.

I have a ramdisk setup, I just need to test it.  

- Alex

---

From: Oliver Frommel <[email-masked]>
Date: Fri, 22 Aug 1997 12:45:18 +0200 (MET DST)

> and send me the output of the crash? 

now i get 

"Unable to handle kernel paging request at virtual address 00003004, epc == 
 880cb0d4, ra == 880cb698"

funny, i now get a scsi error after successfully (?) passing the eth driver 
init:

sda: scsi disk I/O error dev 08:00, sector 0
unable to read part. table

i guess that'd impose some problems to fdisk, too :)

o.

---

From: Oliver Frommel <[email-masked]>
Date: Sat, 23 Aug 1997 18:02:10 +0200 (MET DST)

hello,

now i put r4k_show_regs() right after  printk(KERN_ALERT "Unable to handle.."
into fault.c and get the following output (using kernel linux-970704, btw :)

$0 : 00000000 1004fc00 00000010 00000000
$1 : 00000010 00000000 1fffffff 00000000
$2 : 89f772b8 00000000 00000000 00000000
$12: 00000008 00000282 88368038 1004fc01
$16: 89f77000 8811d2f8 00000005 8810317c
$20: bfb34000 bfbd4000 00000003 00000000
$24: 00000000 0000000f
$28: 566a6ead 89f91da0 00000001 880d8f04
epc   : 880d8f24
Status: 1004fc03
Cause : 1000000c

my System.map shows this:
880d8d74 t sgiseeq_set_multicast
880d8d7c T sgiseeq_init
880d9084 T sgiseeq_probe

gdb disas this:
0x880d8f18 <sgiseeq_init+412>:  move $v1,$a3
0x880d8f1c <sgiseeq_init+416>:  addu $v0,$a3,$a0
0x880d8f20 <sgiseeq_init+420>:  and $v0,$v0,$a2
0x880d8f24 <sgiseeq_init+424>:  sw $v0,8($v1)

dunno if that helps :)

o.