Subject: Re: What works - what doesn't

From: Miguel de Icaza <[email-masked]>
Date: Tue, 19 Aug 1997 10:25:48 -0500

Hello Stephen,

>    I have just tested booting linux using nfs on 6 indys. I have the following
> results :
> Error :
> 
> Unable to handle kernel paging request at virtual address 00000008, epc ==
> 880cbc5c , ra == 880cbc3c

Can you tell us which kernel you are using?  Did you compile it
yourself?  In that case, can you look up the epc and ra addresses on
the System.map file and tell us where those addresses fall?

Cheers,
Miguel.

---

From: Eric Kimminau <[email-masked]>
Date: Tue, 19 Aug 1997 14:06:50 -0400

YES!  WE ARE NOT INSANE!!!  WE WERE DOING EVERYTHING RIGHT!

Ugh... :)

Stephen Gass wrote:
> Hi All,
> The following systems worked. Notice that the ones that worked are all R4600
> based CPUs with varying memory, CPU speed , CPU cache and Newport graphics
> options. The Indys I couldn't get to boot from a NFS server were all R4400
> based systems !
> 
> ------------------------------------------------------------------------------
> 
> Iris Audio Processor: version A2 revision 4.1.0
> 1 100 MHZ IP22 Processor
> FPU: MIPS R4610 Floating Point Chip Revision: 2.0
> CPU: MIPS R4600 Processor Chip Revision: 2.0
> On-board serial ports: 2
> On-board bi-directional parallel port
> Data cache size: 16 Kbytes
> Instruction cache size: 16 Kbytes
> Main memory size: 96 Mbytes
> Integral ISDN: Basic Rate Interface unit 0, revision 1.0
> Integral Ethernet: ec0, version 1
> Integral SCSI controller 0: Version WD33C93B, revision D
> Disk drive: unit 3 on SCSI controller 0
> Disk drive: unit 1 on SCSI controller 0
> Graphics board: Indy 8-bit
> Vino video: unit 0, revision 0, IndyCam connected
> 
> -----------------------------------------------------------------------------
> 
> Iris Audio Processor: version A2 revision 4.1.0
> 1 133 MHZ IP22 Processor
> FPU: MIPS R4600 Floating Point Coprocessor Revision: 2.0
> CPU: MIPS R4600 Processor Chip Revision: 2.0
> On-board serial ports: 2
> On-board bi-directional parallel port
> Data cache size: 16 Kbytes
> Instruction cache size: 16 Kbytes
> Secondary unified instruction/data cache size: 512 Kbytes on Processor 0
> Main memory size: 96 Mbytes
> Vino video: unit 0, revision 0, IndyCam connected
> Integral ISDN: Basic Rate Interface unit 0, revision 1.0
> Integral Ethernet: ec0, version 1
> Integral SCSI controller 0: Version WD33C93B, revision D
>   Scanner: unit 7 on SCSI controller 0
>   Disk drive: unit 1 on SCSI controller 0
> Graphics board: Indy 24-bit
> 
> N.B. - Worked only after removing the scanner !
> 
> -----------------------------------------------------------------------------
> 
> Iris Audio Processor: version A2 revision 4.1.0
> 1 133 MHZ IP22 Processor
> FPU: MIPS R4600 Floating Point Coprocessor Revision: 2.0
> CPU: MIPS R4600 Processor Chip Revision: 2.0
> On-board serial ports: 2
> On-board bi-directional parallel port
> Data cache size: 16 Kbytes
> Instruction cache size: 16 Kbytes
> Secondary unified instruction/data cache size: 512 Kbytes on Processor 0
> Main memory size: 96 Mbytes
> Vino video: unit 0, revision 0, IndyCam connected
> Integral ISDN: Basic Rate Interface unit 0, revision 1.0
> Integral Ethernet: ec0, version 1
> Integral SCSI controller 0: Version WD33C93B, revision D
>   Disk drive: unit 1 on SCSI controller 0
> Graphics board: Indy 24-bit
> 
> -----------------------------------------------------------------------------
> 
> Iris Audio Processor: version A2 revision 4.1.0
> 1 133 MHZ IP22 Processor
> FPU: MIPS R4600 Floating Point Coprocessor Revision: 2.0
> CPU: MIPS R4600 Processor Chip Revision: 2.0
> On-board serial ports: 2
> On-board bi-directional parallel port
> Data cache size: 16 Kbytes
> Instruction cache size: 16 Kbytes
> Secondary unified instruction/data cache size: 512 Kbytes on Processor 0
> Main memory size: 64 Mbytes
> Vino video: unit 0, revision 0, IndyCam connected
> Integral ISDN: Basic Rate Interface unit 0, revision 1.0
> Integral Ethernet: ec0, version 1
> Integral SCSI controller 0: Version WD33C93B, revision D
>   CDROM: unit 4 on SCSI controller 0
>   Disk drive: unit 2 on SCSI controller 0
>   Disk drive: unit 1 on SCSI controller 0
> Graphics board: Indy 24-bit
> 
> ------------------------------------------------------------------------------
> 
> The following systems did not work :
> 
> ------------------------------------------------------------------------------
> 
> Iris Audio Processor: version A2 revision 4.1.0
> 1 150 MHZ IP22 Processor
> FPU: MIPS R4000 Floating Point Coprocessor Revision: 0.0
> CPU: MIPS R4400 Processor Chip Revision: 5.0
> On-board serial ports: 2
> On-board bi-directional parallel port
> Data cache size: 16 Kbytes
> Instruction cache size: 16 Kbytes
> Secondary unified instruction/data cache size: 1 Mbyte on Processor 0
> Main memory size: 64 Mbytes
> Vino video: unit 0, revision 0, IndyCam not connected
> Integral ISDN: Basic Rate Interface unit 0, revision 1.0
> Integral Ethernet: ec0, version 1
> Integral SCSI controller 0: Version WD33C93B, revision D
>     Disk drive / removable media: unit 2 on SCSI controller 0
>   Disk drive: unit 1 on SCSI controller 0
> Graphics board: Indy 24-bit
> 
> Error :
> 
> -----------------------------------------------------------------------------
> 
> Iris Audio Processor: version A2 revision 4.1.0
> 1 200 MHZ IP22 Processor
> FPU: MIPS R4000 Floating Point Coprocessor Revision: 0.0
> CPU: MIPS R4400 Processor Chip Revision: 6.0
> On-board serial ports: 2
> On-board bi-directional parallel port
> Data cache size: 16 Kbytes
> Instruction cache size: 16 Kbytes
> Secondary unified instruction/data cache size: 1 Mbyte
> Main memory size: 64 Mbytes
> Integral ISDN: Basic Rate Interface unit 0, revision 1.0
> Integral Ethernet: ec0, version 1
> Integral SCSI controller 0: Version WD33C93B, revision D
> Disk drive: unit 4 on SCSI controller 0
> Disk drive: unit 3 on SCSI controller 0
> Disk drive: unit 2 on SCSI controller 0
> Disk drive: unit 1 on SCSI controller 0
> Graphics board: Indy 24-bit
> Vino video: unit 0, revision 0, IndyCam connected
> 
> Error :
> 
> -----------------------------------------------------------------------------
> 
> --
> Silicon Graphics Pty Ltd    |  E-mail: [email-masked]
> 446 Victoria Rd             |  Phone : +61-2-9879-9500  VM#: 56721
> Gladesville, 2111, NSW      |  Mobile :+61-419-879-504
> 
>       "Force - the result of pushing on a door marked pull"

-- 
Eric Kimminau                           System Engineer/RSA
[email-masked]                     Silicon Graphics, Inc
Voice: (248) 848-4455                   39001 West 12 Mile Rd.
Fax:   (248) 848-5600                   Farmington, MI 48331-2903

                 VNet Extension - 6-327-4455
              "I speak my mind and no one else's."
       http://www.dcs.ex.ac.uk/~aba/rsa/perl-rsa-sig.html

    When confronted by a difficult problem, solve it by reducing 
    it to the question, "How would the Lone Ranger handle this?"

Windows 95: n.
    32 bit extensions and a graphical shell for a 16 bit patch to an
    8 bit operating system originally coded for a 4 bit microprocessor,
    written by a 2 bit company that can't stand 1 bit of competition.

    Author unknown.

---

From: "Stephen Gass" <[email-masked]>
Date: Tue, 19 Aug 1997 14:25:14 -0500

Hi All,

Error :

Error :