Subject: Indy netboot problems

From: Charles Lepple <[email-masked]>
Date: Wed, 24 Sep 1997 17:37:26 -0400

Hello all,
Sorry to bother you if this is a routine question, but I read the FAQ, and 
therein lies my problem.

I'm trying to make an Indy netboot, but I'm not too familiar with the new 
monitor (let's just say that I knew sifex much better...Anyone remember the 
IRIS 3130s?). I need a way to correct the HW address, since it appears to be 
set to '0:0:FF:FF:0:0', and it is complaining about it.

Is there any other way to change nvram settings except through the 
setenv/printenv commands?

I hope to be contributing to this project soon, but I'm off to a fairly rocky 
start ;-)

Thanks in advance,

--Charles Lepple, <[email-masked]>
<[email-masked]>
http://www.ee.vt.edu/solarcar/
http://www.mitre.org/research/nanotech/

---

From: "William J. Earl" <[email-masked]>
Date: Wed, 24 Sep 1997 15:23:52 -0700

> setenv/printenv commands?
...

      "setenv -p xxx yyy" will set xxx permanently (in NVRAM) to yyy.  Without
the "-p", it just sets xxx in the environment in memory.  For the hardware
address ("eaddr"), however, you cannot readily change it, as it is the
system serial number as well as the MAC address.  I don't know any easy
way for it have been corrupted; it would normally be fixed by field service.

---

From: Alistair Lambie <[email-masked]>
Date: Thu, 25 Sep 1997 12:50:18 +1200

> setenv/printenv commands?

You can not change this with setenv.  If it is '0:0:FF:FF:0:0' there is
a fault and you need to get the motherboard replaced.  It is probably
the 'Dallas Chip' that is the problem.  I have twice seen where a pin
gets bent on this and it returns funny MAC adresses....so if you have
some hardware knowledge it may be worth checking that it is seated
correctly and the pins are not bent.

Cheers, Alistair

-- 
Alistair Lambie					    [email-masked]
Silicon Graphics New Zealand				  SGI Voicemail: 56791
Level 5, Walsh Wrightson Tower,				    Ph: +64-4-802 1455
94-96 Dixon St, Wellington, NZ			  	   Fax: +64-4-802 1459