Subject: Step by step, cont'd

From: Emmanuel Mogenet <[email-masked]>
Date: Fri, 24 Oct 1997 16:15:55 -0700

Today, I tried to boot Linux on my Indy with an NFS mounted
root. Failed again. Here's what I did:

1. Installed the root tree on machine 192.0.2.15, in /disk4
2. Configured bootp on machine 192.0.2.3 so that it could inform
   my machine that it's address is 192.0.2.2.
3. Rebooted my machine
4. Went to sash.
5 Typed:

scsi(0)disk(1)rdisk(0)partition(0)/vmlinux nfsroot=192.0.2.15:/disk4

So far, so good.

5. The linux kernel booted, and said:

Root-NFS: Got BOOTP answer from 192.0.2.3, my address is 192.0.2.2
Root-NFS: Adding default route failed!
Root-NFS: Unable to contact server ...

Anybody knows why it couldn't add a route ?
I'm using the following kernel:

	vmlinux-970916-efs

I'm going to try an older one.

	- Mgix

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 25 Oct 1997 01:57:24 +0200 (MEST)

> I'm going to try an older one.

I've you've got a working crosscompiler, try building one of the most
current ones.  The bug you're reporting is fixed in current kernels.

  Ralf

---

From: Emmanuel Mogenet <[email-masked]>
Date: Fri, 24 Oct 1997 17:22:33 -0700

> current ones.  The bug you're reporting is fixed in current kernels.

Ok, I've dowloaded the cross-compiling environment from
ftp://ftp.linux.sgi.com/pub/crossdev/mips-sgi-irix6.2/mips-linux

but where do I get the latest kernel sources from ?

Is the SGI port back into the standard ports on the net ?

	- Mgix