Subject: Re: Problems with booting SGI/Linux

From: "Michael Hill" <[email-masked]>
Date: Sat, 29 Nov 1997 15:03:47 -0500

>
> > :PROMLIB: SGI ARCS firmware Version1 Revision 10
> > :PROMLIB: Total free ram 31502336 bytes (...)
> > :ARCH: SGI-IP22
> > :CPU: MIPS-R4600 FPU<MIPS-R4600FPC> ICACHE DCACHE
> > :Loading R4000 MNV routines
> > :CPU revision is: 00002020
>                         ^^^^

Ditto (for the most part).

> That's a R4600 V2.0.  The kernel sources/binaries on Linus don't handle
> the silicon bugs of this beast correctly.  I fixed the problem this
> morning testing them on a SNI RM200.  For a proof of the test I compiled
> X a couple of times; the box now looks stable even under high load.  Will
> commit the bug fixes shortly.

This is a huge relief since I didn't know what to try next (haven't been able
to compile a kernel).  Ralf,  where can I access your committed bug fixes?  Any
chance of someone posting a compiled kernel incorporating these to
ftp.linux.sgi.com?

Thanks,

Mike

--
Michael Hill
Toronto, Canada
[email-masked]

---

From: [email-masked]
Date: Sun, 30 Nov 1997 01:25:55 +0100

> > commit the bug fixes shortly.

Bad luck, my box is still not stable even though this bug has been fixed.

> to compile a kernel).  Ralf,  where can I access your committed bug fixes?
> Any chance of someone posting a compiled kernel incorporating these to
> ftp.linux.sgi.com?

I'm working on it.  There are several issues that will take me a couple
of days to work them out.  My two main projects are

 - rebuilding RedHat 4.9.1 for big endian MIPS (like the Indy).  This is
   the most urgent part and I'm working (well, my Indy ...) on it.
 - my kernel tree has diverged significantly from what were publishing
   on Linus.  Have to merge them both.

You can usually get the bugfixes from the kernel sources/binaries available
on Linus.  The last one is a bit old, though ...

  Ralf

---

From: Alex deVries <[email-masked]>
Date: Sun, 30 Nov 1997 01:55:31 -0500 (EST)

They're available now:

ftp://ftp.engsoc.carleton.ca/pub/redhat-5.0/srpms/

- Alex

      Alex deVries          Rent this space for a $5 donation 
  System Administrator      to EngSoc per day.
   The EngSoc Project       Send spam to [email-masked].