Subject: Re: Pentium F00F bug Linux workaround; BSDI Response

From: [email-masked] (William Fisher)
Date: Mon, 17 Nov 1997 13:28:20 -0800 (PST)

Here is the response I got from BSDI on the Pentium F00F bug fix.

-- Bill
-----------------------
>From [email-masked]  Sat Nov 15 09:32:26 1997
Date: Sat, 15 Nov 1997 11:32:42 -0600 (CST)
From: David Borman <[email-masked]>
Message-Id: <[email-masked]>
To: [email-masked]
Subject: Re: Pentium F00F bug Linux workaround

Hi Bill,

> Is this true that:
> 
> "BSDI signed an NDA with Intel to get early fix techniques"?
> 
> ...
> Subject: Re: Pentium F00F bug Linux workaround
> References:  <199711142117.NAA27890@.....>
> Sender: owner-linux@cthulhu
> Precedence: bulk
> 
> We also got some good press from it pretty fast after we released the fixes:
> 
> http://www.news.com/News/Item/0,4,16312,00.html
> 
> Whats extremely humorous is that BSDI signed an NDA with Intel to get
> early fix techniques told to them by Intel engineers.  But the NDA
> stated they could not release patch sets for BSDI until Intel said so,
> the thinking on Intel's part is that they wanted nobody to be the
> first with a fix.  BSDI overlooked this and put the fix out, then
> quickly took the fixes down once they released they had breached the
> Intel NDA.
> 
> After the Linux fix was already out, Intel engineers spoke with Linus
> and tried to get him to sign an NDA, I've never laughed so hard in my life.
>
Hmm... The Linux message is not accurate.  At no time has BSDI violated
any agreements with Intel.  The first patch that we put up was a beta
patch.  It solves the problem, but we made some minor improvements on
it in our official patch.

I'll also point out that Intel called us.  From our official patch:

	BSDI has worked closely with Intel since they contacted us about
	this erratum. We were able to develop a workaround for BSD/OS very
	quickly, and Intel's assistance was invaluable in this process.
	BSDI is confident that the software workaround solves this problem
	for our customers.
	...
	Thanks to Intel Corporation for contacting BSDI with data that
	led to the fix.

Also, though I don't personally have anything to support this, it is our
understanding that the Linux fix was based at least in part upon
disassembling our beta patch.

I've attached our "press release".

		-David Borman, [email-masked]

FOR IMMEDIATE RELEASE
Contact:	Donna Faulkner
		Baron, McDonald & Wells
		770/492-0373
		[email-masked]

First Intel Pentium Processor 'F0' Bug Fix Announced for BSDI ISP Customers

ISPs and other users of BSD/OS can be protected against system 'freezes'
caused by illegal code strings 

COLORADO SPRINGS, Co.  (November 17, 1997)

Internet Service Providers (ISPs) and other users of the BSD/OS can now protect themselves against problems associated with the 'F0' bug discovered in Intel's Pentium processor.  Berkeley Software Design, Inc. (BSDI) today announced a patch that protects companies running BSD/OS 3.1, 3.0, 2.1 against system freezes caused when the processor receives an illegal, one-line instruction.  
	BSDI's patch enables the BSD/OS to gain control whenever an invalid sequence is executed, enabling the system to take its normal action in response to illegal instructions.  The patch offers a solution to more than 7,000 organizations and companies relying on the BSD/OS, including over 3,000 ISPs worldwide.  ISPs are particularly vulnerable to system attacks based on the Pentium processor bug, since any user or subscriber with malicious intent has the potential to create a system-wide hang-up.

	"BSDI has developed an outstanding reputation for rapid response to attacks," said Mike Karels, vice president of engineering for BSDI.  "Last summer, we were the first commercial vendor to provide a defense against 'SYN-flooding' attacks.  This week, we have once again demonstrated industry-leading support for our customers."

The BSD/OS patch is downloadable from the company's web site at
	http://www.bsdi.com. 
Berkeley Software Design, Inc. is the commercial supplier of the
high-performance BSD Internet and networking system software originally
developed at the University of California, Berkeley.

Internet experts worldwide are powering the networked economy with over 75,000 deployed servers running BSDI software engines and applications.  BSDI products for Intel-based PC platforms include the BSDI Internet Server, BSD/OS, and network software for networking appliance developers.  BSDI customers include Adobe Systems, Chase Manhattan Bank, CompuServe, U.S. West, UUNET Technologies, Volvo, and leading Internet Service Providers worldwide.  BSDI is privately held and headquartered in Colorado Springs, Colorado.  Contact BSDI at 719-593-9445, [email-masked] or http://www.bsdi.com.

BSDI, BSD/OS and the BSDI logo are trademarks of Berkeley Software Design, Inc.  All other product or service names are trademarks of their respective owners.

---

From: "David S. Miller" <[email-masked]>
Date: Mon, 17 Nov 1997 15:23:46 -0800

I'm going to choose more lightly what I decide to post here if it's
going to make it's way to every tom, dick, and harry out there in the
unix industry...

Fact is that Intel was trying to make sure _no_ vendor had a fix out
before anyone else.  If it was not explicitly stated in the NDA they
signed with Intel, this was a mistake and not what was intended.

Now that you've talked to Borman about this fish, ask him why he had
to take the patch set down within a day or so.  If he says "because it
was a BETA patch set", I'd find his response hard to believe.

Intel engineers internally were working themselves on fixes for
various systems that they did have source to (Linux, maybe
{net,free}BSD and a few others) and planned to release those patch
sets and allow vendors to release their own patches at the same exact
time.

BSDI putting out their patch ahead of that point in time was, if
anything, totally against how Intel wanted things happen.

Later,
David S. Miller
[email-masked]

---

From: [email-masked] (Alan Cox)
Date: Mon, 17 Nov 1997 23:56:37 +0000 (GMT)

> anything, totally against how Intel wanted things happen.

Dave talk this off list. And if you are going to say things like
"XYZ violated their NDA" expect them to both hear about it and reply. Fair's
fair.