Subject: Re: Announce: New uploads

From: Joe Alonso <[email-masked]>
Date: Thu, 11 Dec 1997 09:50:39 -0500

Pardon my ignorance, but...
I have a couple of questions;  
is there a how-to document that outlines how to load linux on an sgi?
is the Indigo Elan (r4000) supported?

I'm not sure how to initialize a loading of linux on the sgi.
Here's what I've assumed:
- bring over the src's to the sgi
- compile a basic system (under irix)
- copy over the original irix kernel with the new linux kernel
- re-boot

The begging questions:
The FS are not compatible, therefore a new mkfs has to be done on the
(root) partitions.
This just doesn't "sound" right to me. 
What am I overlooking?

ja

Ralf Baechle wrote:
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> 
> Hi all,
> 
> ok, here are the toys I promised to upload to ftp.linux.sgi.com:
> 
>  - tons of srpms some of which have been modified compared to RedHat's
>    original versions for the ``Mustang'' release and  big endian binaries.
>  - tarballs of libc binaries.
>  - srpms and both big and little endian binaries of an updated binutils
>    package.
>  - a tarball with big endian binaries of XFree 3.3.1.
>  - kernel binaries for the Indy and RM200.  The RM200 kernel has the support
>    for a couple of other little endian machines in it but I didn't test.
> 
> All in all this is around 350mb.
> 
> Have fun leeching,
> 
>   Ralf
>

---

From: [email-masked] (Ariel Faigon)
Date: Thu, 11 Dec 1997 10:21:49 -0800 (PST)

:
:Pardon my ignorance, but...
:I have a couple of questions;  
:is there a how-to document that outlines how to load linux on an sgi?
:
We are waiting for someone to write this.

You may get all the info by reading:

	http://reality.sgi.com/ariel/linux.gz

(an archive of this mailing list).  The problem is that
it is way too long in this form.

:is the Indigo Elan (r4000) supported?
:

Unfortunately, no.

:I'm not sure how to initialize a loading of linux on the sgi.
:Here's what I've assumed:
:- bring over the src's to the sgi
:- compile a basic system (under irix)
:- copy over the original irix kernel with the new linux kernel
:- re-boot
:
:The begging questions:
:The FS are not compatible, therefore a new mkfs has to be done on the
:(root) partitions.
:This just doesn't "sound" right to me. 
:What am I overlooking?
:

You should be either:

1) boot via bootp (/vmlinux on a remote filesystem) and mount
   stuff via NFS.

2) Go through a complex and not well documented way of creating
   an ext2fs filesystem on your Indy (better get an additional disk)
   copy the kernel and root to that system and reboot.

--
Peace, Ariel