Subject: bus error IRQ

From: Joachim Schmitz <[email-masked]>
Date: Tue, 16 Dec 1997 11:36:08 +0100 (CET)

Hi list

I'm new to this list and currently trying to setup my Indy for Linux.
For a start I tried just to boot vmlinux-970916-efs and vmlinux-2.1.67
... without success. Both boots ends up with:

boot vmlinux-2.1.67
PROMLIB: SGI ARCS firmware Version 1 Revision 10
PROMLIB: Total free ram 64376832 bytes (62868k,61MB)
ARCH: SGI-IP22
CPU: MIPS-R4600 FPU<MIPS-R4600FPC> ICACHE DCACHE
Loading R4000 MMU routines.
CPU revision is: 00002020
Primary ICACHE 16k (linesize 32 bytes)
Primary DCACHE 16k (linesize 32 bytes)
R4600/R5000 SCACHE size 0K linesize 32 bytes
MC: SGI memory controller Revision 3
calculating r4coff... 000a8fe8(692200)
GFX INIT: SHMIQ setup
usemaclone misc device registered (minor: 151)
Video screen size is 00004c88 at 883e5d48
Console: 16 point font, 992 scans
Console: color NEWPORT 158x62, 1 virtual console (max 63)
Calibrating delay loop.. ok - 138.04 BogoMIPS
Memory: 60304k/196196k available (1164k kernel code, 2880k data)
Swansea University Computer Society NET3.039 for Linux 2.1
NET3: Unix domain sockets 0.16 for Linux NET3.038.
Swansea University Computer Society TCP/IP for NET3.037
IP Protocols: IGMP, ICMP, UDP, TCP
Checking for 'wait' instruction... available.
Linux version 2.1.67 (ralf@indy) (gcc version 2.7.2) #1 Sat Dec 6 12:48:52 PST 1997
POSIX conformance testing by UNIFIX
Starting kswapd v 1.23
SGI Zilog8530  serial driver version 1.00
tty00 at 0xbfdb9838 (irq=21) is a Zilog8530
tty01 at 0xbfdb9830 (irq=21) is a Zilog8530
loop: registered device at major 7
Got a bus error IRQ, shouldn't happen yet
$0 : 00000000 1000fc01 88130000 00000000
$4 : 88174274 8812cb10 883fdcb8 00000001
$8 : 1000fc03 00000201 0000bf81 8813de68
$12: 00000001 00000001 00000001 fffffffc
$16: 0000c000 8bf81000 00000000 00000000
$20: a87ffc20 a8746d10 9fc55064 00000000
$24: 1000fc01 0000000f
$28: 881da370 883fdcb8 00000001 8800b0e8
epc   : 880359f8
Status: 1000fc03
Cause : 00004000
Spinning...

boot vmlinux-970916-efs
...
calculating r4coff... 000a6cc0(683200)
...
usema device registered (major 86)
Video screensize is 00004c88 at 883a5c60
...
Calibrating delay loop.. ok - 136.40 BogoMIPS
Memory: 60560k/196196k available (1020 kernel code, 2768k data)
...
Linux version 2.1.55 ([email-masked]) (gcc version 2.7.2) #121 Tue Sep 16 16:30:52 EDT 1997
...
$0 : 00000000 00000000 00030000 80004000
$4 : 00000080 8bf84000 1000fc01 80003fe0
$8 : 00000000 00000000 0000bf83 881194d8
$12: 00000001 00000001 00000001 fffffffc
$16: 0bf83000 8bf8r300 00000000 00000000
$20: a87ffc20 a8746d10 9fc55064 00000000
$24: 1000fc01 0000000f
$28: 881da370 883bfda8 00000001 880d5910
epc   : 880261bc
Status: 1000fc03
Cause : 00004000
Spinning...

(I hope I didn't make to much mistakes keying in the above)
At this point it hangs. Only pulling the power cord helps.
I have no linux-root filesystem (yet), but I don't think
this is the reason for this behavoir, right?

-- 
Bye,	Jojo

email:
work [email-masked]
home [email-masked]

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 16 Dec 1997 13:24:07 +0100

> R4600/R5000 SCACHE size 0K linesize 32 bytes
                          ^^
That's the problem, there is a kernel bug which prevents Linux from
working on R4600/R5000 Indys without second level cache.  My next
kernel release will fix that.

  Ralf