Subject: Linux-installer-0.1.tar.gz

From: Mike Shaver <[email-masked]>
Date: Sat, 20 Dec 1997 16:17:12 -0800

ftp://ftp.linux.sgi.com/pub/mips-linux/GettingStarted/Linux-installer-0.1.tar.gz
has the goods.

I've attached the INSTALL file that comes with it -- comments welcome.

I'm going to see if I can't fix that RPM problem now, because that would
let me cut the cpio size down further.

Share and enjoy!

Mike

First, you must pick a partition.  I can't help you with this, beyond
assuring you that you don't want to choose one that IRIX needs.  This
partition can be on a new drive, etc.  Anything SCSI is fine, I suspect,
although I've only tried disk drives.

Once you've chosen a partition, make a symbolic link to it so that
you don't slip up and toast something: I chose "drive".

Now, it's a matter of a few simple steps:
1: make the ext2 partition:
   indy #./mke2fs drive
   [much information flies by]
   
2: start the installer, and make your basic devices:
  indy #./installer drive
  cjwsh> MAKEDEV
  [device info]
  
3: still in the installer, load the bootstrap file
  cjwsh> cpio root-be-0.01.cpio
  [piles of cpio extraction information]
  cjwsh> exit
  [ a moderately lengthy pause, and possibly a bus error -- don't worry
    about it ]
  indy #

4: check the filesystem, and repair minor damage
  indy #./e2fsck -fy drive
  [ diagnostic messages, including a few bad bits found -- all is well ]

5: copy the kernel into place in the root of your EFS partition
  indy #gzip -dc vmlinux.gz > /vmlinux
  [ XXX need info on how to boot from non-default devices ]

6: reboot!
  At the boot prompt, you'll want to enter something like:
  boot vmlinux root=/dev/sdb3
  Your choice of root= parameter will vary.  sda is the first SCSI device,
  sdb the second, etc., all assigned in increasing order of SCSI ID.  The
  partition number also varies, and it doesn't necessarily match the
  "slice ID" from IRIX.  Experiment a bit -- you can't hurt anything.
  If it prompts you to enter a runlevel, you got it right.  Enter 's'
  and press Enter when prompted for a root password.  You're in, and there
  are tools there to allow you to configure your network and ftp out.

Known problems:
- RPM doesn't work, so you can't continue the installation easily.  Fixing
  this is my first priority, and I suspect it's a library issue.
- telnet doesn't work, because it's missing ncurses.  Duh.
- If you want to change anything, you need to remount the root drive
  read-write.  This should be made easier in the future when I remember
  to fix the /etc/mtab stuff, but in the meantime, I use this:
  # mount -t ext -n -orw,remount /dev/sdc4 /
  (sdc4 is my root partition)
  # mount -t proc none /proc
  # cat /proc/mounts > /etc/mtab
- the installer should include "netcfg" to ease the network setup.

---

From: Mike Shaver <[email-masked]>
Date: Mon, 22 Dec 1997 20:42:51 +0000

Eric Kimminau wrote:
> where is this binary???

Oops!
I'll fix that, and put a new version (0.2) up tonight.

Mike

-- 
572996.46 547171.35