Subject: some glibc issues...

From: Alex deVries <[email-masked]>
Date: Sun, 11 Jan 1998 17:49:45 -0500 (EST)

Two things that puzzle me:

- exactly what's wrong with using -lbsd now?
- why does sys/mount.h have no MS_ defines in it now?

- A

-- 
      Alex deVries          Run Linux on everything,
  System Administrator      run everything on Linux.
   The EngSoc Project       Send spam to [email-masked].

---

From: [email-masked]
Date: Mon, 12 Jan 1998 01:35:41 +0100

> - exactly what's wrong with using -lbsd now?

It simply doesn't exist anymore.  RedHat on kludges things by making
libbsd.a a link to libbsd-compat.a.  That's a broken attempt to keep
Makefiles alive because -D_BSD_SOURCE needs to be added to CFLAGS for
BSD code anyway ...

> - why does sys/mount.h have no MS_ defines in it now?

Duh?  It does have them ...

  Ralf

---

From: Thomas Bogendoerfer <[email-masked]>
Date: Mon, 12 Jan 1998 19:37:55 +0100

> Makefiles alive because -D_BSD_SOURCE needs to be added to CFLAGS for

but that's not enough for getpgrp and getpgrp. These function have
different arguments in *BSD.

> Duh?  It does have them ...

really ? 

[root@mips sys]# grep MS_ /usr/include/sys/mount.h 
[root@mips sys]# 

Not in my sys/mount.h.

Thomas.

-- 
See, you not only have to be a good coder to create a system like Linux,
you have to be a sneaky bastard too ;-)
                   [Linus Torvalds in <[email-masked]>]