Subject: Getting Started ..... NOT

From: "Tony C. Wu" <[email-masked]>
Date: Fri, 13 Mar 1998 03:35:36 +0800 (CST)

Hi,

After the 101st failure on getting sgi-linux to work on our poor SGI indy,
I decided to beg you guys for a clue. I used installer-0.10d and
root-be-0.03-cpio. I followed every step listed in the INSTALL that came
with installer-0.10d. 

1. ./mke2fs /dev/dsk/dks0d2s0			ok
2. ./installer /dev/dsk/dks0d2s0		ok
3. MAKEDEV					ok
4. cpio root-be-0.03-cpio			ok
5. exit						ok
6. ./e2fsck -fy /dev/dsk/dks0d2s0		fixed some errors, ok
7. gzip -d vmlinux-2.1.65.efs.gz /vmlinux	ok

>> boot vmlinux root=/dev/sdb1			failed.

I tried every pre-compiled kernel that's in the pub/test dir of
ftp.linux.sgi.com pub/test, but all failed.

2.1.65 gave: bus error
2.1.72 gave: blank screen
2.1.72_NOSL: put me in repair fs mode, but i can't change anything.
             It said it couldn't read superblock on /dev/sdb

Here's what hinv says about our indy.
---- HINV -------------------------------------------------------------
Iris Audio Processor: version A2 revision 4.1.0
1 100 MHZ IP22 Processor
FPU: MIPS R4600 Floating Point Coprocessor Revision: 2.0
CPU: MIPS R4600 Processor Chip Revision: 2.0
On-board serial ports: 2
On-board bi-directional parallel port
Data cache size: 16 Kbytes
Instruction cache size: 16 Kbytes
Main memory size: 64 Mbytes
Vino video: unit 0, revision 0, IndyCam not connected
Integral ISDN: Basic Rate Interface unit 0, revision 1.0
Integral Ethernet: ec0, version 1
Integral SCSI controller 0: Version WD33C93B, revision D
  Disk drive: unit 2 on SCSI controller 0
  Disk drive: unit 1 on SCSI controller 0
Graphics board: Indy 8-bit
---------------------------------------------------------------------

Any help is appreciated.
Thanks,
--
Tony C. Wu 
System administrator            Email: [email-masked]
Dept. of Life Sciences          Voice: +886-3-574-2772
NTHU, Hsin-Chu, Taiwan            Fax: +886-3-571-5934

---

From: Eric Kimminau <[email-masked]>
Date: Thu, 12 Mar 1998 15:44:55 -0500

>              It said it couldn't read superblock on /dev/sdb

Re-read the HOWTO wehere it tells you how to remount / read-write
 
Ive gotten this far as well. I then could ifconfig my ethernet interface
and add the necessary routing information to talk to the network, but I
couldn't ever actually get it to talk. I could ping myself but nothing
else. I assumed this was because I didn't have things like inetd, rc
scripts to start things, etc...

My next step was to then pull down all of the mips RPMS to the 1st disk
running linux, and I was going to then try to mount the first disk after
booting Linux off of the second disk - then installing all of the RPM's
- but I haven't gotten there yet.

It would be REALLY nice, if someone could take their installed system,
tar/cpio the whole ball of wax and put it up for download.

Eric.

-- 
---------1---------2---------3---------4---------5---------6---------7---------8
Eric Kimminau                           RTA/RSA
[email-masked]                     Silicon Graphics, Inc
Voice: (248) 848-4455                   39001 West 12 Mile Rd.
Fax:   (248) 848-5600                   Farmington, MI 48331-2903

                 VNet Extension - 6-327-4455
              "I speak my mind and no one else's."
       http://www.dcs.ex.ac.uk/~aba/rsa/perl-rsa-sig.html

    When confronted by a difficult problem, solve it by reducing 
    it to the question, "How would the Lone Ranger handle this?"
	
         "I am the great supportfolio, do you have http?"

---

From: [email-masked] (Alan Cox)
Date: Thu, 12 Mar 1998 21:16:36 +0000 (GMT)

>              It said it couldn't read superblock on /dev/sdb

Ok. The disk image expects to be /dev/sdb
do

mount -n -o remount,rw /dev/sdb1  /

vi /etc/fstab

change /dev/sdb to /dev/sdb1

exit

Best of luck

---

From: Alex deVries <[email-masked]>
Date: Thu, 12 Mar 1998 16:20:28 -0500 (EST)

> tar/cpio the whole ball of wax and put it up for download.

Uh, I could, but that's about 1GB uncompressed...

- Alex

---

From: Eric Kimminau <[email-masked]>
Date: Thu, 12 Mar 1998 16:48:12 -0500

> Uh, I could, but that's about 1GB uncompressed...

Tell me where to come get it :)

OK, lets re-define "whole ball of wax"

A functional distribution with X, network tools, normally used sys-admin
tools, a compiler and the source for the kernel plus a few odds and
ends. This should be "do-able" in 2-300MB, which I don't think would be
considered excessivly large.

Eric.

---

From: "Tony C. Wu" <[email-masked]>
Date: Fri, 13 Mar 1998 13:22:01 +0800 (CST)

Ok. done that. I can successfully remount the / rw, but still, wont go any
further. I tested fsck manually, no matter what device I specified, it
always printed the same error and exited immediately. If I comment fsck
part, and boot directly, still wont go. So I think the root-be-0.03-cpio
is somehow broken. Can anyone provide another working mini-set of root ?

Thanks,

---

From: "Francis M. J. Hsieh" <[email-masked]>
Date: Wed, 25 Mar 1998 02:19:54 +0800

>is somehow broken. Can anyone provide another working mini-set of root ?

Well, is there any new root-be-*-cpio currently?
--
Francis Meng Juei Hsieh, Life Science Department, NTHU, Taiwan. 
Welcome to Life Science BBS bbs.life.nthu.edu.tw (140.114.98.61)