Subject: new to sgi linux

From: Dong Liu <[email-masked]>
Date: Fri, 27 Mar 1998 15:25:08 -0500

Hello,

I'm new to sgi linux, just got a spare Indy :=), can some one help me on this.

According the linux sgi FAQ on http://www.linux.sgi.com, I download
vmlinux-970916-efs and the small root fs. When I boot it using bootp,
I get 

Unable to handle kernel paging request at virtual address 00000000,
epc == 800cbfdc, ra == 800cbfbc

right after linux kernel displayed

eth0: SGI Seeq8003 xx:xx:xx:xx:xx:xx

I also noticed that something unusual, the kernel printed out

Memory: 60964/196604k avaialble (1020k kernel code, 2772k data)
              ^^^^^^ this is too big for 62M
   
My machine is a Indy which has 62M memory, and PROMLIB detected it right.

Another thing it didn't get the right capacity of scsi disk.

I also tried the newer kernels from ftp.linux.sgi.com:/pub/test, but
they immediately crashed.

Thanks.

Dong

---

From: [email-masked]
Date: Fri, 27 Mar 1998 22:05:50 +0100

> epc == 800cbfdc, ra == 800cbfbc

The addresses 0x800cbfdc / 0x800cbfbc are not valid kernel addresses on
the Indy.  Is it possible you wrote them down wrong?  0x880cbfdc /
0x880cbfbc however would make sense and are indeed in the sgiseeq driver.
I'll take a closer look at it.

>               ^^^^^^ this is too big for 62M

The message is correct.  The difference is because of a hole in the Indy's
address space comparable to the 640kb - 1024kb hole on PCs.

(This should go into the FAQ)

> Another thing it didn't get the right capacity of scsi disk.

Are you shure?  Some peopple got fooled by the 1024 vs. 1024 bytes per
kb isue ...  Or are the numbers way off?

> they immediately crashed.

There is a command named ``hinv'' under IRIX.  Can you mail me the output?

I'm going to put binaries of 2.0.91 online.  That kernel seems to be
running very reliable for me.  In fact it's too reliable to debug, I can't
reproduce the one killer bug I know of it must be still there ...

  Ralf

---

From: Dong Liu <[email-masked]>
Date: Fri, 27 Mar 1998 16:59:26 -0500

> I'll take a closer look at it.

Sorry, my mistake, they are 0x880cbfdc 0x880cbfbc

 > kb isue ...  Or are the numbers way off?

This what I got

sda: sector size 0 reported, assume 512
SCSI device sda: hdwr sector= 512 bytes, Sectors=1 [0 MB][0.0 GB]

:=)

 > There is a command named ``hinv'' under IRIX.  Can you mail me the output?

Here it is

1 100 MHZ IP22 Processor
FPU: MIPS R4010 Floating Point Chip Revision: 0.0
CPU: MIPS R4000 Processor Chip Revision: 3.0
On-board serial ports: 2
On-board bi-directional parallel port
Data cache size: 8 Kbytes
Instruction cache size: 8 Kbytes
Secondary unified instruction/data cache size: 1 Mbyte
Main memory size: 64 Mbytes
Iris Audio Processor: version A2 revision 4.1.0
Integral Ethernet: ec0, version 1
Disk drive / removable media: unit 2 on SCSI controller 0
Disk drive: unit 1 on SCSI controller 0
Integral SCSI controller 0: Version WD33C93B, revision D
Graphics board: Indy 24-bit
Vino video: unit 0, revision 0, Indycam connected

---

From: Ulf Carlsson <[email-masked]>
Date: Sat, 28 Mar 1998 00:49:43 +0100 (CET)

On Fri, 27 Mar 1998 [email-masked] wrote:

> I'm going to put binaries of 2.0.91 online.

I hope I finally get a kernel which boots my Indy now..
This will the most exciting moment of my life :-)
(greetings to Ralf)

- Ulf

---

From: [email-masked]
Date: Sat, 28 Mar 1998 05:52:01 +0100

> SCSI device sda: hdwr sector= 512 bytes, Sectors=1 [0 MB][0.0 GB]

Hmmm...  I speculate we misstreat R4000MC / R4400MC CPUs :-(

> Secondary unified instruction/data cache size: 1 Mbyte

Sigh, was suspecting that.  Actually handling of these CPUs should be
fixed in current kernels ...

  Ralf

---

From: Brendan Black <[email-masked]>
Date: Mon, 30 Mar 1998 10:40:00 +1200

> fixed in current kernels ...

seeeing I am having exactly the same problem, it might fix me too
-- 
Brendan Black - Network Engineer, Telecom Internet Services
email:	[email-masked] (personal)	phone: +-649 3555238
	                                mob:   +-6425 2752667
"Waving away a cloud of smoke, I look up, and am blinded by a bright, white
light. It's God. No, not Richard Stallman, or Linus Torvalds, but God. In
a booming voice, He says: "THIS IS A SIGN. USE LINUX, THE FREE UNIX SYSTEM
FOR THE 386." -- Matt Welsh