Subject: Ooops!

From: Alex deVries <[email-masked]>
Date: Thu, 9 Apr 1998 16:11:06 -0400 (EDT)

I've recompiled 2.1.91 without the -N flag, and the image boots.  

Now, I get an oops on bootup, here's my handdrawn facsimile of the bootup:

...
Starting kswapd v 1.5
SGI Zilog8530 serial driver version 1.00
tty00 at 0xbfbd9838 (irq = 21) is a Zilog8530
tty01 at 0xbfbd9830 (irq = 21) is a Zilog8530
Uniform CD-ROM driver Revision: 2.12
Unable to handle kernel paging request at virtual address 0000001f6, epc
== 080d6f44, ra == 880d6f4c
Ooops: 001
$0 : 00000000 1000fc01 000001f6 000000a0
$4 : 8818f1d0 000000ec 000003f6 88148190
$8 : 8bf59e20 1000fc01 00000067 00000064
$12: 00000068 80000000 40000000 000000a1
$16: 8818f1d0 000000ec 8818f1v0 00000020
$20: 40000000 8818f2fd 80000000 1000fc01
$24: 00000040 00000008
$28: 8bf58000 8bf59d98 9fc4be80 880d6f4c 
epc   : 880d6f44
Status: 1000fc03
Cause : 8000000c

My .config and System.map files are available; please mail me if you're
interested.  Some previous mails got bumped from the list because of the
total message size. 

- Alex

-- 
Alex deVries
http://www.engsoc.carleton.ca/~adevries/ .
EngSoc, US National Headquarters

---

From: [email-masked]
Date: Fri, 10 Apr 1998 23:26:21 +0200

> I've recompiled 2.1.91 without the -N flag, and the image boots.  

We should document that problem somewhere.  It's a bug in the binutils and
I don't want to put workarounds for it into the kernel.  Could you do me
a favor and add a note to the webpages?

> == 080d6f44, ra == 880d6f4c

I could bet you have support for IDE peripherals, probably CDROMs, in
your kernel.  0x1f6 is the address of an IDE port of the first IDE
hostadaptor.  IDE support plus Indy -> no good.

  Ralf