Subject: RE: Making Progress

From: Mike Hill <[email-masked]>
Date: Thu, 7 May 1998 13:11:41 -0400

This is booting with /vmlinux root=/dev/sdb.

I'm at work at the moment, so I'm not in front of the Indy.  I didn't
transcribe the rest, but as I recall, hard drive model and size are
reported (correctly) for sda and sdb, followed by a line with Dave
Miller's address.  The three lines I did write out came next.

My previous two boot attempts got hung up before the network detection,
seemingly because of the floptical and CD drives.  I yanked out the
first and switched off the second.

Should I be doing something to partition sdb?

Thanks,

Mike

> -----Original Message-----
> From:	Alex deVries [SMTP:[email-masked]]
> Sent:	Thursday, May 07, 1998 11:27 AM
> To:	Michael Hill
> Cc:	[email-masked]
> Subject:	Re: Making Progress
> 
> On Thu, 7 May 1998, Michael Hill wrote:
> > Trying to boot the kernel (2.1.90) I can now get beyond the SCSI
> > detection stage but now it stops at this point:
> > 	Sending BOOTP and RARP requests............. timed out!
> > 	IP-Config: Auto-configuration of network failed.
> > 	Partition check:
> 
> Hm.  The bootup actually stops at that point?  It doesn't identify any
> partitions or complain about any errors?  This sounds like a SCSI
> problem
> to me.
> 
> In theory, you should be able to boot with 'vmlinux root=/dev/sdb'.
> 
> - alex

---

From: Alex deVries <[email-masked]>
Date: Thu, 7 May 1998 13:16:09 -0400 (EDT)

> Miller's address.  The three lines I did write out came next.

Hmmm.  Odd.  Can you give us the results of a 'hinv'?

- Alex

---

From: Michael Hill <[email-masked]>
Date: Fri, 8 May 1998 05:48:26 -0400 (EDT)

> Hmmm.  Odd.  Can you give us the results of a 'hinv'?
Iris Audio Processor: version A2 revision 4.1.0
1 133 MHZ IP22 Processor
FPU: MIPS R4600 Floating Point Coprocessor Revision: 2.0
CPU: MIPS R4600 Processor Chip Revision: 2.0
On-board serial ports: 2
On-board bi-directional parallel port
Data cache size: 16 Kbytes
Instruction cache size: 16 Kbytes
Main memory size: 32 Mbytes
Vino video: unit 0, revision 0
Integral ISDN: Basic Rate Interface unit 0, revision 1.0
Integral Ethernet: ec0, version 1
Integral SCSI controller 0: Version WD33C93B, revision D
  Disk drive: unit 4 on SCSI controller 0
  Disk drive: unit 1 on SCSI controller 0
Graphics board: Indy 8-bit

Here's this morning's result from 'boot /vmlinux root=/dev/sdb
ip=none':

[snip]
scsi : detected 2 SCSI disks total.
SCSI device sda: hdwr sector= 512 bytes. Sectors= 1070496 [522 MB]
[0.5 GB]
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 2400302 [1172 MB]
[1.2 GB]
sgiseeq.c: David S. Miller ([email-masked])
eth0: SGI Seeq8003 08:00:69:07:e3:0d
Sending BOOTP and RARP requests............. timed out!
IP-Config: Auto-configuration of network failed.
Partition check:
[end]

Next I'll try adding a partition to be checked.

Mike
-- 
Michael Hill
Toronto, Canada
[email-masked]

---

From: Alex deVries <[email-masked]>
Date: Fri, 8 May 1998 07:36:58 -0400 (EDT)

> CPU: MIPS R4600 Processor Chip Revision: 2.0

Hm.  that looks okay to me.

> IP-Config: Auto-configuration of network failed.

It's still doing bootp/rarp, which is weird.  

Can you try the kernel that's in
ftp://ftp.linux.sgi.com/pub/test/vmlinux-indy-2.1.99.tar.gz ?

This doesn't have bootp enabled.

- alex