Subject: rs_cons_hook() ?

From: Alex deVries <[email-masked]>
Date: Thu, 7 May 1998 14:00:33 -0400 (EDT)

in drivers/char/console.c, there's a reference to rs_cons_hook() that
looks like:

#ifdef CONFIG_SGI
    if (serial_console) {
...
        rs_cons_hook(0, 0, serial_console);
        rs_cons_hook(0, 1, serial_console);
...
#endif

... and the final link complains that it can't find rs_cons_hook defined
anywhere.  That's because I'm not compiling in
drivers/sgi/char/sgiserial.c (which has other linking errors, and is
another problem, but you should be able to compile in console support
without having to have compiled in SGI serial support).

So, should that #ifdef in console.c not be SGI_SERIAL?

- Alex

-- 
Alex deVries
"romantic engsoc guy who runs marathons" - [email-masked]
http://www.engsoc.carleton.ca/~adevries/ .

---

From: Oliver Frommel <[email-masked]>
Date: Fri, 8 May 1998 08:22:21 +0200 (MET DST)

> without having to have compiled in SGI serial support).

you need SGI serial support (sgi/char/sgiserial.c) for the serial console 
support ..

o.

---

From: Alex deVries <[email-masked]>
Date: Fri, 8 May 1998 07:42:26 -0400 (EDT)

> you need SGI serial support (sgi/char/sgiserial.c) for the serial console 

Except I don't have CONFIG_SERIAL_CONSOLE in my .config ... see below.
I'm pretty sure my recommended change is correct.

I am going to have a look at my sgiserial.c compile problems, too.

- Alex

#
# Character devices
#
CONFIG_VT=y
CONFIG_VT_CONSOLE=y
# CONFIG_SERIAL is not set
# CONFIG_SERIAL_EXTENDED is not set
# CONFIG_SERIAL_NONSTANDARD is not set
# CONFIG_PRINTER is not set
# CONFIG_MOUSE is not set
CONFIG_UMISC=y
# CONFIG_SGI_GRAPHICS is not set
# CONFIG_QIC02_TAPE is not set
# CONFIG_APM is not set
# CONFIG_WATCHDOG is not set
# CONFIG_RTC is not set
# CONFIG_VIDEO_DEV is not set
# CONFIG_NVRAM is not set
# CONFIG_JOYSTICK is not set
# CONFIG_MISC_RADIO is not set

#
# Ftape, the floppy tape device driver
#
# CONFIG_FTAPE is not set

#
# Sound
#
# CONFIG_SOUND is not set

#
# SGI Character devices
#
# CONFIG_SGI_SERIAL is not set

#
# Kernel hacking
#
CONFIG_CROSSCOMPILE=y
# CONFIG_REMOTE_DEBUG is not set
# CONFIG_PROFILE is not set

---

From: Oliver Frommel <[email-masked]>
Date: Fri, 8 May 1998 15:19:22 +0200 (MET DST)

> I'm pretty sure my recommended change is correct.

CONFIG_SERIAL_CONSOLE is for i386 only as far as i could figure out ..

this is what i have in my -working- kernel:
# CONFIG_SERIAL_CONSOLE is not set
CONFIG_SGI_SERIAL=y
CONFIG_SERIAL=y

o.

---

From: Alex deVries <[email-masked]>
Date: Fri, 8 May 1998 11:11:44 -0400 (EDT)

> CONFIG_SERIAL_CONSOLE is for i386 only as far as i could figure out ..

Hmmm.  I'm not entirely sure that makes sense.  Shouldn't serial consoles
be architecture independant?

> # CONFIG_SERIAL_CONSOLE is not set

... and I get a lot of compile errors when I try to compile with
CONFIG_SGI_SERIAL=y, so I'm forced to turn it off, which is what gives me
errors.

In any case, there's a problem because you should be able to compile a
kernel with enabling SGI_SERIAL.

The problems with sgiserial.c also need to be looked at.  I'll sort this
out... 

- Alex

---

From: Oliver Frommel <[email-masked]>
Date: Sat, 9 May 1998 13:39:49 +0200 (MET DST)

> The problems with sgiserial.c also need to be looked at.  I'll sort this

i just checked out the cvs version from sgi.com and it compiled out of the box.
which problems do have exactly??

o.