Subject: Re: Installer changes...

From: "Francis M. J. Hsieh" <[email-masked]>
Date: Thu, 14 May 1998 03:25:48 +0800

At 12:37 AM 1998/5/13 -0400, you wrote:
>As per Mike Shaver's suggestions, I've made some changes to root-be (now
>version 0.04), which affects Linux-installer (now version 0.2).  The
>changes listed are below. Tehy're all in teh GettingStarted directory.
>root-be chnages include adding ftp, libncurses and /etc/protocols,
>/etc/services and /etc/termcap.
>There's also now a script in /etc/rc.d which creates new sd* devices if
>they aren't created already.

I'm sorry if this was discussed in the maillist.

Should there be /etc dirctory after I cpio into my partition? I can't
find /etc in my linux partition under installer prompt.

BTW, I use the kernel in /pub/test/vmlinux-indy-2.1.99.tar.gz and got
panic. The "NICE" panic message is:

[deleted]
sgiseeq.c: David S. Miller ([email-masked])
eth0: SGI Seeq8003 blah:blah:blah:blah
Partition check
   blah....
   blah....
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 32k freed
Warning: unable to open an initial console.
kernel panic: No init found. Try passing init= optional to kernel.
[halt]

And I use the kernel in GetingStarted directory, and got panic, too.
("should not happened yet")
--
Francis Meng Juei Hsieh, Life Science Department, NTHU, Taiwan. 
Welcome to Life Science BBS bbs.life.nthu.edu.tw

---

From: Alex deVries <[email-masked]>
Date: Wed, 13 May 1998 15:47:57 -0400 (EDT)

> find /etc in my linux partition under installer prompt.

There should be a /etc in the ext2 file system after you run the
installer.  As far as I know, there is no way to read an ext2 partition
from within Irix.

But it sounds like you're having problems even booting up...

> kernel panic: No init found. Try passing init= optional to kernel.

Hm.  You might want to run it with 'init=/bin/sh' to skip init.

> ("should not happened yet")

I don't know about that.  That is Ralf's department.

- Alex

---

From: "Francis M. J. Hsieh" <[email-masked]>
Date: Thu, 14 May 1998 04:08:16 +0800

>installer.  As far as I know, there is no way to read an ext2 partition

Sure, I browse the partition in installer.

[deleted]
>Hm.  You might want to run it with 'init=/bin/sh' to skip init.

Well, didn't work. :~(

---

From: [email-masked]
Date: Wed, 13 May 1998 22:37:25 +0200

> kernel panic: No init found. Try passing init= optional to kernel.

Alex already said it, try adding init=/bin/sh to the boot options.

> ("should not happened yet")

That was a real bug.  The kernel in GettinStarted in truely ancient.  I
replaced it by vmlinux-2.1.99.

  Ralf

---

From: Michael Hill <[email-masked]>
Date: Thu, 14 May 1998 05:36:16 -0400 (EDT)

> kernel panic: No init found. Try passing init= optional to kernel.

I too get this with the new root-be.

Mike
-- 
Michael Hill
Toronto, Canada
[email-masked]

---

From: "Francis M. J. Hsieh" <[email-masked]>
Date: Thu, 14 May 1998 17:48:06 +0800

At 03:47 PM 1998/5/13 -0400, you wrote:
>installer.

This log is copied from my installation output. Is anyone having idea
what's wrong with the installation?

---->15# ./installer /dev/dsk/dks0d2s0
SGILinux Installer 2.6
Alan Cox (c) 1997 - based on the MacLinux68K installer 2.6
Copyright © 1997 by Christiaan Welvaart

mounted .
cjwsh>MAKEDEV                                
/dev doesn't exist, creating...
making standard devices & console
/dev/mem
/dev/kmem
/dev/null
/dev/port
/dev/zero
/dev/full
/dev/ram
/dev/tty
/dev/tty0
symlinking /dev/console to /dev/tty0

cjwsh>cpio root-be-0.04.cpio
.
.
.
[deleted]
.
.
.
D       dev/vcsa56
(failed to create)
D       dev/vcsa57
(failed to create)
D       dev/vcsa58
(failed to create)
D       dev/vcsa59
(failed to create)
D       dev/vcsa6
(failed to create)
D       dev/zero
(failed to create)
D       dev/vcsa60
(failed to create)
D       dev/vcsa61
(failed to create)
D       dev/vcsa62
(failed to create)
D       dev/vcsa63
(failed to create)
D       dev/vcsa7
(failed to create)
D       dev/vcsa8
(failed to create)
D       dev/vcsa9
(failed to create)
R       dev/need_disks_created
cjwsh>
--
Francis Meng Juei Hsieh, Life Science Department, NTHU, Taiwan. 
Welcome to Life Science BBS bbs.life.nthu.edu.tw

---

From: Alistair Lambie <[email-masked]>
Date: Thu, 14 May 1998 23:41:02 +1200

> installer.  As far as I know, there is no way to read an ext2 partition
Alex,

It stops right at the file /dev/need_disks_created.  There are a bunch
of errors before this.  The /dev/need_disks_created file does not seem
to get written to disk correctly....the e2fsck cleans it up by the looks
of things.  I guess there is something about the cpio that the installer
doesn't like.

I tried extracting the cpio archive with Irix cpio and it seems fine.

Does that give any clues?  Just another thought...I'm running Irix
6.5beta.  Wonder if that could be causing a problem with the installer??

Cheers, Alistair

-- 
Alistair Lambie                         [email-masked]
Silicon Graphics                      SGI Voicemail/VNET: 234-1455
Level 5, Cigna House,                                M/S: INZ-3780
PO Box 24 093,                                  Ph: +64-4-494 6325
40 Mercer St, Wellington,                      Fax: +64-4-494 6321
New Zealand                                 Mobile: +64-21-635 262

---

From: Alex deVries <[email-masked]>
Date: Thu, 14 May 1998 11:13:41 -0400 (EDT)

> of things.  I guess there is something about the cpio that the installer

Wow.  I really messed it up badly somehow.

I suspect it's having a problem writing a file that's 0 bytes long.  Let
me repackage it, and make the file 1 byte.

As we speak, I'm debugging the initrd stuff in the kernel to sort out why
initial ramdisks don't get loaded.

- Alex

---

From: "Francis M. J. Hsieh" <[email-masked]>
Date: Tue, 19 May 1998 00:59:28 +0800

>me repackage it, and make the file 1 byte.

So, can anybody have time to fix it up? :-) I am new to sgi-linux and
want to "getting start" :-).

---

From: Alex deVries <[email-masked]>
Date: Mon, 18 May 1998 13:24:42 -0400 (EDT)

> want to "getting start" :-).

I know this has been a couple of days that I've let this slip... I'll take
care of it (hopefully) tonight.

In the meantime, you can get by with a bit of pain on 0.01d, which is in
the old subdir.  I used that yesterday when I mistakenly reformatted by
entire Linux system.  *sigh*. That was actually the first time I'd used
the installer, which is a bit odd, seeing as how I've been maintaining it. 

There are definite strides in the right direction for never having to use
the installer again, though.  I now understand how the initrd stuff works,
and have a start in puting in prom_initrd stuff. 

The biggest thing we can do to further the project right now is to get
more people onboard with the fewest hassles possible.  Getting a decent
install program is critical to it. initrd (or prom_initrd) is the right
solution to that.

- Alex

---

From: "Francis M. J. Hsieh" <[email-masked]>
Date: Tue, 19 May 1998 05:55:10 +0800

>install program is critical to it. initrd (or prom_initrd) is the right

Can't agree more. The more people we get, the more thing we can do.   :-)

---

From: Alistair Lambie <[email-masked]>
Date: Tue, 19 May 1998 15:13:46 +1200

> me repackage it, and make the file 1 byte.

No, this is not the problem.  The problem is that the /dev directory is
getting too big for 'installer' to handle.  If I repackage the cpio
after deleting some files from the directory all is well.  Maybe we need
to do a very minimal package of the files in the /dev directory and run
some MAKEDEV's on first boot?

> initial ramdisks don't get loaded.

I think this is the way to go for the future...saves maintaining
installer :-)

Cheers, Alistair