Subject: Re: (fwd) linux SEGV details (another one)

From: [email-masked] (Ariel Faigon)
Date: Wed, 17 Jun 1998 09:07:22 -0700 (PDT)

----- Forwarded message from David Kostal -----

>From [email-masked]  Wed Jun 17 08:59:20 1998
From: David Kostal <[email-masked]>
Message-Id: <[email-masked]>
Subject: Re: (fwd) linux SEGV details
In-Reply-To: <[email-masked]> from Ariel Faigon at "Jun 17, 98 08:43:11 am"
To: ariel@cthulhu
Date: Wed, 17 Jun 1998 17:59:09 +0200 (MET DST)
Cc: linux@cthulhu
X-Mailer: ELM [version 2.4ME+ PL39 (25)]
MIME-Version: 1.0
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 7bit

> #mkswap /dev/sdb2
> Segmentation fault
> #
> 
> and on console (there is no syslogd :( ) is:
> 
> #dmesg
> [...skipped...]
> VFS: brelse: Trying to free free buffer
> Unable to handle kernel paging request at virtual address 00050040,
> epc == 88041e7c, ra == 880464e0
> Oops: 0000
> $0 : 00000000 88140000 00000028 00000009
> $4 : 00050028 00000001 bf0f0000 00000000
> $8 : 00000720 00000000 00000000 00000000
> $12: 00000008 000003e2 8836e59c 7ffffcf0
> $16: 00050028 894c7c88 894c7d80 00000001
> $20: 00000000 00000000 894c7c80 00000000
> $24: 00000001 7ffffcf1
> $28: 894c6000 894c7c58 00000000 880464e0
> epc   : 88041e7c
> Status: 3000fc03
> Cause : 00000008
> 
> 
> [and just another attempt to mkswap...]
> VFS: brelse: Trying to free free buffer
> Unable to handle kernel paging request at virtual address 00050040,
> epc == 88041e7c, ra == 880464e0
> Oops: 0000
> $0 : 00000000 88140000 00000028 00000009
> $4 : 00050028 00000001 bf0f0000 00000000
> $8 : 00000720 00000000 00000000 00000000
> $12: 00000008 000003e2 8836e59c 7ffffcf0
> $16: 00050028 894c7c88 894c7d80 00000001
> $20: 00000000 00000000 894c7c80 00000000
> $24: 00000001 7ffffcf1
> $28: 894c6000 894c7c58 00000000 880464e0
> epc   : 88041e7c
> Status: 3000fc03
> Cause : 00000008
> 
> The same with recompiled mkswap.
> 

New report :-)

It looks like mkswap is not able to determine the size of (swap)
partition. If I try to do
#mkswap /dev/sdb2 1024
it works OK. When I try 
#mke2fs /dev/sdb2, 
it works fine too, but 
#dd if=/dev/sdb2 of=/dev/null 
segfaults (and kernel messages are nearly the same as massages from
mkswap).

dd if=/dev/sdb1 of=/dev/null works ok. 

Disc is partitioned from Irix 5.3, /dev/sdb1 is swap, /dev/sdb2 is
ext2 with sgi/linux installed on it. 

I have noticed another problem. Linux happily mounts the same
swap-file twice and if the system needs to swap, kswapd starts to run
at 60% CPU (or more) and the system slows down to death.

david kostal ([email-masked])
----+

----- End of forwarded message from David Kostal -----

-- 
Peace, Ariel

---

From: [email-masked]
Date: Wed, 17 Jun 1998 21:20:49 +0200

> at 60% CPU (or more) and the system slows down to death.

On what kernel did this happen?  Some Linux kernels in the 2.1.x series
had this problem in the generic swap code, it's was not a specific
MIPS problem.

  Ralf

---

From: Honza Pazdziora <[email-masked]>
Date: Wed, 17 Jun 1998 23:56:20 +0200 (MET DST)

> On what kernel did this happen?  Some Linux kernels in the 2.1.x series

2.1.99 from the RH 5.1 Alpha 1 distribution (the original /vmlinux).

------------------------------------------------------------------------
 Honza Pazdziora | [email-masked] | http://www.fi.muni.cz/~adelton/
                   I can take or leave it if I please
------------------------------------------------------------------------

---

From: Alex deVries <[email-masked]>
Date: Wed, 17 Jun 1998 20:39:26 -0400 (EDT)

> 2.1.99 from the RH 5.1 Alpha 1 distribution (the original /vmlinux).

I am guilty of not having released a kernel that contains System.map and
.config with it;  I'll correct this.

- Alex