Subject: 4d/25 docs.

From: Matthew Kirkwood <[email-masked]>
Date: Wed, 10 Jun 1998 20:25:34 +0100 (BST)

Hi,

Someone has offered me a Personal Iris (4D/25) box which I'd
quite like to put Linux on.  I am aware that very little R3K
work has been and is being done, and that's fine by me :-)

William Earl suggested a while ago (I checked the archive),
that docs for the 4D/?? boxes could be made available on the
same basis as those for the Indy.

Since I don't know what basis this is, I'm a bit stumped :)

Do I have to be a member of the Inner Circle(tm) to see these
things?

FWIW, almost anything with enough detail will do.  I can sometimes
even read my own code :-)

Cheers,
Matthew.

---

From: Alex deVries <[email-masked]>
Date: Wed, 10 Jun 1998 15:39:04 -0400 (EDT)

> even read my own code :-)

I am none of the following:
- a member of the Inner Circle
- a paid person by SGI
- someone who has his name in kernel CREDITS

However, I have a lot of docs from SGI on the Indy hardware, which seem to
improve in quality as you re-read them.

What does this mean to you getting such docs?  Probably nothing.

Seeing as how the Iris is older than the Indy, I'd suspect that there
would be even more likelyhood of you getting access to the docs.  I expect
the biggest restraint will be finding someone within SGI who has the time
to follow this kind of thing up. Certainly William Earl is a good person
to follow up with. I believe Ariel is quite busy these days.

Personally, I'd love to see something like the Iris supported.  As time
goes on, more an dd more people will want a modern OS with a lower
overhead to run on their retired machines. 

- Alex

---

From: [email-masked] (Ariel Faigon)
Date: Wed, 10 Jun 1998 12:51:32 -0700 (PDT)

:
:Hi,
:
:Someone has offered me a Personal Iris (4D/25) box which I'd
:quite like to put Linux on.  I am aware that very little R3K
:work has been and is being done, and that's fine by me :-)
:
:William Earl suggested a while ago (I checked the archive),
:that docs for the 4D/?? boxes could be made available on the
:same basis as those for the Indy.
:
:Since I don't know what basis this is, I'm a bit stumped :)
:
:Do I have to be a member of the Inner Circle(tm) to see these
:things?
:
:FWIW, almost anything with enough detail will do.  I can sometimes
:even read my own code :-)
:
:Cheers,
:Matthew.
:

Matthew,

Before I start. You know about:

	http://www.geocities.com/SiliconValley/Pines/2258/4dfaq.html

If not, check it out.

Really honestly, and by no means to sound negative but-- :

I think the main problem is the handling.

Someone who is probably highly paid (at SGI) needs to go and
search for those antique docs (they are not online as far as
I can tell/search), send them to the copy center (and pay them),
ship them (ditto) all while stoppping the work they are paid to do
in the first place and delaying their schedules etc.  All in all
a waste of a few hours which most probably amounts to more than
the market price of such a system.

The return: some hacker somewhere will have a little fun with
the docs or with the donated hardware.

We are paid to do different things even though some of us
lurk on the list and want Linux on SGI to be successful.

Bill Earl and I together spent several hours to locate, duplicate
and ship Indy specs to about 7 people, I'm not sure much
ever came out of all this effort so I personally don't feel
like I would like to repeat it :-)   I'd say, better get an old,
used 486. it should cost between $0-$100 and be about as fast.

Again: not to sound negative! really, just to tell how this
looks from this end.

Happy Linuxing.

-- 
Peace, Ariel

---

From: Matthew Kirkwood <[email-masked]>
Date: Wed, 10 Jun 1998 21:14:58 +0100 (BST)

> - someone who has his name in kernel CREDITS

Snap! *grin*

> However, I have a lot of docs from SGI on the Indy hardware, which seem
> to improve in quality as you re-read them.

Cool.

> would be even more likelyhood of you getting access to the docs.  I

This is what I was hoping, but a couple of people have told me of bad
luck so far.  But then they all tried the developer support channels,
rather than this list, it seems.

> expect the biggest restraint will be finding someone within SGI who
> has the time to follow this kind of thing up. Certainly William Earl
> is a good person to follow up with. I believe Ariel is quite busy these
> days.

Mr Earl seems to be away until the 29th, but I have[1] high hopes...

> overhead to run on their retired machines. 

Indeed.  However, Ariel's response was slightly less optimistic than
yours, and I don't want to be putting him or any other helpful "insiders"
off helping with more useful/realistic things.

Cheers,
Matthew.

[1] Now had; see Ariel's post.