Subject: Re: hmmmm.... nice job!!

From: Alex deVries <[email-masked]>
Date: Sun, 28 Jun 1998 14:58:20 -0400 (EDT)

On Mon, 29 Jun 1998, Francis M. J. Hsieh wrote:
> I just installed this nice/impressive OS in our indy, the network speed
> is faster than it is on irix6.2. And it had a huge screen :-)

Good!

> I have setup a ftp service and one www service on this linux, it works
> fine. :-)
> 
> here are some small problems :-)
>  - Sometimes after closing telnet connection, it shows
> 	bpti [/home/mjhsieh] -mjhsieh- logout
> 	tput: tgetent failure: No such file or directory
> 	tput: tgetent failure: No such file or directory
> 	Connection closed by foreign host."

Hm.  That's new to me.  I look at it.

>  - possible no sound support (beep ?)

No, no sound support yet.

>  - (sometimes) a strange garbage image, about 1 character size in the
>    lowerleft corner of the screen

Yup, that's a console bug, I get that too.

- Alex

---

From: "Francis M. J. Hsieh" <[email-masked]>
Date: Mon, 29 Jun 1998 04:59:58 +0800

On Sun, Jun 28, 1998 at 10:35:41PM +0200, Ulf Carlsson wrote:
> I think I've heard something about strange chars in the lower corners of
> the screen. Try 'clicking' on it, maybe you get access to some secret
> database. (maybe it just works in movies)

I really wish it is a pi symbol.

maybe somebody can hack it to be a pi :-)

---

From: [email-masked] (Alan Cox)
Date: Mon, 29 Jun 1998 00:52:37 +0100 (BST)

> Yup, that's a console bug, I get that too.

And a few other artifacts. They look like a race on how we handle scrolling,
cursors and other related items. Perhaps its time to go plug into abscon ?

---

From: [email-masked]
Date: Mon, 29 Jun 1998 12:46:15 +0200

On Mon, Jun 29, 1998 at 08:52:24PM +0800, Francis M. J. Hsieh wrote:

> is faster than it is on irix6.2.

[makes a notch into his Indy's keyboard ...]

>  - possible no sound support (beep ?)

Yes, that's still missing and as far as just the equivalent of the
PC beeper is affected I'd call it a feature ;-)

>    lowerleft corner of the screen

Yes, and there are some more artefacts in the console code, aside of it's
afully slow speed.  As Alan already mentioned it's time to reimplement the
console code for the Indy, this time based on abscon.  And just yesterday
Thomas who already did the abscon support for the G364 board (Magnum 4000),
volunteered to implement this for the Newport.

  Ralf

---

From: "Francis M. J. Hsieh" <[email-masked]>
Date: Mon, 29 Jun 1998 20:52:24 +0800

Dear Linux/SGI developer;

-- Francis

---

From: "Francis M. J. Hsieh" <[email-masked]>
Date: Mon, 29 Jun 1998 23:47:08 +0800

> Hm.  That's new to me.  I look at it.

Seems to be a small problem of term emulation (I guessed.)

After some observation, I found it only occurs on console
telneting to some certain host. I will check it, too.

--
Francis M. J. Hsieh