Subject: Stuff that needs to be done.

From: Alex deVries <[email-masked]>
Date: Wed, 17 Jun 1998 14:19:02 -0400 (EDT)

In a fury of organization and managment, I wrote down a list of packages
and things that need to be fixed.  Please discuss, or take one of them on.
Or, tell me what else needs to go on this list or what we can cross off.
I'm operating on the assumption that I have the most up to date packages.
If you have something newer send it to the list, or at least me.

They are roughly in order of priority.

Packages that are currently broken in some way:
-----------------------------------------------
- termcap appears to be broken in the current install.  I know I have a
functioning one on my machine, but that doesn't preclude the RPMified one
being broken. (Thanks to Mike Shaver for reporting this)

- something appears to be wrong with mkswap

Components that we definitely intend on fixing for inclusion:
-------------------------------------------------------------

The install program and distribution
     Lots wrong here... the comps list, we need an initrd, etc.

XFree86-75dpi-fonts
XFree86-libs
XFree86
     Huge problems here with building the X server itself, although
     both Ralf and Mike are working on this.  There's a good chance
     of creating a .src.rpm for the fonts and libs, though. Ralf has
     released an up to date patch that lets you build the libraries.

libstdc++
libstdc++-devel
egcs
egcs-c++
     We have both rths and Ralf's sources for egcs that appear to work.
     All that needs to be done is packaging.

gcc
     For inclusion in the packaging, it should really be regenerated from
     the source RPM.  Needs lots of building time.

kernel
kernel-source
kernel-headers
     The entire kernel source package needs to be regenerated.

modutils
     Easy, just need to package the functional modutils that's in
     the CVS on linus.

netscape-common
netscape-communicator
     The whole thing needs to be patched, I haven't even started
     to think about it.  Obviously we will have to include Mozilla.

strace
     Even the CVS version of this dies on compile.

xxgdb
    This requires gdb to work first.

binutils
     This should be regenerated from the source RPM for 5.1.

glibc
     This should be updated for pthreads (Ralf).

emacs
emacs-X11
emacs-nox
     What a pain. We need to setup some configurations, and debugging
     anything takes 4 hours to rebuild.  This needs patience.

clock
     Needs to be completely redone because there's no clock on the ISA
     bus.

Applications that really should be fixed before we release the final
version:
--------------------------------------------------------------------

mkinitrd
     Architecture not currently supported, should be easy to fix.

xpm
xpm-devel

xv
    This can't compile because it needs csh in the building, and
    tcsh currently hangs.
    
ical
     Ical thinks it is compiling on Irix, and so dies on with
     strncasecmp().

fvwm2
fvwm2-icons
     Somehow, fvwm2 doesn't compile everything on a build.

postgresql
postgresql-clients
postgresql-data
postgresql-devel
     This is huge, and the source is broken for mipseb.  I think
     it thinks this is IRIX.

ppp
     Gets problems with compiling, dies with FD_ZERO problems.

quota
     Architecture not supported.

smbfs
     Architecture support not included.

mawk
    This dies on compile with floating point errors.

mars-nwe
     Architecture specific.

ypserv
    Problems linking on gdbm; for some reason -lgdbm isnt' set.

ncpfs
    Problems with socket.h.

acm
     Thinks it is Irix in the configure.

dip
     Unknown.

xlispstat
     Architecture unsupported.

smbfs
     Architecture not supported.

xosview
     Architecture unsupported.

kaffe
     Architecture unsupported.

ElectricFence
     Source level architecture problems.

ImageMagick
     Has problems building, and finishes with:
         install -m 0755 utils/fvwmrc_c5 utils/fvwmrc_cntize_pixmaps \n
            /vntize_pixmaps /vt/usr/X11R6/bin
     in %install

cmu-snmp
cmu-snmp-utils
     Problems compiling, and finishes with conflicting internal types.

ipxutils
     This is byte order dependant.  I suspect the Sparc folks would like
     this.  We should investigate both m68k and sparc patches.

Things that don't belong in this architecture
---------------------------------------------
aout-libs
     I'm not sure.

bin86
     Too difficult to do.

kernel-pcmcia-cs
     No SGIs with PCMCIA, I suspect.

lilo
     We need a different boot loader.

sndconfig
     There is no sound support at all yet.

zgv
SVGATextMode
svgalib
svgalib-devel
vga_cardgames
vga_gamespack
      My SGI doesn't have VGA...

xdosemu
dosemu
      Emulate DOS on a MIPS?  Not right away.

mkboodisk
     SGI's don't have bootdisks, never mind.

aboot
     I'm not sure what this is.

isapnptools
     No ISA bus on an SGI.

ld.so
libc
     Mipseb is only glibc.

minlabel
     This is for Alpha disk labels.

mouseconfig
     There's only ever one type of mouse...

quickstrip
     I don't remember what this is.

rhs-hwdiag
     This requires a lot of hacking to get it to handle non-i386.

---

From: Honza Pazdziora <[email-masked]>
Date: Thu, 18 Jun 1998 00:08:55 +0200 (MET DST)

> - something appears to be wrong with mkswap

If this is the problem from me, if might be a problem with the disk
(I do not see into it however). The mkswap fails if I do not specify
the size.

>      the source RPM.  Needs lots of building time.

If you assume the make will go clean, I can start it right away.

------------------------------------------------------------------------
 Honza Pazdziora | [email-masked] | http://www.fi.muni.cz/~adelton/
                   I can take or leave it if I please
------------------------------------------------------------------------

---

From: Thomas Bogendoerfer <[email-masked]>
Date: Thu, 18 Jun 1998 01:39:17 +0200

>      I don't remember what this is.

that's all Alpha stuff, you don't need it.

Thomas.

-- 
See, you not only have to be a good coder to create a system like Linux,
you have to be a sneaky bastard too ;-)
                   [Linus Torvalds in <[email-masked]>]

---

From: [email-masked]
Date: Thu, 18 Jun 1998 04:18:07 +0200

>      released an up to date patch that lets you build the libraries.

I'm desperately trying to package this thing, but it takes __time__, a
R5000 Indy is annoyingly slow for doing this, so I end up every couple
of hours in front of my Indy's console, type a few keys and let it
compile for another few hours.

On the positive side: with just a few keystrokes I made the XF68_FBDev
server compile, so combining this with the framebuffer device which just
has been written for the Magnum 4000 G364 board by Thomas we should
have the first X server for a Linux/MIPS box.

>      the source RPM.  Needs lots of building time.

Actually we might consider droping gcc in favor of egcs.

>      Easy, just need to package the functional modutils that's in

Modules are currently one of the more efficient ways to crash the machine,
don't know why.

>      Even the CVS version of this dies on compile.

Kernel bug, fixed in my private version.  I could commit the patches,
but I'd have to reboot into IRIX, anybody got a XFS kernel module
handy ... ;-)

>      anything takes 4 hours to rebuild.  This needs patience.

I once build patches for this and even published the srpms.

>      Needs to be completely redone because there's no clock on the ISA

The clock data sheets are on the Dallas Semiconductor webserver at
www.dalsemi.com.  Only the PC architecture garbage needs to be disabled,
/dev/rtc is a quite sane and portable interface to the RTC.

Add to the list ncompress which makes stupid assumptions about the
machines byteorder.  Works fine on both byte orders but on the one it
cannot exchange files with the other.

> Applications that really should be fixed before we release the final

Builds and installs without modifications for me.

>      This is huge, and the source is broken for mipseb.  I think

It's a quite common problem with older sources that the preprocessor
symbol __mips__ get missrecognized as either Risc/OS or IRIX.

>      Architecture unsupported.

This is nontrivial, as Miguel explained to me this'd require writing
a JIT.

>      Source level architecture problems.

Known kernel bug, the definition of PROT_NONE needs to be fixed.

>             /vntize_pixmaps /vt/usr/X11R6/bin

Rebuilds for me.

> Things that don't belong in this architecture

We don't want this.

>      Too difficult to do.

We don't want this :-)

>      No SGIs with PCMCIA, I suspect.

Wrong idea, think in terms of MIPS machines in general, not just SGI.

>       My SGI doesn't have VGA...

Thanks god.

>      No ISA bus on an SGI.

But RM200.  And Mips Magnum.  And Acer PICA.  And Deskstation Tyne.  And ...

  Ralf

---

From: Mike Shaver <[email-masked]>
Date: Thu, 18 Jun 1998 09:57:29 -0400

> This is nontrivial, as Miguel explained to me this'd require writing

Hrm.
http://www.kaffe.org lists MIPS as a supported processor type (OS
choices are IRIX 5, IRIX 6 and NetBSD), although it doesn't run with a
JIT (interpreter only).

Also, at the Expo DaveM said something about working on a JVM for the
Qube; perhaps that work would help us?

Mike

-- 
488733.52 411902.28

---

From: [email-masked] (Alan Cox)
Date: Thu, 18 Jun 1998 23:43:04 +0100 (BST)

>      Easy, just need to package the functional modutils that's in

What happened there. My 4.9.1 modutils built fine

>     This dies on compile with floating point errors.

Those look like kernel problems

>      Architecture specific.

Forget it - its very very non portable.

>      I'm not sure.

Not needed

>      Too difficult to do.

The Red Hat supplied bin86 isnt portable. It'll build on mips and write
invalid code. Get the Dev86 kit for ELKS. That one is portable

>       Emulate DOS on a MIPS?  Not right away.

0.99 has CPU emulation in progress. So "soon"

alan

---

From: Miguel de Icaza <[email-masked]>
Date: Fri, 19 Jun 1998 09:02:31 -0500

> This is nontrivial, as Miguel explained to me this'd require writing

No.  A simplistic port of Kaffe to Linux/MIPS should not take more
than a couple of minutes.  Just the time to define what you can use to
do simplistic poking of some registers inside a signal handler.

There is not JIT for MIPS in Kaffe yet, so you only get the
interpreter at this point.

Miguel.