Subject: possible driver error?

From: "Francis M.J. Hsieh" <[email-masked]>
Date: Fri, 26 Jun 1998 18:47:31 +0800

Dear SGI/Linuxer:
 
  Here is a possible driver error (but seems harmless, I checked it
  using network managerment hardware, no transmission error occured)

[root@helix /root]# ifconfig -a
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:3584  Metric:1
          RX packets:18 errors:0 dropped:0 overruns:0
          TX packets:0 errors:1260 dropped:18 overruns:0
          ^^^^^^^^^^^^ ---> ?

eth0      Link encap:Ethernet  HWaddr 08:00:69:08:BD:9A
          inet addr:140.114.98.34  Bcast:140.114.98.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4144 errors:0 dropped:0 overruns:0
          TX packets:0 errors:0 dropped:943 overruns:0
          ^^^^^^^^^^^^ ---> ?
          Interrupt:
-- 
Francis M. J. Hsieh      | Email:   [email-masked]
Life Science Department, | Webpage: http://www.life.nthu.edu.tw/~mjhsieh/
National Tsing Hua Univ, | Voice:   +886 3 5715131 ext 3482
HsinChu, Taiwan Republic | 	    +886 3 5715649

---

From: [email-masked] (Alan Cox)
Date: Fri, 26 Jun 1998 12:03:48 +0100 (BST)

>   using network managerment hardware, no transmission error occured)

I think someone is shipping old ifconfig tools with Linux/SGI. See if
"cat /proc/net/dev" makes sense

---

From: Alex deVries <[email-masked]>
Date: Fri, 26 Jun 1998 22:56:08 -0400 (EDT)

> "cat /proc/net/dev" makes sense

"someone" in this case is me;  I'm shipping the same net-tools that comes
with RH 5.1.  Of course, that's a 2.0.34 kernel.  I assume there's some
sort of inconsistancy between the /proc interfaces of 2.1.x and 2.0.34.

So, I'll have to stitch that package up.  In some ways, we're very much
skewed from RH 5.1 distribution because of the 2.1 kernel, apart from
other things. 

If someone would like to do that, it'd be appreciated, but I'll fix this
otherwise.

Thanks for the bug report.

- Alex