Subject: apache and other problems (fwd)

From: [email-masked] (Ariel Faigon)
Date: Thu, 16 Jul 1998 11:53:34 -0700 (PDT)

[forwarding bounced message]

----- Forwarded message from owner-linux@cthulhu -----
From: "Francis M.J. Hsieh" <[email-masked]>
To: [email-masked]
Subject: Re: The pre-release of Hard Hat Linux for SGI...
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
X-Mailer: Mutt 0.79e
In-Reply-To: <[email-masked]>; from Alex deVries on Tue, Jul 14, 1998 at 07:38:32PM -0400

On Tue, Jul 14, 1998 at 07:38:32PM -0400, Alex deVries wrote:
> Enjoy, and let me know if you do have the bandwidth do download and use
> it.

This two files were uploaded in ftp://helix.life.nthu.edu.tw/pub/
(yes, it is a Linux/SGI machine) for people in Taiwan save their
download time.

I got some problem here.

- apache httpd is still buggy (can't deliver text/html correctly)

- ifconfig is still buggy, TX packets is 0 (see followed)

| [root@helix /root]# ifconfig
| lo        Link encap:Local Loopback
|           inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
|           UP LOOPBACK RUNNING  MTU:3584  Metric:1
|           RX packets:27 errors:0 dropped:0 overruns:0
|           TX packets:0 errors:1962 dropped:27 overruns:0
|
| eth0      Link encap:Ethernet  HWaddr 08:00:69:08:BD:9A
|           inet addr:140.114.98.34  Bcast:140.114.98.255  Mask:255.255.255.0
|           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
|           RX packets:157929 errors:0 dropped:0 overruns:0
|           TX packets:0 errors:0 dropped:72422 overruns:0
|           Interrupt:3

- mouse doesn't work?

-- 
Francis M. J. Hsieh      | Email:   [email-masked]
Life Science Department, | Webpage: http://www.life.nthu.edu.tw/~mjhsieh/
National Tsing Hua Univ, | Voice:   +886 3 5715131 ext 3482
HsinChu, Taiwan Republic | 	    +886 3 5715649

----- End of forwarded message from owner-linux@cthulhu -----

-- 
Peace, Ariel

---

From: Alex deVries <[email-masked]>
Date: Fri, 17 Jul 1998 01:32:29 -0400 (EDT)

> (yes, it is a Linux/SGI machine) for people in Taiwan save their

Cool.

> - apache httpd is still buggy (can't deliver text/html correctly)

I don't know what that problem is; mine works fine.  Does it accept a TCP
connection properly? 

> - ifconfig is still buggy, TX packets is 0 (see followed)

Yeah, I think we went over that before although I don't remember what the
solution was.

> - mouse doesn't work?

In the HH install, there's a package called 'kernel-2.1.100-2'.  If you
install this, you'll have something like /boot/vmlinux-2.1.100.  That
kernel (2.1.100) should have mouse support in it.  you'll have to make a
symbolic link from /dev/psaux to /dev/mouse.

For reasons I don't want to get into, the kernel in the install really
sucks, and you should throw it away ASAP and use the packaged one.

- Alex

---

From: Honza Pazdziora <[email-masked]>
Date: Fri, 17 Jul 1998 10:09:43 +0200 (MET DST)

> symbolic link from /dev/psaux to /dev/mouse.

I'm using the new kernel but am confused about the devices. Should I have

	psaux (10/1) and mouse -> psaux ?

Here gpm fails with

	gpm: /dev/mouse: Operation not supported by device

and the same message I get then I do cat /dev/psaux.

Or
	mouse (4/64) and psaux -> mouse ?

Here gpm starts without a problem but no running cursor on the screen.

Yours,

------------------------------------------------------------------------
 Honza Pazdziora | [email-masked] | http://www.fi.muni.cz/~adelton/
                   I can take or leave it if I please
------------------------------------------------------------------------

---

From: "Francis M. J. Hsieh" <[email-masked]>
Date: Fri, 17 Jul 1998 16:23:00 +0800

On Fri, Jul 17, 1998 at 01:32:29AM -0400, Alex deVries wrote:
> On Thu, 16 Jul 1998, "Francis M.J. Hsieh" <[email-masked]> wrote:
> > I got some problem here.

oh, it fixed in vmlinux-2.1.100

> symbolic link from /dev/psaux to /dev/mouse.

well, how can I get gpm work? I had ln -s it, and it didn't work.