Subject: Re: libpthread of hard hat still doesn't work

From: Alex deVries <[email-masked]>
Date: Wed, 15 Jul 1998 19:33:24 -0400 (EDT)

What were you doing to produce this error?

- Alex

-- 
Alex deVries, puffin on LinuxNet.
http://www.engsoc.carleton.ca/~adevries/ .

On Wed, 15 Jul 1998, Dong Liu wrote:

> Date: Wed, 15 Jul 1998 19:48:43 -0400
> From: Dong Liu <[email-masked]>
> To: [email-masked]
> Subject: libpthread of hard hat still doesn't work
> 
> 
> This is what I got
> 
> /usr/lib/libpthread.so: undefined reference to `__libc_accept'
> /usr/lib/libpthread.so: undefined reference to `__libc_send'
> /usr/lib/libpthread.so: undefined reference to `__libc_recvfrom'
> /usr/lib/libpthread.so: undefined reference to `__libc_recvmsg'
> /usr/lib/libpthread.so: undefined reference to `__libc_sendmsg'
> /usr/lib/libpthread.so: undefined reference to `__libc_recv'
> /usr/lib/libpthread.so: undefined reference to `__libc_sendto'
> /usr/lib/libpthread.so: undefined reference to `__libc_connect'
> 
> 
> Thanks!
> 
> Dong.
>

---

From: Dong Liu <[email-masked]>
Date: Wed, 15 Jul 1998 19:48:43 -0400

This is what I got

Thanks!

Dong.

---

From: [email-masked]
Date: Thu, 16 Jul 1998 02:56:59 +0200

> What were you doing to produce this error?

Alex, this problem is known and fixed in my home source tree.  There is
a second problem that prevents kernel threads from being used.  It's
that clone(3), the library wrapper for clone(2), the syscall, is buggy
and I haven't yet fixed that.

We'll provide updated packages for HH 5.1 with this and other things fixed.

  Ralf

---

From: Alex deVries <[email-masked]>
Date: Wed, 15 Jul 1998 21:26:22 -0400 (EDT)

> We'll provide updated packages for HH 5.1 with this and other things fixed.

Perfect!

- Alex