Subject: Compiling kernel on HardHat

From: Takeshi Hakamada <[email-masked]>
Date: Thu, 06 Aug 1998 16:13:25 +0900 (JST)

Hi,

I have installed HardHat on R5000 Indy and it is very cool.
Installation procedure becomes much easier than previous release.
I admire all your effort to port Linux for SGI system.

I tried to compile kernel on HardHat using RPM kernel(2.1.100) source,
I can't build kernel due to following error.
In arch/mips/sgi/kernel/setup.c, 

setup.c:18: asm/vector.h: No such file or directory

Error message shows that I need to have include/asm/vector.h.
How can I get vector.h? Do I have to get latest kernel source from
ftp.linux.sgi.com?

Cheers,
Takeshi

--
Takeshi Hakamada                  
Nihon Silicon Graphics
E-mail: [email-masked], URL: http://reality.sgi.com/hakamada_nsg/
Voice mail: (internal)822-1300, (external)+81-3-5488-1863-1300

---

From: Thomas Bogendoerfer <[email-masked]>
Date: Thu, 6 Aug 1998 21:25:51 +0200

> setup.c:18: asm/vector.h: No such file or directory

that's already fixed in the CVS repository. You just have to remove
the #include in setup.c.

> How can I get vector.h? Do I have to get latest kernel source from

As this should be the only change, you don't need to.

Thomas.

-- 
See, you not only have to be a good coder to create a system like Linux,
you have to be a sneaky bastard too ;-)
                   [Linus Torvalds in <[email-masked]>]

---

From: Takeshi Hakamada <[email-masked]>
Date: Fri, 07 Aug 1998 09:33:47 +0900 (JST)

Hi Thomas,

Thanks for your help. I'll try to remove #include in setup.c and build
kernel tonight.

Cheers,
Takeshi

From: Thomas Bogendoerfer <[email-masked]>
Message-ID: <[email-masked]>

---

From: Takeshi Hakamada <[email-masked]>
Date: Mon, 10 Aug 1998 17:26:54 +0900 (JST)

I can successfully compile kernel after removing #include.

BTW, I brought SGI Linux Indy to TLUG(Tokyo Linux Users Group, mainly
consists of English speaking people who lives in Japan) meeting
and show them HardHat. They are very interested in SGI Linux project.

Cheers,
Takeshi

--
Takeshi Hakamada                  
Nihon Silicon Graphics
E-mail: [email-masked], URL: http://reality.sgi.com/hakamada_nsg/
Phone: +81-45-682-3712, Fax: +81-45-682-0856
Voice mail: (internal)822-1300, (external)+81-3-5488-1863-1300