Subject: Re: crosscompiling on debian/i386

From: Ulf Carlsson <[email-masked]>
Date: Fri, 2 Oct 1998 07:30:15 +0200 (CEST)

On Thu, 1 Oct 1998, Thomas Bogendoerfer wrote:

> no he tries to crosscompile with gcc-2.7.2.x a new kernel from CVS.
> This does no longer work out of the box, because we've changed the 
> #ifdef _LANGUAGE_ASSEMBLY to the egcs predefined ones. And these aren't
> defined in the gcc-2.7 spec file.
> 
> I don't have a patch handy, but simply changing -D__LANGUAGE_ASSMBLEY__ to
> -D_LANGUAGE_ASSEMBLY and -D__LANGUAGE_C__ to -D_LANGUAGE_C in the spec
> file worked for me.

I've already changed those defines.

I don't have a patch (I don't have the old file anylonger), but I can send
the whole file (/usr/local/lib/gcc-lib/mips-linux/2.7.2.2/specs)

It's attached.

- Ulf

---

From: Richard Hartensveld <[email-masked]>
Date: Fri, 02 Oct 1998 18:46:04 +0200

> the whole file (/usr/local/lib/gcc-lib/mips-linux/2.7.2.2/specs)

Works perfectly, i've just build the first kernel with it and i'm  now gonna
try to get al the output on the
serial console. (challenge S).

Richard