Subject: Re: I am interested in helping port to Indigo

From: Alex deVries <[email-masked]>
Date: Mon, 12 Oct 1998 14:15:04 -0400

Fernando D. Mato Mira wrote:

> Hello,
>
> What would one need to do to port what is running of SGI/Linux to
> Indigo R4400 150MHz Elan?

One would need to write device drivers for:
- SCSI
- ethernet
- display or serial

I thought the indigo used either gio64 or gio32.  I might be wrong.

Have I missed anything?

- Alex

---

From: "Fernando D. Mato Mira" <[email-masked]>
Date: Mon, 12 Oct 1998 20:22:18 +0200

Hello,

Regards,

---

From: "William J. Earl" <[email-masked]>
Date: Mon, 12 Oct 1998 11:28:27 -0700

> Indigo R4400 150MHz Elan?

     By "Indigo R4400", I assume you mean "Indigo2 R4400".  As far as
I know, we only supported the R4000 in the "Indigo R4000".  The 
kernel should be mostly compatible, aside from some details about
clocks, the addition of the EISA bus, and the absence of the video
port.  The big issue is the graphics.  Elan has downloaded microcode,
although you might make do with what is downloaded by the PROM.
Unfortunately, I cannot at present supply documentation for the
interface exported by that microcode (partly because I don't have
any ready to hand).

---

From: "William J. Earl" <[email-masked]>
Date: Mon, 12 Oct 1998 11:47:16 -0700

> I thought the indigo used either gio64 or gio32.  I might be wrong.

     The original Indigo (R3000-based) used a different chip set from
the Indigo R4000, Indy, and Indigo2, which shared a common memory controller.
The latter machines use vary a bit in the details of their peripheral
chips, the parts are mostly either the same or different mainly in being
later revisions in some of the systems.  The Indigo2 added EISA bus support
(along with GIO).

---

From: "Fernando D. Mato Mira" <[email-masked]>
Date: Mon, 12 Oct 1998 20:58:24 +0200

>     By "Indigo R4400", I assume you mean "Indigo2 R4400".  As far as

Nope. Indigo "1" R4400 indeed. 

And yes, it's GIO32.

---

From: Rob Lembree <[email-masked]>
Date: Mon, 12 Oct 1998 16:48:32 -0400

> Perhaps you can supply us with a hinv output and picture of it, as I
>have never heard of an Indigo with a R4400...

SGI did indeed build these with both 100 and 150 MHz processors.
It was called the IP20.

-- 

Rob Lembree                Strategic Software Organization

Silicon Graphics, Inc.                  http://www.sgi.com
One Cabot Road                             [email-masked]
Hudson, MA 01749                           [email-masked]
Phone: 978-567-2141                      FAX: 978-567-2341

PGP: 1F EE F8 58 30 F1 B1 20  C5 4F 12 21 AD 0D 6B 29

---

From: "William J. Earl" <[email-masked]>
Date: Mon, 12 Oct 1998 14:13:38 -0700

> SGI did indeed build these with both 100 and 150 MHz processors.
...
      I was familiar with the IP20.  I didn't realize that we had shipped
any 150 MHZ R4400 processors for the IP20.

---

From: darkaeon <[email-masked]>
Date: Mon, 12 Oct 1998 14:30:02 -0700

-Steve

---

From: Rob Lembree <[email-masked]>
Date: Mon, 12 Oct 1998 17:31:07 -0400

Here's a hinv from an R4400 Indigo:

CPU: MIPS R4400 Processor Chip Revision: 4.0
FPU: MIPS R4000 Floating Point Coprocessor Revision: 0.0
1 100 MHZ IP20 Processor
Main memory size: 48 Mbytes
Secondary unified instruction/data cache size: 1 Mbyte on Processor 0
Instruction cache size: 16 Kbytes
Data cache size: 16 Kbytes
Integral SCSI controller 0: Version WD33C93B, revision C
  Disk drive: unit 1 on SCSI controller 0
  Disk drive: unit 2 on SCSI controller 0
On-board serial ports: 2
On-board bi-directional parallel port
Graphics board: GR2-Elan
Integral Ethernet: ec0, version 1
Iris Audio Processor: revision 10
Galileo video  (ev1): unit 0, revision 2.  601 option connected.  

--

---

From: Christian Reisch <[email-masked]>
Date: Mon, 12 Oct 1998 14:37:19 -0700

> >have never heard of an Indigo with a R4400...

[dreamtime:~] hinv
CPU: MIPS R4400 Processor Chip Revision: 5.0
1 150 MHZ IP20 Processor
  Disk drive: unit 3 on SCSI controller 0
Graphics board: GR2-XS24

---

From: "Fernando D. Mato Mira" <[email-masked]>
Date: Tue, 13 Oct 1998 15:44:13 +0200

1 150 MHZ IP20 Processor

On-board serial ports: 2

Secondary unified instruction/data cache size: 1 Mbyte on Processor
0

Main memory size: 256 Mbytes

Tape drive: unit 7 on SCSI controller 0: DAT

Tape drive: unit 6 on SCSI controller 0: QIC 150

CDROM: unit 5 on SCSI controller 0

Disk drive: unit 4 on SCSI controller 0

Disk drive / removable media: unit 2 on SCSI
controller 0: 720K/1.44M floppy

Graphics board: GR2-Elan

There're a couple of old pictures att
www.vrai.com, but how
could you tell? :-)

BTW, 6.2 disk is #3. Used to nvram OSLoadPartition to #1, slide 5.3
in

and compile for MIPS ABI 1.0 . I should still get a big disk for 6.5 dual
boot..

Fernando D. Mato
Mira

Real-Time SW Eng & Networking

Advanced Systems Engineering Division

CSEM - Centre Suisse d'Electronique et de
Microtechnique

Jaquet-Droz 1                         email:  [email-masked]

CH-2007 Neuchatel                       tel: +41 (32) 720-5157

Switzerland                             FAX: +41 (32) 720-5720

www.csem.ch                  www.vrai.com
http://ligwww.epfl.ch/matomira.html