Subject: Halloween doc II

From: [email-masked] (Ariel Faigon)
Date: Thu, 5 Nov 1998 12:53:04 -0800 (PST)

Hi,

A second "what is Linux and how to combat it" document
just came out the Microsoft leak factory:

        http://www.opensource.org/halloween2.html

It is a followup doc to the infamous "Halloween Doc"
(now renamed "Halloween I").   It was leaked by an MS
employee as a reaction to the recent publicity for
Halloween-I.  It adds the threat of Linux as a client
and gives a very positive evaluation of Linux (coming
from within MS, this is telling).

It concludes again, with the sinister suggestions to
"de-commoditize" open protocols, plus (surprise) ways
to attack Linux via litigation (if you can't beat them
on merit, there are always the nukes, Bill).

		---
There's specific interest to this community: David Miller
and Miguel de Icaza are both mentioned and their SPARC
comparison docs are linked from this document.  No doubt,
the MS guys did a great research job.

There's a lot the Linux community learn from this document.
Just read the "what's missing in Linux compared to NT"
part and make sure it is implemented. It doesn't appear
too hard.  Some points which are definitely geared towards
the non sophisticated users include:

	1) Automounting a floppy/CD when it is inserted
	   (BTW: IRIX mediad has been doing this for quite a while)

	2) Simpler installation: e.g. rather than asking 30
	   questions, provide a menu like:
		1) Express install: don't ask me anything,
		   just go ahead and fill my disk.
		2) Pick and chose: let me select
		...

	3) XFree86 installation: don't ask me what chipset I have
	   and what's the scan rates etc.  Instead have an internal
	   mapping table between well known brand names (e.g. ATI Mach64)
	   and the details of the card.  People usually know the latter
	   (what's written on the box, but rarely the former)

	4) Simpler Network config:  DHCP client installed by default
	   Again saving complex questions to the simple user

	5) Of course, a coherent consistent GUI to manage everything
	   from HW devices to access to files etc.  Those who need
	   the simplicity, will never be willing to do command line
	   stuff.

	6) Development tools like VB/VC++ :-)

Someone forward this to Red Hat / Gnome and the XFree86 teams ...

-- 
Peace, Ariel

---

From: [email-masked] (David Watters)
Date: Thu, 5 Nov 1998 16:00:23 -0500 (EST)

It also made some high visibility press:

http://www.news.com/News/Item/0,4,28397,00.html?st.ne.ni.lh

On Nov 5, 12:53pm, Ariel Faigon wrote:
> Subject: Halloween doc II
> Hi,
>

-- 
David Watters         |                 Silicon*Graphics 
Systems Engineer      |                http://www.sgi.com/ 
Silicon Graphics, Inc.|    http://reality.sgi.com/davester/  (6/13/97) 
[email-masked] |  1.800.800.SGI1 (Sales) 1.800.800.4SGI (Support) 
DID 1.614.844.3820    |   http://www.nintendo.com/ (N64, the $130 SGI!)

---

From: [email-masked] (Ariel Faigon)
Date: Thu, 5 Nov 1998 13:34:51 -0800 (PST)

:
:> 	1) Automounting a floppy/CD when it is inserted
:> 	   (BTW: IRIX mediad has been doing this for quite a while)
:
:Yeah we looked at it, and decided it sucked somewhat. Stephen Tweedie
:has a slightly different scheme where you can even be sat in a directory
:on a changable volume when itchanges and all is fine - its called
:supermount
:
As I said, easy to implement -- difficult to get this as standard
into mainstream distributions.  Maybe this is where Red Hat / Caldera
SuSE etc. need to cooperate and just make things happen. Just focus
on those that are the biggest barrier of entry for the Microsoft-versed
masses.  If we do it, we can make great inroads into the desktop as well.
Oh yeah, and of course, now that Corel is funding WINE, we may even get
all the MS apps too.

:
:> 	5) Of course, a coherent consistent GUI to manage everything
:> 	   from HW devices to access to files etc.  Those who need
:> 	   the simplicity, will never be willing to do command line
:> 	   stuff.
:
:Have a look at linuxconf, it works, it does the job. The gui just needs a 
:major rethink
:
My thought exactly.   It is the GUI what makes the non technical
average user run away.  Hacker don't care enough about GUI's.

:> 	6) Development tools like VB/VC++ :-)
:
:Cygnus GNUPro ;)
:
Good point.  People who can afford paying a few hundred dollars
for Visual C++ can afford Cygnus GNUPro.   Not everything should
be free as long as there's someone that got it right and it is
available on Linux.   I'm glad this reality is not even on MS's
radar they just compare "bare" Linux to a fully loaded (with
many additional $$$ NT client).

:> Someone forward this to Red Hat / Gnome and the XFree86 teams ...
:
:We've all seen it. 
:
How naive of me to even hint otherwise :-)

-- 
Peace, Ariel

---

From: [email-masked] (Alan Cox)
Date: Thu, 5 Nov 1998 22:18:34 +0000 (GMT)

> 	   (BTW: IRIX mediad has been doing this for quite a while)

Yeah we looked at it, and decided it sucked somewhat. Stephen Tweedie
has a slightly different scheme where you can even be sat in a directory
on a changable volume when itchanges and all is fine - its called
supermount

> 		2) Pick and chose: let me select

Thats occured a lot

> 	   (what's written on the box, but rarely the former)

Current installers from RH and I think SuSE ask no questions for PCI
installs barring optional monitor abiklity ones 

> 	   Again saving complex questions to the simple user

Yep

> 	   the simplicity, will never be willing to do command line

Have a look at linuxconf, it works, it does the job. The gui just needs a 
major rethink

> 	6) Development tools like VB/VC++ :-)

Cygnus GNUPro ;)

> Someone forward this to Red Hat / Gnome and the XFree86 teams ...

We've all seen it. 

Alan

---

From: [email-masked] (Alan Cox)
Date: Thu, 5 Nov 1998 22:34:23 +0000 (GMT)

> How naive of me to even hint otherwise :-)

Grin

---

From: Miguel de Icaza <[email-masked]>
Date: Thu, 5 Nov 1998 18:13:10 -0600

> Someone forward this to Red Hat / Gnome and the XFree86 teams ...

I can :-)

It also mentions GNOME, which made me extremely happy :-)

Miguel.

---

From: Miguel de Icaza <[email-masked]>
Date: Thu, 5 Nov 1998 18:15:10 -0600

> > 	6) Development tools like VB/VC++ :-)

Yeah, but it is still not licensed under the GPL or an OpenSource
license (at least not all of it)

miguel.

---

From: willwork4play <[email-masked]>
Date: Thu, 05 Nov 1998 20:07:31 -0600

Forget VC++.  Borlands integrated debugger and compiler are the only way
to go!

David M.
First time to post to this list.  Do I get a tootsie roll?

---

From: Pim van Riezen <[email-masked]>
Date: Fri, 06 Nov 1998 10:50:23 +0200

>         6) Development tools like VB/VC++ :-)

A few things could fill that gap (with which I'm experimenting a lot
right now). An upcoming promise is gIDE, which could well fill the role
of a project manager. Interface Design a-la VB can be very well done
with the FLTK toolkit (http://fltk.easysw.com/) which, in my humble
opinion of an application programmer, is the best thing to hit the world
since the invention of the bread-slicing knife.

There's also the JX/JCC (Code Crusader) combination, which unfortunately
is such a pita to compile that I refuse to take it seriously :-)

Pim

---
<This could've been your signature>

[email-masked], [email-masked]
Unix Developer for WebCity / Microhill Automation
Operator for the SaltLake.UT.US.Undernet.Org IRC-Server

---

From: 4819 <[email-masked]>
Date: Fri, 6 Nov 1998 05:39:09 -0500 (EST)

has anyone about ever tried scriptum? it's a pretty nice ide, at least i
think so. it can be adapted to support any language, has a nice class
browser, support cvs, support editing of files on remote hosts via ftp,
etc.
it was recently made opensource, perhaps some features can be borrowed
from it, for use in gIDE. 

url is http://www.scriptum.org/

rob

---

From: "Fernando D. Mato Mira" <[email-masked]>
Date: Fri, 06 Nov 1998 13:40:20 +0100

>url is http://www.scriptum.org/

Whoa! Software from the _other_ cult!

---

From: [email-masked]
Date: Sun, 8 Nov 1998 04:38:02 +0100

> It also mentions GNOME, which made me extremely happy :-)

Miguel Gates ;-)

  Ralf