Subject: bootp on IRIX server

From: Al Aumenta <[email-masked]>
Date: Mon, 21 Dec 1998 16:11:06 -0500

I am attempting to install Linux on an Indy but I am running into a problem

the instructions are for using bootp on a i386 host, I am interpreting
the instructions

for an SGI host .

here is what I have:

/etc/inetd.conf

bootp   dgram   udp     wait
root    /usr/etc/bootp bootp -f /etc/bootptab

tftp    dgram   udp
wait    root    /usr/etc/tftpd  tftpd
-s  /usr/src/sgi/installfs

bootparam/1 dgram   rpc/udp wait    root
/usr/etc/rpc.bootparamd bootparamd

/etc/bootptab:

(server info)

/usr/src/sgi/installfs

vmlinux

(client info)

cygnus
1 08:00:69:09:2d:9b     169.238.59.4
vmlinux

I have successfully connected with the server -- the kernel boots -
but the kernel cannot

mount the network file system.

I get RPC errors pointing to nfs and mountd :

Looking up port of RPC 100003/2 on 169.238.59.23

RPC: sendmsg returned error 128

portmap server 169.238.59.23 not responding , timed out

Looking up port of RPC 100005/1 on 169.238.59.23

RPC: sendmsg returned error 128

portmap server 169.238.59.23 not responding , timed out

Root-NFS: Unable to get mountd port number from serve, using default

rpcinf -p output is :

100000    3   udp
111  portmapper

100000    2   udp
111  portmapper

100000    3   tcp
111  portmapper

100000    2   tcp
111  portmapper

100005    1   tcp
1024  mountd

100005    3   tcp
1024  mountd

100005    1   udp
1027  mountd

100005    3   udp
1027  mountd

100003    2   udp
2049  nfs

100003    3   udp
2049  nfs

100003    2   tcp
2049  nfs

100003    3   tcp
2049  nfs

****

I know I have permissions problems but I'm not sure where. oh by the
way

/etc/exports:

/usr/src/sgi/installfs -anon=root,nohide,root=cygnus

any information you can give will be most appreciated.

Thanks

Al

--
********************************************
Albert Aumenta
Systems Support Engineer
Silicon Graphics Inc.
Phone 518-434-5886
e-mail [email-masked]

---

From: [email-masked] (Ariel Faigon)
Date: Mon, 21 Dec 1998 13:33:48 -0800 (PST)

[Forwarding bounced message.
 Please subscribe with an explicit general-domain (no machine)
 to avoid anti-spam subscriber-only bounces.
 Majordomo is picky about this -- Ariel]

Date: Mon, 21 Dec 1998 13:23:19 -0800
From: Shrijeet Mukherjee <[email-masked]>
To: Al Aumenta <[email-masked]>
cc: "[email-masked]" <[email-masked]>
Subject: Re: bootp on IRIX server
In-Reply-To: <[email-masked]>
Message-ID: <[email-masked]>

I had the same problem .. and I really do not remember what I did to make
it go away ..

but here are 2 things to try ..

1> run snoop on your SGI box .. and see what exactly is happening ..
2> try and bootp the unix kernel (IRIX) and see if bootp is setup and
running right ..

another thing I gathered is that there is some NFS incompatibility and we
need to serve the bootp of an intel linux box .. and thus I resorted to
that ..

hope this helps ..

On Mon, 21 Dec 1998, Al Aumenta wrote:

->I am attempting to install Linux on an Indy but I am running into a
->problem

-- 
Peace, Ariel