Subject: Linux on a Indigo R4000?

From: Andreas Gaffke-Administrator <[email-masked]>
Date: Fri, 4 Dec 1998 16:27:36 +0100

Hi,

I´m new to this list, so please forgive any stupid questions ;-))

I´ve been trying to get an old "Indigo R4000" to run Linux... unfortunaly
without much success. I started out with the "Hardhat-5.1" distribution from the
linux.sgi site. I set up a 2GB disk with a "root" layout under IRIX 4.0.5F and
setup bootpd/tftpd on  a Pentium-II-Linux box. So far, so good!

When I try to boot the linux kernel from the "PROM" monitor, I get the
following output:

>> version
PROM Monitor SGI Version 4.0.5D Rev A IP20, Aug 17, 1992 (BE)
>> boot -f bootp()aks-csd:/vmlinux
Setting $netaddr to 134.130.100.90 (from server aks-csd)
Obtaining /vmlinux from server aks-csd

Cannot load bootp()aks-csd:/vmlinux.
Unable to load bootp()aks-csd:/vmlinux: execute format error

Here is the output of the "hinv" command under IRIX 4.0.5:
----------
1 50 MHZ IP20 Processor
FPU: MIPS R4010 Floating Point Chip Revision: 0.0
CPU: MIPS R4000 Processor Chip Revision: 2.2
On-board serial ports: 2
Data cache size: 8 Kbytes
Instruction cache size: 8 Kbytes
Secondary unified instruction/data cache size: 1 Mbyte
Main memory size: 32 Mbytes
Integral Ethernet: ec0, version 0
CDROM: unit 6 on SCSI controller 0
Tape drive: unit 5 on SCSI controller 0: QIC 150
Disk drive / removable media: unit 3 on SCSI controller 0: 720K/1.44M floppy
Disk drive: unit 2 on SCSI controller 0
Disk drive: unit 1 on SCSI controller 0
Integral SCSI controller 0: Version WD33C93B, revision C
Iris Audio Processor: revision 10
Graphics board: GR2-XS24 with Z-buffer             
-----------

What could be the problem? Is there a chance to get Linux up and running on
this hardware?

I´d appreciate some tips!

Thanks,

Andreas

--

+---------------------------------------------------------+
|   Dr. Andreas Gaffke         Tel/FAX: ++49+241 911646   |
|   Lousbergstr. 57            ICQ: 23487004:AndreasG     |
|   D-52072 Aachen                                        |
|   Germany                                               |
|                                                         |
|        e-Mail: [email-masked]         |
|                                                         |
|  ***  Microsoft: it´s not a bug, it´s a feature.  ***   |
|                                                         |
+---------------------------------------------------------+

---

From: "William J. Earl" <[email-masked]>
Date: Fri, 4 Dec 1998 09:05:49 -0800

Andreas Gaffke-Administrator writes:
...
 > Unable to load bootp()aks-csd:/vmlinux: execute format error

      You have to load sash first (and probably an IRIX 6.2 or later
sash at that), because the IP20 prom only knows how to load MIPS ECOFF
binaries, not ELF binaries.  The newer sash knows how to load ELF.

	sash

Alternately, you could use some tool to produce an ECOFF executable
from the ELF executable, sufficient to allow the PROM to load it.
(The PROM expects only the most basic information, so such a tool
does not have to be very sophisticated.)

     Beyond that, the IP20 is not completely compatible with the Indy
(IP24, IRIX IP22 kernel) and Indigo2 (IP22), although it shares the
same memory controller, and most of the work on Linux/MIPS so far
has been on the Indy.  The graphics are often different, and the I/O
controller is an older revision, compared to Indy, which is not
completely compatible.  The graphics card you have is also different
from the basic Newport (XL) graphics on Indy, and is probably not yet
supported.

      I have been talking with people within SGI about providing
documentation and downloadable firmware for the various graphics cards
and for platforms other than Indy, but I don't yet have final
agreement.  Also, some of these machines were built quite a long time
ago (yours was probably built in 1992), so locating some of the
documentation is quite an effort.  

 > Disk drive / removable media: unit 3 on SCSI controller 0: 720K/1.44M flo=
 > ppy
 > Graphics board: GR2-XS24 with Z-buffer            =20
 > -----------
 > 
 > What could be the problem? Is there a chance to get Linux up and running =
 > on
 > this hardware?
 > 
 > I=B4d appreciate some tips!
 > 
 > Thanks,
 > 
 > Andreas
 > 
 > 
 > 
 > --
 > 
 > |  ***  Microsoft: it=B4s not a bug, it=B4s a feature.  ***   |
 > |                                                         |