Subject: Parallel port support.

From: Alex deVries <[email-masked]>
Date: Tue, 26 Jan 1999 12:03:08 -0500 (EST)

I've never seen any documentation of the parallel port that hangs off of
the pbus; does anyone know:
- what kind of chip it is
- how it hangs off of the pbus?

I'm thinking this is a pretty easy device driver to write for testing that
the pbus code works well.  It'd help out with HAL2 support.

- Alex

-- 
Alex deVries, puffin on LinuxNet.
I know exactly what I want in life.

---

From: [email-masked] (Dave Olson)
Date: Tue, 26 Jan 1999 09:09:10 -0800 (PST)

Alex deVries wrote: 
|  
|  I've never seen any documentation of the parallel port that hangs off of
|  the pbus; does anyone know:
|  - what kind of chip it is

Just another part of the hpc3 asic.

|  - how it hangs off of the pbus?

It doesn't.  That's just the address space where the control registers are.

Dave Olson, Silicon Graphics
http://reality.sgi.com/olson   [email-masked]

---

From: Alex deVries <[email-masked]>
Date: Tue, 26 Jan 1999 12:16:18 -0500 (EST)

> Just another part of the hpc3 asic.

Oh, it's *included* in the HPC3?  I'd missed that in the docs.

> It doesn't.  That's just the address space where the control registers are.

Ah, I see.

So the only things that actually hang off the pbus in the indy are:
- some of the SCSI control registers for the wd33c93
- HAL2

Where does ISDN fit in?

What other machines have the HPC3, and what kind of devices do they have
on them?

- Alex

---

From: Ulf Carlsson <[email-masked]>
Date: Tue, 26 Jan 1999 18:21:40 +0100

> I've never seen any documentation of the parallel port that hangs off of

I'm curious as well.

> the pbus code works well.  It'd help out with HAL2 support.

We don't need any special support for the PBUS when it comes to HAL2, and
there's no special PBUS code written. Everything is done directly by
reading/writing to the PBUS PIO registers, and they don't need any kind of
setup. This is not difficult at all. What's more complicated is to setup the
PBUS DMA, but the parallel port doesn't use DMA.

It would be nice to have parallel port support, but the reason to write it is
_not_ to make it easier to build the HAL2 driver. Write it anyway :)

- Ulf

---

From: Ulf Carlsson <[email-masked]>
Date: Tue, 26 Jan 1999 18:26:09 +0100

> Oh, it's *included* in the HPC3?  I'd missed that in the docs.

It should be in a separate document like the HAL2. None of the PBUS devices are
documented in the HPC3 spec. Maybe it's some standard PC stuff?

- Ulf

---

From: [email-masked] (Dave Olson)
Date: Tue, 26 Jan 1999 09:55:16 -0800 (PST)

Ulf Carlsson wrote: 
|  > Oh, it's *included* in the HPC3?  I'd missed that in the docs.
|  
|  It should be in a separate document like the HAL2. None of the PBUS devices are
|  documented in the HPC3 spec. Maybe it's some standard PC stuff?

HAL2 *is* a seperate chip.  Documenting pieces of one chip in
seperate docs would be, ummm, strange...

---

From: Ulf Carlsson <[email-masked]>
Date: Tue, 26 Jan 1999 18:58:24 +0100

> seperate docs would be, ummm, strange...

How would I know? I know where it's located in the memory space but not where
it's located in the machine :)

- Ulf

---

From: Alex deVries <[email-masked]>
Date: Tue, 26 Jan 1999 13:12:14 -0500 (EST)

> seperate docs would be, ummm, strange...

Okay.  So the HPC3 has lp support. I don't see any docs on registers, etc
for it.  Where might I find these?

- Alex

---

From: [email-masked] (Dave Olson)
Date: Tue, 26 Jan 1999 10:32:38 -0800 (PST)

Alex deVries wrote: 
|  So the only things that actually hang off the pbus in the indy are:
|  - some of the SCSI control registers for the wd33c93

Yes, the "control" interface to the wd93.

|  - HAL2

Yep.

And as earlier discussed:
	RTC, prom, interrupt controller, serial ports.

Now, I do have an old spec that describes the parallel port
as a seperate chip, but I am nearly certain we folded it into
hpc3.  I may have to retract that though.  None of the specs
I have in my office are the final versions, and I don't have
an indigo2 lying around to look at the final chip layout.  If
you find a chip marked PI1, then I am remembering wrong, and we
did the parallel port as a seperate chip.

|  Where does ISDN fit in?

I don't remember, and I don't have the Indy specs handy, and I can't
find the online docs right now.  I think it went on the pbus, but
that's a vague memory.

|  What other machines have the HPC3, and what kind of devices do they have
|  on them?

Only the Indigo2 series (r4k, r8k, r10k) and Indy.

---

From: [email-masked] (Dave Olson)
Date: Tue, 26 Jan 1999 10:33:46 -0800 (PST)

Ulf Carlsson wrote: 
|  > HAL2 *is* a seperate chip.  Documenting pieces of one chip in
|  > seperate docs would be, ummm, strange...
|  
|  How would I know? I know where it's located in the memory space but not where
|  it's located in the machine :)

On a seperate board, even (at least for the older indigo2, we were
going to put on the system board later on, I just don't remember if
we ever did it or not; Indy was always on the system board).

---

From: [email-masked] (Dave Olson)
Date: Tue, 26 Jan 1999 10:34:58 -0800 (PST)

Alex deVries wrote: 
|  Okay.  So the HPC3 has lp support. I don't see any docs on registers, etc
|  for it.  Where might I find these?

Well, in the irix include files, which doesn't help you much.

I guess whomever at sgi is sponsoring the indigo2 linux port
should be getting you the docs.  I didn't even know about that
until I read it on this list.