Subject: Problems getting 2.1.131 to build.

From: Alex deVries <[email-masked]>
Date: Mon, 18 Jan 1999 01:18:32 -0500 (EST)

First off, thanks for getting linus.linux.sgi.com back online!

Okay. Here's the log of my build of 2.1.131 from the CVS:

make[3]: Entering directory `/usr/src/newlinux/linux/fs/proc'
egcs -D__KERNEL__ -I/usr/src/newlinux/linux/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic
-mcpu=r4600 -mips2 -pipe   -c -o array.o array.c
array.c: In function `get_phys_addr':
array.c:399: warning: int format, pid_t arg (arg 2)
array.c: In function `task_state':
array.c:738: warning: int format, pid_t arg (arg 4)
array.c:738: warning: int format, pid_t arg (arg 5)
array.c:738: warning: int format, uid_t arg (arg 6)
array.c:738: warning: int format, uid_t arg (arg 7)
array.c:738: warning: int format, uid_t arg (arg 8)
array.c:738: warning: int format, uid_t arg (arg 9)
array.c:738: warning: int format, gid_t arg (arg 10)
array.c:738: warning: int format, gid_t arg (arg 11)
array.c:738: warning: int format, gid_t arg (arg 12)
array.c:738: warning: int format, gid_t arg (arg 13)
array.c:741: warning: int format, long int arg (arg 3)
array.c: In function `get_stat':
array.c:947: warning: int format, pid_t arg (arg 6)
array.c:947: warning: int format, pid_t arg (arg 7)
array.c:947: warning: int format, pid_t arg (arg 8)
array.c: In function `get_root_array':
array.c:1351: duplicate case value
array.c:1347: this is the first entry for that value
array.c:1352: warning: implicit declaration of function
`get_ds1286_status'
make[3]: *** [array.o] Error 1
make[3]: Leaving directory `/usr/src/newlinux/linux/fs/proc'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/newlinux/linux/fs/proc'
make[1]: *** [_subdir_proc] Error 2
make[1]: Leaving directory `/usr/src/newlinux/linux/fs'
make: *** [_dir_fs] Error 2

my egcs version:
[root@black linux]# egcs -v
Reading specs from /usr/lib/gcc-lib/mips-linux/egcs-2.90.27/specs
gcc version egcs-2.90.27 980315 (egcs-1.0.2 release)

Any ideas?  Looking at the code, what's CONFIG_SGI_DS1286?

- Alex

-- 
Alex deVries, puffin on LinuxNet.
I know exactly what I want in life.

---

From: Alex deVries <[email-masked]>
Date: Mon, 18 Jan 1999 01:57:31 -0500 (EST)

> -mcpu=r4600 -mips2 -pipe   -c -o array.o array.c

<snip>

> make[3]: *** [array.o] Error 1

Ah, I see.  Just disabled SGI RTC support, and it builds. Binaries
tomorrow.

- Alex

---

From: Thomas Bogendoerfer <[email-masked]>
Date: Mon, 18 Jan 1999 22:40:57 +0100

> Ah, I see.  Just disabled SGI RTC support, and it builds. Binaries

wrong solution, disable "Enhanced Real Time Clock Support" and let
SGI RTC enabled. It's possible, that this is the cause for your
boot problem.

Thomas.

-- 
   This device has completely bogus header. Compaq scores again :-|
It's a host bridge, but it should be called ghost bridge instead ;^)
                                        [Martin `MJ' Mares on linux-kernel]