Subject: HAL2 support.

From: Alex deVries <[email-masked]>
Date: Sun, 24 Jan 1999 16:01:19 -0500 (EST)

There's a rumour going around that Ulf has had some luck with getting HAL2
support working.  If there's any truth to this,a dn so that we don't
reinvent the wheel, does anyone know where this source might be?

Also, am I right in saying that there's no devices written for HPC3 that
use the pbus?  Looks like the first step to writing a HAL driver is to be
able to write to the pbus.

What else is actually on the pbus on the Indy?  From this HPC
documentation, looks
like:
- fdc (I thought Indy floppies were SCSI though)
- rtc
- prom
- scsi (although not the 33c93)
- int2 (what's this?)
- hal2
- pi1 (what's this?)

- Alex

-- 
Alex deVries, puffin on LinuxNet.
I know exactly what I want in life.

---

From: [email-masked] (Dave Olson)
Date: Sun, 24 Jan 1999 20:06:09 -0800 (PST)

Alex deVries wrote: 
|  Also, am I right in saying that there's no devices written for HPC3 that
|  use the pbus?  Looks like the first step to writing a HAL driver is to be
|  able to write to the pbus.

The pbus interface itself is a pretty simple interface.

|  What else is actually on the pbus on the Indy?  From this HPC
|  documentation, looks
|  like:
|  - fdc (I thought Indy floppies were SCSI though)

There was talk of doing floppy this way, but it never was actually done.

|  - rtc
|  - prom
|  - scsi (although not the 33c93)

scsi is off the hpc3, but it's only the control path (pio to registers)
that uses the pbus interface.  The datapath is a different bus.

|  - int2 (what's this?)

interrupt control.

|  - hal2
|  - pi1 (what's this?)

parallel port.

Dave Olson, Silicon Graphics
http://reality.sgi.com/olson   [email-masked]