Subject: Precompiled 2.1.131 binaries.

From: Alex deVries <[email-masked]>
Date: Sat, 23 Jan 1999 20:39:42 -0500 (EST)

I've put prebuilt Linux binaries for the Indy in:
ftp://linus.linux.sgi.com/pub/linux/mips/test/vmlinux-indy-2.1.131.tar.gz

This is the first prebuilt kernel that includes modules, although I think
there are still problems with modutils.

Sorry for the delay, it took me a long time to figure out what my binutils
problems were.

- Alex

-- 
Alex deVries, puffin on LinuxNet.
I know exactly what I want in life.

---

From: [email-masked]
Date: Sun, 24 Jan 1999 02:50:52 +0100

> there are still problems with modutils.

Use modutils directly from vger.  See

  ftp://vger.rutgers.edu/pub/linux/README.CVS

for how to access vger's CVS.

  Ralf

---

From: Chad Carlin <[email-masked]>
Date: Sun, 24 Jan 1999 17:33:02 -0600 (CST)

Hello All,

Well, I gave the new kernel a try. Now I have new problems and an interesting 
note. The problem is this. "Kernel panic: No init found. Try passing init= 
option to kernel" 

I am following the instructions that call for using "./mke2fs drive" and 
using "boot vmlinux root=/dev/sdb3" to boot the kernel. Are these the correct 
ones or is the bootp server the better way to go? 

In either case I actually tried it the other way (nfsroot=) as well. No 
work-worky that way either. I also tried combining the methods too. Like 
getting the kernel via bootp and setting root=/dev/sda1 (linux disk is scsi 
id 1 and irix is 3). Tried getting the kernel from the local efs fs and 
getting root via nfs from my regular irix Indy. Tried old kernel again too. 

Also note: With the previous kernel I was getting boot information through 
the console port of the indy with nothing being displayed on the gfx monitor. 
Now I only get the "130768+22320+3184+341792+48560d+4604+6816 entry: 
0x8bfa60d0" on the console and the rest on the gfx display.

Questions:
1) Is anyone else using an R4400?
2) Does "VFS: Mounted root (ext2 filesystem) readonly" mean that I guessed 
  the correct disk partition to use?
3) What does init= mean in "Kernel panic: No init found.  Try passing 
  init= option to kernel"?
4) This seems to suggest that the tty0 and tty1 have been discovered OK:
	SGI Zilog8530 serial driver version 1.00
	tty00 at 0xbfbd9838 (irq = 21) is a Zilog8530
	tty01 at 0xbfbd9830 (irq = 21) is a Zilog8530
 Why then would I get this error message?
	Warning: unable to open an initial console

5) Could someone point me to where I can browse the source for this indy kernel?

All responses appreciated. Even if it's just a "There but for the grace 
of God go I" or "Better you than me".

Regards,
Chad

	   -----------------------------------------------------
            Chad Carlin                 	 Special Systems
            Silicon Graphics Inc.	  	    972.205.5911 
            Pager 888.754.1597 		VMail 800.414.7994 X5344
            [email-masked] 	     http://reality.sgi.com/chad
           ----------------------------------------------------- 
	 "flying through hyperspace ain't like dusting crops, boy"

---

From: Alex deVries <[email-masked]>
Date: Mon, 25 Jan 1999 14:37:13 -0500 (EST)

Alright.  There might be other problems.

> 1) Is anyone else using an R4400?

I'd like to know that too.  I know it works on my R4600SC.  Any other
successes?

>   the correct disk partition to use?

Probably... could you see what it reports for teh SCSI probe?

It should look something like:
DS1286 Real Time Clock Driver v1.0
streamable misc devices registered (keyb:150, gfx:148)
loop: registered device at major 7
wd33c93-0: chip=WD33c93B/13 no_sync=0xff no_dma=0 debug_flags=0x00
           setup_args=,,,,,,,,,
           Version 1.25 - 09/Jul/1997, Compiled Jan 22 1999 at 16:43:04
scsi0 : SGI WD93
scsi : 1 host.
 sending SDTR 0103013f0csync_xfer=2c  Vendor: SGI       Model: SEAGATE
ST31200N 
 Rev: 8640
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 1, lun 0
 sending SDTR 0103013f0csync_xfer=2c  Vendor: SGI       Model: SEAGATE
ST31230N 
 Rev: 0532
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdb at scsi0, channel 0, id 2, lun 0
scsi : detected 2 SCSI disks total.
SCSI device sda: hdwr sector= 512 bytes. Sectors= 2077833 [1014 MB] [1.0
GB]
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 2070235 [1010 MB] [1.0
GB]

Could you see what it reports for partitioning?  Mine says:
Partition check:
 sda: sda1 sda2 sda3 sda4
 sdb: sdb1 sdb2 sdb3

> 3) What does init= mean in "Kernel panic: No init found.  Try passing 

It says this because it can't find /sbin/init, because it can't find the
root filesystem.

> 5) Could someone point me to where I can browse the source for this indy kernel?

Two reasons: there's no fielsystem that has /dev/console for you, and I
never built in serial console support.  I will, thuogh.

Could you look into the lack of disk problems first?  This is on an Indy,
right?

- Alex

---

From: Chad Carlin <[email-masked]>
Date: Tue, 26 Jan 1999 13:50:37 -0600

Linux on Indy problems.

Cross-posting this one to sgi.engr.linux. Maybe someone here has had succes with
Linux on an
R4400 Indy.

Here are some answers:

> Probably... could you see what it reports for the SCSI probe?

Yes, I get similar output describing vendor, model and disk sizes. All are correct.
If I get this output
am I OK in this regard. Should I compare this output with mine to look for
discrepencies?

> Could you see what it reports for partitioning?
>
> Mine says:
>
>      Partition check:
>       sda: sda1 sda2 sda3 sda4
>       sdb: sdb1 sdb2 sdb3
>
Yes, I get this feedback.

> It says this because it can't find /sbin/init, because it can't find the

That's what I was afraid of. At least my errors seem to be pointed at filesystem
mounting.

> never built in serial console support.  I will, thuogh.

It seems like I had it in the previous vmlinux kernel. I was using my irix-indy's
console port to
connect to the console port of my linux-indy. I never got feedback on the local
linux-indy's gfx
(prom> setenv console d). With this new kernel, the reverse is true (now behaves like
prom>
setenv console g).

> Could you look into the lack of disk problems first?  This is on an Indy,

Yes it is.

Aside from the config that I performed on the disk from IRIX (below), what else
should I look at?

What I did (from my recollection):
irix% mk2efs /dev/dsk/dks0d1s0
irix% installer /dev/dsk/dks0d1s0
   cjwsh> MAKEDEV (What should `ls dev` look like at this point?)
   cjwsh> cpio.....
   cjwsh> exit
irix% e2fsck -fy /dev/linux-disk
cp /dist/linux/mipseb/vmlinux /mnt/vmlinux    (/mnt + /dks0d3s1)

prom> boot vmlinux root=/dev/sdb3 (similar)

Notes:
IRIX 6.5 is installed on an XFS partition dks0d3s0. Linux was cpio'ed onto an ext2
partition
at dks0d1s0. I have an IRIX made efs partition at dks0d1s1.

In this case, I am following the instruction included with "Linux-installer". In
these instructions
there is no talk of using bootp/tftp/nfs for anything. Should these instructions
work? Are these
better/same/worse than the instructions available on the webpage which call for using
bootp to
get the kernel?

BTW I did try the webpage instructions as well. I get errors like cannot open system
console.
This happens after the disk discovery completes OK or at least similar to your
example.

Is the reason for needing IRIX on the linux-indy?: a) Needs to boot sash from VH? b)
Be able
to run installion script which executes under IRIX? c) Some other reason?

Thanks,
Chad

        "flying through hyper space ain't like dusting crops, boy"