Subject: Challange S question..

From: Chris Chiapusio <[email-masked]>
Date: Wed, 10 Feb 1999 16:34:30 -0500 (EST)

This is my first time working witha  net booting workstation and i'm
having a problem w/ the install kernel booting on a Challenge S.

I saw the mention in the mail archive and attempted to do as it instructs,
but alas, I have had no success.

the kernel says this on boot:
SGI Zilog8530 serial driver version 1.00
Keyboard timeout
Keyboard timeout
tty00 at 0xbfbd9838 (irq = 21) is a Zilog8530
tty01 at 0xbfbd9830 (irq = 21) is a Zilog8530
<snip>
VFS: Mounted root (nfs filesystem).
Adv: done running setup()
Freeing unused kernel memory: 44k freed

and freezes there.

now what i've done regarding the instructions on the web site are:
[root@outland dev]# pwd
/usr/src/sgi/installfs/dev
[root@outland dev]# ls -al tty* console*
lrwxrwxrwx   1 root     root            5 Feb 10 16:16 console -> ttyS0
lrwxrwxrwx   1 root     root            5 Feb 10 16:21 tty00 -> ttyS0
lrwxrwxrwx   1 root     root            5 Feb 10 16:21 tty01 -> ttyS1
crw-------   1 root     root       4,   1 May 11  1998 tty1
crw-------   1 root     root       4,   2 May 11  1998 tty2
crw-------   1 root     root       4,   3 May 11  1998 tty3
crw-------   1 root     root       4,   4 May 11  1998 tty4
crw-------   1 root     root       4,   5 May 11  1998 tty5
crw-r--r--   1 root     root       4,  64 Feb 10 16:16 ttyS0
crw-r--r--   1 root     root       4,  65 Feb 10 16:13 ttyS1

Am I doing something obviously wrong?

Chipper

------
                    Please encrypt anything important.
PGP Key: http://pgp.ai.mit.edu:11371/pks/lookup?op=get&search=0x6CFA486D

---

From: Alex deVries <[email-masked]>
Date: Wed, 10 Feb 1999 16:58:25 -0500 (EST)

> Freeing unused kernel memory: 44k freed

Yup.  The thing is the machine's actually working well, but you don't have
the graphics console to show anything.  That kernel doesn't have the
ability to handle serial consoles. :(

I really need to rebuild a kernel for installation that includes R4400
support and serial console.  I just wish I could find a serial console
cable somewhere.

- Alex
-- 
Alex deVries, puffin on LinuxNet.
I know exactly what I want in life.

---

From: Thomas Bogendoerfer <[email-masked]>
Date: Thu, 11 Feb 1999 00:25:34 +0100

> support and serial console.  I just wish I could find a serial console

I've already done that last week (announced on this mailing list) and that 
kernel boots fine on a Challenge S (tested on a real Challenge S, thanks to
Richard Hartensveld).

URL is:

ftp://ftp.linux.sgi.com/pub/linux/mips/test/vmlinux-indy-990205.gz

Thomas.

-- 
   This device has completely bogus header. Compaq scores again :-|
It's a host bridge, but it should be called ghost bridge instead ;^)
                                        [Martin `MJ' Mares on linux-kernel]

---

From: Richard Hartensveld <[email-masked]>
Date: Wed, 10 Feb 1999 17:12:17 -0800

> crw-r--r--   1 root     root       4,  65 Feb 10 16:13 ttyS1

You should link /dev/ttyS1 to /dev/console and all will be fine.

Richard

---

From: Chris Chiapusio <[email-masked]>
Date: Thu, 11 Feb 1999 11:05:23 -0500 (EST)

>ftp://ftp.linux.sgi.com/pub/linux/mips/test/vmlinux-indy-990205.gz

where can i find info on what the kernel is doing at each stage of the
boot process for a 'install' kernel like this so i can try to debug this
without buggin you guys for each problem?

in the mean time, this is with Thomas' kernel.. I got farther along

Red Hat install init version 1.1 starting
mounting /proc filesystem... done
opening /proc/cmdline... done
checking command line arguments... done
checking for NFS root filesystem...yes
mke2fs 1.10, 24-Apr-97 for EXT2 FS 0.5b, 95/08/09
/dev/ram: Operation not supported by device while setting up superblock
creating 100k of ramdisk space... done
mounting /tmp from ramdisk... failed.

I can't recover from this.

Chipper

------

---

From: Thomas Bogendoerfer <[email-masked]>
Date: Fri, 12 Feb 1999 00:29:15 +0100

> without buggin you guys for each problem?

the kernel has already booted. The HardHat kernel isn't able to work
with a serial console, and in mine is /dev/ram missing.

> mounting /tmp from ramdisk... failed.

ok, I didn't include the ramdisk driver in the kernel. Please try:

ftp://ftp.linux.sgi.com/pub/linux/mips/test/vmlinux-indy-990212.gz

This kernel boots with the Rough Cut CD I have here.

Thomas.