Subject: problem booting sgi linux

From: Eric Melville <[email-masked]>
Date: Sun, 14 Feb 1999 16:04:09 -0800

ok, i fixed my problem with /dev/console ... but now it stops just a few
lines after that. this is printed to the screen:

Adv: done running setup()
Freeing unused kernel memory: 44k freed
page fault from irq handler: 0000
$0: blah blah blah
$4: blah blah blah
$8: blah blah blah
$12: blah blah blah
$16: blah blah blah
$20: blah blah blah
$24: blah blah blah
epc: 880e3e47
Status: 1004fc02
Cause: 00000008
Aiee, killing interrupt handler
Kernel panic: Attempted to kill the idle task!
In swapper task: not syncing

then it's stuck... i could write down the "blah blah blah" numbers if
they would be helpfull. any ideas?

-E

---

From: Thomas Bogendoerfer <[email-masked]>
Date: Mon, 15 Feb 1999 01:35:27 +0100

> they would be helpfull. any ideas?

Could give us a hinv of your Indy ?

Have you tried following kernel

ftp://ftp.linux.sgi.com/pub/linux/mips/test/vmlinux-indy-990212.gz

?

Thomas.

-- 
   This device has completely bogus header. Compaq scores again :-|
It's a host bridge, but it should be called ghost bridge instead ;^)
                                        [Martin `MJ' Mares on linux-kernel]

---

From: Eric Melville <[email-masked]>
Date: Mon, 15 Feb 1999 10:04:11 -0800

uhm... what's a hinv?

the kernel listed below gives a similar problem. it doesn't blurt out a
bunch of error messages, but just like before, it says freeing unused
kernel memory, then hangs.

-E

---

From: Eric Melville <[email-masked]>
Date: Tue, 16 Feb 1999 04:38:50 -0800

hinv of my indy:

Iris Audio Processor: version A2 revision 4.1.0
1 200 MHZ IP22 Processor
FPU: MIPS R4010 Floating Point Chip Revision: 0.0
CPU: MIPS R4400 Processor Chip Revision: 6.0
On-board serial ports: 2
On-board bi-directional parallel port
Data cache size: 16 Kbytes
Instruction cache size: 16 Kbytes
Secondary unified instruction/data cache size: 1 Mbyte
Main memory size: 64 Mbytes
Integral ISDN: Basic Rate Interface unit 0, revision 1.0
Integral Ethernet: ec0, version 1
Integral SCSI controller 0: version WD33C93B, revision D
Disk drive: unit 2 on SCSI controller 0
Disk drive: unit 1 on SCSI controller 0
Graphics board: Indy 24-bit
Vino video: unit 0, revision 0, IndyCam not connected

any ideas as to why every kernel i've tried hangs when it tries to free
unused kernel memory? thanks...

-E

---

From: Thomas Bogendoerfer <[email-masked]>
Date: Tue, 16 Feb 1999 20:25:55 +0100

> CPU: MIPS R4400 Processor Chip Revision: 6.0
[..]
> unused kernel memory? thanks...

looks like we have still a problem with R4400. Ralf ?

Thomas.

---

From: Harald Koerfgen <[email-masked]>
Date: Tue, 16 Feb 1999 21:01:07 +0100 (MET)

Hi,

> looks like we have still a problem with R4400. Ralf ?

Sorry for stepping in here, guys. This isn't strictly SGI related, but...

[root@localhost /root]# cat /proc/cpuinfo
cpu                     : MIPS
cpu model               : R4400SC V4.0
system type             : Digital DECstation 5000/2x0
BogoMIPS                : 59.90
byteorder               : little endian
unaligned accesses      : 0
wait instruction        : no
microsecond timers      : yes
extra interrupt vector  : no
hardware watchpoint     : yes
VCED exceptions         : 5244
VCEI exceptions         : 17100    

OTOH there may be significant differences between V4.0 and V6.0, but maybe
this helps.

---
Regards,
Harald

---

From: [email-masked]
Date: Wed, 17 Feb 1999 00:49:53 +0100

> looks like we have still a problem with R4400. Ralf ?

Nope, no known problem, but we definately have a problem with the R4700.
Fixed.  Not that Indys would use a R4700 ...

I'll have to get V6.0 erratas, maybe that'll explain something.

  Ralf

---

From: Eric Melville <[email-masked]>
Date: Tue, 16 Feb 1999 21:18:57 -0800

uhm... does this mean that i'm doing something wrong, or that the
software doesn't quite support my hardware?...

-E