Subject: Strange bootp behavior.

From: [email-masked]
Date: Wed, 17 Mar 1999 12:06:29 -0600

I've been playing with my 'new' challenge S for awhile and decided I wanted to 
be free of the Irix HD sitting there just for the vmlinux it contains.

I've got other Linux boxes about the house so decided to do a bootp from one 
of them.
The results have been mixed to say the least.
Here's what I do to the PROM:
>> printenv
SystemPartition=scsi(0)disk(1)rdisk(0)partition(8)
OSLoadPartition=scsi(0)disk(2)rdisk(0)partition(0)
OSLoader=sash
OSLoadFilename=/unix
AutoLoad=Yes
TimeZone=PST8PDT
console=d
diskless=0
dbaud=9600
volume=80
sgilogo=y
autopower=y
netaddr=204.112.93.74
eaddr=08:00:69:08:8e:af
ConsoleOut=serial(0)
ConsoleIn=serial(0)
cpufreq=150
>> setenv SystemPartition bootp():/
>> setenv OSLoader vmlinux
>> boot bootp():vmlinux root=/dev/sdb1
(this is what's suggested by the PROM manual for diskless stations)
And here's what happens when the kernel gets going:
SCSI device sda: hdwr sector= 512 bytes. Sectors= 2077833 [1014 MB] [1.0 GB]
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 2070235 [1010 MB] [1.0 GB]
SCSI device sdc: hdwr sector= 512 bytes. Sectors= 4110000 [2006 MB] [2.0 GB]
sgiseeq.c: David S. Miller ([email-masked])
eth0: SGI Seeq8003 08:00:69:08:8e:af
Partition check:
 sda: sda1 sda2 sda3 sda4
 sdb: sdb1 sdb2 sdb3 sdb4
 sdc: sdc1 sdc2 sdc3
VFS: Mounted root (ext2 filesystem) readonly.
Freeing prom memory: 2132k freed
Freeing unused kernel memory: 36k freed
scsidisk I/O error: dev 08:11, sector 528
Warning: unable to open an initial console.
scsidisk I/O error: dev 08:11, sector 528
scsidisk I/O error: dev 08:11, sector 528
scsidisk I/O error: dev 08:11, sector 528
Kernel panic: No init found.  Try passing init= option to kernel.
This is the 2.2.1 tarball released around February 26th.

It seems something is trying to talk to the SCSI drive for the console.

If I leave the PROM booting with sash from the IRIX drive, it works.
(This is also using bootp to get the kernel)
So, now it's even sillier, I'm using a 1 Gig drive for what's probably a 9K 
shell.  :)

Anyone have an idea why this happens, or how to fix?
Second, anyone know where to put the root=/dev/sdb1 so I can have it autoboot 
with bootp?  I've gotten it to autobootp, but it always tries to root off of 
Dev 00:00

Thanks in advance..

Greg

---

From: Thomas Bogendoerfer <[email-masked]>
Date: Thu, 18 Mar 1999 22:57:05 +0100

> Kernel panic: No init found.  Try passing init= option to kernel.

you have problems with that disk. The kernel isn't able to read the init
binary form it. The messages are for access to /dev/sdb1.

> It seems something is trying to talk to the SCSI drive for the console.

yes to get major/minor of the console and for /sbin/init.

> If I leave the PROM booting with sash from the IRIX drive, it works.

so you removed this harddisk from the scsi chain ? Have you thought about
scsi termination ?

Thomas.

-- 
   This device has completely bogus header. Compaq scores again :-|
It's a host bridge, but it should be called ghost bridge instead ;^)
                                        [Martin `MJ' Mares on linux-kernel]

---

From: Thomas Bogendoerfer <[email-masked]>
Date: Fri, 19 Mar 1999 22:26:18 +0100

On Thu, Mar 18, 1999 at 05:20:16PM -0600, Greg Moeller wrote:
> Broke printenv:
> SystemPartition=bootp():/
> OSLoader=vmlinux

this one didn't work for me at all, I had to change it to
SystemPartition=bootp(). With this it works without problems.

I see in your boot messages, that on your machine the freed prom
memory is higher than on my machine. Ulf Carlson needed to disable
the prom memory freeing to get his kernel working. So I'm pretty
sure, there something wrong with it. I've disabled this feature
in the current CVS version. Please try it (the updated file is 
arch/mips/arc/memory.c).

Thomas.