Subject: kernel compilation problem

From: Charles Lepple <[email-masked]>
Date: Thu, 15 Apr 1999 04:20:04 +0000

While configuring the kernel (2.2.5 from ftp.kernel.org), I get the
following message:

 Sound card support (CONFIG_SOUND) [N/y/m/?]
>scripts/Configure: drivers/sgi/char/Config.in: No such file or
directory
 *
 * Kernel hacking

Then, while executing 'make dep', I see a bunch of messages about
'SOCK_DGRAM' being redefined.

And when I try 'make zImage', it bombs compiling init/main.c -- there's
a "parse error" in linux/sched.h, and lots of stuff breaks. I have the
compile log if anyone can decipher it, but is this just a simple case of
me overlooking a patch? Or where can I find a preconfigured kernel
source tree?

Thanks in advance,

--
Charles Lepple
System Administrator, Virginia Tech EE Workstation Labs
[email-masked] || http://www.foo.tho.org/charles/

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 14 Apr 1999 21:37:58 -0700

> me overlooking a patch? Or where can I find a preconfigured kernel

Get the kernel from {ftp,www}.linux.sgi.com.

  Ralf

---

From: Matthias Kleinschmidt <[email-masked]>
Date: Thu, 15 Apr 1999 00:48:28 -0400

Hi,

> While configuring the kernel (2.2.5 from ftp.kernel.org), I get the

You have to get the kernel from cvs:

export CVSROOT=":pserver:[email-masked]:/cvs"
cvs login (cvs as password)
cvs -z3 checkout linux

The config is a little tricky. Look at
ftp.linux.sgi.com/pub/linux/mips/test/vmlinux-indy-990212.conf
as example

> And when I try 'make zImage', it bombs compiling init/main.c

"make zImage" doesn't work. Try "make vmlinux".

Matthias

-- 
Matthias Kleinschmidt
Cedar Dell 568B, Box 5398
UMass Dartmouth
285 Old Westport Rd.
North Dartmouth, MA 02747
Tel.:  +1 508 910 6851
email: [email-masked]