Subject: using ec3 on a Challenge S

From: Chris Pezzee <[email-masked]>
Date: Wed, 28 Apr 1999 10:07:50 -0700

The situation:
  I inherited 20+  SGI Challenge S machines that I would like to use for 
  web test clients and/or DIPC personal projects.  I would like to use
  the second Ethernet port (ec3 in Irix) for something other than dust
  collection.  I've read the list-archive, and there was a brief mention
  of adding some probing code to the driver but that was all.

What I'd like to know:
  Is anyone working on this right now?
  If not, I'd love to try to get this working, but I haven't done any driver
work before, 
  so where's a good place to start?

Also, www.linux.sgi.com is refusing http connections for me, 
is anyone else having a problem with this? 

Thanks for everything.
----------------------
Chris Pezzee  
Work: (425-70)3-1616
[email-masked] <mailto:[email-masked]>

---

From: Matthias Kleinschmidt <[email-masked]>
Date: Wed, 28 Apr 1999 13:35:08 -0400

> is anyone else having a problem with this? 

Yes. And cvs does not work as well.

Matthias

-- 
Matthias Kleinschmidt
Cedar Dell 568B, Box 5398
UMass Dartmouth
285 Old Westport Rd.
North Dartmouth, MA 02747
email: [email-masked]

---

From: Alex deVries <[email-masked]>
Date: Wed, 28 Apr 1999 13:42:22 -0400 (EDT)

>   Is anyone working on this right now?

I'm reasonably sure that nobody has started.

>   so where's a good place to start?

You should probably try to figure out where on the GIO64 that is located,
it shouldn't be too difficult with some guidance from folks at SGI.  What
ethernet controller is on there exactly?

At some point I was going to inherit such a card for my Indy (which would
replace my Newport temporarily), but I never got the card, and have been
busy with other things.  I wouldn't mind looking at this though.

- Alex

---

From: [email-masked] (Dave Olson)
Date: Wed, 28 Apr 1999 10:53:47 -0700 (PDT)

Alex deVries wrote: 
|  You should probably try to figure out where on the GIO64 that is located,
|  it shouldn't be too difficult with some guidance from folks at SGI.  What
|  ethernet controller is on there exactly?

It's basicly the same ethernet setup as the IP20 (r4k Indigo).
The driver is quite similar, but there are a few differences in
features.  The DMA is the IP20 dma (hpc1, not hpc3), but the 
ethernet chip is identical to the one on the indy/challenge S,
just some features enabled by hpc3 aren't present.

If you have an irix system, the HPC31 defines in hpc3.h provide
most of the necessary info.  On irix, it's actually shipped as
a seperate binary driver from the onboard ethernet, because of
the dma/control register differences.  It would be possible to
do it all in one driver, but we didn't bother.  The source code
for irix is the same for both, with a few ifdefs.

Dave Olson, Silicon Graphics
http://reality.sgi.com/olson   [email-masked]

---

From: [email-masked] (Ariel Faigon)
Date: Wed, 28 Apr 1999 10:54:46 -0700 (PDT)

Chris wrote:
:
:Also, www.linux.sgi.com is refusing http connections for me, 
:is anyone else having a problem with this? 
:
Yes. We all having the same problem.

The machine lost its data disk (where all the CVS, ftp, and web
stuff is stored).  It is back up now but that disk is not mounted...
I reported the problem and hopefuly we'll get a fix soon.

Sorry for all the trouble.

-- 
Peace, Ariel