Subject: Errors building...

From: Alex deVries <[email-masked]>
Date: Wed, 14 Apr 1999 02:03:19 -0400 (EDT)

So, I've finally found a few minutes to catch up on the amazing recent SGI
Linux excitements... I destroyed my old kernel tree, and re imported.

Now my builds die with:

egcs -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -G 0 -mno-abicalls -fno-pic -mcpu=r4600 -mips2 -pipe
-c -o r2300.o r2300.c
{standard input}: Assembler messages:
{standard input}:2486: Internal error!
Assertion failure in tc_gen_reloc at ./config/tc-mips.c line 10203.
Please report this bug.

And so here I am, dutifully reporting this bug.

I'm a bit unclear on why r2300.c is even being compiled, when clearly I
have an R4600SC, but I did set R4000 support in my .config.

- A

---

From: Harald Koerfgen <[email-masked]>
Date: Wed, 14 Apr 1999 21:09:05 +0200 (MEST)

Hi,

> And so here I am, dutifully reporting this bug.

Strange, works fine on my end. Anyone else seeing this?
 
> have an R4600SC, but I did set R4000 support in my .config.

That's normal and always has been so. The goal is to be able to build
generic kernel, i.e. kernels which work on R3000 *and* higher CPUs.

---
Regards,
Harald

---

From: Thomas Bogendoerfer <[email-masked]>
Date: Wed, 14 Apr 1999 23:15:50 +0200

> And so here I am, dutifully reporting this bug.

what egcs/binutils are you using ? I can't reproduce it here with
a selfbuild egcs 1.0.2 and bintutils 2.8.1 from Rough Cuts.

Thomas.

-- 
   This device has completely bogus header. Compaq scores again :-|
It's a host bridge, but it should be called ghost bridge instead ;^)
                                        [Martin `MJ' Mares on linux-kernel]

---

From: Alex deVries <[email-masked]>
Date: Wed, 14 Apr 1999 21:37:50 -0400 (EDT)

Somehow my egcs was corrupt, so I reinstalled it and life is much better.

- Alex "back in the game" deVries

-- 
Alex deVries, puffin on LinuxNet.
Linux on HP PA RISC. The final frontier.

---

From: [email-masked]
Date: Wed, 14 Apr 1999 20:08:59 -0700

> Somehow my egcs was corrupt, so I reinstalled it and life is much better.

Not corrupt.  The problem is that the compiler options -msplit-addresses
results in code that cannot be assembled when the compiler is being built
with HAIFA enabled.  Newer releases fixed that.

  Ralf