Subject: Re: HAL2 driver 0.2

From: Matthias Kleinschmidt <[email-masked]>
Date: Tue, 06 Apr 1999 21:52:09 -0400

On Tue, Apr 06, 1999 at 10:16:41PM -0400, Ulf Carlsson wrote:
> Hello,
> 
> I've uploaded new version of ALSA HAL2 sounddrivers now. Works much better.
> 
> Check: ftp://ftp.linux.sgi.com/pub/linux/mips/test/ALSA

-rw-------    1 9032     user         915 Apr  6 21:57 ALSA-HAL2-HOWTO

Is this supposed to be non readable?

Ciao
 Matthias

-- 
Matthias Kleinschmidt
Cedar Dell 568B, Box 5398
UMass Dartmouth
285 Old Westport Rd.
North Dartmouth, MA 02747
Tel.:  +1 508 910 6851
email: [email-masked]

---

From: [email-masked] (Ariel Faigon)
Date: Tue, 6 Apr 1999 19:15:58 -0700 (PDT)

Matthias wrote:
:Ulf wrote:
:> Hello,
:>
:>I've uploaded new version of ALSA HAL2 sounddrivers now.
:>Works much better.
:>
:> Check: ftp://ftp.linux.sgi.com/pub/linux/mips/test/ALSA
:
:-rw-------    1 9032     user         915 Apr  6 21:57 ALSA-HAL2-HOWTO
:
:Is this supposed to be non readable?
:
:Ciao
: Matthias
:

Matthias,

Thanks for noticing, I just fixed that.

-- 
Peace, Ariel

---

From: Ulf Carlsson <[email-masked]>
Date: Tue, 6 Apr 1999 22:16:41 -0400

Hello,

New features:
o Better sound quality
o Support for both Mono / Stereo
o Support for sample rates in range 4.000 kHz to 48.000 kHz
o Support for both Big endian and Little endian
o Limited support for recording (doesn't work very good yet)

(don't forget to patch mpg123)

- Ulf

---

From: Matthias Kleinschmidt <[email-masked]>
Date: Wed, 07 Apr 1999 01:59:56 -0400

Hi,

> I've uploaded new version of ALSA HAL2 sounddrivers now. Works much better.

I got a new kernel from cvs and compiled with soundcore.o.
When I try to install alsa-driver-0.3.0-pre5-1.mipseb.rpm I get many errors
about unresolved symbols. And when I try to load snd.o I get the following
output:

snd.o: unresolved symbol lookup_dentry_Rbf9ede0c
snd.o: unresolved symbol register_chrdev_R79319a7e
snd.o: unresolved symbol create_proc_entry_R4bfb68d0
snd.o: unresolved symbol __up_R224e7279
snd.o: unresolved symbol register_sound_dsp_Rb255d4ae
snd.o: unresolved symbol proc_unregister_R77de8be6
snd.o: unresolved symbol __down_R3d27099f
snd.o: unresolved symbol register_sound_special_Rdf061e7e
snd.o: unresolved symbol mem_map_R89246c1b
snd.o: unresolved symbol proc_root_R04ac0340

Does anyone have a solution for that?

Matthias

---

From: Ulf Carlsson <[email-masked]>
Date: Wed, 7 Apr 1999 12:22:57 -0400

> about unresolved symbols. And when I try to load snd.o I get the following

Oops, sorry. I had compiled the modules with a kernel configured to set version
information on all symbols. I've uploaded a new version, this problem should be
solved now. Please download alsa-driver-0.3.0-pre5-2.mipseb.rpm instead.

- Ulf

---

From: Matthias Kleinschmidt <[email-masked]>
Date: Wed, 07 Apr 1999 13:41:33 -0400

> solved now. Please download alsa-driver-0.3.0-pre5-2.mipseb.rpm instead.

I had version information activated in the first place. Now I compiled the
kernel without it and installed alsa...-pre5-2...  but I still have
unresolved modules. 

insmod snd.o now gives me

If my kernel configuration would be helpful it can be found at
http://www-fs.mach.uni-karlsruhe.de/~matthias/.config

Matthias

---

From: Ulf Carlsson <[email-masked]>
Date: Wed, 7 Apr 1999 20:27:31 +0200

> kernel without it and installed alsa...-pre5-2...  but I still have unresolved
> modules. 
> 
> snd.o: unresolved symbol register_sound_dsp_Rb255d4ae snd.o: unresolved symbol
> register_sound_special_Rdf061e7e

This is a bit strange. I don't have those symbols either. I have the normal
register_sound_dsp and register_sound_special symbols. I'm looking at this
problem and how I'll solve it completely. It's a bit tricky to build modules
which are compatible.

It looks like the rest of the symbols in the kernel are resolved. Maybe you
forgot to rebuild the modules or to install them when you built them?

Anyhow, in the meanwhile you may build your own driver package. There shouldn't
be any problem if you have a kernel installed in /usr/src/linux, just get the
source package of the drivers instead an execute:

rpm --rebuild alsa-driver-0.3.0-pre5-2.src.rpm 

(Please have a bit patiance, you're the first tester)

- Ulf

---

From: Matthias Kleinschmidt <[email-masked]>
Date: Wed, 07 Apr 1999 17:15:38 -0400

> forgot to rebuild the modules or to install them when you built them?

Ok, I apologize. I forgot to rebuild soundcore.o. Now I can load the
modules. But the order in your HOWTO is wrong. I had to load snd-timer
before snd-pcm1. Playing wavs and mpegs works as well after building the
ALSA devices.
Great job!
 
> rpm --rebuild alsa-driver-0.3.0-pre5-2.src.rpm 

Unfortunately that did not work. Maybe because all files in that package
have timestamps Jan xx 2000?
 
> (Please have a bit patiance, you're the first tester)

No problem. I'm only trying to help.
 
Matthias

---

From: Ulf Carlsson <[email-masked]>
Date: Thu, 8 Apr 1999 06:14:52 +0200

> before snd-pcm1. Playing wavs and mpegs works as well after building the

Ok, this is another thing I forgot. I did a ``make install'' once so my devices
where ok all the time. Maybe I can extract that util which sets up the devices
from ALSA or is it included in the RPM?

I've fixed the HOWTO now.

> Great job!

Thanks :-)

> Unfortunately that did not work. Maybe because all files in that package have
> timestamps Jan xx 2000?

I have set my clock correctly now, I actually did that yesterday. I have also
touched the all the files on my harddrives so I will not end up with any Jan xx
2000 files again. I'll upload correct versions..

- Ulf