Subject: glibc cross-compile error

From: Masami Komiya <[email-masked]>
Date: Tue, 20 Jul 1999 21:06:00 +0900

I could not cross-compile glibc using Linux/MIPS-2.2.10 sources
because of asm-mips/timex.h.
My workarround is 

*** timex.h.org	Fri Jun 11 11:18:29 1999
--- timex.h	Tue Jul 20 20:34:59 1999
***************
*** 31,36 ****
--- 31,40 ----
  typedef unsigned int cycles_t;
  extern cycles_t cacheflush_time;
  
+ #ifndef __ASM_MIPS_MIPSREGS_H
+ #include <asm/mipsregs.h>
+ #endif
+ 
  static inline cycles_t get_cycles (void)
  {
  	return read_32bit_cp0_register(CP0_COUNT);

I afraid this workarround will be the cause of the another.
Does anyone has the better solution ?

Masami Komiya

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 23 Jul 1999 02:04:03 +0200

> --- timex.h	Tue Jul 20 20:34:59 1999

Wrap all the C-code in that file with #ifdef __KERNEL__ ... #endif.

It's fixed in my development sources.

  Ralf