Subject: RE: Floptical Drive

From: Mike Hill <[email-masked]>
Date: Fri, 6 Aug 1999 16:30:25 -0400

Same problem with 2.2, just a different error:

make[3]: Entering directory `/usr/src/mips/linux/drivers/net'
mips-linux-gcc -D__KERNEL__ -I/usr/src/mips/linux/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic
-mcpu=r4600 -mips2 -pipe   -c -o sgiseeq.o sgiseeq.c
sgiseeq.c: In function `sgiseeq_probe':
sgiseeq.c:741: `SGI_ENET_IRQ' undeclared (first use this function)
sgiseeq.c:741: (Each undeclared identifier is reported only once
sgiseeq.c:741: for each function it appears in.)
make[3]: *** [sgiseeq.o] Error 1
make[3]: Leaving directory `/usr/src/mips/linux/drivers/net'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/mips/linux/drivers/net'
make[1]: *** [_subdir_net] Error 2
make[1]: Leaving directory `/usr/src/mips/linux/drivers'
make: *** [_dir_drivers] Error 2

> -----Original Message-----
> From:	Ulf Carlsson [SMTP:[email-masked]]
> Sent:	Wednesday, August 04, 1999 2:30 PM
> To:	Mike Hill
> Cc:	[email-masked]
> Subject:	Re: Floptical Drive
> 
> > When I try to add msdos or vfat filesystem support to the kernel (latest
> > CVS) I get the following failure:
> 
> Linus broke all filesystems some time ago, this is not MIPS specific.
> 
> Try the 2.2 kernel instead, I think they should be ok.
> 
> Ulf

---

From: "Andrew R. Baker" <[email-masked]>
Date: Mon, 9 Aug 1999 16:24:19 -0500 (CDT)

This patch should fix the error you are seing below, but probably won't do
much for your original complaint.

--- sgiseeq.c~	Fri Aug  6 08:25:29 1999
+++ sgiseeq.c	Mon Aug  9 16:18:16 1999
@@ -32,6 +32,7 @@
 #include <linux/skbuff.h>
 
 #include <asm/sgihpc.h>
+#include <asm/sgint23.h>
 #include <asm/sgialib.h>
 
 #include "sgiseeq.h"