Subject: Linux->Indy->O2

From: Gavin Kistner <[email-masked]>
Date: Mon, 27 Sep 1999 08:49:49 -0500

I noticed the previous poster mentioning that the Indy2 doesn't have X support yet under Linux. I'm wondering: does linux support for one machine get fully implemented and then tweaked to go to others, or is it a ground-up approach for each new machine in the port list?

Basically, I'm wondering how hard its going to be to take linux over to the O2 once the Indy stuff gets really done.

In that vein, I want linux for my O2 so badly (even just in a command-line configuration) that I'm thinking about trying to help. What are the major obstacles which need overcoming to get the current state of linux-mips to work on an O2?

TIA,
--
Gavin Kistner                                   Creative Director
+1 314 725 5096                        Image Refinery Productions
[email-masked]                        http://www.refinery.com

---

From: Gavin Kistner <[email-masked]>
Date: Mon, 27 Sep 1999 09:03:58 -0500

At 8:49 AM -0500 1999-09-27, Gavin Kistner wrote:
>I noticed the previous poster mentioning that the Indy2 doesn't have X support yet under Linux.

I, of course, meant the Indigo 2.

---

From: Han-Wen Nienhuys <[email-masked]>
Date: Mon, 27 Sep 1999 16:22:38 +0200 (CEST)

> In that vein, I want linux for my O2 so badly (even just in a command-line configuration) that I'm thinking about trying to help. What are the major obstacles which need overcoming to get the curre…

[Disclaimer, I don't use Linux/SGI, and don't know much about the
details].

Concerning X: 

Last thing I heard was that a simple SGI/Indy framebuffer was going to
be in XFree86 v4.

The architecture of the O2 and Indy are entirely different (the indy
has a pipeline of graphics chips that do successive transformations),
while the O2 has one big pool of memory that is used as framebuffer,
main memory, texture memory, etc. simultaneously. The architecture is
different, so you can't simply port the Indy X server.

I'm not sure about the O2 port, but it has been asked before.  Maybe
you can browse the list archive.

-- 

Han-Wen Nienhuys, [email-masked] ** GNU LilyPond - The Music Typesetter 
      http://www.cs.uu.nl/people/hanwen/lilypond/index.html

---

From: Alan Hoyt <[email-masked]>
Date: Tue, 28 Sep 1999 19:27:26 +0000

Gavin Kistner wrote:

> I noticed the previous poster mentioning that the Indy2 doesn't have X support yet under Linux. I'm wondering: does linux support for

I believe Ulf Carlsson is working on REX3 support - that's Indy and Indigo2

> one machine get fully implemented and then tweaked to go to others, or is it a ground-up approach for each new machine in the port list?

Two issues: X is huge and the architectures are quite different - your talking a *major* serious effort.

 - Alan Hoyt -

---

From: "William J. Earl" <[email-masked]>
Date: Tue, 28 Sep 1999 13:36:35 -0700 (PDT)

> I believe Ulf Carlsson is working on REX3 support - that's Indy and Indigo2

      REX3 is "Newport", AKA "XL", graphics, which was the default on
Indy and a lower-cost option on Indigo2.  Most Indigo2 and some Indy
systems have more complex graphics adapters ("Elan", "Extreme", "XZ", "Impact").

---

From: Alan Hoyt <[email-masked]>
Date: Tue, 28 Sep 1999 22:42:14 +0000

> systems have more complex graphics adapters ("Elan", "Extreme", "XZ", "Impact").

Sorry, thought everyone knew - here is an excerpt from the SGI Hardware FAQ for those who are curious:

  Indy: IP22:
  Express (XZ ["GR3-Elan": 24, Z, 4 GE7, 1 RE3.1]),
  Newport (XL ["NG1": 8|24, soft Z, NG1, REX3])

  Indigo2: IP22:
  Express (XZ ["GR3-Elan": 24, Z, 4 GE7, 1 RE3.1]),
  Newport (XL ["NG1": 8|24, soft Z, NG1, REX3]),
  Newpress (Extreme+XL ["GU1-Extreme": 32 Z]),
  Ultra (Extreme ["GU1-Extreme", 32 Z])

What was the most prevalent graphics configuration on the Indigo2s?

 - Alan Hoyt -

---

From: Alan Hoyt <[email-masked]>
Date: Tue, 28 Sep 1999 23:04:00 +0000

Bob Pielock wrote:

> So are there any websites with message boards for all of this? Can someone at SGI setup a web based bulliten board for all the developement
> stuff? I think if something people could all communicate on a board was available, updates would be more likely to be posted, and the website
> would have more info on it then its current state..

I guess I am missing something - isn't that what this list accomplishes?  If you want more detail,  you can access the source via anonymous CVS
- you can't follow development any closer than that!

 - Alan Hoyt -

---

From: "William J. Earl" <[email-masked]>
Date: Tue, 28 Sep 1999 17:18:27 -0700 (PDT)

> What was the most prevalent graphics configuration on the Indigo2s?

      XZ was probably the most common, until Impact was released.  On
the Indigo2 R10000, Impact (not on the above list) is probably the
most common.