Subject: latest binutils cygnus CVS 991025

From: Florian Lohoff <[email-masked]>
Date: Tue, 26 Oct 1999 16:20:26 +0200

Hi,
does anyone have experiences with the latest (e.g. 991025) binutils from 
cygnus CVS ?

I got it build for "mipsel-unknown-linux-gnu" and got a libgmp2
build (Which fails with binutils 2.8.1 -> segfault ld)

The resulting library links against ssh (with 2.8.1) without problems
and seems to work (SSH works)

Are there any other known problems i might not have noticed ?

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-5241-470566
  ...  The failure can be random; however, when it does occur, it is
  catastrophic and is repeatable  ...             Cisco Field Notice

---

From: Florian Lohoff <[email-masked]>
Date: Thu, 28 Oct 1999 00:30:35 +0200

On Wed, Oct 27, 1999 at 10:33:26AM +0200, Ralf Baechle wrote:
> On Tue, Oct 26, 1999 at 04:20:26PM +0200, Florian Lohoff wrote:
> 
> > Hi,
> Try the following:
>   echo 'main(){}' > test.c
>   gcc -o test test.c -lm -lieee

(root@repeat)/tmp/tt#   echo 'main(){}' > test.c
(root@repeat)/tmp/tt#   gcc -o test test.c -lm -lieee
collect2: ld terminated with signal 11 [Segmentation fault]
(root@repeat)/tmp/tt# ld -v
GNU ld version 2.8.1 (with BFD 2.8.1)

(root@repeat)/tmp/tt# export PATH=/data/devel/binutils-991025/bin/:$PATH
(root@repeat)/tmp/tt#   gcc -o test test.c -lm -lieee
(root@repeat)/tmp/tt# ls -la
total 15
drwxrwxr-x   2 root     root         1024 Oct 27 22:07 .
drwxr-xr-x   6 root     root         2048 Oct 27 22:07 ..
-rwxrwxr-x   1 root     root        12201 Oct 27 22:07 test
-rw-rw-r--   1 root     root            9 Oct 27 22:07 test.c
(root@repeat)/tmp/tt# ./test
(root@repeat)/tmp/tt# ld -v
GNU ld version 2.9.5 (with BFD 2.9.5)

> I hope you got a cronjob to remove core files ;-)

Nope - Dont seem to need it ...

>  - Symbol versioning is broken in the CVS version.  There is no fix yet for
>    this problem.
>  - The CVS gas version has a few problems with weak symbols, aliases and
>    other special cases.  These usually don't show up.  Anyway, the patchkit
>    on oss.sgi.com has all these fixes which haven't made their way into
>    CVS.
> 
> I've spent a tremendous amount of time into tracking down a large number of
> other bugs in binutils; I was able to rebuild entire RH 6.0 with that
> linker.

Flo

---

From: "Jay Carlson" <[email-masked]>
Date: Thu, 28 Oct 1999 07:26:51 -0400

> other bugs in binutils; I was able to rebuild entire RH 6.0 with that

This is the 2.8.1+mips patchkit?

Jay