Subject: Re: EXT2 fs error

From: Marc Esipovich <[email-masked]>
Date: Mon, 29 Nov 1999 20:03:06 +0200 (IST)

> 	Hi,

Hi.

> 	While running updatedb from crontab, my Indy crashed with the 
> 	following errors.It became OK when I booted it.What can be the
> 	reason?
> 

Hardware problem, probably your disk, it's called a bad-sector ;)

> 	...
> 	EXT2-fs error (device 08:11) ext2_free blocks: Freeing blocks not in
> 	datazone - block = ...., count=1
> 	EXT2-fs error (device 08:11): ext2_readdir: bad entry in directory
> 	#... :directory entry across blocks - ...
> 	scsi0 channel 0 : resetting for second half of entries.
> 	SCSI bus is being reset for 0 channel 0.
> 	scsi0 reset. sending SDTR
> 

SCSI reset is due to repeated attempts to read a block, or I might be
wrong and it it's due to a malfunction of the controller on your HD.

> 	thanx in advance,
> 	           baris.

Get some newer hardware,  I'd suggest running the 'badblocks' utility.

        Marc Esipovich.

--
root is only a few clicks away...

---

From: SERTKAYA BARIS <[email-masked]>
Date: Tue, 30 Nov 1999 18:37:41 +0200 (EET)

Hi,

	...

	thanx in advance,
	           baris.

-- 
-------------------------
#!/usr/bin/perl          |
use Tranquilizan;        |
goto bed;                |
bed: while (!&asleep) {  |
                ++$sheep;|
        }                |
sub asleep {             |
        return 0;        |
}                        |
--------------------------

---

From: Alan Cox <[email-masked]>
Date: Tue, 30 Nov 1999 19:52:04 +0000 (GMT)

> Hardware problem, probably your disk, it's called a bad-sector ;)

If there is a scsi error before the ext2fs error then yes probably so
You are looking for a "media error" probably.

> wrong and it it's due to a malfunction of the controller on your HD.

You can get it off some working sane hardware if you try and ask for stupid
block numbers. It is worth doing a full fsck on the drive before assuming
hardware. Also check the cabling seems sound and is well attached and that
parity is enabled on the controller if the bios sets it.