Subject: Re: Question for David Miller or anyone else about R6000 code

From: Marc Esipovich <[email-masked]>
Date: Sun, 5 Dec 1999 12:34:01 +0200 (IST)

Hello,

	How about R10000 on O2 ? are you working on that aswell?
	Do you have or know where to get documentation of O2's hardware,
	I've opened mine up, the only thing I was able to recognize were
	two Adaptec 7880P controllers (if I recall the model number
	correctly),  could you point me to some place which has docs?

	Thanks,
		Marc Esipovich.

--
root is only a few clicks away...

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Mon, 6 Dec 1999 10:58:10 +0100

I tried sending this to David Miller at his SGI email
address, just in case it would work.  Of course, it
didn't.  David, if you are reading this mailing list,
I'd appreciate your comments.  And anyone else
having knowledge should feel free to respond as
well!

David:

I don't know that you are still at SGI - indeed, with
all the changes in recent months, I would be a bit
surprised if you were - but this is the last email
address I have for you.

I'm working on cleaning up and enhancing the
MIPS/Linux code to support the new families
of CPUs coming out of MIPS Technologies Inc.
In doing so, I've come across and fixed a number
of bugs, most of which I've also passed back to
Ralf Baechle for integration with the moving
target at linux.sgi.com.   But I came across 
something this morning that, while not a problem
for us, puzzles me.   In arch/mips/mm/r6000.c,
which has your name on it, there is a compiler
directive to use MIPS III instructions, and the
resulting code does indeed end up containing
64-bit (daddiu, etc.) instructions.   I've never
actually programmed an R6000, but all of the
information I have on that processor indicates
that it is a MIPS II, 32-bit design, and that those
instructions should therefore cause exceptions.

Am I mistaken, or is that directive a bug?

            Regards,

            Kevin K.
__

Kevin D. Kissell
MIPS Technologies European Architecture Lab
[email-masked]
Tel. +33.4.78.38.70.67
FAX. +33.4.78.38.70.68

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 6 Dec 1999 09:28:30 -0200

> Am I mistaken, or is that directive a bug?

It obviously is.  The R6000 code isn't supposed to work and given that
currently none of the Linux/MIPS hackers has a) R6000 documentation and
b) an R6000 machine an R6000 port ever happening is highly unprobable.
As the result of this I think I'm going to just burry the R6000 support
and while I'm at it also the R8000.

  Ralf

---

From: [email-masked] (William Fisher)
Date: Tue, 7 Dec 1999 19:13:05 -0800 (PST)

> and while I'm at it also the R8000.
	Since the R6000 was an ECL machine produced in late 1992, just
	before the MIPS/SGI merger. There were only a few machines sold
	and the machine was designed to be a Fortran FP specialist.

	Hence the R6000 is long since dead. We still have the MIPS risc/os 5.01
	operating system source code, so if anybody has lots of free cycles
	to waste, I'm sure we can send them locore.

-- Bill

---

From: Alistair Lambie <[email-masked]>
Date: Wed, 08 Dec 1999 17:30:49 +1300

>         to waste, I'm sure we can send them locore.

Don't forget CDC used the R6000 and ramped it to 90MHz.  They also got
it going in an SMP configuration with 4 processors from what I can
remember.  I guess it is possible that someone could actually want to
burn some cycles on this, although they had better have a cheap source
of power and good airconditioning :-)

Alistair

-- 
Alistair Lambie                                [email-masked]
SGI Global Product Support
Level 5, Cigna House,                                M/S: INZ-3780
PO Box 24 093,                                  Ph: +64-4-494 6325
40 Mercer St, Wellington,                      Fax: +64-4-494 6321
New Zealand                                 Mobile: +64-21-635 262

---

From: "William J. Earl" <[email-masked]>
Date: Tue, 7 Dec 1999 22:00:15 -0800 (PST)

William Fisher writes:
...
 > 	to waste, I'm sure we can send them locore.

      Actually, CDC later sold quite a few multiple-processor machines, after
MIPS was merged into SGI.  They are not very practical, however, as they
use a lot of power and are only a little faster than a 100 MHZ R4000SC.

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 8 Dec 1999 09:21:12 -0200

> of power and good airconditioning :-)

At one time some Linux/m68k hacker was seriously looking into porting
Linux to a 3-CPU 256mb CDC which at that time was used as
ftp.uni-erlangen.de.

As usual the largest problem was technical documentation for the machine
and the CPU; the R6k is covered very badly by the freely available
documentation.

  Ralf