Subject: Re: Question for David Miller or anyone else about R6000 code

From: "Kevin D. Kissell" <[email-masked]>
Date: Mon, 6 Dec 1999 12:41:08 +0100

The R10000/R12000 programs are still within SGI,
and are not supported directly by MIPS Technologies
Inc.   The MIPS/Linux kernel today does not support
the R10000 (there's a panic("CPU too expensive");
somewhere if the Processor ID for R10K is detected),
but the CPU should not be at all difficult to support in
the kernel - it was a design constraint of the R10K
that it run the same Windows NT kernel as the
R4400, so the CP0 is a pretty strict superset of 
the R4K.   The hard part of an R10K/O2 port would
be more in the drivers than in the CPU support.
The O2 went for a high-bandwidth "unified memory
architecture" design which has very little resemblence
to any other Linux platform of which I am aware.
I've seen references on this and other mailing lists
to people working on getting Linux onto the O2.
Hopefully, they will respond.

            Regards,

            Kevin K.

-----Original Message-----
From: Marc Esipovich <[email-masked]>
To: Kevin D. Kissell <[email-masked]>
Cc: Linux SGI <[email-masked]>
Date: Monday, December 06, 1999 11:33 AM
Subject: Re: Question for David Miller or anyone else about R6000 code

>Hello,
>
> How about R10000 on O2 ? are you working on that aswell?
> Do you have or know where to get documentation of O2's hardware,
> I've opened mine up, the only thing I was able to recognize were
> two Adaptec 7880P controllers (if I recall the model number
> correctly),  could you point me to some place which has docs?
>
> Thanks,
> Marc Esipovich.
>
>--
>root is only a few clicks away...
>
>

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 6 Dec 1999 10:09:00 -0200

> somewhere if the Processor ID for R10K is detected),

MIPS64 has R10k support.  I didn't even try to fix it for MIPS32 because
that kernel only supports upto 512mb memory.  And as you say it was
easy to implement.

  Ralf