Subject: Nomenclature: "MIPS32", "MIPS64"

From: "Kevin D. Kissell" <[email-masked]>
Date: Mon, 6 Dec 1999 13:44:55 +0100

I note that various people involved in this effort
refer to the 32-bit version of the MIPS/Linux
port as "MIPS32" and the 64-bit version as
"MIPS64".   Thus far, I have not observed those
strings making it into the source repositories,
but before they do, there's something I must
point out.

"MIPS32" and "MIPS64" have a very specific
meaning now, and for all I know are already
trademarked/brandmarked/whatever by
MIPS Technologies Inc. to describe the new
baseline ISA and privileged resource architecture
(CP0, in other words) standards for 32-bit
and 64-bit MIPS devices.   It's no big deal
for informal discussion, but *please* do not
use the strings "MIPS32" or "MIPS64" in the
code or documentation unless you are really
and truly referring to MIPS32 and MIPS64
as defined by MIPS.   If you want to refer to
the 64-bit versus 32-bit Linux ports, please
express it otherwise, e.g. MIPS64bit,
MIPS_64_bit, 64bitMIPS, etc.   Otherwise
there is going to be a lot of needless confusion
and a further source schism.

            Regards,

            Kevin K.
__

Kevin D. Kissell
MIPS Technologies European Architecture Lab
[email-masked]
Tel. +33.4.78.38.70.67
FAX. +33.4.78.38.70.68

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 6 Dec 1999 10:59:28 -0200

> and a further source schism.

The use of these terms is pretty coherent with their meaning as given by
Mips, Inc.  Linux/MIPS32 is a implementation of Linux (mostly) for MIPS32
processors, Linux/MIPS64 for MIPS64 processors, so I don't see the problem.

  Ralf