Subject: Snapshot

From: Ralf Baechle <[email-masked]>
Date: Mon, 6 Dec 1999 21:44:29 -0200

I've put a snapshot of current CVS kernel sources into
oss.sgi.com:/pub/linux/mips/src/kernel/linux-19991206.tar.gz.

  Ralf

---

From: "A. Wrasman" <[email-masked]>
Date: Mon, 6 Dec 1999 23:07:17 -0600

> oss.sgi.com:/pub/linux/mips/src/kernel/linux-19991206.tar.gz.
                                        ^
     Put in v2.3/ and you find it.    --+
>   Ralf

Raz

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 7 Dec 1999 09:11:01 -0200

On Mon, Dec 06, 1999 at 10:14:12PM -0500, Ryan Rafferty wrote:

> Any highlights about important changes present in this snapshot?

Most important for you guys out there the upgrade to 2.3.21 and a number
of bug fixes.  Try it, break it.  Again ;-)  Aside of this this kernel
also has a good part of the 64-bit stuff.  Not all of it, I'm maintaining
the 32-bit kernel, the Indy 64-bit and the Origin kernel as separate
trees to prevent bugs from creeping from on tree in the other.

> On Mon, 6 Dec 1999, Ralf Baechle wrote:
>

---

From: Florian Lohoff <[email-masked]>
Date: Thu, 9 Dec 1999 16:49:08 +0100

> oss.sgi.com:/pub/linux/mips/src/kernel/linux-19991206.tar.gz.

Short resume:

Doesnt work on Decstation 5000/150 Mips R4000 ...
Reboots immediatly after end of tftp download ...

KN04 V2.1k    (PC: 0x8005c044, SP: 0x838a9de0)

-tftp boot(3), bootp 193.189.250.46:/boot/vmlinux-2.3.21-decR4k.ecoff
-tftp load 1222624+0+369568

KN04 V2.1k    (PC: 0x8005c044, SP: 0x80047f78)

-tftp boot(3), bootp 193.189.250.46:/boot/vmlinux-2.3.21-decR4k.ecoff
-tftp load 1222624+0+369568

So long ...

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-5241-470566
  ...  The failure can be random; however, when it does occur, it is
  catastrophic and is repeatable  ...             Cisco Field Notice

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 9 Dec 1999 17:02:09 -0200

> -tftp load 1222624+0+369568

The CVS now has a couple of fixes, could you retry?

  Ralf

---

From: Harald Koerfgen <[email-masked]>
Date: Thu, 09 Dec 1999 22:00:02 +0100 (MET)

> -tftp load 1222624+0+369568

http://oss.sgi.com/www.linux.sgi.com/mips/mips-howto.html

" 6.2 Self compiled kernels crash when booting.

When I build my own kernel, it crashes. On an Indy the crash message looks like
the following; the same problem hits other machines as well but may look
completely different. 

 [...]

This problem is caused by a still unfixed bug in Binutils newer than version
2.7. As a workaround, change the following line in arch/mips/Makefile from: 

   LINKFLAGS       = -static -N
 
to: 

   LINKFLAGS       = -static"

BTW, little endian semaphores for R4xxx and TLB miss handlers for R3xxx are
broken in this snapshot. This is fixed since yesterday and 2.3.21 is happily
running on a /260 and a /133. If you want to play around with recent kernels I
suggest a fresh cvs checkout. Instructions can be found at the above URL.

Hope this helps.

---
Regards,
Harald

---

From: Jun Matsuda <[email-masked]>
Date: Tue, 21 Dec 1999 21:02:56 +0900

Hi,

I plan to construct the cross compilation environment as
described in the Linux/MIPS-HOWTO. But I could not find the
patch for glibc-2.0.6 (glibc-2.0.6-mips.patch) and without
this patch, I failed to compile glibc-2.0.6.

Does anyone tell me the place where to find it?

--
Best regards,
Jun Matsuda ([email-masked])

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 21 Dec 1999 15:19:30 +0100

> Does anyone tell me the place where to find it?

In the SRPM package of glibc.

  Ralf

---

From: Florian Lohoff <[email-masked]>
Date: Tue, 21 Dec 1999 16:54:44 +0100

> Does anyone tell me the place where to find it?

There is a source rpm for it somewhere - Or a debian source package
for 2.0.7.981112 or something at

ftp://ftp.rfc822.org/pub/local/debian/debian/experimental 

or something like that - It doesnt compile out of the box because
the tic and rpcgen get linked to the wrong lib ...

Flo

---

From: Jun Matsuda <[email-masked]>
Date: Wed, 22 Dec 1999 08:59:45 +0900

Hi,

> In the SRPM package of glibc.

I found the SPRM package for egcs and binutils, but I could not
find package for glibc.

I expect the SPRM package for glibc is in:
ftp://ftp.linux.sgi.com/pub/linux/mips/crossdev/src/

Does anyone know the exact place of the SPRM package for
glibc in ftp.linux.sgi.com?

> ftp://ftp.rfc822.org/pub/local/debian/debian/experimental 

Thanks! I will try it.