Subject: Re: Kernel Semaphores

From: "Kevin D. Kissell" <[email-masked]>
Date: Mon, 6 Dec 1999 21:33:38 +0100

>> To make it work on 32-bit CPUs, I looked at using
>> the x386 model, but that one uses interrupt disables
>> and is intrinsically SMP-unsafe.
>
>semaphore-helper.h uses spin_lock_irqsave which is smp-safe.  The way
>we do things for 64-bit MIPS is just more performant.

spin_lock_irqsave() in 2.2.12 for MIPS is just a save_and_cli().
The MIPS spin_lock macros all collapse the lock into nothingness.

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 6 Dec 1999 19:13:51 -0200

> The MIPS spin_lock macros all collapse the lock into nothingness.

Spinlocks are SMP safe; it's just the MIPS implementation which doesn't
get this right so far.

  Ralf