Subject: Re: Nomenclature: "MIPS32", "MIPS64"

From: "Kevin D. Kissell" <[email-masked]>
Date: Mon, 6 Dec 1999 14:29:06 +0100

>On Mon, Dec 06, 1999 at 01:44:55PM +0100, Kevin D. Kissell wrote:
>
>> "MIPS32" and "MIPS64" have a very specific
>> meaning now, and for all I know are already
>> trademarked/brandmarked/whatever by
>> MIPS Technologies Inc. to describe the new
>> baseline ISA and privileged resource architecture
>> (CP0, in other words) standards for 32-bit
>> and 64-bit MIPS devices.   It's no big deal
>> for informal discussion, but *please* do not
>> use the strings "MIPS32" or "MIPS64" in the
>> code or documentation unless you are really
>> and truly referring to MIPS32 and MIPS64
>> as defined by MIPS.   If you want to refer to
>> the 64-bit versus 32-bit Linux ports, please
>> express it otherwise, e.g. MIPS64bit,
>> MIPS_64_bit, 64bitMIPS, etc.   Otherwise
>> there is going to be a lot of needless confusion
>> and a further source schism.
>
>The use of these terms is pretty coherent with their meaning as given by
>Mips, Inc.  Linux/MIPS32 is a implementation of Linux (mostly) for MIPS32
>processors, Linux/MIPS64 for MIPS64 processors, so I don't see the problem.
>
>  Ralf

The problems are twofold.  First, while it is of course possible to create
a kernel that will run on both MIPS64 and pre-MIPS64 MIPS-III and
MIPS-IV CPUs, it is also possible to create a MIPS64 kernel that
would not necessarily run on R10000s and vice versa.  Secondly,
we are referring to two distinct things that ought to be distinguished
at the source and documentation level.   We need a name for something 
that is 64-bit-MIPS but not necessarily tied up with any particular CPU 
and a distinct name for something that is compatible with a particular 
CPU type.  "MIPS32" and "MIPS64" are already trademarked
by MIPS to describe the CPUs, so we need another name for the 
generic OS infrastructure for 64-bit MIPS registers/addresses.

---

From: Alan Cox <[email-masked]>
Date: Mon, 6 Dec 1999 13:35:54 +0000 (GMT)

> generic OS infrastructure for 64-bit MIPS registers/addresses.

I would suggest that until someone from MIPS legal specifically raises an issue
you don't worry about it. With the sparc people they were quite happy with
Linux/sparc - which denotes Linux for sparc systems (they objected to 
sparclinux as that implied it was their product). In fact given the "/" is
'for' then I don't think there is even a valid trademark issue to be raised.

Its also not in MIPS interest to cause trouble. Its a product for their
system. If they started being silly then everyones lawyers would be advising
them to pull their "xyz product for mips" as a legal precaution.

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 6 Dec 1999 12:19:10 -0200

> them to pull their "xyz product for mips" as a legal precaution.

I wouldn't expect MIPS to create any legal problems for anybody; you should
consider this no more than an advice.

  Ralf