Subject: Current cvs kernerl fails to compile for decstation

From: Florian Lohoff <[email-masked]>
Date: Fri, 18 Feb 2000 10:25:05 +0100

On Decstation:

make[3]: Entering directory `/data/kernel/linux/drivers/net'
gcc -D__KERNEL__ -I/data/kernel/linux/include -Wall -Wstrict-prototypes -O2 -fom
it-frame-pointer -G 0 -mno-abicalls -fno-pic -mcpu=r4600 -mips2 -pipe    -DEXPOR
T_SYMTAB -c slhc.c
In file included from slhc.c:74:
/data/kernel/linux/include/net/tcp.h:343: #error HZ != 100 && HZ != 1024.
make[3]: *** [slhc.o] Error 1
make[3]: Leaving directory `/data/kernel/linux/drivers/net'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/data/kernel/linux/drivers/net'
make[1]: *** [_subdir_net] Error 2
make[1]: Leaving directory `/data/kernel/linux/drivers'
make: *** [_dir_drivers] Error 2

------------

#if HZ == 100
#define TCP_TW_RECYCLE_TICK (7+2-TCP_TW_RECYCLE_SLOTS_LOG)
#elif HZ == 1024
#define TCP_TW_RECYCLE_TICK (10+2-TCP_TW_RECYCLE_SLOTS_LOG)
#else
#error HZ != 100 && HZ != 1024.
#endif

-------------

Hrmpf ...

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-5241-470566
"Technology is a constant battle between manufacturers producing bigger and
more idiot-proof systems and nature producing bigger and better idiots."

---

From: Marc Esipovich <[email-masked]>
Date: Fri, 18 Feb 2000 15:05:18 -0200 (GMT+2)

> #error HZ != 100 && HZ != 1024.

Without looking or knowing the source,  my recommendation is, see where HZ
is defined, and find out why it's not defined as either 100 or 1024, but
you know that already ;)

	Marc.

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 18 Feb 2000 22:36:28 +0100

> #error HZ != 100 && HZ != 1024.

How about making that:

#if HZ == 100
#define TCP_TW_RECYCLE_TICK (7+2-TCP_TW_RECYCLE_SLOTS_LOG)
#elif HZ == 64
#define TCP_TW_RECYCLE_TICK (6+2-TCP_TW_RECYCLE_SLOTS_LOG)
#elif HZ == 1024
#define TCP_TW_RECYCLE_TICK (10+2-TCP_TW_RECYCLE_SLOTS_LOG)
#else
#error HZ != 100 && HZ != 1024.
#endif

Without further reading the context that would by my first attempt.

> Hrmpf ...

Imagine, and tomorrow I'm going to break all networking drivers :-)

  Ralf

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 18 Feb 2000 22:46:09 +0100

> is defined, and find out why it's not defined as either 100 or 1024, but

It's 64 because it's not possible to program the DECstation RTC to 100Hz
or 1024Hz.

  Ralf

---

From: Harald Koerfgen <[email-masked]>
Date: Sat, 19 Feb 2000 13:26:54 +0100 (MET)

>> > #error HZ != 100 && HZ != 1024.

Well, I changed that to 
#if HZ == 100 || HZ == 128

HZ has been changed to 128 somewhere in the early 2.3.x series...

> It's 64 because it's not possible to program the DECstation RTC to 100Hz

Well, 1024 Hz would be possible but certainly total overkill for a DECstation
2100 with a 12.5 Mhz R2000 :-)

---
Regards,
Harald