Subject: Re: FP emulation patch available

From: "Kevin D. Kissell" <[email-masked]>
Date: Wed, 8 Mar 2000 10:43:23 +0100

Hearald Koerfgen wrote:
>
>On 07-Mar-00 Andrew R. Baker wrote:
>> 
>> 
>> On Tue, 7 Mar 2000, Gleb O. Raiko wrote:
>>> "Bradley D. LaRonde" wrote:
>>> > 
>>> > I would jump right on this but I really need it for 2.3.47+.
>>> > 
>>> > Regards,
>>> > Brad
>>> 
>>> I vote for 2.3 too. It seems 2.2 will vanish soon anyway.
>> 
>> Working on it.
>
>Me too. Compiles and links but doesn't work. I guess the cpu detection doesn't
>work properly for my Mobilon yet. I am actually compiling it for a DECstation
>:-)

It's odd - I'm on at least one of the mailing lists in question, but I missed
part of this thread yesterday - such as Bradley's message, and another
that must have come from someone (Dom?) at Algorithmics.  

Anyway, the my CPU detection would certainly not have worked for
a Mobilon.   But it ought to have worked for a DECstation.  What
CPU does it have?   In addition to the cpu_probe() routine itself,
arch/mips/kernel/cpu_probe.c contains a table that describes the
CPU's that are recognized, and in principle it "knows" all the CPUs
that were recognized by the old assembler code in head.S, plus
a couple more (R4300 and MIPS 4Kc/5Kc).   The problem may
be a CPU that is mis-identified, or it may be that the options in the
table associated with that CPU are incorrectly defined.  Please
let me know what CPU and "PrID" the system has.

            Regards,

            Kevin K.

---

From: Richard van den Berg <[email-masked]>
Date: Wed, 8 Mar 2000 18:02:46 +0100 (MET)

> that must have come from someone (Dom?) at Algorithmics.  

Yep, you can read the thread that went through fnet.fr on the mailing list
archive, including Dom's message, at
http://web.inter.nl.net/users/schnecke/fnet-mips/2000-03/thread.html with
user mips and password rules.

Regards,
Richard

---

From: Harald Koerfgen <[email-masked]>
Date: Wed, 08 Mar 2000 19:43:39 +0100 (MET)

Hi Kevin,

> let me know what CPU and "PrID" the system has.

Been there, done that. It was just a missing case statement that got lost during
the merge :-)

For the records (Sharp Mobilon HC-4500):

Philips PR31700 (identical to Toshiba TMPR3912) @ 73.7 MHz, Implementation 0x22
(same as R46[45]0), Revision 0x10 (does anybody know what R46[45]0 have?).

Based on an R300A core with some ISA-II extensions, 1KB instruction cache, and
4KB write-through data cache, 32 TLB entries.

Back on topic:

My Mobilon dies horribly with the screen going blank and even a soft reset
doesn't revive it. All that helps is to remove all batteries. No error messages
can be seen.

My DS 5000/133 (R3000A) with FPU disabled and FPU emulation shows:
 Illegal instruction 00000034 at 801ce924, ...

System.map shows:
 801ce920 b dsemul_insns
 801ce928 b dsemul_cpc

Looks like your trick in mips_dsemul() doesn't work too well for ISA-I CPUs. Do
you have an idea for an alternative?

-- 
Regards,
Harald