Subject: 2.3.47 success on Decstation 5000/150, problems with login

From: Florian Lohoff <[email-masked]>
Date: Wed, 1 Mar 2000 11:50:53 +0100

Hi,
i just succeeded in compiling current CVS 2.3.47 and succeeded booting
the same kernel.

This DECstation is a DS5000/1xx
Loading R4000 MMU routines.
CPU revision is: 00000430
Primary instruction cache 8kb, linesize 16 bytes)
Primary data cache 8kb, linesize 16 bytes)
Secondary cache sized at 1024K linesize 32
Linux version 2.3.47 ([email-masked]) (gcc version egcs-2.90.27 980315 (egcs-1.0.2 release)) #2 Wed Mar 1 08:21:08 GMT 2000
On node 0 totalpages: 16384
zone(0): 4096 pages.
zone(1): 12288 pages.
zone(2): 0 pages.
Calibrating delay loop... 49.81 BogoMIPS
Memory: 62584k/65536k available (1012k kernel code, 2952k reserved, 72k data, 48k init)
Buffer-cache hash table entries: 4096 (order: 2, 16384 bytes)
Page-cache hash table entries: 16384 (order: 4, 65536 bytes)
Checking for 'wait' instruction...  unavailable.
POSIX conformance testing by UNIFIX
TURBOchannel rev. 1 at 12.5 MHz (no parity)
    slot 0: DEC      PMAZ-AA  V5.3d   
    slot 1: DEC      PMAZ-AA  V5.3b   
    slot 2: DEC      PMAF-FA  V1.1    
Linux NET4.0 for Linux 2.3
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 4096 bind 4096)
Starting kswapd v1.6
DECstation Z8530 serial driver version 0.03
tty00 at 0xbc100001 (irq = 4) is a Z85C30 SCC
tty01 at 0xbc100009 (irq = 4) is a Z85C30 SCC
tty02 at 0xbc180001 (irq = 4) is a Z85C30 SCC
tty03 at 0xbc180009 (irq = 4) is a Z85C30 SCC
SCSI ID 7 Clk 25MHz CCF=5 TOut 167 NCR53C9x(esp236)
SCSI ID 7 Clk 12MHz CCF=3 TOut 139 NCR53C9x(esp236)
SCSI ID 7 Clk 12MHz CCF=3 TOut 139 NCR53C9x(esp236)
ESP: Total of 3 ESP hosts found, 3 actually in use.
scsi0 : ESP236 (NCR53C9x)
scsi1 : ESP236 (NCR53C9x)
scsi2 : ESP236 (NCR53C9x)
scsi : 3 hosts.
  Vendor: Quantum   Model: XP34300           Rev: L912
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
  Vendor: SEAGATE   Model: ST15150N          Rev: 8902
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdb at scsi0, channel 0, id 2, lun 0
scsi : detected 2 SCSI disks total.
esp0: target 0 [period 200ns offset 15 5.00MHz synchronous SCSI]
SCSI device sda: hdwr sector= 512 bytes. Sectors= 8399520 [4101 MB] [4.1 GB]
Partition check:
 sda: sda1 < sda5 sda6 sda7 sda8 sda9 sda10 >
esp0: target 2 [period 200ns offset 15 5.00MHz synchronous SCSI]
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 8388315 [4095 MB] [4.1 GB]
 sdb: sdb1 sdb2
declance.c: v0.008 by Linux Mips DECstation task force
eth0: IOASIC onboard LANCE, addr = 08:00:2b:28:f0:a3, irq = 3
Sending BOOTP requests.... OK
IP-Config: Got BOOTP answer from 193.189.250.46, my address is 193.189.250.44
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused PROM memory: 124k freed
Freeing unused kernel memory: 48k freed

The problem is that i am NOT able to log in via SSH afterwards which
works flawlessly with 2.3.21 i am running right now ... Might this
be a devpts PTY98 problem ?

--------------------------------------------------------
(flo@ping)~# ssh [email-masked]
[email-masked]'s password: 
Warning: Remote host denied X11 forwarding, perhaps xauth program could not be run on the server side.
Connection to repeat.rfc822.org closed by remote host.
Connection to repeat.rfc822.org closed.
--------------------------------------------------------

Ideas ?

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-5241-470566
"Technology is a constant battle between manufacturers producing bigger and
more idiot-proof systems and nature producing bigger and better idiots."

---

From: Geert Uytterhoeven <[email-masked]>
Date: Wed, 1 Mar 2000 12:25:02 +0100 (MET)

> be a devpts PTY98 problem ?

What does `ssh -v [email-masked]' say?

BTW, does this mean you have a Debian/mipsel ssh package now?

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven ------------- Sony Software Development Center Europe (SDCE)
[email-masked] ------------------- Sint-Stevens-Woluwestraat 55
Voice +32-2-7248638 Fax +32-2-7262686 ---------------- B-1130 Brussels, Belgium

---

From: Florian Lohoff <[email-masked]>
Date: Wed, 1 Mar 2000 12:23:29 +0100

> What does `ssh -v [email-masked]' say?

(flo@ping)~# ssh -v [email-masked] 
SSH Version 1.2.26 [i586-unknown-linux], protocol version 1.5.
Standard version.  Does not use RSAREF.
ping: Reading configuration data /etc/ssh/ssh_config
ping: ssh_connect: getuid 1000 geteuid 0 anon 0
ping: Connecting to repeat.rfc822.org [193.189.250.44] port 22.
ping: Allocated local port 1021.
ping: Connection established.
ping: Remote protocol version 1.5, remote software version 1.2.27
ping: Waiting for server public key.
ping: Received server public key (768 bits) and host key (1024 bits).
ping: Host 'repeat.rfc822.org' is known and matches the host key.
ping: Initializing random; seed file /home/flo/.ssh/random_seed
ping: Encryption type: idea
ping: Sent encrypted session key.
ping: Installing crc compensation attack detector.
ping: Received encrypted confirmation.
ping: Trying rhosts or /etc/hosts.equiv with RSA host authentication.
ping: Server refused our rhosts authentication or host key.
ping: Connection to authentication agent opened.
ping: RSA authentication using agent refused.
ping: Trying RSA authentication with key 'flo@move'
ping: Server refused our key.
ping: Doing password authentication.
[email-masked]'s password: 
ping: Requesting pty.
ping: Requesting X11 forwarding with authentication spoofing.
ping: Remote: Client requested X11 forwarding, but the server has no xauth program.
ping: Remote: This is usually caused by "xauth" not being in PATH during compile.
Warning: Remote host denied X11 forwarding, perhaps xauth program could not be run on the server side.
ping: Requesting authentication agent forwarding.
ping: Requesting shell.
ping: Entering interactive session.
Connection to repeat.rfc822.org closed by remote host.
Connection to repeat.rfc822.org closed.
ping: Transferred: stdin 0, stdout 0, stderr 97 bytes in 0.2 seconds
ping: Bytes per second: stdin 0.0, stdout 0.0, stderr 392.2
ping: Exit status -1

> BTW, does this mean you have a Debian/mipsel ssh package now?

ftp.rfc822.org

/pub/local/debian/debian-non-US/dists/potato/non-US/non-free/binary-mipsel/ssh_1.2.27-2_mipsel.deb

Flo

---

From: Florian Lohoff <[email-masked]>
Date: Wed, 1 Mar 2000 12:26:50 +0100

> Standard version.  Does not use RSAREF.

BTW:

ssh [email-masked] reboot 

Works - So it has to be something with the "interactive session" therefor
i suspected PTY98 things ...

Flo

---

From: Geert Uytterhoeven <[email-masked]>
Date: Wed, 1 Mar 2000 12:58:28 +0100 (MET)

> /pub/local/debian/debian-non-US/dists/potato/non-US/non-free/binary-mipsel/ssh_1.2.27-2_mipsel.deb

Ah, now I remember. This package depends on a package that's not available.

Gr{oetje,eeting}s,

						Geert

---

From: Andy Isaacson <[email-masked]>
Date: Wed, 1 Mar 2000 10:39:16 -0500

> Connection to repeat.rfc822.org closed by remote host.

Ooh ooh, I think I know this one.  Check that your tty baud rate on
the originating host is not set to 0.  ('stty 9600').  Otherwise maybe 
some other tty setting?

-andy
-- 
Andy Isaacson  http://web.mr-happy.com/~adisaacs/   Fight Spam, join CAUCE:
[email-masked] [email-masked] [email-masked]   www.cauce.org