Subject: resources.h patch / RLIM_INFINITY __KERNEL__ depend ?

From: Florian Lohoff <[email-masked]>
Date: Thu, 30 Mar 2000 14:27:05 +0200

Hi,
again - short patch - RLIM_INFINITY - This is also defined in
both glibc 2.0 and glibc 2.1 headers so it should be __KERNEL__
dependend - Shouldnt it ?

Index: resource.h
===================================================================
RCS file: /cvs/linux/include/asm-mips/resource.h,v
retrieving revision 1.5
diff -u -r1.5 resource.h
--- resource.h	2000/02/04 07:40:53	1.5
+++ resource.h	2000/03/30 12:19:42
@@ -25,13 +25,13 @@
 
 #define RLIM_NLIMITS 10			/* Number of limit flavors.  */
 
+#ifdef __KERNEL__
+
 /*
  * SuS says limits have to be unsigned.
  * Which makes a ton more sense anyway.
  */
 #define RLIM_INFINITY	0x7fffffffUL
-
-#ifdef __KERNEL__
 
 #define INIT_RLIMITS					\
 {							\

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-5241-470566
"Technology is a constant battle between manufacturers producing bigger and
more idiot-proof systems and nature producing bigger and better idiots."

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 30 Mar 2000 18:47:15 +0200

> dependend - Shouldnt it ?

Glibc 2.1 doesn't include <asm/resource.h>, and 2.0 shouldn't do as well
as per convention.  So the fix is to copy the necessary definitions from
kernel headers into glibc headers.

Thanks for reporting this.  I'm just cooking  a new glibc release ...

  Ralf

---

From: Florian Lohoff <[email-masked]>
Date: Fri, 31 Mar 2000 10:29:52 +0200

> Thanks for reporting this.  I'm just cooking  a new glibc release ...

My glibc does include asm/resource.h - This is default hardhat (little endian)

resourcebits.h:#include <asm/resource.h>

This is what caused a lot of userspace builts to fail.

Flo

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 31 Mar 2000 13:46:01 +0200

> This is what caused a lot of userspace builts to fail.

I know.  It's something that used to work with kernel 2.2 but breaks with
2.3.  There are a few more problems of this kind with glibc 2.0 and I'm
cooking up a patch that will make glibc usable and compilable with 2.3
as well.

  Ralf