Subject: homemade kernel

From: Richard <[email-masked]>
Date: Wed, 22 Mar 2000 14:01:13 +0100

Hi,

Why is it, that with the latest repository sources,  i still get this:

  Exception: <vector=UTLB Miss>
   Status register: 0x300004803<CU1,CU0,IM4,IPL=???,MODE=KERNEL,EXL,IE>
   Cause register: 0x8008<CE=0,IP8,EXC=RMISS>
   Exception PC: 0x881385cc, Exception RA: 0x88002614
   exception, bad address: 0x47c4
   Local I/O interrupt register 1: 0x80 <VR/GIO2>
   Saved user regs in hex (&gpda 0xa8740e48, &_regs 0xa8741048):
     arg: 7 8bfff938 8bfffc4d 880025dc
     tmp: 8818c14c 8818c14c 10 881510c4 14 8bfad9e0 0 48
     sve: 8bfdf3e8 8bfffc40 8bfb2720 8bfff938 a8747420 9fc56394 0
9fc56394
     t8 48 t9 8bfffee66 at 1 v0 0 v1 8bfff890 k1 bad11bad
     gp 881dfd90 fp 9fc4be88 sp 8bfff8b8 ra 88002614

   PANIC: Unexpected exception

I checked the arch/mips/Makefile for the linkflags, but there's no -N
there. Has it gone to some other place ?

Richard

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 22 Mar 2000 20:20:31 +0100

> there. Has it gone to some other place ?

There have been various changes by other people working on non-Indy
targets that haven't been tested on silicon.  Similar I didn't test the
last kernel merges on silicon but only made sure they compile.  Will
try it and fix asap ...

  Ralf