Subject: Decstation 5000/150 2.3.99pre2/ still login problems

From: Florian Lohoff <[email-masked]>
Date: Fri, 24 Mar 2000 13:43:15 +0100

Hi,
still the same problems - since the mid 2.3.4x kernels i cant
log into my decstation 5000 - It seems the pseudo tty code
is non functional.

An telnet or "ssh" causes the connection to close if requesting a tty.

(flo@ping)~# ssh [email-masked] sh
[email-masked]'s password: 
Warning: Remote host denied X11 forwarding, perhaps xauth program could not be run on the server side.
uname -a
Linux 193.189.250.44 2.3.99-pre2 #1 Fri Mar 24 13:12:06 CET 2000 mips unknown
tty
not a tty
cat /proc/devices
Character devices:
  1 mem
  2 pty/m%d
  3 pty/s%d
  4 ttyS
  5 cua
 10 misc
162 raw

Block devices:
  7 loop
  8 sd
 65 sd
 66 sd

cat /proc/tty/drivers
pty_slave            /dev/pty/s%d    3   0-255 pty:slave
pty_master           /dev/pty/m%d    2   0-255 pty:master
unknown              /dev/cua        5   64-67 serial:callout
unknown              /dev/ttyS       4   64-67 serial
/dev/console         /dev/console    5       1 system:console
/dev/tty             /dev/tty        5       0 system:/dev/tty

I have compiled the kernel without PTY98 support:

# CONFIG_UNIX98_PTYS is not set
# CONFIG_DEVPTS_FS is not set

This looks a bit different:

(root@193)~# uname -a
Linux 193.189.250.44 2.3.21 #1 Tue Jan 4 18:39:20 GMT 2000 mips unknown
(root@193)~# cat /proc/devices
Character devices:
  1 mem
  2 pty
  3 ttyp
  4 ttyS
  5 cua
 10 misc
162 raw

Block devices:
  8 sd
(root@193)~# cat /proc/tty/drivers
pty_slave            /dev/ttyp       3   0-255 pty:slave
pty_master           /dev/pty        2   0-255 pty:master
unknown              /dev/cua        5   64-67 serial:callout
unknown              /dev/ttyS       4   64-67 serial
/dev/console         /dev/console    5       1 system:console
/dev/tty             /dev/tty        5       0 system:/dev/tty

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-5241-470566
"Technology is a constant battle between manufacturers producing bigger and
more idiot-proof systems and nature producing bigger and better idiots."

---

From: Harald Koerfgen <[email-masked]>
Date: Fri, 24 Mar 2000 18:05:57 +0100 (MET)

On 24-Mar-00 Geert Uytterhoeven wrote:
> On Fri, 24 Mar 2000, Florian Lohoff wrote:
> I can confirm this on my DDB 5074. Does it work on SGI boxes? If yes, it may
> be
> an endianness problem (both DS 5000 and DDB 5074 are little endian).

Same here on my 5k/260 but it seems to be neither an endianness nor a semaphore
problem.

I haven't nailed it down yet but with some hacks I am able to boot 2.3.99-pre2
on my 5k/133. To my surprise I *can* telnet into this box, hmmm...

On the other hand, a kernel for the /260 compiled without CONFIG_CPU_HAS_LLSB
(i.e. using the R3000 semaphore code) does not work as well.

-- 
Regards,
Harald

---

From: Richard <[email-masked]>
Date: Fri, 24 Mar 2000 16:41:05 +0100

Geert Uytterhoeven wrote:

> I can confirm this on my DDB 5074. Does it work on SGI boxes? If yes, it may be

Right now, it seems the kernel won't boot at all on SGI boxes.

Richard

---

From: Geert Uytterhoeven <[email-masked]>
Date: Fri, 24 Mar 2000 15:08:55 +0100 (MET)

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven ------------- Sony Software Development Center Europe (SDCE)
[email-masked] ------------------- Sint-Stevens-Woluwestraat 55
Voice +32-2-7248638 Fax +32-2-7262686 ---------------- B-1130 Brussels, Belgium

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 25 Mar 2000 01:58:55 +0100

> An telnet or "ssh" causes the connection to close if requesting a tty.

Can anybody provide an strace / tcpdump of the session?

  Ralf

---

From: Florian Lohoff <[email-masked]>
Date: Sat, 25 Mar 2000 07:30:09 +0100

> Can anybody provide an strace / tcpdump of the session?

tcpdump is uninteresting because the session just gets dropped 
as one can see in my ssh output. - Same applies to telnet and rsh.

Hmmm - strace - I think i have to get the cobalt strace 3.2 as current
4.0 straces dont build

Flo