Subject: /usr/include/statfsbuf.h - undefined __fsid_t

From: Florian Lohoff <[email-masked]>
Date: Mon, 24 Apr 2000 20:38:06 +0200

Hi,
might this be a problem in the current glibc headers ?

__fsid_t doesnt seem to be defined there ...

In file included from /usr/include/sys/statfs.h:26,
                 from /usr/include/sys/vfs.h:4,
                 from unix/getfree.c:18:
/usr/include/statfsbuf.h:34: parse error before `__fsid_t'
/usr/include/statfsbuf.h:34: warning: no semicolon at end of struct or union
/usr/include/statfsbuf.h:37: parse error before `}'

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-subject-2-change
"Technology is a constant battle between manufacturers producing bigger and
more idiot-proof systems and nature producing bigger and better idiots."

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 25 Apr 2000 12:19:20 -0700

> /usr/include/statfsbuf.h:37: parse error before `}'

Yes, <statfsbuf.h> should include <gnu/types.h>.  Fixing ...

  Ralf