Subject: Re: Should send SIGFPE to .*

From: "Kevin D. Kissell" <[email-masked]>
Date: Thu, 20 Apr 2000 19:09:07 +0200

>> if it was actually a problem), and as such the force_sig() should
>> use the value returned by compute_return_epc() as the signal
>
>I dont think compute_return_epc returns a signal value.

Oops.  You're right.  It returns -EFAULT.  And it handles
the signal propagation all by its lonesome, so nothing
further needs to be done if it failed.

>> I was going to make another cleanup pass over traps.c this
>> week, so it looks like you've found me another nit to excise.
>> (Although we've got the full-blown Algorithmics emulator
>> in our source base - coming soon to a repository near you -
>> we kept the old stuff around for people wanting to build for
>> a minimal footprint).
>
>How much is the full emulator as binary ?

About 47Kbytes, I'm afraid.

__

Kevin D. Kissell
MIPS Technologies European Architecture Lab
[email-masked]
Tel. +33.4.78.38.70.67
FAX. +33.4.78.38.70.68

---

From: Florian Lohoff <[email-masked]>
Date: Thu, 20 Apr 2000 23:03:45 +0200

> further needs to be done if it failed.

This is what i assumed :)

> About 47Kbytes, I'm afraid.

Hmmm - With a 2MB Kernel Image total and 64-128MB machines this is 
ok :)

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-subject-2-change
"Technology is a constant battle between manufacturers producing bigger and
more idiot-proof systems and nature producing bigger and better idiots."