Subject: sgiserial.c / rs_init invoke ?

From: Florian Lohoff <[email-masked]>
Date: Wed, 12 Apr 2000 20:18:29 +0200

Hi,
i am currently digging deeper into sgiserial.c and friends.
My problem right now is that i dont understand when and how the
rs_init should and will be called - Currently i have an
__initcall(rs_init) in arch/mips/sgi/kernel/setup.c which is definitly
wrong - But should this be invoked - I cant find how i386 does this
(Could somebody enlighten me what module_init(rs_init) in
drivers/char/serial.c does ?)

Currently i have problems switching from serial_console to tty code
for userspace - I see sgiserial.c receiving transmit fifo empty
IRQs and i see filling the fifo but i dont see any chars although
i see chars with serial_console :(

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-subject-2-change
"Technology is a constant battle between manufacturers producing bigger and
more idiot-proof systems and nature producing bigger and better idiots."

---

From: Geert Uytterhoeven <[email-masked]>
Date: Fri, 14 Apr 2000 14:48:42 +0200 (CEST)

> drivers/char/serial.c does ?)

module_init(rs_init) == __initcall(rs_init)

Both add rs_init() to the list (read: array) of functions to be called during
initialization.

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- Linux/{m68k~Amiga,PPC~CHRP} -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds