Subject: New mini-distribution

From: Keith M Wesolowski <[email-masked]>
Date: Fri, 19 May 2000 15:45:11 -0700

Hi all,

I got bored last week and put together a new mini-distribution for
SGIs. I know it works on Indigo2 at least. It's a lot smaller and has
some more up to date components than Hard Hat. Perhaps it would be a
good starting point for someone to use, or maybe it will be of no use
to anyone but me. :) Those interested can read a quick HOWTO at
http://foobazco.org/~wesolows/Install-HOWTO.html; the necessary files
are at ftp://ftp.foobazco.org/pub/people/wesolows/mips-linux/.

Quick rundown:

Kernel 2.2.14 from CVS
glibc 2.0.6 with patches
egcs 1.1.2 with patches
binutils 000425 with patches
bash 2.04
vim 5.6
barebones initscripts
miscellaneous useful software
NFS-based installation

Plans:

Not much. I will probably try to get gcc 2.96 and glibc 2.2 working
with it, those being the least up to date parts of it all. I don't
really think this is going anywhere; Debian will hopefully be finished
soon.

-- 
Keith M Wesolowski			[email-masked]
University of Nevada			http://www.chem.unr.edu
Chemistry Department Systems and Network Administrator

---

From: Florian Lohoff <[email-masked]>
Date: Sat, 20 May 2000 14:16:23 +0200

> really think this is going anywhere; Debian will hopefully be finished

be officially started would be a better status definition :)

There are a lot packages already available lacking most of the 
important ones like gcc/binutils/perl etc ..

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-subject-2-change
"Technology is a constant battle between manufacturers producing bigger and
more idiot-proof systems and nature producing bigger and better idiots."

---

From: "Eric Watkins" <[email-masked]>
Date: Wed, 24 May 2000 10:29:26 -0700

Hello,

I noticed in your instructions that you suggest removing the framebuffer
from the video card so the distribution will boot?

QUOTE:
"Note: If your system has an XZ framebuffer in it, you must remove it prior
to booting and use a serial console instead. The XZ framebuffer will likely
prevent your system from booting Linux even if you are not using it. "

Are you suggesting that I remove the vid card?

I'm trying to get my indigo2 to boot linux. Can you go into more detail on
how to remove the framebuffer?

For the rest of the list.. When will I be able to use these monitors? The
monitor is almost the best part of the whole system. I've got PCs that will
run rings around the indigo2 that don't have 21 inch monitors. It's not good
to tell people 'Oh ya linux boots on that but then I have to use this dumb
terminal to do anything.' At this point people start to laugh.

When can I see X in all of it's glory on an indigo2?

Thanks!

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Keith M Wesolowski
> Sent: Friday, May 19, 2000 3:45 PM
> To: [email-masked]
> Subject: New mini-distribution
>
>
> Hi all,
>

---

From: Keith M Wesolowski <[email-masked]>
Date: Wed, 24 May 2000 12:11:59 -0700

> Are you suggesting that I remove the vid card?

Yes. I needed to and it's mentioned at
http://reality.sgi.com/raju/SGI-Linux-mini-HOWTO.html.

> how to remove the framebuffer?

Pop the cover off and hinge the left rear panel to the left. Unscrew
the two graphics boards from the case (just like peecee boards) and
take the thing out.

> When can I see X in all of it's glory on an indigo2?

Guido just got X on XL working. No idea what the timetable for XZ
might be.

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 25 May 2000 02:38:02 +0200

> Guido just got X on XL working. No idea what the timetable for XZ

Don't hold your breath, the XZ is a completly different animal than
the XL.  It's complexity will prevent a quick success.

  Ralf

---

From: [email-masked]
Date: Wed, 24 May 2000 21:29:36 -0400 (EDT)

Hi, is there any way for me to reset the root password on an indy?  I
bought an indy cheap from a liquidator, and have no way to get the root
password.  I can probably set it up, and then rsh into it from a "trusted
host" (I own the network it's now on, and I could cat it's /.rhosts), but
that would take alot of effort.  All I need is to make one little change
to the FS from SASH or bootprom.
Thanks
	Nick

---

From: Florian Lohoff <[email-masked]>
Date: Thu, 25 May 2000 10:25:27 +0200

> to the FS from SASH or bootprom.

The indigo2 has a jumper onboard to "erase" the nvram setting (I multiple
times accidently changes the console setting)

Flo

---

From: [email-masked] (Dag Bakke)
Date: Thu, 25 May 2000 12:52:21 +0200 (CEST)

On May 25, 10:25, Florian Lohoff wrote:
> Subject: Re: New indy problems

The nvram pw is unrelated to the root pw on the systemdisk. (Which I am sure
you are aware of.  :-)

This question is a FAQ and not even related to Linux. You really should read
the SGI FAQs.

The fix is to boot miniroot from network or a CD. Then enter a shell by typing
'shroot' at the Inst> prompt. From here you can edit the passwd file.

Dag B

---

From: Florian Lohoff <[email-masked]>
Date: Thu, 25 May 2000 17:53:54 +0200

> The nvram pw is unrelated to the root pw on the systemdisk. (Which I am sure

If running linux you will reinstall anyway - So why do you care on the
IRIX rootpw ?

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-waiting-4-telekom
"Technology is a constant battle between manufacturers producing bigger and
more idiot-proof systems and nature producing bigger and better idiots."

---

From: [email-masked]
Date: Thu, 25 May 2000 12:33:49 -0400 (EDT)

I'd prefer to try both, and I don't have irix media.
	Nick