Subject: newport driver for XFree

From: Mitja Bezget <[email-masked]>
Date: Wed, 24 May 2000 12:31:49 +0200 (MET DST)

hi!

I'm having problems running xfree on an old Indy
so i tought i should report&ask for help..

First I applyed the patch (is it recent??):

# tar -xzvf X400src.tgz
# cd xc
# patch -p0 <newport_000514.diff
(files are from a webpage previously posted)

and it didn't create drivers/newport/ directory.. (it exited
cleanly!)
should i have done something else before that?
Anyway.. i created the missing files by hand..
afterwards it failed again while making World

newport.c:136: `MGA' undeclared (first use of this function)
newport.c:774: `caddr_t' undeclared (first use of this function)
+ some other errors originating from here..

i fixed the caddr_t (missing #include <sys/types.h>)
i changed  MDA to NEWPORT and it compiled ok!  and i was happy!

But now it just wont run.. error message is attached..
I think it has something to do with socketbits.h and declaration
of enum __socket_type.. Namely i added this enum because i couldn't
find #define for socket types in any of system installed header
files.. (The very first reason server didn't compile) 

i'm running glibc-2.0.6-4 (+devel) and egcs-1.0.2-9..

Thank you!

cya 
Mitja
	
ps. for Guido (or who coded that part):
i went thru newport_regs.h and i noticed your comment in line 153
/* This causes a warning. Why??? */
I believe it was just a simple innocent typo.. you pressed
the semi-colon twice. ;)) 

_XSERVTransSocketCreateListener: listen() failed
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: failed to create listener for tcp
_XSERVTransSocketCreateListener: listen() failed
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: failed to create listener for local

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".

---

From: Guido Guenther <[email-masked]>
Date: Wed, 24 May 2000 13:42:15 +0200

> First I applyed the patch (is it recent??):
There's a newer patch available on that site but this one should work
also.

> newport.c:136: `MGA' undeclared (first use of this function)
This comes from the NewPortSetup function which should only be compiled
if the server supports loadable modules. We currently don't do this on
mips. Add a "#define DoLoadableServer NO" to your host.def and recompile. 

> files.. (The very first reason server didn't compile) 
Why did the compile break?
> the semi-colon twice. ;)) 
I'm aware of that. It's just a reminder for me to check the c-specs why a 
"useless" semicolon causes a compiler warning at all.

[..snip..] 
-- 
GPG-Public Key: http://honk.physik.uni-konstanz.de/~agx/guenther.gpg.asc

---

From: Guido Guenther <[email-masked]>
Date: Wed, 24 May 2000 15:34:45 +0200

> There's a newer patch available on that site but this one should work
I checked the patch and 000514 doesn't create the correct host.def,
I messed up some filenames. Fetch instead:
 http://honk.physik.uni-konstanz.de/~agx/mipslinux/x/source/newport_000524.diff
then:
 tar zxvf X400src-1.tgz
 patch -p1 < newport_000524.diff

[..snip..] 
> > i'm running glibc-2.0.6-4 (+devel) and egcs-1.0.2-9..
I had numerous problems with egcs 1.0.2. I'd recommend to use egcs
1.0.3.
 -- Guido

[..snip..]