Subject: Problems with multiple harddisks on my Indigo2

From: Klaus Naumann <[email-masked]>
Date: Wed, 21 Jun 2000 11:23:43 +0200

Hi all

While trying to build a 2nd harddisk into my Indigo2
I experienced the following problems.
The bus is terminated correctly and with 2 m external
cable to my scsi case it also shouldn't be to long.
When I try to copy data from a harddisk to the other
I get weired I/O erros after some time of heavy I/O.
On the console I get something like:
cp: /mnt/redhat/kernel23/linux/arch/sparc/lib/COPYING.LIB: Input/output error

And dmesg shows:
attempt to access beyond end of device
08:03: rw=0, want=959546428, limit=1888830
attempt to access beyond end of device
08:03: rw=0, want=958585434, limit=1888830
attempt to access beyond end of device
08:03: rw=0, want=959546428, limit=1888830
attempt to access beyond end of device
08:03: rw=0, want=958585434, limit=1888830
attempt to access beyond end of device
08:03: rw=0, want=941858675, limit=1888830

Ususally the system is pretty unstable after these messages.

Also I'm getting a message
sc1,2,0: cmd=0x12 timeout after 2 sec.  Resetting SCSI bus
every time I restart my Indigo2 on the serial console -
does anyone know what that means and if it's a problem ?

Further more it happens that after heavy I/O a simple "sync"
needs more than one minute.

Has anyone seen the same or equal problems in any way
and/ was able to resolve these ?

	TIA, Klaus

-- 
Full Name   : Klaus Naumann     | (http://www.mgnet.de/) (Germany)
Nickname    : Spock             | Org.: Mad Guys Network
Phone / FAX : ++49/177/7862964  | E-Mail: ([email-masked])
PGP Key     : www.mgnet.de/keys/key_spock.txt

---

From: "Ian Chilton" <[email-masked]>
Date: Wed, 21 Jun 2000 13:43:07 +0100

Hello,

> 08:03: rw=0, want=959546428, limit=1888830
[SNIP]

I have an SGI Indy, with 2 internal hard disks, a 4GB and a 1GB

I get the same thing!

> sc1,2,0: cmd=0x12 timeout after 2 sec.  Resetting SCSI bus

I started getting this when I added the 2nd HD (1GB).

Bye for Now,

Ian

                     \|||/ 
                     (o o)
 /----------------ooO-(_)-Ooo----------------\
 |  Ian Chilton                              |
 |  E-Mail :   [email-masked]            |
 |  IRC Nick:  GadgetMan                     |
 \-------------------------------------------/

---

From: Paul Jakma <[email-masked]>
Date: Wed, 21 Jun 2000 22:38:42 +0100 (IST)

> I started getting this when I added the 2nd HD (1GB).

fwiw, i got this too on my indy when i added a Quantum Empire 1GB.

>From cold boot the PROM doesn't recognise the second disk, but IRIX
does (PROM gives me the exact same error message as the one you wrote
above - but prints it twice). If i halt back to PROM then the PROM
does see the second disk. (and only prints that error message once)

my theories are:

1. PROM controller driver is minimal and doesn't init the
controller/disks properly whereas the IRIX driver does. 

2. disk spin up times.. ??

3. Perhaps cause the outboard SCSI port is not terminated. (least not
on my indy)

-- 
Paul Jakma	[email-masked]
PGP5 key: http://www.clubi.ie/jakma/publickey.txt
-------------------------------------------
Fortune:
Give me a fish and I will eat today.

Teach me to fish and I will eat forever.

---

From: "J.K. Hill" <[email-masked]>
Date: Wed, 21 Jun 2000 19:11:39 -0400 (EDT)

All,

Try looking up the jumper'ing information for the drive... There is probably a
delay for spinning the drive up at boot (or some such nonsense).

Regards,

Ken

On Jun 21, 10:38pm, Paul Jakma wrote:
> Subject: RE: Problems with multiple harddisks on my Indigo2
>-- End of excerpt from Paul Jakma

---

From: Paul Jakma <[email-masked]>
Date: Thu, 22 Jun 2000 00:24:43 +0100 (IST)

On Wed, 21 Jun 2000, J.K. Hill wrote:

> All,
> 
> Try looking up the jumper'ing information for the drive... There
> is probably a delay for spinning the drive up at boot (or some
> such nonsense).
> 

checked that.. and it's not it. the jumper isn't set. (i think).

however, this drive used to be in an Alpha, and ARCSBIOS on Alpha had
a problem with not recognising it from cold too, sometimes.

so maybe the drive just doesn't spin up fast enough.

> Ken

thanks,
-- 
Paul Jakma	[email-masked]
PGP5 key: http://www.clubi.ie/jakma/publickey.txt
-------------------------------------------
Fortune:
The price one pays for pursuing any profession, or calling, is an intimate
knowledge of its ugly side.
		-- James Baldwin

---

From: "Roald Lygre" <[email-masked]>
Date: Thu, 22 Jun 2000 08:51:15 +0200

> 3. Perhaps cause the outboard SCSI port is not terminated. (least not

The SCSI port should be terminated with an active terminator on the Indy,
regardless of if you have 1 or 2 drives installed.

-Roald

-- 
    
---------------------------------------------------------------
| Company: SGI Norge A/S                                      |
| Email:   [email-masked]          Tlf:          +47 5163 4183 |
| Addr:    Luramyrveien 79        Mobil:        +47 909 33 903|
|          N-4313 Sandnes         VMail (SGI):  870-4679      |
|          NORWAY                 VMail(ext):   +47 6711 4679 |
---------------------------------------------------------------
Essential SGI Websites:
http://www.sgi.com/             SGI
http://www.sgi.no/              SGI Norge
http://support-europe.sgi.com/  Log calls, patches+overlays, ++
http://freeware.sgi.com/        Freeware - "ready-to-eat"
http://oss.sgi.com/mips/        Linux for SGI (Mips/Intel)
http://www.sgi.com/developers/  Developer Central
http://www.sgi.com/Products/Evaluation/   Evaluation Software

---

From: "Ian Chilton" <[email-masked]>
Date: Thu, 22 Jun 2000 11:33:04 +0100

Hello,

Just to let you guys know...

I just tried the 2x HD thing in IRIX (on my Indy), and no problems!  So, it
IS a Linux/MIPS problem!!

I did:  cp -R /usr /hd2

It was going for about 10 mins, before it ran out of disk space (1GB !). No
errors at all   :)

Bye for Now,

Ian

                     \|||/
                     (o o)

---

From: David Keen <[email-masked]>
Date: Fri, 23 Jun 2000 09:25:42 -0500

Good Morning,
The SCSI reset problem occurred on my Indy after I added a Floptical on
ID 2. I am not running Linux on the box at this time. Have upgraded to
6.2 from 5.3 but haven't tried to reinstall the floptical yet. Set
jumpers to Indy specs, so am unsure why. BTW, would the Indy boot from
the floptical for Linux without doing a net boot?
Sincerely,
Dave Keen

---

From: Klaus Naumann <[email-masked]>
Date: Fri, 23 Jun 2000 16:44:42 +0200

> the floptical for Linux without doing a net boot?

I've heard from someone that it is possible - but I'm not
sure - try it ;)

	CU, Klaus