Subject: sgi prom console

From: Keith M Wesolowski <[email-masked]>
Date: Wed, 26 Jul 2000 21:54:16 -0700

Hi,

This patch gets the sgi prom console outputting again, and eliminates
the "cannot open initial console" error. Unfortunately, all output
from userland goes to the serial port, not the the prom console.
Looking at the code, this isn't at all surprising; the prom console
pretends to be 4,64, ttyS0. It's quite beyond me how the prom console
could ever have worked for userland.

Index: drivers/char/mem.c
===================================================================
RCS file: /cvs/linux/drivers/char/mem.c,v
retrieving revision 1.35
diff -u -r1.35 mem.c
--- drivers/char/mem.c	2000/06/25 01:20:03	1.35
+++ drivers/char/mem.c	2000/07/27 04:48:33
@@ -49,6 +49,9 @@
 #ifdef CONFIG_PROM_CONSOLE
 extern void prom_con_init(void);
 #endif
+#ifdef CONFIG_SGI_PROM_CONSOLE
+extern void sgi_prom_console_init(void);
+#endif
 #ifdef CONFIG_MDA_CONSOLE
 extern void mda_console_init(void);
 #endif
@@ -632,6 +635,9 @@
 #endif
 #if defined (CONFIG_PROM_CONSOLE)
 	prom_con_init();
+#endif
+#if defined (CONFIG_SGI_PROM_CONSOLE)
+	sgi_prom_console_init();
 #endif
 #if defined (CONFIG_MDA_CONSOLE)
 	mda_console_init();

-- 
Keith M Wesolowski <[email-masked]> http://foobazco.org/~wesolows/
(( Project Foobazco Coordinator and Network Administrator )) aiieeeeeeee!
"The list of people so amazingly stupid they can't even tie their shoes?"
"Yeah, you know, /etc/passwd."

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 28 Jul 2000 01:59:30 +0200

> could ever have worked for userland.

Ok, patch applied.

  Ralf