Subject: Question concerning necessary libraries for 2.4.x kernel upgrade

From: Jeff Harrell <[email-masked]>
Date: Thu, 06 Jul 2000 11:21:41 -0600

I am currently upgrading my MIPS development board (Atlas) that contains
a R4Kc (jade core)
and version 2.2.12 of the Linux kernel to a 2.4.x series kernel.   I
believe the  libraries and applications
were built off of the hardhat distribution.  We are able to run the
2.4.x version of the kernel on the Atlas
board but are seeing problems with some of the executables.  I examined
the Changes file and am in the
process of upgrading the following binaries/libraries..

GNU C  2.7.2.3
binutils 2.9.1.0.22
util-linux 2.10g
modutils 2.3.0
e2fsprogs 1.18
pcmcia-cs 3.1.13
ppp 2.4.0b1

I am seeing problems with executables such as awk, groff, troff, etc.
Will I need to rebuild each of these
applications  against the new libraries to run or should they still
function after I have upgraded the previously
mentioned packages?  Are there mipsel version of these packages (either
source or binaries) available somewhere?
Any information would be greatly appreciated.

Jeff

--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Jeff Harrell                    Work:  (801) 619-6104
Broadband Access group/TI
[email-masked]
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 7 Jul 2000 02:46:08 +0200

> process of upgrading the following binaries/libraries..

2.7.2.3 may work or not.  Most people are using egcs 1.0.3a, so I recommend
using that one.

> binutils 2.9.1.0.22

DON'T touch, stick with 2.8.1.

> modutils 2.3.0

I have no reports about modutils 2.3.0.

> source or binaries) available somewhere?

You can try the DECstation package (see howto) or get the src.rpm
packages from oss.sgi.com which has a preliminary RH 6.0 port.  The packages
should build for little endian also.

  Ralf

---

From: Wichert Akkerman <[email-masked]>
Date: Fri, 7 Jul 2000 17:03:36 +0200

> modutils 2.3.0

There is (and was) no such thing as modutils 2.3.0. Perhaps you
mean modutils 2.3.10?

Wichert.

-- 
  _________________________________________________________________
 / Generally uninteresting signature - ignore at your convenience  \
| [email-masked]                   http://www.liacs.nl/~wichert/ |
| 1024D/2FA3BC2D 576E 100B 518D 2F16 36B0  2805 3CB8 9250 2FA3 BC2D |