Subject: Okay, lost

From: "A. Wrasman" <[email-masked]>
Date: Mon, 17 Jul 2000 20:53:03 -0500

Okay, I can't seem to get any of the pre-compiled linux kernels  after the 2.2.14 one on oss.sgi.com to boot on my Indy.

I get this type of error:
Exception: <vector=Normal>
Status register: 0x10044803<CU0,CH,IM7,IM4,IPL=???,MODE=KERNEL,EXL,IE>
Cause register: 0x8034<CE=0,IP8,EXC=TRAP>
Exception PC: 0x88240004, Exception RA: 0x8816d610
Processor Trap exception at address 0xffffffff
Local I/O interrupt register 1: 0x80 <VR/GIO2>
	Saved user regs in hex (&gpda 0xa8740e48, &_regs 0xa8741048):
	arg: a8740000 28 8847ff80 a
	tmp: a8740000 8480 88002000 8480 881932a0 1 fffffffc 47dfa8
	sve: a8740000 0 0 0 0 0 0 0
	t8 a8740000 t9 0 at 0 v0 0 v1 0 k1 88002000
	gp a8740000 fp 0 sp 0 ra 0

PANIC: unexpected exception

Or something similar.

---

From: Keith M Wesolowski <[email-masked]>
Date: Mon, 17 Jul 2000 21:00:35 -0700

> Exception: <vector=Normal>

I've no idea what kernels you're using. Try
/pub/linux/mips/mips-linux/simple/kernels/vmlinux-000717-38400 if you
want to try a post-2.2 kernel. It really should work.

-- 
Keith M Wesolowski			[email-masked]
University of Nevada			http://www.chem.unr.edu
Chemistry Department Systems and Network Administrator

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 18 Jul 2000 05:23:09 +0200

> PANIC: unexpected exception

Now that looks like a kernel compiled by somebody who doesn't read
documentation, see http://oss.sgi.com/mips/mips-howto.html.  In short:
remove the -N linker flag from arch/mips/Makefile.

  Ralf

---

From: Ulf Carlsson <[email-masked]>
Date: Tue, 18 Jul 2000 15:27:23 -0700 (PDT)

> remove the -N linker flag from arch/mips/Makefile.

I had the same problem on one of my machines.  The -N linker flag was
not the solution.  Note that the kernels ran on other machines.  I
only got this for the 2.4, not 2.2.

Ulf

---

From: "A. Wrasman" <[email-masked]>
Date: Sun, 23 Jul 2000 14:56:14 -0500

On Sun, Jul 23, 2000 at 03:03:24AM +0200, Ralf Baechle wrote:
> On Sat, Jul 22, 2000 at 12:35:49PM -0500, A. Wrasman wrote:
> 
> > Well removed the 2 extra cards from the box. Still no go.
> 
> Thanks.
> 
> I suspect that there is some magic configuration which crashes.  Since
> hardware doesn't make the difference it might also be the PROM version.
> Basically I believe that under certain circumstances the kernel overwrites
> PROM data structures or vice versa or there is (yet another ...) ARC
> firmware bug which results in a crash.

I've got version 5.3 of the prom for IP22. Of course SGI is doing some update of the support section of their site this weekend
so I can't even poke around to see what updates have come out, since I have't patched IRIX 6.2 in over 2 years on this box.

How can I go about troubleshooting the kernel at this point? The odd thing is a 2.2.14 (and an older 2.2.1) kernel all work fine.

Since most of the work is now being done on the 2.4 kernel it would be nice to get nearer to what the development is being done on.