Subject: Re: CVS [email-masked]: linux

From: Ralf Baechle <[email-masked]>
Date: Tue, 4 Jul 2000 23:22:16 +0200

On Tue, Jul 04, 2000 at 07:27:53PM +0200, Harald Koerfgen wrote:

> > Log message:
> >       We have to clobber ``hi'' and ``lo'' in __udelay.  Nasty bug.
> 
> Unfortunately my compilers don't like it.
> 
> mipsel-linux-gcc: egcs-2.90.29 980515 (egcs-1.0.3 release) (rpm from oss):
> 
> timer.c: In function `sys_nanosleep':
> timer.c:848: fixed or forbidden register was spilled.
> This may be due to a compiler bug or to impossible asm
> statements or clauses.

I've commited a fix for this.  It only tackles the __udelay() functions
for mips and mips64 but not the other multu instruction in the
DECstation HZ_TO_STD function.  Can you take a look at this one?

  Ralf

---

From: Harald Koerfgen <[email-masked]>
Date: Wed, 05 Jul 2000 20:24:20 +0200 (CEST)

> DECstation HZ_TO_STD function.  Can you take a look at this one?

Done.

-- 
Regards,
Harald