Subject: Re: [Install trouble]

From: Famille Chauvat <[email-masked]>
Date: Sun, 06 Aug 2000 15:03:30 +0000

Hi Florian,

Thanks for your response. Humm, I don't know how to boot with rw support...
And, Keith M Wesolowski, see messages in this thread, modify the kernel to
have a ramdisk support.
>>>> Keith M Wesolowski
>>>> I've uploaded a new kernel, dated 0731, which should have the necessary support.
>>>>
That what I don't understand, except a lot of another things :-), is how it
runs. You know, I took a lot of things on internet, I read a lot of papers,
perhaps not those I had to, and I've never ask to support or not the
ramdisk. So my question is, how the kernel I took doesn't support something
I never asked for. I'm not sure to be very clear :-)

With the new kernel I have, I've a new trouble. After the partition step, a
message "mount failed, bad address" appears and I 've to reboot. Of course,
the next time I'ld the same things. Any suggestion, any help, would be very
appreciate.
Btw, if you know someone of your team or friends who speak french, it could
be better, for me, to explain what going wrong.

Philippe

---

From: Florian Lohoff <[email-masked]>
Date: Fri, 4 Aug 2000 21:03:04 +0200

On Sun, Jul 30, 2000 at 07:16:38PM +0000, Famille Chauvat wrote:
> Hello,
> 
> I'm working with an Indy station and the corresponding kernel.
> On the bootp() step, i got a message:
> >>>>>>>
> 
> creating 100k of ramdisk space... done
> mounting /tmp from ramdisk... failed
> 
> I can't recover from this.
> <<<<<<<

Probably this is a kernel with no ramdisk support ?  Ah wait - No - 
You have booted the kernel with a read-only root - Which means - When
mounting /tmp i tries to write /etc/mtab which is read-only - Try
to append "rw" to your prom console boot line

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-5201-669912
     "If you're not having fun right now, you're wasting your time."

---

From: Florian Lohoff <[email-masked]>
Date: Mon, 7 Aug 2000 10:16:20 +0200

> And, Keith M Wesolowski, see messages in this thread, modify the kernel to

Look into /usr/src/linux/Documentation 

Booting with an "rw" root you just have to append "rw" to the command
line you boot with ...

> I never asked for. I'm not sure to be very clear :-)

Not the kernel uses it - The installer does - The installer tries
to create a /tmp filesystem in a ramdisk to proceed installation.
When there is no ramdisk support the /tmp filesystem creation will fail.

> the next time I'ld the same things. Any suggestion, any help, would be very

No idea

> be better, for me, to explain what going wrong.

Sorry - Cant help you :)

Flo