Subject: egcs problem

From: Ian Chilton <[email-masked]>
Date: Tue, 26 Sep 2000 23:37:24 +0100

Hello,

I am building a Linux system with egcs 1.0.3a, binutils 2.8.1 and glibc 2.0.6 (before I try the latest CVS stuff).

I sucsssfully built the esentials statically, and used that to build everything dynamically...the only 2 things I could not compile were groff and egcs (dynamically, although it worked statically).

make[4]: Leaving directory `/lfstmp/egcs-1.0.3a/gcc-build/libraries/el/libio'
/lfstmp/egcs-1.0.3a/gcc-build/gcc/xgcc -B/lfstmp/egcs-1.0.3a/gcc-build/gcc/ -g -O2 -fno-implicit-templates  -EL -Wl,-soname,libstdc++.so.`echo 2.8.0 | sed 's/\([0-9][.][0-9]\).*/\1/'` -shared -o libstdc++.so.2.8.0 `cat piclist` -lm
/usr/lib/libm.so: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[3]: *** [libstdc++.so.2.8.0] Error 1
make[3]: Leaving directory `/lfstmp/egcs-1.0.3a/gcc-build/libraries/el/libstdc++'
make[2]: *** [multi-do] Error 1
make[2]: Leaving directory `/lfstmp/egcs-1.0.3a/gcc-build/libraries/libstdc++'
make[1]: *** [multi-all] Error 2
make[1]: Leaving directory `/lfstmp/egcs-1.0.3a/gcc-build/libraries/libstdc++'
make: *** [all-target-libstdc++] Error 2
bash-2.04#    

bash-2.04# ls /usr/lib/libstdc*
/usr/lib/libstdc++.a
bash-2.04# ls /usr/lib/libm*   
/usr/lib/libm.a  /usr/lib/libm.so  /usr/lib/libm_p.a  /usr/lib/libmcheck.a
bash-2.04# 

Any ideas?

Thanks!

Bye for Now,

Ian

                     \|||/ 
                     (o o)
 /----------------ooO-(_)-Ooo----------------\
 |  Ian Chilton                              |
 |  E-Mail : [email-masked]              |
 \-------------------------------------------/

---

From: Keith M Wesolowski <[email-masked]>
Date: Wed, 27 Sep 2000 10:30:29 -0700

> make[3]: Leaving directory `/lfstmp/egcs-1.0.3a/gcc-build/libraries/el/libstdc++'

I believe this is ignorable. It's trying to build a little-endian
libstdc++ by its multilib mechanism, but your system is big-endian so
the math library isn't compatible with it. Since it's already built
the bigendian one, just do make install and you should have a working
library. You didn't indicate what happened when building groff, so I
won't attempt to guess.

-- 
Keith M Wesolowski			[email-masked]
University of Nevada			http://www.chem.unr.edu
Chemistry Department Systems and Network Administrator