Subject: base.tgz

From: Jan-Benedict Glaw <[email-masked]>
Date: Mon, 16 Oct 2000 04:33:47 +0200

Hi!

Flo gave me a DECStation some days (2 weeks or so?) ago. I now
finally got it running so far. My compiler is quite a bit old
(gcc version egcs-2.90.29 980515 (egcs-1.0.3 release), from SRPMS),
but it con compile actual CVS.

For first tests I used a kernel Flo compiled (R3k-240-test8-pre1
from ftp.rfc822.org:/pub/local/...), but with that one there was
no great chance to even copy some files. Actual CVS is quite
more stable (well, it doesn't survive a nmap scan, but I con
copy tenth of megabytes without any favourite segfaults/bus errors/
core dumps/ ...)

My next goal is to cleanly build something like base.tgz. Maybe
we can get a smooth debian installation in some days;)

So, and now I'll go to bed...

MfG, JBG

-- 
Fehler eingestehen, Größe zeigen: Nehmt die Rechtschreibreform zurück!!!
/* Jan-Benedict Glaw <[email-masked]> -- +49-177-5601720 */
keyID=0x8399E1BB fingerprint=250D 3BCF 7127 0D8C A444 A961 1DBD 5E75 8399 E1BB
     "insmod vi.o and there we go..." (Alexander Viro on linux-kernel)

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Tue, 17 Oct 2000 04:14:50 +0200

On Mon, Oct 16, 2000 at 04:33:47AM +0200, Jan-Benedict Glaw wrote:

Hi!

> we can get a smooth debian installation in some days;)

Okay, I took the package list off potato's base.tgz. Please comment
on the missing packets or which files to take instead. Please also
have a look at the perl packages...

Packages which seem to be not used/useable. They'll not be included:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Package: console-tools-libs
Package: fbset
Package: fdflush
Package: fdutils
Package: isapnptools
Package: lilo
Package: mbr
Package: pciutils
Package: pump
Package: syslinux
Package: xviddetect
Package: pcmcia-cs

Packages which are broken in some way right now:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Package: debconf-tiny (not found)
Package: bsdutils (not found)
Package: libc6 (will use converted 206-5 rpm)
Package: libnewt0 (not found, will use newt-0.40-9.rpm)
Package: libstdc++2.10 (not found)
Package: locales (not found)
Package: mount (not found, will take mount-2.9o-1.rpm)
Package: util-linux (not found, will take util-linux-2.7-19.rpm)
Package: whiptail (not found, will use declinux' version)

Packages which are okay:
~~~~~~~~~~~~~~~~~~~~~~~~
* Package: adduser 
* Package: ae
* Package: apt
* Package: base-config
* Package: base-files
* Package: base-passwd
* Package: bash
* Package: debianutils
* Package: diff
* Package: dpkg
* Package: e2fsprogs
* Package: elvis-tiny
* Package: fileutils
* Package: findutils
* Package: ftp
* Package: gettext-base
* Package: grep
* Package: gzip
* Package: hostname
* Package: ldso
* Package: libdb2
* Package: libgdbmg1
* Package: libncurses5
* Package: libpam-modules
* Package: libpam-runtime
* Package: libpam0g
* Package: libpopt0
* Package: libreadline4
* Package: libwrap0
* Package: login
* Package: makedev
* Package: mawk
* Package: modconf
* Package: modutils
* Package: ncurses-base
* Package: ncurses-bin
* Package: netbase (using netstd_3.07-17.deb)
* Package: passwd
* Package: perl-5.005-base (using perl-5.005_5.005.03-7.1_mipsel.deb)
* Package: perl-base (using perl-5.005-base_5.005.03-7.1_mipsel.deb)
* Package: ppp
* Package: pppconfig
* Package: procps
* Package: psmisc
* Package: sed
* Package: setserial
* Package: shellutils
* Package: slang1
* Package: sysklogd
* Package: sysvinit
* Package: tar
* Package: tasksel
* Package: tcpd
* Package: telnet
* Package: textutils
* Package: update

MfG, JBG

---

From: Geert Uytterhoeven <[email-masked]>
Date: Tue, 17 Oct 2000 13:20:04 +0200 (CEST)

> Packages which seem to be not used/useable. They'll not be included:
  ^^^^^^^^^^^^^^^^^
I prefer to have pciutils. It's very handy for debugging PCI problems.

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

---

From: Florian Lohoff <[email-masked]>
Date: Tue, 17 Oct 2000 16:27:24 +0200

> Packages which seem to be not used/useable. They'll not be included:

We should include them without syslinux, lilo, mbr which
are i386 specific. All others might need some special
hacking ...

> Packages which are broken in some way right now:
  from util-linux

> Package: locales (not found)
 This is glibc ...

> Package: mount (not found, will take mount-2.9o-1.rpm)
  from util-linux
> Package: util-linux (not found, will take util-linux-2.7-19.rpm)
  from util-linux

The util-linux stuff is tricky - I have made a debian-mips package
from it using wesolows patches - The packages are at
ftp://ftp.rfc822.org/pub/local/debian-mips/temp-packages

One could easily build these for mipsel ...

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-5201-669912
      "Write only memory - Oops. Time for my medication again ..."

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Tue, 17 Oct 2000 17:35:25 +0200

> On Tue, Oct 17, 2000 at 04:14:50AM +0200, Jan-Benedict Glaw wrote:

[Some less interesting packages]

> are i386 specific. All others might need some special

Will see what I can do;) First of all, I'll combine all the .deb's
I've currently fetched up. Btw, Geert asked for pciutils. Are there
MIPSel machines with PCI bus(ses)?

> One could easily build these for mipsel ...

Thanks. I'll try to compile it for mipsel as soon as I've got a 
working toolchain. Currently, I'm only able to x-compile kernels
on a ia32 machine...

MfG, JBG

---

From: Mike McDonald <[email-masked]>
Date: Tue, 17 Oct 2000 08:50:31 -0700

>Date:   Tue, 17 Oct 2000 17:35:25 +0200
>From: Jan-Benedict Glaw <[email-masked]>
>To: [email-masked]
>Subject: Re: base.tgz

>MIPSel machines with PCI bus(ses)?

  Yes.

  Mike McDonald
  [email-masked]

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Tue, 17 Oct 2000 18:33:49 +0200

> >MIPSel machines with PCI bus(ses)?

Heck, I've got two different ones in the lab!

            Kevin K.

---

From: Florian Lohoff <[email-masked]>
Date: Wed, 18 Oct 2000 03:30:31 +0200

> MIPSel machines with PCI bus(ses)?

RM200C i guess 

Flo

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 18 Oct 2000 04:12:36 +0200

> > MIPSel machines with PCI bus(ses)?

All SNI MIPS PCI machines can be reconfigured for both byte orders.

And of course Cobalt's ...

  Ralf

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Wed, 18 Oct 2000 22:16:03 +0200

> * Package: base-files

base-files_2.2.2_mipsel.deb provides /etc/nsswitch.conf as well
as glibc_2.0.6ml5.rpm does. Which one do you prefer to have in
a base.tgz?

--------- .rpm version, comments/blank lines removed
passwd:     files nisplus nis
shadow:     files nisplus nis
group:      files nisplus nis
hosts:      files nisplus nis dns
services:   nisplus [NOTFOUND=return] files
networks:   nisplus [NOTFOUND=return] files
protocols:  nisplus [NOTFOUND=return] files
rpc:        nisplus [NOTFOUND=return] files
ethers:     nisplus [NOTFOUND=return] files
netmasks:   nisplus [NOTFOUND=return] files     
bootparams: nisplus [NOTFOUND=return] files
netgroup:   nisplus
publickey:  nisplus
automount:  files nisplus
aliases:    files nisplus

--------- .deb version, comments/blank lines removed
passwd:         compat
group:          compat
shadow:         compat
hosts:          files dns
networks:       files
protocols:      db files
services:       db files
ethers:         db files
rpc:            db files
netgroup:       nis

Personally, I prefer to have the .deb version, but I think it's
better to ask before;) Esp the nisplus entries in RH's variant
make me to dislike is...

MfG, JBG