Subject: Glibc Problem

From: Ian Chilton <[email-masked]>
Date: Wed, 25 Oct 2000 16:06:51 +0100

Hello,

I am having this problem cross-compiling todays CVS glibc:

../sysdeps/generic/dl-cache.c: In function `_dl_load_cache_lookup':
../sysdeps/generic/dl-cache.c:177: warning: large integer implicitly truncated to unsigned type
../sysdeps/generic/dl-cache.c:181: `CACHEMAGIC_VERSION_NEW' undeclared (first use in this function)
../sysdeps/generic/dl-cache.c:181: (Each undeclared identifier is reported only once
../sysdeps/generic/dl-cache.c:181: for each function it appears in.)
make[2]: *** [/crossdev-build/mips-linux/glibc-001025-obj/elf/dl-cache.o] Error 1
make[2]: Leaving directory `/crossdev-build/src/glibc-001025/elf'
make[1]: *** [elf/subdir_lib] Error 2
make[1]: Leaving directory `/crossdev-build/src/glibc-001025'
make: *** [all] Error 2

It worked the other day  :-)

Bye for Now,

Ian

                     \|||/ 
                     (o o)
 /----------------ooO-(_)-Ooo----------------\
 |  Ian Chilton                              |
 |  E-Mail : [email-masked]              |
 \-------------------------------------------/

---

From: Keith M Wesolowski <[email-masked]>
Date: Wed, 25 Oct 2000 08:45:44 -0700

> ../sysdeps/generic/dl-cache.c:181: `CACHEMAGIC_VERSION_NEW' undeclared (first use in this function)

A simple platform-independent typo. I'm sure it'll be fixed soon. In
the meantime here's a patch.

Index: dl-cache.c
===================================================================
RCS file: /cvs/glibc/libc/sysdeps/generic/dl-cache.c,v
retrieving revision 1.25
diff -u -r1.25 dl-cache.c
--- dl-cache.c	2000/10/25 08:07:18	1.25
+++ dl-cache.c	2000/10/25 15:41:06
@@ -178,13 +178,13 @@
 
 	  cache_new = (struct cache_file_new *) ((void *) cache + offset);
 	  if (cachesize < (offset + sizeof (struct cache_file_new))
-	      || memcmp (cache_new->magic, CACHEMAGIC_VERSION_NEW,
-			 sizeof CACHEMAGIC_VERSION_NEW - 1) != 0)
+	      || memcmp (cache_new->magic, CACHEMAGIC_NEW,
+			 sizeof CACHEMAGIC_NEW - 1) != 0)
 	    cache_new = (void *) -1;
 	}
       else if (file != NULL && cachesize > sizeof *cache_new
-	       && memcmp (cache_new->magic, CACHEMAGIC_VERSION_NEW,
-			  sizeof CACHEMAGIC_VERSION_NEW - 1) == 0)
+	       && memcmp (cache_new->magic, CACHEMAGIC_NEW,
+			  sizeof CACHEMAGIC_NEW - 1) == 0)
 	{
 	  cache_new = file;
 	  cache = file;

-- 
Keith M Wesolowski			[email-masked]
University of Nevada			http://www.chem.unr.edu
Chemistry Department Systems and Network Administrator

---

From: Andreas Jaeger <[email-masked]>
Date: 25 Oct 2000 17:54:12 +0200

>>>>> Ian Chilton writes:

 > I am having this problem cross-compiling todays CVS glibc:

Better ask on the glibc list - and there'll you find a patch already.

check the archives of libc-alpha on: http://sources.redhat.com/glibc

 > It worked the other day  :-)
And will work tomorrow ;-) 

Andreas
-- 
 Andreas Jaeger
  SuSE Labs [email-masked]
   private [email-masked]
    http://www.suse.de/~aj