Subject: Atlas Board!

From: Nicu Popovici <[email-masked]>
Date: Thu, 26 Oct 2000 08:50:58 -0400

Hello ,

I want to ask few questions about an Atlas board. Who has such a board
maybe will give me some tips to have an working Linux on that machine.

1. What type of RAM do I need ?
2. I want to cross - compile the CVS linux kernel for Mips but I failed
on a i686. Could anyone tell me if I try to compile the kernel on Atlas
board I will  succeed.

Regards,
Nicu

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Thu, 26 Oct 2000 09:15:48 +0200

> maybe will give me some tips to have an working Linux on that machine.

I'm one of the guys who did the 2.2 port, so I hope I can help.

> 1. What type of RAM do I need ?

A PC100 SDRAM SIM - at least, that's what mine has.

> on a i686. Could anyone tell me if I try to compile the kernel on Atlas

I do all my builds native, either on an Indy or an Algorithmics
board (I've done it on the Atlas to prove it worked, but the other
two are faster).  What you might consider doing would be to
download a 2.2 kernel binary and the NFS installation kit
from the MIPS FTP site, bootstrap install the OS, then 
install the sources and native tools.  

See ftp://ftp.mips.com/pub/linux/mips/.  I've got a web
site at http://www.paralogos.com/mipslinux/ with pointers
to the relevant FTP directories at MIPS, and an HTML
version of the setup and installation procedure.

One word of warning.  The Atlas design uses a Philips
"super I/O" chip that has some bugs.  Specifically, the
ethernet interface is wonky under load.  It works well
enough for the boot PROM monitor (YAMON) to be
able to boot the Linux kernel from your TFTP server
completely reliably, but under serious FTP or NFS
traffic, it tends to lose interrupts/packets.  I *strongly*
recommend putting an AMD PCnet PCI card in the
Atlas' PCI slot.   The driver should already be built
into the kernel binaries on the MIPS FTP site.

            Regards,

            Kevin K.

---

From: Brady Brown <[email-masked]>
Date: Thu, 26 Oct 2000 14:34:30 -0600

> on a i686. Could anyone tell me if I try to compile the kernel on Atlas

We have linux running on several Atlas boards here. We are Cross-Compiling
the kernel successfully on an Intel machine. The cross tools we are
currently using are:
binutils-mipsel-linux-2.8.1-1
egcs-c++-mipsel-linux-1.0.3a-2
egcs-g77-mipsel-linux-1.0.3a-2
egcs-mipsel-linux-1.0.3a-2
egcs-libstdc++-mipsel-linux-2.8.0-2
egcs-objc-mipsel-linux-1.0.3a-2

These are available at
ftp://oss.sgi.com/pub/linux/mips/crossdev/i386-linux/mipsel-linux/
Note: the binutils version 2.9.5-1 gave us some problems when we tried it
so we are still using 2.8.1-1
--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Brady Brown ([email-masked])       Work:(801)619-6103
Texas Instruments: Broadband Access Group
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~