Subject: Still cannot compile the KERNEL!!!

From: Nicu Popovici <[email-masked]>
Date: Mon, 30 Oct 2000 12:21:38 -0500

Hello you all,

I have a problem. I've built a crosscompiler for MIPS on my intel
machine but until now I could not compile any mips kernel. I tried with
version from CVS site  and now I an trying with
linux-2.2.12.mips-src.01.04.tar.gz and I an running into errors from the
beggining.( are in the attached file )

I still succeded to compile a test.c file on my intel machine with my
crosscompiler and then to run the resulted file on the mips machine and
it worked.
When I tried with the g++ and with the test.cpp ( a simple class ) the
crosscompiler made a file but when I executed on the mips machine it
says
a.out error in loading shared libraries
undefined simbol : _deregister_frame_info

I hope that anyone will help me on that . I am running out of time .

Regards,
Nicu
n file included from /usr/src/atlas_linux/include/linux/timex.h:138,
                 from /usr/src/atlas_linux/include/linux/sched.h:14,
		                  from /usr/src/atlas_linux/include/linux/mm.h:4,
				                   from /usr/src/atlas_linux/include/linux/slab.h:14,
						                    from /usr/src/atlas_linux/include/linux/malloc.h:4,
								                     from /usr/src/atlas_linux/include/linux/proc_fs.h:5,
										                      from init/main.c:23:
												      /usr/src/atlas_linux/include/asm/timex.h:36: warning: implicit declaration of function `read_32bit_cp0_register'
												      /usr/src/atlas_linux/include/asm/timex.h:36: `CP0_COUNT' undeclared (first use this function)
												      /usr/src/atlas_linux/include/asm/timex.h:36: (Each undeclared identifier is reported only once
												      /usr/src/atlas_linux/include/asm/timex.h:36: for each function it appears in.)
												      make: *** [init/main.o] Error 1

---

From: Klaus Naumann <[email-masked]>
Date: Mon, 30 Oct 2000 12:45:11 +0100 (CET)

On Mon, 30 Oct 2000, Nicu Popovici wrote:

Sounds really like you have /usr/src/linux linked to your intel
kernel and not to the mips kernel - check that first.

	HTH, Klaus

-- 
Full Name   : Klaus Naumann     | (http://www.mgnet.de/) (Germany)
Nickname    : Spock             | Org.: Mad Guys Network
Phone / FAX : ++49/177/7862964  | E-Mail: ([email-masked])
PGP Key     : www.mgnet.de/keys/key_spock.txt

---

From: Florian Lohoff <[email-masked]>
Date: Mon, 30 Oct 2000 15:21:29 +0100

> undefined simbol : _deregister_frame_info

I guess you have a broken 2.07 glibc for mips lying around - Try to eliminate
that and use the 2.06 made by ralf or start with glibc 2.2
(For experienced users)

BTW: For compiling a kernel you dont need and glibc on the cross devel machine
at all.

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?

---

From: Keith M Wesolowski <[email-masked]>
Date: Mon, 30 Oct 2000 07:23:20 -0800

> undefined simbol : _deregister_frame_info

Please tell us the exact versions of the toolchain and libc you are
using. gcc -v, ld --version, and the exact libc version and any
patches you applied and where you got them. In all likelihood one or
more of these things is either a known broken version or a mismatch.
Make sure too that, regardless of what versions you have, you copy all
the libraries from the same versions onto the mips machine.

In addition, I'd recommend using current 2.2 CVS kernels unless for
some reason you know you can't. The tag is linux_2_2. Please note that
you don't need libc at all to cross-build a kernel.

-- 
Keith M Wesolowski			[email-masked]
University of Nevada			http://www.chem.unr.edu
Chemistry Department Systems and Network Administrator