Subject: r4k_dma_cache_inv_pc() does writeback

From: Jun Sun <[email-masked]>
Date: Mon, 30 Oct 2000 10:45:05 -0800

It just occur to me that r4k_dma_cache_inv_pc() actually does a
writeback before it invalidates the cache.  Is there story behind it? 
Or just a plain bug?

If it is a bug, I don't find an easy way to invalidate the whole dcache
other than writing a new function, perhaps in r4kcache.h.

Jun

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 31 Oct 2000 03:43:34 +0100

> writeback before it invalidates the cache.  Is there story behind it? 

No big story, I was simply to lazy to implement yet another function.
You could probably get some performance gains.

> other than writing a new function, perhaps in r4kcache.h.

  Ralf