Subject: ld problem

From: Ian Chilton <[email-masked]>
Date: Sat, 14 Oct 2000 01:10:56 +0100

Hello,

I am running a system with glibc 2.0.6 (-5lm), binutils 2.8.1 and egcs 1.0.3a, oh, and linux-2.2.14-mips

Everything compiled fine, including X4.0.1, except when I try to run startx, I get:

bash-2.04# startx
xinit: error in loading shared libraries
libXmu.so.6: cannot open shared object file: No such file or directory

That's when I found the ldconfig problem:

bash-2.04# /sbin/ldconfig 
Bus error

Any ideas??

Is this useful -->

bash-2.04# file /sbin/ldconfig 
/sbin/ldconfig: ELF 32-bit MSB mips-1 executable, MIPS R3000_BE, version 1, statically linked, not stripped
bash-2.04# 

Thanks!

Bye for Now,

Ian

                     \|||/ 
                     (o o)
 /----------------ooO-(_)-Ooo----------------\
 |  Ian Chilton                              |
 |  E-Mail : [email-masked]              |
 \-------------------------------------------/

---

From: Ian Chilton <[email-masked]>
Date: Sat, 14 Oct 2000 13:04:52 +0100

Hello,

> Which is probably the root of the evil - I assume at the point when it's
> crashing the new /etc/ld.so.conf file is still incomplete.  I don't have
> a theory what's causing that, sorry.

Do you think it could be something to do with the glibc-2.0.6-5lm?

or, what about ld.so?  I think I compiled v1.9.9

> Hmm...  Checkout your /etc/ld.so.conf file.  It should exist and contain
> a number of lines like:

I checked that before the origional post...ld.so.conf looks fine..

> A workaround which may try is the LD_LIBRARY_PATH variable:
>   export LD_LIBRARY_PATH=`tr '\n' ':' </etc/ld.so.conf`

Before I origionally posted, I tried doing:
export LD_LIBRARY_PATH=/usr/X11R6/bin
but this did the same thing...

I'll try the one you gave me soon

Thanks!

Bye for Now,

Ian

                     \|||/ 
                     (o o)

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 14 Oct 2000 14:13:32 +0200

> or, what about ld.so?  I think I compiled v1.9.9

That explains it.  Don't use the ld.so package at all.  glibc has it's
own dynamic linker.

  Ralf

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 14 Oct 2000 12:32:33 +0200

/usr/X11R6/lib
/usr/lib
/usr/local/lib

and probably others more.

Maybe ldconfig crashes if the file doesn't exist or contains garbage.

After this command you should be able to execute binaries as long as they
are not SUID or SGID binaries.

  Ralf

---

From: Ian Chilton <[email-masked]>
Date: Sat, 14 Oct 2000 23:55:20 +0100

Hello,

> > bash-2.04# /sbin/ldconfig 

I recompiled glibc-2.0.6-5lm, but still get the same "Bus Error" with ldconfig  :(

>   export LD_LIBRARY_PATH=`tr '\n' ':' </etc/ld.so.conf`

This worked though...I got passwd that last error with X, just hit another problem to do with X..

Bye for Now,

Ian

                     \|||/ 
                     (o o)