Subject: Re: Decstation broken Was: CVS [email-masked]: linux

From: Geert Uytterhoeven <[email-masked]>
Date: Sun, 1 Oct 2000 11:40:41 +0200 (CEST)

On Fri, 29 Sep 2000, Florian Lohoff wrote:
> tty00 at 0xbf900001 (irq = 4) is a Z85C30 SCC
> tty01 at 0xbf900009 (irq = 4) is a Z85C30 SCC
> tty02 at 0xbf980001 (irq = 4) is a Z85C30 SCC
> tty03 at 0xbf980009 (irq = 4) is a Z85C30 SCC

Shouldn't these be reported as ttyS0[0-3]?

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

---

From: Ralf Baechle <[email-masked]>
Date: Sun, 1 Oct 2000 12:27:10 +0200

> Shouldn't these be reported as ttyS0[0-3]?

Search for tty% in the serial drivers - it's actually a widespread mistake ...

  Ralf

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Mon, 2 Oct 2000 13:39:39 +0200 (MET DST)

On Fri, 29 Sep 2000, Florian Lohoff wrote:

> Sorry for the confusion - It seems i was inaccurate - I tried on
> the /260 and it works ... See attached - Ill retry the /125 in a minute.

 Good -- I was really wondering what would be wrong here -- the only
difference between the /260 and the (well-tested) /240 path is the use of
cycle counter routines and they weren't changed seriously.

  Maciej

-- 
+  Maciej W. Rozycki, Technical University of Gdansk, Poland   +
+--------------------------------------------------------------+
+        e-mail: [email-masked], PGP key available        +

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Tue, 3 Oct 2000 12:34:14 +0200 (MET DST)

> Shouldn't these be reported as ttyS0[0-3]?

 Ralf, could you please apply?  Thanks.

diff -u --recursive --new-file linux-mips-2.4.0-test7-20000829.macro/drivers/char/dz.c linux-mips-2.4.0-test7-20000829/drivers/char/dz.c
--- linux-mips-2.4.0-test7-20000829.macro/drivers/char/dz.c	Fri Jun 30 04:26:16 2000
+++ linux-mips-2.4.0-test7-20000829/drivers/char/dz.c	Mon Oct  2 22:27:38 2000
@@ -1047,7 +1047,7 @@
   }
 
   if (--info->count < 0) {
-    printk("ds_close: bad serial port count for ttys%d: %d\n",
+    printk("ds_close: bad serial port count for ttyS%02d: %d\n",
 	   info->line, info->count);
     info->count = 0;
   }
@@ -1379,7 +1379,7 @@
     if (! info->port)
       return 0;
 
-    printk("ttyS%02d at 0x%04x (irq = %d)\n", info->line, info->port, SERIAL);
+    printk("ttyS%02d at 0x%08x (irq = %d)\n", info->line, info->port, SERIAL);
   }
 
   /* reset the chip */
diff -u --recursive --new-file linux-mips-2.4.0-test7-20000829.macro/drivers/tc/zs.c linux-mips-2.4.0-test7-20000829/drivers/tc/zs.c
--- linux-mips-2.4.0-test7-20000829.macro/drivers/tc/zs.c	Fri Aug 11 04:26:34 2000
+++ linux-mips-2.4.0-test7-20000829/drivers/tc/zs.c	Mon Oct  2 22:25:15 2000
@@ -623,7 +623,7 @@
 	save_flags(flags); cli();
 
 #ifdef SERIAL_DEBUG_OPEN
-	printk("starting up ttyS%d (irq %d)...", info->line, info->irq);
+	printk("starting up ttyS%02d (irq %d)...", info->line, info->irq);
 #endif
 
 	/*
@@ -1258,7 +1258,7 @@
 	}
 	
 #ifdef SERIAL_DEBUG_OPEN
-	printk("rs_close ttys%d, count = %d\n", info->line, info->count);
+	printk("rs_close ttyS%02d, count = %d\n", info->line, info->count);
 #endif
 	if ((tty->count == 1) && (info->count != 1)) {
 		/*
@@ -1273,7 +1273,7 @@
 		info->count = 1;
 	}
 	if (--info->count < 0) {
-		printk("rs_close: bad serial port count for ttys%d: %d\n",
+		printk("rs_close: bad serial port count for ttyS%02d: %d\n",
 		       info->line, info->count);
 		info->count = 0;
 	}
@@ -1463,7 +1463,7 @@
 	retval = 0;
 	add_wait_queue(&info->open_wait, &wait);
 #ifdef SERIAL_DEBUG_OPEN
-	printk("block_til_ready before block: ttys%d, count = %d\n",
+	printk("block_til_ready before block: ttyS%02d, count = %d\n",
 	       info->line, info->count);
 #endif
 	cli();
@@ -1499,7 +1499,7 @@
 			break;
 		}
 #ifdef SERIAL_DEBUG_OPEN
-		printk("block_til_ready blocking: ttys%d, count = %d\n",
+		printk("block_til_ready blocking: ttyS%02d, count = %d\n",
 		       info->line, info->count);
 #endif
 		schedule();
@@ -1510,7 +1510,7 @@
 		info->count++;
 	info->blocked_open--;
 #ifdef SERIAL_DEBUG_OPEN
-	printk("block_til_ready after blocking: ttys%d, count = %d\n",
+	printk("block_til_ready after blocking: ttyS%02d, count = %d\n",
 	       info->line, info->count);
 #endif
 	if (retval)
@@ -1600,7 +1600,7 @@
 	info->pgrp = current->pgrp;
 
 #ifdef SERIAL_DEBUG_OPEN
-	printk("rs_open ttys%d successful...", info->line);
+	printk("rs_open ttyS%02d successful...", info->line);
 #endif
 /* tty->low_latency = 1; */
 	return 0;
@@ -1817,7 +1817,7 @@
 		info->normal_termios = serial_driver.init_termios;
 		init_waitqueue_head(&info->open_wait);
 		init_waitqueue_head(&info->close_wait);
-		printk("tty%02d at 0x%08x (irq = %d)", info->line, 
+		printk("ttyS%02d at 0x%08x (irq = %d)", info->line, 
 		       info->port, info->irq);
 		printk(" is a Z85C30 SCC\n");
 	}