Subject: delo 0.1 / Decstation Boot Loader

From: Florian Lohoff <[email-masked]>
Date: Sat, 14 Oct 2000 13:35:02 +0200

Hi,
i started to hack on a Decstation bootloader - It is currently
not booting anything but i thought of letting you know.

I put the stuff i already have at

ftp://ftp.rfc822.org/pub/local/debian-mipsel/experimental

And it is called "delo" - The Decstation Loader - It is loosly
designed like "SILO" the Sparc Loader.

I have a small application called "writeboot" which is based on
lilo and bootprep and inserts the extents to load into the
bootsector of the defined disk. This seems to work quiet well.
I succeeded to load a full kernel dumped with objcopy like this.

The second thing is the "loader" which will (when finished) use
the libe2fs to open an ext2 filesystem, load the kernel and run it.

Goal is to be able to select the kernel image to be loaded on the
prom command line like

boot 3/rz0 /boot/vmlinux root=/dev/sda5 console=ttyS2

Although i am not shure on how to select the partition/filesystem
on which to look for the kernel. Also MS-DOS Disklabel support
has to be added to be able to automatically find the partitions.
Currently i am using the first partition starting at 64 (Although
the open_ext2 currently fails :( )

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-5201-669912
      "Write only memory - Oops. Time for my medication again ..."

---

From: Florian Lohoff <[email-masked]>
Date: Sat, 14 Oct 2000 20:03:37 +0200

> designed like "SILO" the Sparc Loader.

Update

delo 0.2 is up and running

I booted Debian GNU/Linux/Mips/Decstation multiple times on
my 5000/260 - delo is now able to read an ELF kernel from
the first partition on the disk, copy the sections to the
right locations and run it at e_entry.

The TODO list is getting shorter - Biggest problem i right now
see is crashes of the resulting kernel - But only when disabling
DEBUG output - I think there are some alignment issues.

Flo

---

From: Florian Lohoff <[email-masked]>
Date: Sun, 15 Oct 2000 04:47:53 +0200

> delo 0.2 is up and running

Next update - Delo 0.5 up and running 

I added MS-Dos Partition support that Delo can load from and partition
you select - Syntax for me is

boot 3/rz0 5/boot/vmlinux root=/dev/sda5 console=ttyS2

As you might guess - 5 is the partition number as in /dev/sda5. Currently
i do have the problem that the machine locks hard as soon as the kernel
spits out the Kernel Command Line and i am unsure if this is Kernel or
Bootloader related.

KN05 V2.1k    (PC: 0xa002cab8, SP: 0x83a4dde8)
3/prcache
>>boot 3/rz0 5/boot/vmlinux root=/dev/sda5 console=ttyS2
delo V0.3
Opening ext2fs on partition 5
Loading /boot/vmlinux ................................................ok
This DECstation is a DS5000/2x0
Loading R4000 MMU routines.
CPU revision is: 00000440
Primary instruction cache 16kb, linesize 16 bytes.
Primary data cache 16kb, linesize 16 bytes.
Secondary cache sized at 1024K linesize 32 bytes.
Linux version 2.4.0-test8-pre1 ([email-masked]) (gcc version egcs-2.90.29 980515 (egcs-1.0.3 release)) #3 Fri Oct 13 16:27:07 CEST 2000
On node 0 totalpages: 16384
zone(0): 16384 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: 5/boot/vmlinux root=/dev/sda5 console=ttyS2

At this position it locks hard (No reset button pressing - Powercycle)

Flo