Subject: delo 0.7

From: Florian Lohoff <[email-masked]>
Date: Wed, 18 Oct 2000 02:45:32 +0200

Hi,
new "delo" release - It seems that i might call it "everyday use" release.

New features:

- reads /etc/delo.conf for parameters and kernel image name
- command line arguments for the bootsector installer

-----------------schnipp------------------------------------

KN05 V2.1k    (PC: 0xbfc007ac, SP: 0x82e47de8)
3/prcache
delo V0.7 Copyright 2000 Florian Lohoff <[email-masked]>
Loading /etc/delo.conf .. ok
Loading /boot/vmlinux ................... ok
This DECstation is a DS5000/2x0
Loading R4000 MMU routines.
CPU revision is: 00000440
Primary instruction cache 16kb, linesize 16 bytes.
Primary data cache 16kb, linesize 16 bytes.
Secondary cache sized at 1024K linesize 32 bytes.
Linux version 2.4.0-test8-pre1 ([email-masked]) (gcc version egcs-2.90.29 980515 (egcs-1.0.3 release)) #3 Fri Oct 13 16:27:07 CEST 2000

-----------------schnapp------------------------------------

There is a known bug i cant seem to find - Look into the readme.

I only tried on /260 so far but i guess itl work on any REX machine.
There is currentl no "NON-REX" support but someday ....

The loading is currently SLOW like hell - I guess
its because of the PROM beeing very slow. There are possibilities
to speed up - But - Who wants to boot his Decstation that often ?

Flo
-- 
Florian Lohoff		[email-masked]		      	+49-5201-669912
      "Write only memory - Oops. Time for my medication again ..."

---

From: Florian Lohoff <[email-masked]>
Date: Wed, 18 Oct 2000 03:39:40 +0200

> new "delo" release - It seems that i might call it "everyday use" release.
[...]
> There is currentl no "NON-REX" support but someday ....

Ok - I tried again on a /133 and a /120 which both worked 

So consider this a VERY usable release .... Patches always
welcome - How does the CD-Rom boot on the decstation work ?
Are they doing the same on cd-rom ?

Ahh - wait - yes - This is why the Decstation cdroms
had to support 512 byte blocking :)

Flo

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Wed, 18 Oct 2000 09:43:07 +0200

> Ok - I tried again on a /133 and a /120 which both worked 

Would you mind to build a .deb of it? I'm not yet so skilled to
build "proper" packages (keeping to learn that as well;)

I'd like to include it in my base.tgz...

MfG, JBG

-- 
Fehler eingestehen, Größe zeigen: Nehmt die Rechtschreibreform zurück!!!
/* Jan-Benedict Glaw <[email-masked]> -- +49-177-5601720 */
keyID=0x8399E1BB fingerprint=250D 3BCF 7127 0D8C A444 A961 1DBD 5E75 8399 E1BB
     "insmod vi.o and there we go..." (Alexander Viro on linux-kernel)

---

From: Florian Lohoff <[email-masked]>
Date: Wed, 18 Oct 2000 11:19:28 +0200

> I'd like to include it in my base.tgz...

Ill do that - Some things missing but it will be available this week
somewhen ...

Flo