Subject: Re: MIPS linux

From: Ian Chilton <[email-masked]>
Date: Wed, 8 Nov 2000 18:57:11 +0000

Hello,

> and noticed that you do not recommend using the hardhat distro based on

You can use it, but it is old and broken. It will get you booted into Linux, but IIRC you can not even compile a kernel  :(

I am currently putting together some base systems, which you can net-boot and/or copy to a HD. Also, will write an installation guide. Hoping to upload these after the weekend. I started with a Hardhat install, then used the Redhat 6.0 packages from ftp://oss.sgi.com/pub/linux/mips/redhat/test-6.0, but that was not an easy procedure  :)

Ralf is currently working on a Redhat 7.0 port, and Flo (lolo) has started uploading packages to debian.org

Then there is Simple Linux/MIPS, byt Keith...that is available from oss.sgi.com now...

So, there is lots in the pipeline, but not a lot to actually go on for end-users right now, more hackers :)

All the links should be on the links page at our site... (or the news page).

There are pointers to some installation guides..

In the redhat dir on oss, there is a file called instructions, which is the guide I used when I first started out...It describes setting up the network boot server etc...

As I say though, I am currently working on an installation guide for my bases (hoping to release a glibc 2.0.6/kernel 2.2.14 one and a kernel 2.4 / glibc 2.2 one, but the 2.2 is still being worked on  :)

So, i'd say, you can get in there and try some of the stuff downloadable, but if you are in no hurry, hang on for a bit, because there are developments happening...

If you are on IRC, join us on irc.openprojects.net, channel #mipslinux (I am GadgetMan), and definatly subscribe to the linux-mips mailinglist on oss.sgi.com

Hope this helps a bit!

Bye for Now,

Ian

                                \|||/ 
                                (o o)
 /---------------------------ooO-(_)-Ooo---------------------------\
 |  Ian Chilton     (IRC Nick - GadgetMan)     [email-masked]  |
 |-----------------------------------------------------------------|
 |  Web Site      -->  http://www.ichilton.co.uk                   |
 |-----------------------------------------------------------------|
 |  "Unix is user friendly - it's just picky about it's friends."  |
 \-----------------------------------------------------------------/

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Wed, 08 Nov 2000 12:03:11 -0800

> You can use it, but it is old and broken. It will get you booted into Linux, but IIRC you can not even compile a kernel  :(

Sure you can!  I've done it hundreds of times. ;-)
You can even build binutils.  But you can't
build gcc, and any application that depends
on certain subtleties of signal behavior will be 
betrayed by the discrepancy between the
HardHat glibc and the 2.2-3-4 kernels.

So I too am eagerly looking forward to 
a 6.0 or 7.0 based solution - provided that
the glibc disconnects are fixed as well.

	Kevin K.

---

From: "J. Scott Kasten" <[email-masked]>
Date: Wed, 8 Nov 2000 18:26:52 -0400

Try the simple linux stuff.  I had great success with the 0.1 release, and
some degree with the 0.2 series (the Death on a Stick releases).