Subject: Re: GCC Compile Failed

From: Ian Chilton <[email-masked]>
Date: Wed, 1 Nov 2000 22:43:04 +0000

Hello,

After this problem with GCC, I have compiled the kernel, binutils, batch etc...but now have had problems with glibc.

It has been compiling glibc for about 2 hours (I2, 200Mhz, 96Mb) so must have been nearly finished, and I get:

gcc -nostdlib -nostartfiles -o /mnt/hd2/lfstmp/glibc-001027/glibc-build/iconv/iconv_prog  -Wl,-dynamic-linker=/lib/ld.so.1   /mnt/hd2/lfstmp/glibc-001027/glibc-build/csu/crt1.o /mnt/hd2/lfstmp/glibc-001027/glibc-build/csu/crti.o `gcc --print-file-name=crtbegin.o` /mnt/hd2/lfstmp/glibc-001027/glibc-build/iconv/iconv_prog.o  -Wl,-rpath-link=/mnt/hd2/lfstmp/glibc-001027/glibc-build:/mnt/hd2/lfstmp/glibc-001027/glibc-build/math:/mnt/hd2/lfstmp/glibc-001027/glibc-build/elf:/mnt/hd2/lfstmp/glibc-001027/glibc-build/dlfcn:/mnt/hd2/lfstmp/glibc-001027/glibc-build/nss:/mnt/hd2/lfstmp/glibc-001027/glibc-build/nis:/mnt/hd2/lfstmp/glibc-001027/glibc-build/rt:/mnt/hd2/lfstmp/glibc-001027/glibc-build/resolv:/mnt/hd2/lfstmp/glibc-001027/glibc-build/crypt:/mnt/hd2/lfstmp/glibc-001027/glibc-build/linuxthreads /mnt/hd2/lfstmp/glibc-001027/glibc-build/libc.so.6 /mnt/hd2/lfstmp/glibc-001027/glibc-build/libc_nonshared.a -lgcc `gcc --print-file-name=crtend.o` /mnt/hd2/lfstmp/glibc-001027/glibc-build/csu/crtn.o
/mnt/hd2/lfstmp/glibc-001027/glibc-build/libc.so.6: undefined reference to `__pthread_initialize_minimal'
collect2: ld returned 1 exit status
make[2]: *** [/mnt/hd2/lfstmp/glibc-001027/glibc-build/iconv/iconv_prog] Error 1
make[2]: Leaving directory `/mnt/hd2/lfstmp/glibc-001027/iconv'
make[1]: *** [iconv/others] Error 2
make[1]: Leaving directory `/mnt/hd2/lfstmp/glibc-001027'
make: *** [all] Error 2

Any ideas?

Thanks!

Bye for Now,

Ian

                     \|||/ 
                     (o o)
 /----------------ooO-(_)-Ooo----------------\
 |  Ian Chilton                              |
 |  E-Mail : [email-masked]              |
 \-------------------------------------------/

---

From: Keith M Wesolowski <[email-masked]>
Date: Wed, 1 Nov 2000 16:25:56 -0800

> make[2]: *** [/mnt/hd2/lfstmp/glibc-001027/glibc-build/iconv/iconv_prog] Error 1

Asked and answered. That archaic compiler cannot be used to build
glibc 2.2 because it doesn't deal with weak symbol references
properly.

-- 
Keith M Wesolowski			[email-masked]
University of Nevada			http://www.chem.unr.edu
Chemistry Department Systems and Network Administrator

---

From: "Clarence Donath" <[email-masked]>
Date: Thu, 2 Nov 2000 07:42:35 -0500

Hello,

I've been trying to get GCC to compile on my Indy for weeks now.  I started out
with the latest version of GCC, and have stepped back to egsc-1.1.2.  Each time
I try to 'make bootstap', which takes days, I get this error:

cc ERROR parsing -W:  bad syntax for option
cc WARNING:  phase key (-)  is no longer supported
cc ERROR parsing -W:  bad phase for -W option
cc WARNING:  phase key (W)  is no longer supported
cc ERROR parsing -W:  bad phase for -W option
cc ERROR parsing -W:  unknown flag
*** Error code 2 (bu21)
*** Error code 1 (bu21)
*** Error code 1 (bu21)
*** Error code 1 (bu21)

I'm trying to compile it using CC as I don't have GCC on this machine now.  I
do not have the ability to install the freeware copy of GCC from SGI because I
do not have root privileges to install.  I've configured with a --prefix in my
own work area.

Can anyone help me out here?

Much appreciated.

Clarence Donath