Subject: RE: I'm stuck...

From: Calvine Chew <[email-masked]>
Date: Thu, 30 Nov 2000 16:32:06 +0800

Hi Klaus...

> -----Original Message-----
> From: Klaus Naumann [mailto:[email-masked]]
> Sent: Thursday, November 30, 2000 3:52 PM
> To: Calvine Chew
> Cc: [email-masked]'
> Subject: Re: I'm stuck...
> 
> On Thu, 30 Nov 2000, Calvine Chew wrote:
> 
> > Hi folks.
> 
> Hi there,
> 
>  
> > I'm trying to get Linux up on an Indy. I'm using an old 
> laptop to act as the
> > tftp/bootp/nfs server. I've installed
> > SuSE 6.4 on it and I am not sure if I've configured the 
> server properly. I
>   ^^^^-- This is your first mistake ... :)))
>   .oO(I hope Andreas doesn't read that)
>
I would have installed RedHat 6.2 (like a trueblue SGI-man :-) but
the boot kernel hits the PC Card Services hang on installation.
SuSE 6.4 doesn't, hooked up my ethernet/modem and scsi cards beautifully.
 
> > try tftp'ing and bootp'ing from the server
> > side, and both seem to respond to requests, however, when I 
> try from the
> > Indy client, the Indy just shoots back
> > a "server not found for vmlinux" when I do "boot -f 
> bootp():vmlinux".
> > 
> > How do I ensure that things on the server side are indeed configured
> > properly? Are there proper tests I can do?
> > For example, if I run "bootpd -s -d4" then run "bootptest", 
> bootpd reports
> > back a large number of things like
> > sending the linux kernel I exported via NFS, and something 
> about a magic
> > number, then bootptest quits. tftp
> > at the server side allows me to download files from the NFS 
> directory.
> > 
> > I already have numerous copies of readmes teaching me how 
> to install Linux
> > on MIPS, but somehow all of them
> > vary in many ways, especially the config parts. Is there 
> some install readme
> > for super-idiots like myself who need
> > to be told word for word what to do?
> 
> I have written a HOWTO for Linux on the Indigo2 - it's now 
> more and more
> a HOWTO for installing Linux on any SGI box ;)
> You can have a look at http://oss.sgi.com/mips/i2-howto.html
> I hope this helps a bit. ALso please don't miss the Pitfalls 
> section - 
> maybe you're hitting one of the described.
> 
When I try bootp from the Indy, my Linux bootp server doesn't
even respond. tcpdump doesn't report anything. The only things
I can confirm are working are that I can use tftp to grab files
off the exported nfsroot and I can use a program called bootptest
to send bootp requests to the bootp server. However, both are done
from the server end.

In fact if I were to configure bootptab to accept requests from the
server itself, bootptest reports this (apologies for the verbosity!!):

% bootptest
bootptest: version 2.4.3
Sending to 192.168.0.1 (request) htype:0 hlen:0 xld:706 C:192.168.0.1
vend-rfc1395
Revcd from 192.168.0.1 (reply) htype:0 hlen:0 xld:706 C:192.168.0.1
Y:192.168.0.1 S:192.168.0.1 sname:"calvine" file: "/linux/mipseb/vmlinux"
vend-rfc1395 SM:255.255.255.0 TZ:7200 ROOT:"/linux/mipseb"
%

bootpd itself (I'm running it on standalone mode) reports this:

%bootpd -s -d4
bootp: info(6): bootptab mtime: Wed Jan 11 17:054:20 1995   (excuse the
clock :-)
bootp: info(6): reading "/etc/bootptab"
bootp: info(6): read 1 entries (1 hosts) from "/etc/bootptab"
bootp: info(6): recvd pkt from IP addr 192.168.0.1
bootp: info(6): bootptab mtime: Wed Jan 11 17:054:20 1995
bootp: info(6): request from IP addr 192.168.0.1
bootp: info(6): found 192.168.0.1 (calvine.suse.sgi.com)
bootp: info(6): bootfile="/linux/mipseb/vmlinux"
bootp: info(6): vendor magic field is 99.130.83.99
bootp: info(6): sending reply (with RFC1048 options)

and my bootptab looks like this:

**** bootptab begin ****
calvine.suse.sgi.com:hd=/linux/mipseb:rp=/linux/mipseb:ht=ethernet:ha:blahbl
ah:ip=192.168.0.1:bf=vmlinux:sm=255.255.255.0:to=7200:
**** bootptab end ******

Everything seems to be in ship shape (is it?)... I'm thinking if it's a
hardware
issue. For example, this Indy of mine had a bad Dallas chip, so I swapped a
working chip from another dead Indy and placed it into the one I'm using.
Could also be a crosscable issue (it's Linux to Indy connection now), since
there just isn't any traffic going on.

Damn, this is getting really annoying. We really should be porting Irix to
IA,
instead of Linux to MIPS.

I realise that my issues are becoming more Linux than MIPS/Linux,
but honestly I can't be sure. I don't exactly have alot of resources to
do trial&error testing. I have a few years' Linux experience but never
bootp/remote booting. This mailing list was my last respite!

--
Calvine Chew, Technical Consultant
Technology & Industry Consulting Group (Asia South), SGI.
***************************************************************
Inter spem curamque, timores inter et iras, omnem crede diem tibi
diluxisse supremum: grata superveniet quae sperabitur hora.
http://www.cyberjunkie.com/arcana
***************************************************************

---

From: "J. Scott Kasten" <[email-masked]>
Date: Thu, 30 Nov 2000 13:41:25 -0500

I'm using the ISC DHCP server under RH.  I've configured it to offer bootp
to the specific hardware address of the SGI box.  here's an excerpt:

subnet 192.168.254.0 netmask 255.255.255.0 {
        server-name "minerva";
        next-server 192.168.254.1;
        option domain-name-servers 192.168.254.1;
        option routers 192.168.254.1;
        option root-path "/mnt/archives/SimpleLinux-0.1_Indy";

        host SGI {
                hardware ethernet 08:00:69:09:13:9A;
                fixed-address 192.168.254.240;
                filename "vmlinux";
        }
 }

The 192.168.254.1 host is also the tftp and nfs server.  If I recall
correctly, the tftp and nfs server must be the same host.

Good luck.

---

From: Klaus Naumann <[email-masked]>
Date: Thu, 30 Nov 2000 22:30:01 +0100 (CET)

> SuSE 6.4 doesn't, hooked up my ethernet/modem and scsi cards beautifully.

It's ok - I was just kiddin' because it's known that I'm not a big fan
of the SuSE distribution for several reasons - but I'm far away from
wanting to start a distro war here. So to make it clear I really was
joking.

[snipped verbose message]

Calvine, what I'm asking myself is, if the box actually has connection
to the net. Becuase if you don't get a single packet out on bootp time
then something really is broken. So please try to check in any way if
the box has netconn - does it have an AUI ? Some SGI systems seem
to use that as first ethernet adapter and have problems with it ...

			HTH, Klaus

-- 
Full Name   : Klaus Naumann     | (http://www.mgnet.de/) (Germany)
Nickname    : Spock             | Org.: Mad Guys Network
Phone / FAX : ++49/177/7862964  | E-Mail: ([email-masked])
PGP Key     : www.mgnet.de/keys/key_spock.txt