Subject: Re: Can you help me?

From: [email-masked]
Date: Mon, 13 Nov 2000 10:20:14 +0100 (CET)

> On Mon, Nov 13, 2000 at 10:45:17AM +0800, Zheng Baojian wrote:
> 
> >      I'm a Chinese student,i want to run linux on SGI O2 workstation.
> > I see that O2 not support linux now on your web,can you tell me the
> > reason?As series of SGI workstations,O2,Indy,Onyx ,Origin,they have
same
> > architecture,same cpu,why others support linux,O2 not support.
> 
> Harald Koerfgen and I (at least) have done some work on O2 and I can
> verify that it has at one point booted to userland (I no longer have
> the machine and thus do not know the status).  To say that an O2 has
> the same architecture as the other machines you mention, however, is
> an oversimplification at best; these machines have numerous
> differences (no two use the same bus type/controller), and afaik Onyx
> is not and never has been supported.  In fact, these machines don't

AFAIK Onyx is pretty much the same as an Origin, except for the graphics
hardware. Since Ralf is working on an Origin port, which is in quite a good
state, I guess, Onyx should be supported, too.
Without graphics, of course.

Florian

---

From: "Markus Hoff-Holtmanns" <[email-masked]>
Date: Mon, 13 Nov 2000 11:30:12 +0100

Hi folks!

There probably already were numerous threads concerning this subject, but
I'm new and I didn't find anything fitting in the archives. So here is my
question.

Anyone who did or tried a Linux port for O2, or contributed anything
regarding that topic, could you please give me that information again. At
the moment I try to gather as much info as possible in this regard, as we
have some O2s running IRIX 6.3 and gathering dust most of the time.

Any help appreciated.

Markus

--
Markus Hoff-Holtmanns
RWTH Aachen
Germany
[email-masked]

---

From: Keith M Wesolowski <[email-masked]>
Date: Mon, 13 Nov 2000 07:04:02 -0800

> Without graphics, of course.

You're confusing Onyx with Onyx2.  The Onyx2 is Origin-like and
probably works.  The Onyx is sort of a multiprocessor version of the
Crimson (or, alternately, a graphics-heavy version of a Challenge D).
There were also Power Onyxen, with R8000 CPUs; I can't remember
whether there were r10k versions.

-- 
Keith M Wesolowski			[email-masked]
University of Nevada			http://www.chem.unr.edu
Chemistry Department Systems and Network Administrator

---

From: Klaus Naumann <[email-masked]>
Date: Mon, 13 Nov 2000 19:34:20 +0100 (CET)

> have some O2s running IRIX 6.3 and gathering dust most of the time.

As far as I know only Keith M. Wesolowski and Harald Koerfgen
were trying to get Linux running and also got it to boot into 
usermode - the problem is that noone has such a machine.
So if you have a bunch of them which collect dust and want to
get rid of them this is the right place :-)

				Klaus

-- 
Full Name   : Klaus Naumann     | (http://www.mgnet.de/) (Germany)
Nickname    : Spock             | Org.: Mad Guys Network
Phone / FAX : ++49/177/7862964  | E-Mail: ([email-masked])
PGP Key     : www.mgnet.de/keys/key_spock.txt

---

From: Harald Koerfgen <[email-masked]>
Date: Tue, 14 Nov 2000 22:30:15 +0100 (CET)

> Hi folks!

Selber hi!
 
> have some O2s running IRIX 6.3 and gathering dust most of the time.

Well, I guess I should update the FAQ :)

Keith and I have been working on O2 support, but due to a chronical lack of
time on my side progress is slow.

The actual status is:

o kernel boots and detects the machine and memory size.
o serial console works
o periodic interrupts working (the poor man's CPO_COUNT/CP0_COMPARE version)
o PCI code detects the onboard Adaptec AIC-7880 SCSI host adapters
o The Adaptec driver itself crashes
o The existing cache management does not handle secondary caches tied to a R5000
CPU too well. Read: userland programs crash without evil hacks, actually.
o R10000s will _not_ work for quite a while.

For the records:

> boot bootp()/vmlinux
130768+22320+3184+341792+48560d+4604+6816 entry: 0x87fa60d0
Setting $netaddr to 192.168.0.7 (from server intel)
Obtaining /vmlinux from server intel
656824+81120+112564 entry: 0x80002584
ARCH: SGI-IP32
PROMLIB: ARC firmware Version 1 Revision 10
PROMLIB: Total free ram 122888K / 120MB.
Loading R4000 MMU routines.
CPU revision is: 00002321
Primary instruction cache 32kb, linesize 32 bytes.
Primary data cache 32kb, linesize 32 bytes.
Secondary cache sized at 128K linesize 32 bytes.
Linux version 2.4.0-test9 (harry@intel) (gcc version egcs-2.91.66 19990314
(egcs-1.1.2 release)) #1 Die Nov 14 22:14:10 CET 2000
On node 0 totalpages: 32646
zone(0): 32646 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: 
Calibrating delay loop... 359.63 BogoMIPS
Memory: 120708k/130584k available (641k kernel code, 9876k reserved, 46k data,
32k init)
Dentry-cache hash table entries: 16384 (order: 5, 131072 bytes)
Buffer-cache hash table entries: 4096 (order: 2, 16384 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 8192 (order: 4, 65536 bytes)
Checking for 'wait' instruction...  available.
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Starting kswapd v1.8
Serial driver version 5.02 (2000-08-09) with SHARE_IRQ enabled
ttyS00 at 0x0000 (irq = 14) is a 16550A
ttyS01 at 0x0000 (irq = 0) is a 16550A
Kernel panic: I have no root and I want to scream

Please note that the secondary cache size and the BogoMIPS are, well, bogus :)

-- 
Regards,
Harald