Subject: Findutils and Fileutils under Glibc 2.2

From: Ian Chilton <[email-masked]>
Date: Mon, 6 Nov 2000 21:55:04 +0000

Hello,

I am having more problems with packages that worked fine under glibc 2.2

File utils gives this error:

gcc -DLOCALEDIR=\"/usr/share/locale\" -DSHAREDIR=\"/usr/share\" -DHAVE_CONFIG_H -I.. -I. -I../lib -I../intl  -D_FILE_OFFSET_BITS=64  -g -O2 -c dircolors.c
dircolors.c:40:15: 1 arguments is not enough for macro "strndup"
make[2]: *** [dircolors.o] Error 1
make[2]: Leaving directory `/lfstmp/fileutils-4.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/lfstmp/fileutils-4.0'
make: *** [all-recursive-am] Error 2

Findutils errors, but does not exit  :(
(I only noticed because find did not exist)..

during make install, gives:

making install in find
/bin/sh: invalid character 47 in exportstr for /root
make[1]: Entering directory `/lfstmp/findutils-4.1/find'
gcc -c -DHAVE_CONFIG_H -I.. -I../lib  -g -O fstype.c
fstype.c:34:15: 1 arguments is not enough for macro "strstr"
make[1]: *** [fstype.o] Error 1
make[1]: Leaving directory `/lfstmp/findutils-4.1/find'
making install in xargs
/bin/sh: invalid character 47 in exportstr for /root
make[1]: Entering directory `/lfstmp/findutils-4.1/xargs'
gcc -c -DHAVE_CONFIG_H -I.. -I../lib  -g -O ../find/version.c
gcc -o xargs xargs.o ../find/version.o ../lib/libfind.a  -lintl
gcc: ../find/version.o: No such file or directory
make[1]: *** [xargs] Error 1
make[1]: Leaving directory `/lfstmp/findutils-4.1/xargs'
making install in locate
/bin/sh: invalid character 47 in exportstr for /root
make[1]: Entering directory `/lfstmp/findutils-4.1/locate'
gcc -c -DHAVE_CONFIG_H -I.. -I../lib -DLOCATE_DB=\"/usr/var/locatedb\"  -g -O ../find/version.c
gcc -o locate locate.o ../find/version.o ../lib/libfind.a  -lintl
gcc: ../find/version.o: No such file or directory
make[1]: *** [locate] Error 1
make[1]: Leaving directory `/lfstmp/findutils-4.1/locate'

Thanks!

Bye for Now,

Ian

                     \|||/ 
                     (o o)
 /----------------ooO-(_)-Ooo----------------\
 |  Ian Chilton                              |
 |  E-Mail : [email-masked]              |
 \-------------------------------------------/

---

From: Ian Chilton <[email-masked]>
Date: Mon, 6 Nov 2000 22:04:54 +0000

Hello,

Fixed the fileutils problem...just patch and findutils not working..

Bye for Now,

Ian

                     \|||/ 
                     (o o)