Subject: X

From: Joe Berens <[email-masked]>
Date: Thu, 16 Nov 2000 15:10:53 -0600

Hello,

I have compiled X on my Indy running linux following the directions found
at http://honk.physik.uni-konstanz.de/~agx/mipslinux/x/x.html.  When i to
startx it seems to start X but no x ever shows up.  From
/var/log/xdm-errrors:

XFree86 Version 4.0.1 / X Window System
(protocol Version 11, revision 0, vendor release 6400)
Release Date: 1 July 2000
        If the server is older than 6-12 months, or if your card is newer
        than the above date, look for a newer version before reporting
        problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.1.100 mips [ELF] 
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Nov 15 11:32:55 2000
(==) Using config file: "/etc/X11/XF86Config"
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (??) unknown.
(==) ServerLayout "simple layout"
(**) |-->Screen "Screen 1" (0)
(**) |   |-->Monitor "SGI GDM17e11"
(**) |   |-->Device "Newport Graphics"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi/" does not exist.
        Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi/" does not exist.
        Entry deleted from font path.
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/local/,/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/CID/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(--) using VT number 7

(EE) No OS PCI support available
(II) v4l driver for Video4Linux
(II) Newport: driver for Newport Graphics Card: XL
(**) Newport(0): Depth 8, (--) framebuffer bpp 8
(==) Newport(0): Default visual is PseudoColor
(==) Newport(0): Using gamma correction (1.0, 1.0, 1.0)
xdm error (pid 4268): Hung in XOpenDisplay(:0), aborting
xdm error (pid 4268): server open failed for :0, giving up
xdm error (pid 4265): Display :0 cannot be opened

Any help?

Thank you,

Joe

___________________________________

Joe Berens
SGI Customer Support Center
Operating Systems Group
Phone: 800-800-4744, Direct: 651-683-3254
Email: [email-masked]

___________________________________

---

From: Guido Guenther <[email-masked]>
Date: Fri, 17 Nov 2000 10:25:22 +0100

> startx it seems to start X but no x ever shows up.  From
[..snip..] 
> xdm error (pid 4265): Display :0 cannot be opened
I've never seen this kind of error before but the kernel you're using is
ancient, probably switching to a more recent one helps (2.2.16 and
2.4.0-test9 work fine for me). What version of glibc are you using? If
it is as old as your kernel you won't get anything to work.( I'm using
2.0.6-5lm here).
Regards,
 -- Guido