Subject: Strange messages.

From: Dan Aizenstros <[email-masked]>
Date: Thu, 23 Nov 2000 10:54:09 -0500

Hello All,

Recently I upgraded my Linux/MIPS kernel from 2.2.12 to 
2.4.0-test9 and I started getting messages like the following:

Setting flush to zero for awk.

I did not get this message when using a 2.2.12 kernel but I am
getting them with a 2.4.0-test9 kernel.

The 2.4.0-test9 kernel is based on the code from the snapshot
at oss.sgi.com in the following file,
/pub/linux/mips/mips-linux/simple/crossdev/src/linux-001027.tar.gz
with the patches from the same directory applied.

I get the message many times and for different programs during
system startup.

Has anyone seen this before?

Dan Aizenstros
Software Engineer
V3 Semiconductor Corp.

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Thu, 23 Nov 2000 17:28:06 +0100

This really deserves to be in the  FAQ.  I guess
I ought to put a version of this up an a web site
somewhere and just point people to the URL:
Either Ralf or I end up answering it about
once a month.  

This message occurs when the kernel gets an 
"unimplemented operation" trap from the FPU, 
which means that an FP instruction has been issued
that the hardware cannot handle on its own.  Usually
this is a conversion of an extreme value or an operation 
on a denormalized value. What the OS is supposed 
to do in this case is to deal with the situation, by killing
the process, fixing up the values, or emulating
the instruction in software.

Setting flush-denormal-to-zero mode of the FPU
and replaying the instruction to see if that helps
is a slightly shady (in my opinion) hack that Ralf put in 
as part of a tiny, minimal emulator that handled these 
exceptions in some versions of MIPS Linux.  MIPS later
integrated a full IEEE FPU emulator from Algorithmics
into the 2.2.12 kernel, but it hasn't yet gone into
the 2.3/2.4 repository.

So long as all you got was that message, and
awk didn't subsequently dump core, you're probably
OK.  Just don't do any serious numerical programming
on the system until the full IEEE support goes in!

            Kevin K.

---

From: Ian Chilton <[email-masked]>
Date: Thu, 23 Nov 2000 17:28:20 +0000

Hello,

> Has anyone seen this before?

I get this with sshd from OpenSSH....I get lots of them on the
console...not just at boot time. And, it happens with 2.2.14, not just
2.4test9....

Bye for Now,

Ian

                                \|||/
                                (o o)
 /---------------------------ooO-(_)-Ooo---------------------------\
 |  Ian Chilton        (IRC Nick - GadgetMan)     ICQ #: 16007717  |
 |-----------------------------------------------------------------|
 |  E-Mail: [email-masked]     Web: http://www.ichilton.co.uk  |
 |-----------------------------------------------------------------|
 |        Proofread carefully to see if you any words out.         |
 \-----------------------------------------------------------------/