Subject: Multiple copies of pci-dma.c file.

From: Dan Aizenstros <[email-masked]>
Date: Wed, 22 Nov 2000 09:30:32 -0500

Hello All,

Is there any reason for having multiple copies of
the pci-dma.c file in Linux/MIPS.  The are all
doing basically the same thing.  We could have
just one copy in the arch/mips/lib directory
and have the Makefile build it if CONFIG_PCI
is defined.

Also they appear to have an error in that they
convert the pointer that is returned from the
__get_free_pages function call into a KSEG1
address even if the pointer is NULL.

Dan Aizenstros
Software Engineer
V3 Semiconductor Corp.

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 22 Nov 2000 16:56:53 +0100

> and have the Makefile build it if CONFIG_PCI

Sounds like a plan, done.  Tell me if it breaks something ...

Some chipsets have a builtin scatter / gather facility, those may need
special variants of pci-dma.c for better support.

> address even if the pointer is NULL.

Fixed.

  Ralf

---

From: Dan Aizenstros <[email-masked]>
Date: Thu, 23 Nov 2000 17:04:27 -0500

Hello Ralf,

Should the dma_cache_inv actually be a dma_cache_wback_inv?

Also, the sni directory contains a dma.c which is they same
as pci-dma.c and should be removed.

Dan Aizenstros
Software Engineer
V3 Semicondutor Corp.

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 24 Nov 2000 02:35:45 +0100

> Should the dma_cache_inv actually be a dma_cache_wback_inv?

Conceptually your right and I've therefore changed the kernel.  It wasn't
a bug though because the actual implementation was in both cases
actually doing a dma_cache_wback_inv.

> Also, the sni directory contains a dma.c which is they same as pci-dma.c
> and should be removed.

``He's dead, Jim''.

  Ralf