Subject: MIPS config.in NET configuration

From: Steve Johnson <[email-masked]>
Date: Thu, 16 Nov 2000 18:15:51 -0700

Hi,

    I'm trying to add support for a Galileo Tech. EV64120A board,
building on Pete Popov's work that's already in CVS.  I'm having trouble
with the "Network device support" menu when I "make xconfig".

    If I select "Galileo EV96100 Evaluation board" on the "Machine
selection" menu, I can't select PPP support in the "Network device
support" menu because the IP22/Decstation/Baget code in
arch/mips/config.in eclipses the normal net menu's CONFIG_PPP.  Is there
a reasonable way to resolve two different environments needing the same
variable defined?

    The same problem exists for CONFIG_SERIAL, which is defined by the
Decstation and doesn't let me use the normal character device 16550 UART
menu item.

    Please note that this is only a problem for "make xconfig".  "make
menuconfig" works correctly and selects one set of responses for network
devices based on the machine selection.  Is that the solution, that
everyone in MIPS uses "make menuconfig"?

if [ "$CONFIG_NET" = "y" ]; then
   mainmenu_option next_comment
   comment 'Network device support'

   bool 'Network device support' CONFIG_NETDEVICES
   if [ "$CONFIG_NETDEVICES" = "y" ]; then

      if [ "$CONFIG_SGI_IP22" != "y" -a \
          "$CONFIG_DECSTATION" != "y" -a \
    "$CONFIG_BAGET_MIPS" != "y" ]; then

  source drivers/net/Config.in

  if [ "$CONFIG_ATM" = "y" ]; then
     source drivers/atm/Config.in
  fi
      else
  tristate 'Dummy net driver support' CONFIG_DUMMY
  tristate 'SLIP (serial line) support' CONFIG_SLIP
  if [ "$CONFIG_SLIP" != "n" ]; then
     bool ' CSLIP compressed headers' CONFIG_SLIP_COMPRESSED
     bool ' Keepalive and linefill' CONFIG_SLIP_SMART
  fi
  tristate 'PPP (point-to-point) support' CONFIG_PPP
  if [ ! "$CONFIG_PPP" = "n" ]; then
     comment 'CCP compressors for PPP are only built as modules.'
  fi
         if [ "$CONFIG_SGI_IP22" = "y" ]; then
     bool 'SGI Seeq ethernet controller support' CONFIG_SGISEEQ
  fi
  if [ "$CONFIG_DECSTATION" = "y" ]; then
     bool 'DEC LANCE ethernet controller support' CONFIG_DECLANCE
  fi
  if [ "$CONFIG_BAGET_MIPS" = "y" ]; then
     tristate 'Baget AMD LANCE support' CONFIG_BAGETLANCE
  fi
      fi
   fi
   endmenu
fi

    Steve

---

From: Pete Popov <[email-masked]>
Date: Thu, 16 Nov 2000 17:46:52 -0800

Hi Steve,

>with the "Network device support" menu when I "make xconfig".

xconfig was broken for me the last time I did some powerpc work as
well.  If you want to be really safe, use "make config".

>everyone in MIPS uses "make menuconfig"?

BTW, I hope that by the end of next week, I'll be able to send Ralf the
latest patches for the ev96100. It's running pretty well now with the
scache enabled, but I found 96100 misconfiguration problems in the sdram
decoders/subdecoders. The DEC tulip (with one small patch), serial.c
(small patch again) also run fine, as well as the 96100 internal
10/100Mbps controllers.

-- 
Pete Popov
MontaVista Software, Inc
[email-masked]