Subject: Cannot type on DECstation prom

From: Martin Michlmayr <[email-masked]>
Date: Thu, 14 Dec 2000 11:54:51 -0600

I recently got a DECstation 5000/125 and I'm trying to get Linux to run.
I'm using minicom and while I get output from the machine, I can not
type anything on the prom.  When I power the machine on, I get:

KN02-BA V5.7e
?TFL: #0 PMAGB-BA PATT: 5:  Red screen Test
3/misc/kbd
?STF (4: Ln#0 Kbd self test)

3/misc/mouse
?STF (4: Ln#1 Pntr self test)

When I type anything, nothing happens at all.  When I press the
reset button (or whatever it's called), the machine boots NetBSD:

V5.7e    (PC: 0xbfc00cbc, SP: 0xa000feb4)
>> NetBSD/pmax Secondary Boot, Revision 1.0
>> (root@vlad, Sat Mar  4 14:34:30 EST 2000)
Boot: 3/rz2/netbsd

The funny thing is that I _can_ type when NetBSD is being started.  But
nothing happens on the prom.

What can I do?

FWIW, dmesg on NetBSD says:

DECstation 5000/125 (3MIN)
real mem  = 33554432
avail mem = 27136000
using 819 buffers containing 3354624 bytes of memory
mainbus0 (root)
cpu0 at mainbus0: cpu0: MIPS R3000 CPU Rev. 3.0 with MIPS R3010 FPC Rev. 3.0

-- 
Martin Michlmayr
[email-masked]

---

From: Karel van Houten <[email-masked]>
Date: Thu, 14 Dec 2000 19:30:12 +0100 (MET)

> .....

These DECStations require full modem control signals on the
prom console. I would build a D25 serial modem-faker cable:

 1 ------------------- 1

 2 -------\ /--------- 2
           X
 3 -------/ \--------- 3

 4 -+               +- 4
    |               |
 5 -+               +- 5

 6 -+               +- 6
    |               |
 7 -)---------------)- 7
    |               |
 8 -+               +- 8
    |               |
20 -+               +- 20

This should work.

-- 
Karel van Houten

----------------------------------------------------------
The box said "Requires Windows 95 or better."
I can't understand why it won't work on my Linux computer. 
----------------------------------------------------------

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Thu, 14 Dec 2000 19:44:50 +0100 (MET)

> type anything on the prom.  When I power the machine on, I get:

 Due to historic reasons (DEC 6-pin MMJ connectors) DECstation firmware
only use DTR/DSR hw handshaking on their serial consoles.  You may either
change the wiring (not recommended), use XON/XOFF handshaking or disable
handhaking altogether when talking to the firmware.

-- 
+  Maciej W. Rozycki, Technical University of Gdansk, Poland   +
+--------------------------------------------------------------+
+        e-mail: [email-masked], PGP key available        +

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Thu, 14 Dec 2000 19:49:38 +0100 (MET)

> prom console. I would build a D25 serial modem-faker cable:

 It would work for firmware, but it would break for RTS/CTS hanshaking
(the standard one these days).  At 9600bps you may well live with it, but
for anything faster you'll likely lose characters.