Subject: sgialib.h

From: Guido Guenther <[email-masked]>
Date: Wed, 10 Jan 2001 00:43:05 +0100

Building of latest cvs kernel for IP22 fails for me in 
arch/mips/arc/init.c and arch/mips/kernel/setup.c 
due to a typemismatch in the declaration of prom_init in the above 
mentioned files and sgialib.h. The attached patch fixes this.
 -- Guido
--- include/asm-mips/sgialib.h.orig	Wed Jan 10 00:24:13 2001
+++ include/asm-mips/sgialib.h	Wed Jan 10 00:26:55 2001
@@ -20,7 +20,7 @@
  * Init the PROM library and it's internal data structures.  Called
  * at boot time from head.S before start_kernel is invoked.
  */
-extern int prom_init(int argc, char **argv, char **envp, int *prom_vec);
+extern void prom_init(int argc, char **argv, char **envp, int *prom_vec);
 
 /* Simple char-by-char console I/O. */
 extern void prom_putchar(char c);

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 9 Jan 2001 22:21:42 -0200

> mentioned files and sgialib.h. The attached patch fixes this.

Thanks, applied.

  Ralf