Subject: Re: patches for dvhtool

From: Florian Lohoff <[email-masked]>
Date: Wed, 17 Jan 2001 15:49:37 +0100

On Sun, Oct 15, 2000 at 02:15:23AM +0200, Guido Guenther wrote:
> Hi,
> with the following two patches (first against dvhtool, second against
> current cvs kernel) it's possible to boot the Indy from a local harddisk
> without the need of IRIX to install it in the volume header. Set 
> setenv OSLoader linux 
> and 
> setenv OSLoadPartition /dev/sd(whatever)
> in the boot-prom and do a: 
> dvhtool -d /dev/sda(whatever) --unix-to-vh (your_favorite_ecoff_kernel) linux

I just retried to put the stuff into the volume header wich worked:

I set this in the prom:

OSLoadFilename=vmlinux
OSLoadPartition=/dev/sda1
OSLoader=vmlinux
SystemPartition=scsi(1)disk(4)rdisk(0)partition(0)

when now typing "boot" i get

Unable to load scsi(1)disk(4)rdisk(0)partition(0)/vmlinux: no recognizable
file system on device.

Whereas this is correct - scsi(1) is the extern SCSI Bus on the Indigo2
and disk(4) is therefor /dev/sde

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?

---

From: Guido Guenther <[email-masked]>
Date: Wed, 17 Jan 2001 16:27:18 +0100

> SystemPartition=scsi(1)disk(4)rdisk(0)partition(0)
No need to set OSLoadFilename, OSLoader should be sufficient. Could you
try to use SystemPartition=...partition(8)? Since this is the partition
number of the volume header AFAIR.
 -- Guido

---

From: Florian Lohoff <[email-masked]>
Date: Wed, 17 Jan 2001 16:51:52 +0100

>> setenv SystemPartition scsi(1)disk(4)rdisk(0)partition(8)
>> boot
1212416+135264+143084 entry: 0x880025a8                                        

Thats it - Now silence as the serial console will not be detected
automagically or at least not very reliable.

Flo

---

From: Guido Guenther <[email-masked]>
Date: Wed, 17 Jan 2001 17:06:03 +0100

On Wed, Jan 17, 2001 at 04:51:52PM +0100, Florian Lohoff wrote:
[..snip..] 
> 1212416+135264+143084 entry: 0x880025a8                                        
Good. Will add that to the howto then.
 -- Guido

---

From: Florian Lohoff <[email-masked]>
Date: Wed, 17 Jan 2001 17:31:53 +0100

> Good. Will add that to the howto then.

BTW: Is there any way of deleteing/renaming files in the
volume-header-directory ? Is there a way to set "bootfile" ?

Flo

---

From: Guido Guenther <[email-masked]>
Date: Wed, 17 Jan 2001 17:49:51 +0100

> volume-header-directory ? Is there a way to set "bootfile" ?
Not yet. Only thing you can do is replace files by giving them the same
name as an already existent entry in the volume header. This always
bothered me too. Maybe someone wants to fix that on a 'rainy sunday':)
 -- Guido

---

From: Guido Guenther <[email-masked]>
Date: Sun, 21 Jan 2001 00:44:44 +0100

> > dvhtool -d /dev/sda(whatever) --unix-to-vh (your_favorite_ecoff_kernel) linux

I just noticed that the kernel patch is slightly broken, it fails when
you specify additional boot parameters. Fixed one is at:
    http://honk.physik.uni-konstanz.de/linux-mips/indy-boot/linux-2001-01-20.diff