Subject: MIPS platform recommendations

From: John Van Horne <[email-masked]>
Date: Wed, 24 Jan 2001 11:23:00 -0800

Hello,

Can anyone recommend an R5000/R7000 machine
which can run Linux 2.4 and would be an appropriate
platform on which to build the libraries for an R5000/R7000
embedded Linux application? Which platform has the
most stable version of Linux 2.4 available?

Thanks in advance,
-John Van Horne
[email-masked]

---

From: Pete Popov <[email-masked]>
Date: Wed, 24 Jan 2001 12:30:08 -0800

> John Van Horne wrote:

The EV96100 (PMC RM7000 cpu) might do the job. It's overall stable and
runs with primary and secondary caches turned on.  I merged a network
fix yesterday so I need to do a new kernel release and uploaded it to
ftp.mvista.com. The previous kernel with the network bug is on the ftp
site already.

However, if you're only interested in rebuilding libraries for those
cpus, why not do a cross-build?  We cross build all userland apps
including the libraries.  

Pete

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 24 Jan 2001 16:17:00 -0800

> most stable version of Linux 2.4 available?

I'm doing all this work on a SGI's Origin 200/2000 series machines.  They
may be a tad on the expensive side but they're the only thing that avoids
the major pain of having to modify large amounts of software for propper
crosscompilation and also has serious compute power.

  Ralf

---

From: Pete Popov <[email-masked]>
Date: Wed, 24 Jan 2001 17:13:38 -0800

> crosscompilation and also has serious compute power.

Yes, that's a pain in the neck. But we already have the entire cross
environment built and available at ftp.mvista.com for both, little and
big endian. The only issue is that test10 and beyond require a slighly
newer tools, but those are coming up as well.  

Pete

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Fri, 26 Jan 2001 10:47:13 +0100

MIPS platform recommendationsPersonally, I use an Algorithmics P-5064 board
with an R5260 CPU for this sort of thing.  It's an
ATX board that I've got bolted into a cheapo
generic ATX enclosure on my lab network. They
also have an RM7000 CPU module available.
I'm running the MIPS 2.2.x port on it, however,
not 2.4.  See www.algor.co.uk for info on the
board.

            Kevin K.
  ----- Original Message ----- 
  From: John Van Horne 
  To: [email-masked]' 
  Cc: Paul Lambert 
  Sent: Wednesday, January 24, 2001 8:23 PM
  Subject: MIPS platform recommendations

  Hello, 

  Thanks in advance, 
  -John Van Horne 
  [email-masked]

---

From: Mike McDonald <[email-masked]>
Date: Sat, 27 Jan 2001 14:48:46 -0800

>From: "Kevin D. Kissell" <[email-masked]>
>To: "John Van Horne" <[email-masked]>, <[email-masked]>
>Subject: Re: MIPS platform recommendations
>Date:   Fri, 26 Jan 2001 10:47:13 +0100
>
>This is a multi-part message in MIME format.
>
>------=_NextPart_000_00C7_01C08785.57A97F60
>Content-Type: text/plain;
>	charset="iso-8859-1"
>Content-Transfer-Encoding: quoted-printable
>
>MIPS platform recommendationsPersonally, I use an Algorithmics P-5064 =
>board

  At (US) $3900 a copy, you have deeper pockets than I do. MUCH
deeper! (http://www.algor.co.uk/algor/info/p5064-benefits.html)

  Mike McDonald
  [email-masked]