Subject: Kernel Report - 010117 (2.4.0)

From: Ian Chilton <[email-masked]>
Date: Wed, 17 Jan 2001 12:56:03 +0000

Hello,

OK..this is the normal kernel straight from CVS (010117) on my I2 (not
Indy as in yesturday..)

It seems a lot of things are repeated for some reason ?!?

Also, lolo was right...it doesn't shut down..

>> bootp():/vmlinux root=/dev/sda3 console=ttyS0
Obtaining /vmlinux from server slinky
ARCH: SGI-IP22
PROMLIB: ARC firmware Version 1 Revision 10
CPU: MIPS-R4400 FPU<MIPS-R4400FPC> ICACHE DCACHE SCACHE
Loading R4000 MMU routines.
CPU revision is: 00000460
Primary instruction cache 16kb, linesize 16 bytes.
Primary data cache 16kb, linesize 16 bytes.
Secondary cache sized at 1024K linesize 128 bytes.
Linux version 2.4.0 (ian@slinky) (gcc version 2.95.3 19991030
(prerelease)) #2 1
MC: SGI memory controller Revision 3
Determined physical RAM map:
 memory: 00001000 @ 00000000 (reserved)
 memory: 00001000 @ 00001000 (reserved)
 memory: 001d6000 @ 08002000 (reserved)
 memory: 00568000 @ 081d8000 (usable)
 memory: 000c0000 @ 08740000 (ROM data)
 memory: 05800000 @ 08800000 (usable)
On node 0 totalpages: 57344
zone(0): 57344 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/sda3 console=ttyS0
Calibrating system timer... 1000000 [200.00 MHz CPU]
zs0: console input
Console: ttyS0 (Zilog8530)
ARCH: SGI-IP22
PROMLIB: ARC firmware Version 1 Revision 10
CPU: MIPS-R4400 FPU<MIPS-R4400FPC> ICACHE DCACHE SCACHE
Loading R4000 MMU routines.
CPU revision is: 00000460
Primary instruction cache 16kb, linesize 16 bytes.
Primary data cache 16kb, linesize 16 bytes.
Secondary cache sized at 1024K linesize 128 bytes.
Linux version 2.4.0 (ian@slinky) (gcc version 2.95.3 19991030
(prerelease)) #2 1
MC: SGI memory controller Revision 3
Determined physical RAM map:
 memory: 00001000 @ 00000000 (reserved)
 memory: 00001000 @ 00001000 (reserved)
 memory: 001d6000 @ 08002000 (reserved)
 memory: 00568000 @ 081d8000 (usable)
 memory: 000c0000 @ 08740000 (ROM data)
 memory: 05800000 @ 08800000 (usable)
On node 0 totalpages: 57344
zone(0): 57344 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/sda3 console=ttyS0
Calibrating system timer... 1000000 [200.00 MHz CPU]
zs0: console input
Console: ttyS0 (Zilog8530)
Calibrating delay loop... Calibrating delay loop... 99.94 BogoMIPS
99.94 BogoMIPS
Memory: 91792k/95648k available (1560k kernel code, 3856k reserved, 88k
data, 7)
Memory: 91792k/95648k available (1560k kernel code, 3856k reserved, 88k
data, 7)
Dentry-cache hash table entries: 32768 (order: 6, 262144 bytes)
Dentry-cache hash table entries: 32768 (order: 6, 262144 bytes)
Buffer-cache hash table entries: 16384 (order: 4, 65536 bytes)
Buffer-cache hash table entries: 16384 (order: 4, 65536 bytes)
Page-cache hash table entries: 65536 (order: 6, 262144 bytes)
Page-cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 16384 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 5, 131072 bytes)
Checking for 'wait' instruction... Checking for 'wait' instruction...
unavaila.
 unavailable.
POSIX conformance testing by UNIFIX
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Based upon Swansea University Computer Society NET3.039
Starting kswapd v1.8
Starting kswapd v1.8
initialize_kbd: Keyboard failed self test
initialize_kbd: Keyboard failed self test
Keyboard timed out[1]
Keyboard timed out[1]
pty: 256 Unix98 ptys configured
pty: 256 Unix98 ptys configured
keyboard: Timeout - AT keyboard not present?
keyboard: Timeout - AT keyboard not present?
keyboard: Timeout - AT keyboard not present?
keyboard: Timeout - AT keyboard not present?
DS1286 Real Time Clock Driver v1.0
DS1286 Real Time Clock Driver v1.0
streamable misc devices registered (keyb:150, gfx:148)
streamable misc devices registered (keyb:150, gfx:148)
sgiseeq.c: David S. Miller ([email-masked])
sgiseeq.c: David S. Miller ([email-masked])
eth0: SGI Seeq8003 eth0: SGI Seeq8003 08:08:00:00:69:69:08:08:9d:9d:ec
ec

SCSI subsystem driver Revision: 1.00
SCSI subsystem driver Revision: 1.00
wd33c93-0: chip=WD33c93B/13 no_sync=0xff no_dma=0wd33c93-0:
chip=WD33c93B/13 no0
 debug_flags=0x00
           setup_args=           setup_args=,,,,,,,,,,,,,,,,,,

           Version 1.25 - 09/Jul/1997, Compiled Jan 17 2001 at 11:41:43
           Version 1.25 - 09/Jul/1997, Compiled Jan 17 2001 at 11:41:43
wd33c93-1: chip=WD33c93B/13 no_sync=0xff no_dma=0wd33c93-1:
chip=WD33c93B/13 no0
 debug_flags=0x00
           setup_args=           setup_args=,,,,,,,,,,,,,,,,,,

           Version 1.25 - 09/Jul/1997, Compiled Jan 17 2001 at 11:41:43
           Version 1.25 - 09/Jul/1997, Compiled Jan 17 2001 at 11:41:43
scsi0 : SGI WD93
scsi0 : SGI WD93
scsi1 : SGI WD93
scsi1 : SGI WD93
 sending SDTR  sending SDTR
0101030301013f3f0c0csync_xfer=2csync_xfer=2c  VendoA

  Type:   Direct-Access       Type:   Direct-Access
ANSI S2

Detected scsi disk sda at scsi0, channel 0, id 4, lun 0
Detected scsi disk sda at scsi0, channel 0, id 4, lun 0
SCSI device sda: 4226725 512-byte hdwr sectors (2164 MB)
SCSI device sda: 4226725 512-byte hdwr sectors (2164 MB)
Partition check:
Partition check:
 sda: sda: sda1 sda1 sda2 sda2 sda3 sda3 sda4 sda4 sda5 sda5 sda6 sda6

SGI Zilog8530 serial driver version 1.00
SGI Zilog8530 serial driver version 1.00
tty00 at 0xbfbd9830 (irq = 21)tty00 at 0xbfbd9830 (irq = 21) is a
Zilog8530
 is a Zilog8530
tty01 at 0xbfbd9838 (irq = 21)tty01 at 0xbfbd9838 (irq = 21) is a
Zilog8530
 is a Zilog8530
NET4: Linux TCP/IP 1.0 for NET4.0
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: IP Protocols: ICMP, ICMP, UDP, UDP, TCP
TCP
IP: routing cache hash table of 2048 buckets, 16Kbytes
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 16384)
TCP: Hash tables configured (established 16384 bind 16384)
Sending BOOTP requests...Sending BOOTP requests..... OK
 OK
IP-Config: Got BOOTP answer from 192.168.0.11, IP-Config: Got BOOTP
answer from3
my address is 192.168.0.13
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
VFS: Mounted root (ext2 filesystem) readonly.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing prom memory: 768kb freed
Freeing prom memory: 768kb freed
Freeing unused kernel memory: 72k freed
Freeing unused kernel memory: 72k freed
INIT: version 2.78 booting
Bringing up the loopback interface...[  OK  ]
Setting up hostname...[  OK  ]
[SNIP]

root:~# cat /proc/cpuinfo
cpu                     : MIPS
cpu model               : R4000SC V6.0
system type             : SGI Indigo2
BogoMIPS                : 0.00
byteorder               : big endian
unaligned accesses      : 0
wait instruction        : no
microsecond timers      : yes
extra interrupt vector  : no
hardware watchpoint     : yes
VCED exceptions         : not available
VCEI exceptions         : not available
root:~# cat /proc/iomem
00000000-00000fff : reserved
00001000-00001fff : reserved
08002000-081d7fff : reserved
  08002000-08188297 : Kernel code
  0819c300-081b23bf : Kernel data
081d8000-0873ffff : System RAM
08740000-087fffff : System RAM
08800000-0dffffff : System RAM
root:~# uname -a
Linux dale 2.4.0 #2 Wed Jan 17 11:40:09 GMT 2001 mips unknown
root:~# free -m
             total       used       free     shared    buffers
cached
Mem:            89         34         54          0         26
5
-/+ buffers/cache:          2         86
Swap:            0          0          0
root:~#

On reboot, I get *LOTS* of rubbish coming down the serial console.

About to try the DEBUG thing now...

Bye for Now,

Ian

                                \|||/ 
                                (o o)
 /---------------------------ooO-(_)-Ooo---------------------------\
 |  Ian Chilton        (IRC Nick - GadgetMan)     ICQ #: 16007717  |
 |-----------------------------------------------------------------|
 |  E-Mail: [email-masked]     Web: http://www.ichilton.co.uk  |
 |-----------------------------------------------------------------|
 |         Budget: A method for going broke methodically.          |
 \-----------------------------------------------------------------/

---

From: Ian Chilton <[email-masked]>
Date: Wed, 17 Jan 2001 13:13:48 +0000

Hello,

ARCS MEMORY DESCRIPTOR dump:
[0,a8748674]: base<00000000> pages<00000001> type<Exception Block>
[1,a8748690]: base<00000001> pages<00000001> type<ARCS Romvec Page>
[2,a8748658]: base<00008002> pages<000001d6> type<Standlong Program
Pages>
[3,a8748aa0]: base<000081d8> pages<00000568> type<Generic Free RAM>
[4,a8748a70]: base<00008740> pages<000000c0> type<ARCS Temp Storage
Area>
[5,a8748a54]: base<00008800> pages<00005800> type<Generic Free RAM>
(prerelease)) #3 1
(prerelease)) #3 1

Bye for Now,

Ian

                                \|||/
                                (o o)
 |        Proofread carefully to see if you any words out.         |

---

From: Geert Uytterhoeven <[email-masked]>
Date: Wed, 17 Jan 2001 14:17:33 +0100 (MET)

> It seems a lot of things are repeated for some reason ?!?

That's because printk() now uses the prom print routine as well. So you see
  - all early messages (before console init)
  - repeat of all early messages when the console is initialized
  - two copies of each message (after console init)

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven ------------- Sony Software Development Center Europe (SDCE)
[email-masked] ------------------- Sint-Stevens-Woluwestraat 55
Voice +32-2-7248626 Fax +32-2-7262686 ---------------- B-1130 Brussels, Belgium

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Wed, 17 Jan 2001 15:15:23 +0100 (MET)

>  memory: 05800000 @ 08800000 (usable)
[...]
> Freeing prom memory: 768kb freed

 Good -- I was worrying if the code is able to free areas mared as "ROM
data". 

> 08800000-0dffffff : System RAM

 It looks consistent with what was reported previously -- good. 

 Thanks for the report.  From your other report I see the system works
with debugging code enabled as well.  It's consistent with last Florian's,
too.  Therefore I'm considering the previous Florian's failure report an
accident. 

 I have no idea why swap doesn't work -- I'm actually running NFS-rooted
and unless I twiddle with the NBD thingy, I will not be able to test swap
anytime soon.

 The double output looks like a problem with printk.  Ralf, I recall you
made a few changes related to printk on SGI recently -- could you please
look into it?

  Maciej

-- 
+  Maciej W. Rozycki, Technical University of Gdansk, Poland   +
+--------------------------------------------------------------+
+        e-mail: [email-masked], PGP key available        +

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 17 Jan 2001 13:45:22 -0200

> made a few changes related to printk on SGI recently -- could you please

Yes, it's fairly obvious which change is causing it.  It's less obvious
why it happens.  I use the same strategy for the Momentum Ocelot CP7000
and Origin systems and don't get double output.  Will look into it.

  Ralf