Subject: R[45]KC PRiD fields?

From: Justin Carlson <[email-masked]>
Date: Fri, 19 Jan 2001 10:11:23 -0800

Does anyone happen to know what the R4Kc anc R5KC use for the company ID of the
PrID register (bits 23-16)?  I'm assuming it's 1, which is reserved for MTI,
but bits 15-8 seem to be carefully chosen not to conflict with previous
processors in the non-MIPS32/MIPS64 PRiD space. 

I'm trying to not break detection of those processors in cpu_probe()...

-Justin

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Fri, 19 Jan 2001 23:39:09 +0100

> processors in the non-MIPS32/MIPS64 PRiD space.

The MIPS 4KC has a PrID of 0x000180xx
The MIPS 5KC has a PrID of 0x000181xx

            Kevin K.