Subject: Re: glibc 2.2 on MIPS

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 1 Feb 2001 10:27:45 +0100 (MET)

On Thu, 4 Jan 2001, Maciej W. Rozycki wrote:
>  For binutils 2.10.1 the following fix makes binaries be built as ld.so
> expects.  Other fixes might be needed for 2.10.1 to work at all -- they
> are all available from: 
> ftp://ftp.ds2.pg.gda.pl/pub/macro/SRPMS/binutils-2.10.1-3.src.rpm (or use
> a mirror at: ftp://ftp.rfc822.org/pub/mirror/ftp.ds2.pg.gda.pl/...).

I tried to compile mipsel-binutils using the sources/patches in
mipsel-linux-binutils-2.10.1-3.src.rpm and got the following result:

| gcc -DHAVE_CONFIG_H -I. -I. -I. -D_GNU_SOURCE -I. -I. -I./../include
| -I./../intl -I../intl -g -O2 -W -Wall -c section.c -o section.o
| section.c:571: warning: initialization makes integer from pointer without a cast
| section.c:571: warning: initialization from incompatible pointer type
| section.c:571: warning: initialization from incompatible pointer type
| section.c:571: warning: excess elements in struct initializer
| section.c:571: warning: (near initialization for `bfd_com_section')
| section.c:572: warning: initialization makes integer from pointer without a cast
| section.c:572: warning: initialization from incompatible pointer type
| section.c:572: warning: initialization from incompatible pointer type
| section.c:572: warning: excess elements in struct initializer
| section.c:572: warning: (near initialization for `bfd_und_section')
| section.c:573: warning: initialization makes integer from pointer without a cast
| section.c:573: warning: initialization from incompatible pointer type
| section.c:573: warning: initialization from incompatible pointer type
| section.c:573: warning: excess elements in struct initializer
| section.c:573: warning: (near initialization for `bfd_abs_section')
| section.c:574: warning: initialization makes integer from pointer without a cast
| section.c:574: warning: initialization from incompatible pointer type
| section.c:574: warning: initialization from incompatible pointer type
| section.c:574: warning: excess elements in struct initializer
| section.c:574: warning: (near initialization for `bfd_ind_section')
| section.c: In function `bfd_make_section_anyway':
| section.c:712: structure has no member named `kept_section'
| make[3]: *** [section.lo] Error 1
| make[3]: Leaving directory `/usr/people/geert.nba/mipsel-linux-binutils-2.10.1-3/binutils-2.10.1/bfd'

Should we try mipsel-linux-binutils-2.10.91-1.src.rpm instead?

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven ------------- Sony Software Development Center Europe (SDCE)
[email-masked] ------------------- Sint-Stevens-Woluwestraat 55
Voice +32-2-7248626 Fax +32-2-7262686 ---------------- B-1130 Brussels, Belgium

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Thu, 1 Feb 2001 13:38:24 +0100 (MET)

> mipsel-linux-binutils-2.10.1-3.src.rpm and got the following result:
[...]
> | make[3]: Leaving directory `/usr/people/geert.nba/mipsel-linux-binutils-2.10.1-3/binutils-2.10.1/bfd'

 Did you run `make -C bfd headers' after `./configure'?  It llok like you
didn't.

> Should we try mipsel-linux-binutils-2.10.91-1.src.rpm instead?

 It should not matter apart from this one is newer. 

-- 
+  Maciej W. Rozycki, Technical University of Gdansk, Poland   +
+--------------------------------------------------------------+
+        e-mail: [email-masked], PGP key available        +

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 1 Feb 2001 16:15:08 +0100 (MET)

>  Did you run `make -C bfd headers' after `./configure'?  It llok like you

Thanks! (BTW, this is the first time ever that I made a cross-compiler and had
to type `make -C bfd headers')

Now it aborts later at:

| /bin/sh ./genscripts.sh . /usr/local/lib sparc-sun-solaris2.6 mipsel-unknown-linux-gnu mipsel-linux "elf32lsmip" "/usr/ccs/lib" elf32lsmip "mipsel-linux"
| ./genscripts.sh: ./emulparams/mipsel-linux.sh: not found
| make[3]: *** [eelf32lsmip.c] Error 1
| make[3]: Leaving directory `/usr/people/geert.nba/mipsel-linux-binutils-2.10.1-3/binutils-2.10.1/ld'

ld/emulparams/ doesn't seem to contain any mipsel-related files.

Gr{oetje,eeting}s,

						Geert

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Thu, 1 Feb 2001 16:30:48 +0100 (MET)

> ld/emulparams/ doesn't seem to contain any mipsel-related files.

 Now you didn't run automake in bfd. ;-)  You need to run it in ld as
well.  How about looking at the included spec file?

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 1 Feb 2001 16:48:09 +0100 (MET)

>  Now you didn't run automake in bfd. ;-)  You need to run it in ld as

Thanks!

> well.  How about looking at the included spec file? 

Sorry, I didn't realize you had anything to do besides applying the patches,
configure and make (like I did last time).

Gr{oetje,eeting}s,

						Geert