Subject: bi-endian toolchain switches

From: Jim Freeman <[email-masked]>
Date: Wed, 14 Feb 2001 14:20:24 -0700

For bi-endian cross-compiler toolchains, something akin to the following
patch can be helpful for setting endianness switches according to
CONFIG_CPU_LITTLE_ENDIAN :

	--- linux/arch/mips/Makefile	2001/02/14 21:04:31	1.1
	+++ linux/arch/mips/Makefile	2001/02/14 21:07:00
	@@ -18,9 +18,13 @@
	 ifdef CONFIG_CPU_LITTLE_ENDIAN
	 tool-prefix	= mipsel-linux-
	 output-format	= elf32-littlemips
	+export LD		= $(CROSS_COMPILE)ld -EL
	+export CC		= $(CROSS_COMPILE)cc -EL
	 else
	 tool-prefix	= mips-linux-
	 output-format	= elf32-bigmips
	+export LD		= $(CROSS_COMPILE)ld -EB
	+export CC		= $(CROSS_COMPILE)cc -EB
	 endif
	 
	 ifdef CONFIG_CROSSCOMPILE

---

From: Ralf Baechle <[email-masked]>
Date: Sun, 18 Feb 2001 20:51:19 -0600

> CONFIG_CPU_LITTLE_ENDIAN :

We don't do this because -EB and -EL options don't affect the default
SEARCH_DIR statements in the default linker scripts yet we have to get
ld searching these directories without additional options.  In other words
multilib support is less than perfect ...

  Ralf