Subject: RE: Recommended toolchain

From: Phil Thompson <[email-masked]>
Date: Wed, 21 Mar 2001 14:00:22 -0000

So, going back to the original question, what are the recommended versions -
particularly if you are building 2.4.x kernels?

Are the recomendations in the HOWTO out of date? I had to patch va-mips.h
from the egcs RPM and more fixes seem to be needed before I get a kernel
that compiles.

Thanks,
Phil

-----Original Message-----
From: Ralf Baechle [mailto:[email-masked]]
Sent: 20 March 2001 20:37
To: Karel van Houten
Cc: [email-masked]; [email-masked]
Subject: Re: Recommended toolchain

On Tue, Mar 20, 2001 at 09:12:02PM +0100, Karel van Houten wrote:

> You wrote:
> > Recently I've been working with various version mixes of the gnu tool
> > chain for a mipsel-linux target and settled on a patchy binutils
> > 2.8.1/egcs 1.1.2/glibc 2.0.6 setup. However this lacks the functionality
> > that I would get from a newer toolchain for use with the linux 2.4
> > kernel. As a result, I was wondering if someone could recommend the
> > latest "stable"/recommended toolchain for a mipsel-linux target.
> 
> Well, I'm currently using:
> binutils 2.10.1
> gcc 2.95.3 (with Maciej's patches)
> glibc 2.2.2 (compiled with above toolchain).
> 
> This toolchain works for native compiles on my mipsel box.
> One drawback: I can't compile any kernels with this setup,
> For kernel compiles I use 2.8.1/egcs-2.90.27/glibc-2.0.6.

You MUST use minimum egcs-2.91.66 (1.1.2); older compilers WILL misscompile
kernels.

  Ralf

---

From: Erik Mullinix <[email-masked]>
Date: Wed, 21 Mar 2001 07:11:46 -0500

What Error's are you getting?
Hesp

---

From: Keith M Wesolowski <[email-masked]>
Date: Wed, 21 Mar 2001 08:06:47 -0800

> particularly if you are building 2.4.x kernels?

I don't really know that there is one.  I am using the gcc 3.0 branch
and binutils from CVS (2.11.90).  You can find the same toolchain
that's building my kernels on
ftp://oss.sgi.com/pub/linux/mips/mips-linux/simple/crossdev at all
times, including patches.  No binaries, source and patches only.

This linker has a bug in it regarding section placement, but the
current cvs kernel has a workaround for it.

-- 
Keith M Wesolowski <[email-masked]> http://foobazco.org/~wesolows
------(( Project Foobazco Coordinator and Network Administrator ))------
"I should have crushed his marketing-addled skull with a fucking bat."