Subject: RE: Recommended toolchain

From: Phil Thompson <[email-masked]>
Date: Thu, 22 Mar 2001 09:39:11 -0000

Correct - I am using the standard 2.4.2 sources. I had (obviously
incorrectly) assumed that the standard sources would be up to date and not
"some months" out of date.

How are the differences in the two trees managed? At what point are the
latest non-MIPS changes applied to the MIPS tree? At what point are the MIPS
specific changes applied to the standard tree?

Thanks,
Phil

-----Original Message-----
From: Geert Uytterhoeven [mailto:[email-masked]]
Sent: 22 March 2001 07:50
To: Phil Thompson
Cc: 'Erik Mullinix'; [email-masked]
Subject: RE: Recommended toolchain

On Wed, 21 Mar 2001, Phil Thompson wrote:
> I had to patch va-mips.h to #include <asm/sgidefs.h> rather than
> <sgidefs.h>.
> 
> The current errors are:
> 
> - warnings about struct flock64 not being declared (it's defined in
> asm-mips64/fcntl.h but not asm-mips/fcntl.h)
> 
> - compilation stops because loops_per_sec is undeclared as far as
> asm-mips/delay.h is concerned (although it seems fine in
> asm-mips64/delay.h).
> 
> This seems to imply that the mips architecture (as opposed to mips64)
isn't
> being maintained. Is this the case? Should I be using mips64 - but what
> would be the point on an embedded CPU?

You're definitely not using the Linux/MIPS CVS tree, since these things were
fixed there some months ago.

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven ------------- Sony Software Development Center Europe
(SDCE)
[email-masked] ------------------- Sint-Stevens-Woluwestraat
55
Voice +32-2-7248626 Fax +32-2-7262686 ---------------- B-1130 Brussels,
Belgium

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 22 Mar 2001 10:43:05 +0100 (MET)

> "some months" out of date.

:-)

> latest non-MIPS changes applied to the MIPS tree? At what point are the MIPS

When Ralf finds some time?

> specific changes applied to the standard tree?

When Ralf finds some time and Linus is in a good mood?

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven ------------- Sony Software Development Center Europe (SDCE)
[email-masked] ------------------- Sint-Stevens-Woluwestraat 55
Voice +32-2-7248626 Fax +32-2-7262686 ---------------- B-1130 Brussels, Belgium

---

From: <[email-masked]>
Date: Thu, 22 Mar 2001 12:55:45 -0500 (EST)

http://mail-index.netbsd.org/port-sgimips/2000/06/29/0006.html
I was forwarded this link by a very helpfull fellow working on the Netbsd
mips port.
	Nick