Subject: Re: Embedded MIPS/Linux Needs

From: Justin Carlson <[email-masked]>
Date: Thu, 22 Mar 2001 11:02:20 -0800

On Thu, 22 Mar 2001, you wrote:

> I have a question for those of you who are doing
> Linux work for *new* platforms (as opposed to the
> SGI/DEC legacy box support people).  IF, and I
> emphasize the word *if*, MIPS Technologies were
> make a bigger investment in MIPS/Linux technology,
> be it kernel enhancements, cross/native tools,
> userland ports, libraries, or whatever, what would
> be your prioritized "wish list"?

1)  n64 support in the full current gnu toolchain 
2)  n64 support in the full current gnu toolchain. 
3)  n64...

I, of course, hold no biases whatsoever.  ;)

-Justin

---

From: <[email-masked]>
Date: Thu, 22 Mar 2001 14:03:43 -0500 (EST)

I'd like to modify a couple of those requests...
1) Working 64bit support in the current gnu toolchain
.
.
.

<Grin>
	Nick
(It sorta produces useable code... usually..... on tuesdays... if it's a
blue moon)

---

From: Keith M Wesolowski <[email-masked]>
Date: Thu, 22 Mar 2001 11:22:29 -0800

> (It sorta produces useable code... usually..... on tuesdays... if it's a

gcc 3.0 for mips64 requires hacks to even accept the arguments the
kernel compile wants to give, and even then it reliably produces
extremely incorrect code.  For example:

int i = 0;
prom_printf ("%d", i);

Might yield something like

-14777223

- basically, anything but 0.  The code that causes this is horribly
wrong that it wasn't even worth looking at.  There are all sorts of
similar, related, and dissimilar problems.

On the other hand, the same compiler for mips (not 64) reliably
produces working 2.4 kernels...

-- 
Keith M Wesolowski <[email-masked]> http://foobazco.org/~wesolows
------(( Project Foobazco Coordinator and Network Administrator ))------
"I should have crushed his marketing-addled skull with a fucking bat."