Subject: loop stuff

From: Florian Lohoff <[email-masked]>
Date: Tue, 27 Mar 2001 20:02:19 +0200

Hi,
does anyone know if the 2.4.2 kernel does support loop devices - I mean
in the sense of - "It works" - I do have problems with processes like
mke2fs getting hung while accessing the loop without any error message.

I am not running 2.4.x on any other platform so i cant verify ...

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?

---

From: Justin Carlson <[email-masked]>
Date: Tue, 27 Mar 2001 10:06:46 -0800

> I am not running 2.4.x on any other platform so i cant verify ...

This probably isn't a MIPS specific problem.  It's supposed to be fixed by some
of Jens Axboe's latest stuff, as well as in the 2.4.2ac series on kernel.org;
I'd guess it will be fixed when 2.4.3 is released and imported to
[email-masked].

-Justin

---

From: [email-masked] (Jamie Fifield)
Date: Tue, 27 Mar 2001 14:21:16 -0400

I think Jens' latest loop patches made it into 2.4.3-pre3 (or pre4).

Anyway, they're working fine for me on my IA32 workstation.

jamie:~$ uname -a
Linux jamie 2.4.3-pre8 #1 Mon Mar 26 11:37:58 AST 2001 i686 unknown

-- 
Jamie Fifield

Software Designer		[email-masked]
AMIRIX Systems Inc.		http://www.amirix.com/
Embedded Debian Project		http://www.emdebian.org/
77 Chain Lake Drive		902-450-1700 x247 (Phone)
Halifax, N.S. B3S 1E1		902-450-1704 (FAX)

---

From: David Jez <[email-masked]>
Date: Wed, 28 Mar 2001 17:57:09 +0200

> Hi,
  Hi Flo,

> I am not running 2.4.x on any other platform so i cant verify ...
  Unfortunately this isn't a problem with MIPS platform but whole kernel.
Loopback is broken. You can use mke2fs -o loop <file> instead /dev/loop0,
because loop device will goes to hell.
-- 
-------------------------------------------------------
  David "Dave" Jez                Brno, CZ, Europe
 E-mail: [email-masked]
PGP key: finger [email-masked]
---------=[ ~EOF ]=------------------------------------