Subject: RE: Recommended toolchain

From: Phil Thompson <[email-masked]>
Date: Wed, 21 Mar 2001 18:46:07 -0000

I had to patch va-mips.h to #include <asm/sgidefs.h> rather than
<sgidefs.h>.

The current errors are:

- warnings about struct flock64 not being declared (it's defined in
asm-mips64/fcntl.h but not asm-mips/fcntl.h)

- compilation stops because loops_per_sec is undeclared as far as
asm-mips/delay.h is concerned (although it seems fine in
asm-mips64/delay.h).

This seems to imply that the mips architecture (as opposed to mips64) isn't
being maintained. Is this the case? Should I be using mips64 - but what
would be the point on an embedded CPU?

Thanks,
Phil

-----Original Message-----
From: Erik Mullinix [mailto:[email-masked]]
Sent: 21 March 2001 12:12
To: Phil Thompson; [email-masked]
Subject: Re: Recommended toolchain

What Error's are you getting?
Hesp
----- Original Message -----
From: "Phil Thompson" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, March 21, 2001 9:00 AM
Subject: RE: Recommended toolchain

> So, going back to the original question, what are the recommended
versions -
> particularly if you are building 2.4.x kernels?
>
> Are the recomendations in the HOWTO out of date? I had to patch va-mips.h
> from the egcs RPM and more fixes seem to be needed before I get a kernel
> that compiles.
>
> Thanks,
> Phil
>
> -----Original Message-----
> From: Ralf Baechle [mailto:[email-masked]]
> Sent: 20 March 2001 20:37
> To: Karel van Houten
> Cc: [email-masked]; [email-masked]
> Subject: Re: Recommended toolchain
>
>
> On Tue, Mar 20, 2001 at 09:12:02PM +0100, Karel van Houten wrote:
>
> > You wrote:
> > > Recently I've been working with various version mixes of the gnu tool
> > > chain for a mipsel-linux target and settled on a patchy binutils
> > > 2.8.1/egcs 1.1.2/glibc 2.0.6 setup. However this lacks the
functionality
> > > that I would get from a newer toolchain for use with the linux 2.4
> > > kernel. As a result, I was wondering if someone could recommend the
> > > latest "stable"/recommended toolchain for a mipsel-linux target.
> >
> > Well, I'm currently using:
> > binutils 2.10.1
> > gcc 2.95.3 (with Maciej's patches)
> > glibc 2.2.2 (compiled with above toolchain).
> >
> > This toolchain works for native compiles on my mipsel box.
> > One drawback: I can't compile any kernels with this setup,
> > For kernel compiles I use 2.8.1/egcs-2.90.27/glibc-2.0.6.
>
> You MUST use minimum egcs-2.91.66 (1.1.2); older compilers WILL
misscompile
> kernels.
>   Ralf

---

From: Keith M Wesolowski <[email-masked]>
Date: Wed, 21 Mar 2001 14:06:16 -0800

> would be the point on an embedded CPU?

mips(32) is in fact being actively maintained.  It sounds like your
kernel sources may be out of date; I specifically remember removing
all references to loops_per_sec in favour of loops_per_jiffy in both
mips and mips64.

Ask again about fcntl.h after updating...

-- 
Keith M Wesolowski <[email-masked]> http://foobazco.org/~wesolows
------(( Project Foobazco Coordinator and Network Administrator ))------
"I should have crushed his marketing-addled skull with a fucking bat."

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 22 Mar 2001 08:49:31 +0100 (MET)

> would be the point on an embedded CPU?

You're definitely not using the Linux/MIPS CVS tree, since these things were
fixed there some months ago.

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven ------------- Sony Software Development Center Europe (SDCE)
[email-masked] ------------------- Sint-Stevens-Woluwestraat 55
Voice +32-2-7248626 Fax +32-2-7262686 ---------------- B-1130 Brussels, Belgium