Subject: Re: redhat 7.0

From: Carsten Langgaard <[email-masked]>
Date: Wed, 07 Mar 2001 10:06:14 +0100

Hi Pete

Did you managed to get through the installation of the RedHat 7.0 packages ?
I would like to do something similar.

/Carsten

Pete Popov wrote:

> Ralf Baechle wrote:
> >
> > On Tue, Feb 20, 2001 at 07:49:04AM +0100, David Jez wrote:
> >
> > > > Has anyone tried installing 7.0 that's on oss.sgi.com?  The problem I'm
> > > > running into is that after I netboot and mount simple-0.2b as the root
> > > > fs, and install the rpm-4.0 tarball, rpm doesn't work with the
> > > > libraries, or lack of, of that root fs.  It looks like I need an fs with
> > > > a working rpm-4.0, so that I can mount my second disk somewhere and
> > > > install the 7.0 packages.  Any suggestions?
> > > Yes,
> > > If you download rpm-3.0 (I'm not sure, try get newer version) you'll should
> > > be able to work with rpm 4 packages.
> >
> > Oss has a tarball with statically linked rpm 4 binaries.  Use that to
> > convert your rpm database and then install the rpm 4 rpm package for real.
>
> I tried that; "rpm --rebuilddb" failed because it couldn't find some
> library.  I'll try again.
>
> Pete

--
_    _ ____  ___   Carsten Langgaard   Mailto:[email-masked]
|\  /|||___)(___   MIPS Denmark        Direct: +45 4486 5527
| \/ |||    ____)  Lautrupvang 4B      Switch: +45 4486 5555
  TECHNOLOGIES     2750 Ballerup       Fax...: +45 4486 5556
                   Denmark             http://www.mips.com

---

From: [email-masked]
Date: Wed, 07 Mar 2001 05:01:07 -0800

> I would like to do something similar.

I haven't had time to try again. I tried the debian 2_2 tar ball, went
through the partitioning and dvhtool exersize and managed to setup all
of that.  If I try RedHat 7.0 again and manage to install it before
someone else does, I'll send instructions. 

Pete

---

From: Carsten Langgaard <[email-masked]>
Date: Thu, 08 Mar 2001 12:13:25 +0100

Please Ralf, could you help me here.
I did the same as Pete describe below, and I got the same result.

When I tried "rpm --rebuilddb" it fails because it couldn't find some libraries.
The rpm-tarball contains a statically linked rpm binary, but rpmdb is dynamically
linked, could you please provide me with a statically linked rpmdb binary, that would
be great.

/Carsten

---

From: David Jez <[email-masked]>
Date: Fri, 9 Mar 2001 19:55:05 +0100

Hi Carsten,

try this:

  1. install package rpm-3.0.5 from last rh-6.2 updates
  2. then install package rpm-4.0.4
  this may will be OK, because rpm-3.0.5 know rpm-4 packages format.

Try read this, but I'm afraid you will not understand:
http://www.linux.cz/lists/archive/linux/101281.html

good luck
Dave

-- 
-------------------------------------------------------
  David "Dave" Jez                Brno, CZ, Europe
 E-mail: [email-masked]
PGP key: finger [email-masked]
---------=[ ~EOF ]=------------------------------------