Subject: Tip build error

From: Brady Brown <[email-masked]>
Date: Thu, 29 Mar 2001 13:44:52 -0700

I pulled the CVS tip yesterday and had problems building it for ATLAS because of
the changes to the set_cp0_config arguments. Patch below to
arch/mips/mm/mips32.c of how I fixed this. I think this is the intended new use?

--- mips32.c.orig       Thu Mar 29 13:29:29 2001
+++ mips32.c    Thu Mar 29 13:34:36 2001
@@ -1051,10 +1051,11 @@

        printk("CPU revision is: %08x\n", read_32bit_cp0_register(CP0_PRID));

+       clear_cp0_config(CONF_CM_CMASK);
 #ifdef CONFIG_MIPS_UNCACHED
-       set_cp0_config(CONF_CM_CMASK, CONF_CM_UNCACHED);
+       set_cp0_config(CONF_CM_UNCACHED);
 #else
-       set_cp0_config(CONF_CM_CMASK, CONF_CM_CACHABLE_NONCOHERENT);
+       set_cp0_config(CONF_CM_CACHABLE_NONCOHERENT);
 #endif

        probe_icache(config);

--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Brady Brown ([email-masked])       Work:(801)619-6103
Texas Instruments: Broadband Access Group
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 31 Mar 2001 03:12:17 +0200

On Thu, Mar 29, 2001 at 01:44:52PM -0700, Brady Brown wrote:

> I pulled the CVS tip yesterday and had problems building it for ATLAS
> because of the changes to the set_cp0_config arguments. Patch below to

No, set_cp0_status only sets bits, clear_cp0_status clears bits,
change_cp0_status is the old set_cp0_status function.

I fixed this in CVS.

  Ralf