Subject: glibc 2.2.2 include problems

From: Florian Lohoff <[email-masked]>
Date: Tue, 10 Apr 2001 15:14:49 +0200

Hi,
i am seeing problems on the glibc 2.2.2 headers - Anyone sees the same ?

gcc -c -DLOCALEDIR=\"/usr/share/locale\" -DGNULOCALEDIR=\"/usr/share/locale\" -DLOCALE_ALIAS_PATH=\"/usr/share/locale:.\" -DHAVE_CONFIG_H -I.. -I. -I../intl -I../lib -DNSL_FORK -O2 -DLINUX -D_GNU_SOURCE   loadmsgcat.c
In file included from /usr/include/fcntl.h:37,
                 from loadmsgcat.c:22:
/usr/include/sys/stat.h:352: redefinition of `stat'
/usr/include/sys/stat.h:345: `stat' previously defined here

This is while compiling lynx - The lines in the header are these:

/usr/include/sys/stat.h
    340 #if defined __GNUC__ && __GNUC__ >= 2
    341 /* Inlined versions of the real stat and mknod functions.  */
    342
    343 extern __inline__ int stat (__const char *__path,
    344                             struct stat *__statbuf) __THROW
    345 { 
    346   return __xstat (_STAT_VER, __path, __statbuf);
    347 }
    348
    349 # if defined __USE_BSD || defined __USE_XOPEN_EXTENDED
    350 extern __inline__ int lstat (__const char *__path,
    351                              struct stat *__statbuf) __THROW
    352 { 
    353   return __lxstat (_STAT_VER, __path, __statbuf);
    354 }
    355 # endif

I dont really see the problem.

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Tue, 10 Apr 2001 16:08:25 +0200 (MET DST)

> This is while compiling lynx - The lines in the header are these:
[...]
> I dont really see the problem.

 Replace "-c" with "-E -dD" in the above gcc invocation and check if lynx
doesn't do anything weird (such as defining lstat to stat or so).

-- 
+  Maciej W. Rozycki, Technical University of Gdansk, Poland   +
+--------------------------------------------------------------+
+        e-mail: [email-masked], PGP key available        +