Subject: Re: Recommended toolchain

From: "Houten K.H.C. van (Karel)" <[email-masked]>
Date: Sun, 01 Apr 2001 16:39:34 +0200

"Maciej W. Rozycki" writes:
> So I guess there may be something wrong with the R4k code generation in
>gcc 2.95.2(3) (or possibly binutils, but the latter is quite unlikely).  I
>can't run-time test R4k code but I may see if I can review the generated
>binary of startup code up to the first line output for any
>inconsistencies.  Don't hold your breath, though... 

I've now done a native compile of a CVS checkout from Friday, and
it does compile. It even boots, up until:

esp0: target 1 [period 248ns offset 15 4.03MHz synchronous SCSI]
sr0: scsi-1 drive
Uniform CD-ROM driver Revision: 3.12
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 16384)
Unhandled kernel unaligned access in unaligned.c:emulate_load_store_insn, line 372:
$0 : 00000000 10010c00 8017fed0 00000000
$4 : 801fe33c 80200000 813de000 802db000
$8 : 10010c01 8019af20 00000000 00000000
$12: 00000000 fffff000 fffffff7 802db060
$16: 00000000 813de000 00000001 00000000
$20: 00000005 801cbe34 801eb070 801eb1ac
$24: 00000000 0000000a
$28: 8022e000 8022fe88 00000000 80066cc0
epc   : 8017ff08
Status: 10010c03
Cause : 00002010
Process swapper (pid: 1, stackpage=8022e000)

etc.
I have not yet found the time to look further into that...

---

From: Florian Lohoff <[email-masked]>
Date: Sun, 1 Apr 2001 20:54:32 +0200

> I have not yet found the time to look further into that...

Guido did that last weekend and discovered that this is a toolchain
problem which disappears when compiling with gcc 3.0

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?