Subject: Indy and the multiple disk problem

From: Karel van Houten <[email-masked]>
Date: Wed, 18 Apr 2001 18:21:27 +0200 (MET DST)

Hi All

I've made some observations concerning the indy multiple disk problem:

The setup:
Root FS on /dev/sda1, /local on /dev/sdb3, and some NFS mounted systems.
Kernel 2.4.2 (March 30 CVS).

Doing this:
I mke2fs-ed the sdb3 partition, mounted it at /local, and copied
a tree from an NFS filesystem to /local. No other activity on the system.
I used tar | (cd;tar) for the copy.

What happened:
I tried to 'su' in another window on the machine, and it responded
with a segfault. Several other programs reacted with segfaults or
bus errors. 

I stopped the copy, synced, and fsck-ed (-n) the local partitions.
No problems on the /local partition, but the root was badly corrupted.
Hey! That's strange, I didn't do anything on that partition!
Could it be that there is some bug in the buffer layer, that is
corrupting the buffers belonging to another FS?

Any hints?

I hope that I get the system up again tomorrow when I get to the office :(

-- 
Karel van Houten

----------------------------------------------------------
The box said "Requires Windows 95 or better."
I can't understand why it won't work on my Linux computer. 
----------------------------------------------------------

---

From: Klaus Naumann <[email-masked]>
Date: Wed, 18 Apr 2001 19:41:28 +0200 (CEST)

> Hey! That's strange, I didn't do anything on that partition!

You did. At the time when you opened your other terminal and
typed su you were reading and writing to the partition.
I have observed this behaviour too.
So in fact you're still hitting the same problem - but
it's very aggressive on your side.

		Bye, Klaus

-- 
Full Name   : Klaus Naumann     | (http://www.mgnet.de/) (Germany)
Nickname    : Spock             | Org.: Mad Guys Network
Phone / FAX : ++49/177/7862964  | E-Mail: ([email-masked])
PGP Key     : www.mgnet.de/keys/key_spock.txt

---

From: Florian Lohoff <[email-masked]>
Date: Wed, 18 Apr 2001 20:19:56 +0200

> I hope that I get the system up again tomorrow when I get to the office :(

The problem is read not write from my investigations. I posted a patch
to this list a coupld of days ago which gives a printk if we stop
the dma although it is still running. This is the normal behaviour
on the Amiga as the DMA engine will not stop running until we stop
it. On the Indy/Indigo2 with the HPC the DMA stops when no data is
coming so this is definitly a BUG() case. I have no clue why
this only happens on I/O load.

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?