Subject: Re: CVS [email-masked]: linux

From: Ralf Baechle <[email-masked]>
Date: Wed, 11 Apr 2001 09:35:56 +0200

On Tue, Apr 10, 2001 at 03:42:48PM -0700, Kanoj Sarcar wrote:

> CVSROOT:	/home/pub/cvs
> Module name:	linux
> Changes by:	[email-masked]	01/04/10 15:42:47
> 
> Modified files:
> 	drivers/char   : serial.c 
> 
> Log message:
> 	Fix the IP27 serial driver after the 2.4.3 merge. This is what you
> 	need in /etc/inittab: "7:2345:respawn:/sbin/getty ttyS0 DT9600".
> 	mingetty can also probably be made to work.

Mingetty starts ok but it's impossible to enter something.  This is caused
by CREAD being cleared on the tty.  I don't know why this happens; it
started in 2.4.3.

  Ralf

---

From: Kanoj Sarcar <[email-masked]>
Date: Wed, 11 Apr 2001 11:00:15 -0700 (PDT)

> by CREAD being cleared on the tty.  I don't know why this happens; it

receive_chars() was updated to look at ignore_mask ... if CREAD is not
set, around the time of opening via ioctls etc, it will not take inputs.
I haven't figured the details out, but I believe it is more of a *getty
config issue than anything else. 

Kanoj

---

From: Quinn Jensen <[email-masked]>
Date: Mon, 16 Apr 2001 11:43:44 -0600

> config issue than anything else. 

Same thing happens when I bring up 2.4.3 straight
to a shell w/out any getty, as well.

Quinn

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 17 Apr 2001 14:12:05 -0300

> to a shell w/out any getty, as well.

Known problem on other architectures also.

  Ralf