Subject: Obvious patch for mips64

From: Keith M Wesolowski <[email-masked]>
Date: Sat, 28 Apr 2001 17:46:34 -0700

I need the following trivial patch to build 64-bit binaries with gas.

Index: tc-mips.c
===================================================================
RCS file: /cvs/src/src/gas/config/tc-mips.c,v
retrieving revision 1.39
diff -u -r1.39 tc-mips.c
--- gas/config/tc-mips.c	2001/04/08 05:09:21	1.39
+++ gas/config/tc-mips.c	2001/04/29 00:38:34
@@ -9140,7 +9140,9 @@
 	list = bfd_target_list ();
 	for (l = list; *l != NULL; l++)
 	  if (strcmp (*l, "elf64-bigmips") == 0
-	      || strcmp (*l, "elf64-littlemips") == 0)
+	      || strcmp (*l, "elf64-littlemips") == 0
+	      || strcmp (*l, "elf64-tradbigmips") == 0
+	      || strcmp (*l, "elf64-tradlittlemips") == 0)
 	    break;
 	if (*l == NULL)
 	  as_fatal (_("No compiled in support for 64 bit object file format"));

-- 
Keith M Wesolowski <[email-masked]> http://foobazco.org/~wesolows
------(( Project Foobazco Coordinator and Network Administrator ))------
	"Nothing motivates a man more than to see his boss put
	 in an honest day's work." -- The fortune file

---

From: "H . J . Lu" <[email-masked]>
Date: Sun, 29 Apr 2001 11:00:41 -0700

> I need the following trivial patch to build 64-bit binaries with gas.

I checked it in. Please provide ChangeLog entry next time. 

BTW, please test it on MIPS to make sure nothing is broken.

Thanks.

H.J.