Subject: Insmod messages and modules space

From: Shay Deloya <[email-masked]>
Date: Mon, 9 Apr 2001 20:10:16 +0200

Hi All,

1.Should text segment of module after insmod be in KSEG2 or KUSEG ? 
I've notices that the module address after insmod are c0... instead of 80...
Is it insmod Bug  ?
2. I keep getting in insmod of busybox pkg , "relocation overflow" message 
especially on printk symbols , when I debug the code, changing some function 
declaration from static int func () to int func()  , makes the module to 
insert correctly , anyone ?

Thanks,
-- 
Shay Deloya
______________________________________
Software Developer
Jungo - R&D
email: [email-masked]
web: http://www.jungo.com
Phone: 1-877-514-0537(USA)  +972-9-8859365(Worldwide) ext. 221
Fax:   1-877-514-0538(USA)  +972-9-8859366(Worldwide)

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 9 Apr 2001 21:14:47 +0200

> I've notices that the module address after insmod are c0... instead of 80...

It's a sign of insmod working properly :)

> insert correctly , anyone ?

Two possibilities, either you're using a too old and broken version of
modutils or you used inapropriate options to compile your module.

  Ralf

---

From: Ian Soanes <[email-masked]>
Date: Tue, 10 Apr 2001 09:55:16 +0100

> modutils or you used inapropriate options to compile your module.

Compiling with -mlong-calls worked for me when I had the same problem
(modutils 2.4.5). Relinking the module with 'ld -r -o new_mod.o
orig_mod.o' was useful too ...it worked around some 'exceeds
local_symtab_size' messages.

Ian

---

From: Keith Owens <[email-masked]>
Date: Tue, 24 Apr 2001 08:57:55 +1000

On Tue, 10 Apr 2001 09:55:16 +0100, 
Ian Soanes <[email-masked]> wrote:
>> > especially on printk symbols
>
>(modutils 2.4.5).

Compiling what with -mlong-calls, modutils or the kernel modules?  I
guess it must be the modules, in which case adding
  MODFLAGS += -mlong-calls
in arch/$(ARCH)/Makefile is the best fix.

---

From: Ian Soanes <[email-masked]>
Date: Tue, 24 Apr 2001 09:22:20 +0100

> in arch/$(ARCH)/Makefile is the best fix.

Yes... the modules.