Subject: insmod problems

From: Shay Deloya <[email-masked]>
Date: Sun, 6 May 2001 19:13:43 +0300

Hi All,

I have an old problem came up again and the old solution aren't helping.
I'm using busybox version 0.50 and with kernel 2.2 , and inserting 
some modules ,especially those with DEBUG macroes e.g:
#define DEBUG_HIGH(args...) {if (debug_level >= HIGH) printk(args);}
causes the message :
Relocation overflow of type 4 for

and insmod fails.

I'm compiling the modules with -mlong-calls and still getting this message.

Is it insmod knowen bugs that the relocation is done in bad way or 
a linker/compiler bug. I'm using compiler: egcs ver 1.0.3a
I'm checking this problem at the moment and looking for insmod bug.

Thanks,

Shay Deloya
______________________________________
Software Developer
Jungo - R&D
email: [email-masked]
web: http://www.jungo.com
Phone: 1-877-514-0537(USA)  +972-9-8859365(Worldwide) ext. 221
Fax:   1-877-514-0538(USA)  +972-9-8859366(Worldwide)

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 8 May 2001 23:40:36 -0300

> I'm checking this problem at the moment and looking for insmod bug.

You'll have to upgrade to very current binutils which for mips*-linux
targets default to elf32-trad{big,little}mips, not IRIX ELF format.  Also
it seems your modutils are a bit rotten, get the latest from ftp.kernel.org.

  Ralf

---

From: Michael Shmulevich <[email-masked]>
Date: Thu, 10 May 2001 11:53:12 +0300

> it seems your modutils are a bit rotten, get the latest from ftp.kernel.org.

On the same topic: same source (!!) 'insmod' executable compiled with 
new (2.10) binutils doesn't exibit such relocation problem.

What may be causing 'insmod' to be dependant on binutils which compile 
it? The module *.o is exactly same as it was before.

Sincerely yours,
Michael Shmulevich
______________________________________
Software Developer
Jungo - R&D
email: [email-masked]
web: http://www.jungo.com
Phone: 1-877-514-0537(USA)  +972-9-8859365(Worldwide) ext. 233
Fax:   1-877-514-0538(USA)  +972-9-8859366(Worldwide)

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 10 May 2001 15:46:39 -0300

> it? The module *.o is exactly same as it was before.

Without further explanation this one just sounds bizarre for now.

There always have been differences between the code generated by binutils
in the various versions; the resulting changes may result in different
behaviour of a broken programs.  These are fun to debug to say the least.
The other possibility would be binutils bugs but I'm not aware of one
with the effect you described.

  Ralf