Subject: Patch tx3912 - inb/outb definition

From: Florian Lohoff <[email-masked]>
Date: Fri, 4 May 2001 14:34:10 +0200

Hi,
there are incompatible definitions of inb/outb in the tx3912 header
which clash the io.h definitions

Index: include/asm-mips/tx3912.h
===================================================================
RCS file: /cvs/linux/include/asm-mips/tx3912.h,v
retrieving revision 1.1
diff -u -r1.1 tx3912.h
--- include/asm-mips/tx3912.h	2001/04/01 03:28:23	1.1
+++ include/asm-mips/tx3912.h	2001/05/04 12:33:00
@@ -14,14 +14,6 @@
 
 #include <asm/addrspace.h>
 
-#define inb(addr)	(*(volatile unsigned char *)(addr))
-#define inw(addr)	(*(volatile unsigned short *)(addr))
-#define inl(addr)	(*(volatile unsigned int *)(addr))
-#define outb(b,addr)	(*(volatile unsigned char *)(addr)) = (b)
-#define outw(b,addr)	(*(volatile unsigned short *)(addr)) = (b)
-#define outl(b,addr)	(*(volatile unsigned int *)(addr)) = (b)
-
- 
 /******************************************************************************
 *
 * 	01  General macro definitions

So i guess this is correct

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 5 May 2001 14:55:36 -0300

> So i guess this is correct

At least those definitions look dubious enough to be dumped ...

  Ralf