Subject: Problem with module loading on a 2.4 kernel

From: Brian Murphy <[email-masked]>
Date: Tue, 15 May 2001 11:48:42 +0200

When we try to load a module into a 2.4.3 kernel we get the following
error:

# insmod /lib/modules/ipchains.o
insmod: kernel: QM_SYMBOLS: Unknown error 716862128

does anyone know what the matter here.

The toolchain we use is based on the patched egcs-1.1.2 and
binutils-2.8.1
at oss.

/Brian

---

From: "Steven J. Hill" <[email-masked]>
Date: Tue, 15 May 2001 06:44:58 -0500

> The toolchain we use is based on the patched egcs-1.1.2 and
And thus your problem. You need a newer toolchain. The binutils and
gcc out of CVS. For binutils you can also use HJ Lu's with version
2.11.90.0.5 or better.

-Steve

-- 
 Steven J. Hill - Embedded SW Engineer
 Public Key: 'http://www.cotw.com/pubkey.txt'
 FPR1: E124 6E1C AF8E 7802 A815
 FPR2: 7D72 829C 3386 4C4A E17D