Subject: stabs or ecoff for Linux/mips

From: "H . J . Lu" <[email-masked]>
Date: Thu, 7 Jun 2001 09:31:49 -0700

What is the better debug format for Linux/mips in the terms of gdb
and binutils, stabs or ecoff? I know the future is dwarf2. But I need
something stable now. Since Linux/x86 uses stabs, I lean toward to
stabs. Any comments?

H.J.

---

From: Daniel Berlin <[email-masked]>
Date: Thu, 7 Jun 2001 12:56:14 -0400 (EDT)

STABS definitely.

---

From: Stan Shebs <[email-masked]>
Date: Thu, 07 Jun 2001 11:41:13 -0700

> something stable now. Since Linux/x86 uses stabs, I lean toward to

Go with stabs and ELF.  Neither ecoff's base file format nor the debug
info were particularly well-documented (I remember some of the bits in
GNU being figured out by reverse engineering!), perpetuating it will
just make your life more difficult in the long run.  It will also be
easier to move to dwarf2 when the opportunity arises.

Stan

---

From: Daniel Berlin <[email-masked]>
Date: 07 Jun 2001 15:05:14 -0400

> easier to move to dwarf2 when the opportunity arises.

mdebugread is also an evil piece of code. 
It duplicates almost all of buildsym.  I've had to perform *major*
surgery (and am still not done yet) to do the block hash table thing.

-- 
"I looked out my apartment window, and I saw a bird wearing
sneakers and a button saying, "I ain't flying no where."  I
said, "What's your problem buddy?"  He said, "I'm sick of this
stuff -- winter here, summer there, winter here, summer there.
I don't know who thought this stuff up, but it certainly wasn't
a bird."  I said, "Well, I was just making breakfast, come on
in.  Want some eggs?  Sorry."
"-Steven Wright

---

From: "H . J . Lu" <[email-masked]>
Date: Thu, 7 Jun 2001 12:24:05 -0700

> mdebugread is also an evil piece of code. 

That matches my own experiences. In case you haven't noticed, I
have checked in patches to switch Linux/mips to stabs in ELF :-).

H.J.