Subject: A patch for linux/mips libgcc

From: "H . J . Lu" <[email-masked]>
Date: Wed, 6 Jun 2001 14:55:34 -0700

This patch is against gcc 2.86-85. But it is trivial to convert it for
gcc 3.0. The problem is

# gcc gcc/testsuite/gcc.c-torture/execute/ieee/fp-cmp-4.c  -w -O0  -ffloat-store  -lm 
 /tmp/ccaUWHSO.o: In function `test_isunordered':
gcc/testsuite/gcc.c-torture/execute/ieee/fp-cmp-4.c(.text+0x44): undefined reference to `__unorddf2'

I copied it from IRIX 6.

H.J.
---
2001-06-06  H.J. Lu <[email-masked]>

	* config/mips/t-linux: New.

	* configure.in: Add mips/t-linux to tmake_file.

--- gcc/config/mips/t-linux.fp	Tue Jun  5 22:14:03 2001
+++ gcc/config/mips/t-linux	Tue Jun  5 22:24:33 2001
@@ -0,0 +1,20 @@
+# We want fine grained libraries, so use the new code to build the
+# floating point emulation libraries.
+FPBIT = fp-bit.c
+DPBIT = dp-bit.c
+
+dp-bit.c: $(srcdir)/config/fp-bit.c
+	echo '#ifdef __MIPSEL__' > dp-bit.c
+	echo '#define FLOAT_BIT_ORDER_MISMATCH' >> dp-bit.c
+	echo '#endif' >> dp-bit.c
+	echo '#undef US_SOFTWARE_GOFAST' >> dp-bit.c
+	echo '#undef FLOAT' >> dp-bit.c
+	cat $(srcdir)/config/fp-bit.c >> dp-bit.c
+
+fp-bit.c: $(srcdir)/config/fp-bit.c
+	echo '#ifdef __MIPSEL__' > fp-bit.c
+	echo '#define FLOAT_BIT_ORDER_MISMATCH' >> fp-bit.c
+	echo '#endif' >> fp-bit.c
+	echo '#undef US_SOFTWARE_GOFAST' >> fp-bit.c
+	echo '#define FLOAT' >> fp-bit.c
+	cat $(srcdir)/config/fp-bit.c >> fp-bit.c
--- gcc/configure.in.fp	Tue Jun  5 22:14:03 2001
+++ gcc/configure.in	Tue Jun  5 22:14:03 2001
@@ -2747,7 +2747,7 @@ changequote([,])dnl
 		       mips*el-*)  tm_file="elfos.h mips/elfl.h mips/linux.h" ;;
 		       *)	  tm_file="elfos.h mips/elf.h mips/linux.h" ;;
 		esac
-		tmake_file=t-linux
+		tmake_file="t-linux mips/t-linux"
 		extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
 		gnu_ld=yes
 		gas=yes

---

From: "H . J . Lu" <[email-masked]>
Date: Wed, 6 Jun 2001 17:45:20 -0700

> This patch is against gcc 2.86-85. But it is trivial to convert it for
			^^^^^^^^^^^^

I meant to say gcc 2.96-85 from RedHat rawhide.

H.J.