Subject: SGI Challenge S Serial Port (zs0) Driver question

From: "Robert Rusek" <[email-masked]>
Date: Wed, 6 Jun 2001 10:59:11 -0700

I am trying to install RedHat 5.1 Linux on my Challenge.  I finally got the kernel to boot from the prom via bootp/tftp.  The loading of the kernel stops with the following messag:

Warning: unable to open an initial console.

The HOW-TO states the following:

--------------------------------------------------------------------------------
This problem has two possible solutions. First make sure you actually have a driver for the console of your system configured. If this is the case and the problem persists you probably got victim of a widespead bug in Linux distributions and root filesystems out there. The console of a Linux systems should be a character device of major id 5, minor 1 with permissions of 622 and owned by user and group root. If that's not the case, cd to the root of the filesystem and execute the following commands as root: 

   rm -f dev/console
   mknod --mode=622 dev/console

You can also do this on a NFS root filesystem, even on the NFS server itself. However note that the major and minor ids are changed by NFS, therefore you must do this from a Linux system even if it's only a NFS client or the major / minor ID might be wrong when your Linux client boots from it. 
--------------------------------------------------------------------------------

I have followed the above instructions and still I get:

Warning: unable to open an initial console.

I would assume then that I need a special driver for for the serial port (zs0).  Just to clarify I am connecting a terminal to the serial port of the Challenge.

Any help would be greatly appreciated.

Thank you in advance,
Robert Rusek

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 6 Jun 2001 22:09:41 +0200

> The HOW-TO states the following:

The standard SGI serial driver (CONFIG_SGI_SERIAL) supports the serial ports
of the Challenge S also.  Only if this one is configured you'll get all
the output upto ``Warning: unable to open ...'' printed onto the serial
console.  You also should see a message about two serial interfaces
being detected.

PS: Pressing the return character once every ~ 75 characters produces
    properly formatted mails ...