Subject: about linux mips ext2fs

From: Barry Wu <[email-masked]>
Date: Mon, 25 Jun 2001 08:51:38 -0700 (PDT)

Hi, all,

I am new to this maillist. I want to mount root 
file system under mipsel linux. I got root file
system from MIPS company. But I have no ready mips
linux system. Therefore I have to copy this root
file system to hard disk under intel linux. Using
its fdisk and ext2fs. I do not know if it can work
under mipsel linux. That mean mipsel linux can
support same ext2fs and partition? If someone knows,
please help me.
Thanks in advance!

Qingbo

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: Florian Lohoff <[email-masked]>
Date: Mon, 25 Jun 2001 20:20:30 +0200

> support same ext2fs and partition? If someone knows,

Linux/mips uses ext2 - Ext2 is per definition little endian and all
big endian targets use byteswap mechanisms (All but very old Linux/m68k
systems). So - yes - you can read i386 written ext2 on mips machines.

With the partition type - I guess all architectures are able to read
dos partition tables allthough they might not be the default (On SGI
we mostly use IRIX style partition tables)

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?

---

From: Keith M Wesolowski <[email-masked]>
Date: Mon, 25 Jun 2001 12:04:57 -0700

> we mostly use IRIX style partition tables)

All true, though the more standard way to get software onto your
system is using network booting and nfsroot.  Then you can create
partition tables and filesystems locally, then copy or install
appropriate software from the nfsroot onto local disk.

-- 
Keith M Wesolowski <[email-masked]> http://foobazco.org/~wesolows
------(( Project Foobazco Coordinator and Network Administrator ))------
	"Nothing motivates a man more than to see his boss put
	 in an honest day's work." -- The fortune file

---

From: Geert Uytterhoeven <[email-masked]>
Date: Tue, 26 Jun 2001 09:56:14 +0200 (MEST)

> systems). So - yes - you can read i386 written ext2 on mips machines.

All but very old Linux/m68k and Linux/PPC systems.

If you insist on booting such old kernels, `man e2fsck' for the flag to change
the endianness.

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven ------------- Sony Software Development Center Europe (SDCE)
[email-masked] ------------------- Sint-Stevens-Woluwestraat 55
Voice +32-2-7248626 Fax +32-2-7262686 ---------------- B-1130 Brussels, Belgium