Subject: Linux on PlayStation 2

From: Jun Sun <[email-masked]>
Date: Fri, 01 Jun 2001 14:05:07 -0700

I got forwarded by the following link, although in Japanese, which says Sony
is selling a Linux kit for PS2.  Does anybody know more details about this
port?  Specifically, does anyone have the source code?

http://www.jp.playstation.com/linux/

Jun

---

From: Mark Lehrer <[email-masked]>
Date: Fri, 1 Jun 2001 15:35:21 -0600

Well, the kernel is GPL'd, so Sony should have some kind of source
code package available if you buy their Linux kit.

Mark

---

From: Wayne Gowcher <[email-masked]>
Date: Fri, 1 Jun 2001 15:06:16 -0700 (PDT)

Going to link

http://www.jp.playstation.com/linux/dmesg.html

I see that bogo mips are reported as :

Calibrating delay loop... 392.40 BogoMIPS
Estimated CPU clock:  294.240 MHz

I thought the PS2 was a dual pipelined processor and
so maybe would see a higher BogoMIPS figure ? Possibly
double ?

Anybody know the ins and outs of this ?

Wayne

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/

---

From: Wayne Gowcher <[email-masked]>
Date: Mon, 4 Jun 2001 10:48:18 -0700 (PDT)

Dear All,

I am trying to native compile for mipsel-linux using
the declinuxroot tar file as my NFS and egcs-1.0.3a-1
as my compiler, glibc-2.0.6-5lm as my libraries as
suggested by the README file in
oss.sgi.com/pub/linux/mips/mipsel-linux/README.

But when I try to compile I get the following error :

/usr/bin/ld: /tmp/cca003091.o: uses different e_flags
(0x102) fields than previous modules (0x2)
Bad value: failed to merge target specific data of
file /tmp/cca003091.o
collect2: ld returned 1 exit status
make: *** [pointer] Error 1

When I compile the same program using the RedHat 5.1
rpms / nfs the program compiles to completion OK.

Anybody seen this before ?
Any ideas what I am doing wrong ? missed out ? 

Any help appreciated.

Wayne

---

From: Wayne Gowcher <[email-masked]>
Date: Mon, 4 Jun 2001 12:20:01 -0700 (PDT)

I found out what was breaking the compile :

I was setting -mcpu=r4600 -mips2. If I leave this off
everything compiles OK, but now the code isn't
optimized for the processor and does run slower ( of
course).

I also noted that if I use :
-mcpu=r4000 -mips2

I get the error :

/usr/bin/ld: /tmp/cca007591.o: ISA mismatch (-mips3)
with previous modules (-mips1)
/usr/bin/ld: /tmp/cca007591.o: uses different e_flags
(0x102) fields than previous modules (0x2)
Bad value: failed to merge target specific data of
file /tmp/cca007591.o
collect2: ld returned 1 exit status

Which I totally don't understand because I never set
mips3 I set mips2.

I am coming to the conclusion that :

the egcs-1.03a compiler as found on the sgi web site
only supports mips 1.

Can someone confirm or deny this ?

If that is so, how does anyone compile native mips2
code ? You have to build your own compiler / libraries
?

If anyone has / knows of an egcs-1.03a or higher
compiler capapble of compiling mips2 I'd really like
to hear from them.

TIA

Wayne

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 4 Jun 2001 22:28:50 +0200

> Any ideas what I am doing wrong ? missed out ? 

This is a bug in certain binutils versions which gets triggered by
certain kernel configurations.  Upgrade to newer binutils.

   Ralf

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 4 Jun 2001 22:36:52 +0200

> Which I totally don't understand because I never set

The source itself sets the assembler to mips3 mode.

> the egcs-1.03a compiler as found on the sgi web site

Wrong.

  Ralf

---

From: Wayne Gowcher <[email-masked]>
Date: Mon, 4 Jun 2001 13:53:33 -0700 (PDT)

Ralf,

Thanks for the reply.

I was using binutils found in
ftp://oss.sgi.com/pub/linux/mips/mipsel-linux/RedHat-6.1/RPMS/mipsel/

version is 2.10.91-1lm.mipsel.rpm

Do you have a rpm neweer than this or know where I may
get one ?

TIA

Wayne

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 4 Jun 2001 23:54:43 +0200

> Do you have a rpm neweer than this or know where I may

There is one in the Redhat 7.0 directory.  I think we only have big endian
binaries, so you may have to build little endian binaries yourself.

   Ralf

---

From: "Houten K.H.C. van (Karel)" <[email-masked]>
Date: Tue, 05 Jun 2001 09:50:06 +0200

> binaries, so you may have to build little endian binaries yourself.

I have my RH 7.0 mipsel (glibc 2.2 based) set nearly ready. Should I
upload what I have for now?

Regards,
Karel.

-- 
Karel van Houten

----------------------------------------------------------
The box said "Requires Windows 95 or better."
I can't understand why it won't work on my Linux computer. 
----------------------------------------------------------