Subject: Re: KSEG2 Segment not used on Linux?

From: Ralf Baechle <[email-masked]>
Date: Mon, 25 Jun 2001 08:54:59 +0200

On Thu, Jun 21, 2001 at 08:08:06PM +0530, Raghav P wrote:

> From: "Raghav P" <[email-masked]>
> To: <[email-masked]>
       ^^^^^^^^^^^^^^^^

Don't send email to the owner address - it may stay unread forever!

> Is KSEG2 used on Linux ports for R2300?

Yes, ioremap and kernel modules use that address space on all 32-bit kernels.

> Also does Linux recognise physical memory more than 512MB on MIPS system? Is
> there any equivalent of highmem for MIPS?

Not yet.

  Ralf

---

From: Timothy Daly <[email-masked]>
Date: Mon, 25 Jun 2001 07:53:37 -0700 (PDT)

Hi all. :)  I'd like to introduce myself, if I may.

My name's Tim, and I'm in Berlin at the moment.  I 
recently picked up an Indigo2 R10000 SI, which is a
very nice purple.  I can't really knock Irix, but I
don't have the source, and I don't have a compiler,
which is like a car with no seats where you can't
open the hood.  Besides, I've always wanted to have
a good reason to hack around on the Linux kernel a
bit.
So, here I am. :)

I'm going to spend the next week or two getting my
bearings on what's been done, and what's waiting to
be done.  Then, if I'm not completely out of my depth,
maybe I can help with some stuff.  

One thing that's somewhat unfortunate is that it seems
SGI still hasn't released any documentation for the
Impact graphics hardware.  Is there any word on that?

Well, pleased to meet you all.  Have fun.

-Tim

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: George Gensure <[email-masked]>
Date: Mon, 25 Jun 2001 21:53:42 -0400 (EDT)

> very nice purple.  I can't really knock Irix, but I

I can...

George
[email-masked]