Subject: 2.4.5 in cvs - Did anyone try ?

From: Florian Lohoff <[email-masked]>
Date: Fri, 15 Jun 2001 21:04:33 +0200

Hi,
i am  just trying 2.4.5 on an Indy and i have no luck. The kernel
gets confused very fast on the root ext2 filesystem the 2.4.3 continues
to boot from. It is spitting our "EXT2: Bit already set for inode x"
and hangs in a tight loop.

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 16 Jun 2001 04:14:55 +0200

> and hangs in a tight loop.

There was a stupid braino in include/asm-mips/bitops.h, make sure you
have revision 1.16 of that file.

  Ralf

---

From: Florian Lohoff <[email-masked]>
Date: Sat, 16 Jun 2001 11:14:43 +0200

> have revision 1.16 of that file.

I have 1.16 of that file.

Flo

---

From: "���L��" <[email-masked]>
Date: Tue, 19 Jun 2001 11:39:06 +0800

dear all,
after we replace our mipsel-linux compiler tools with sgi's
we meet a problem which was not occurried before:
(any hint to fix? thanks alot in advanced!:)
##
genromfs -v -f rom_image -d /usr/mnt/rootfs
mipsel-linux-ld -EL -Tld.script.rd -b binary -o /usr/mnt/ramdisk.img
rom_image
##
mipsel-linux-ld: rom_image: compiled for a little endian system and target
is big endian
File in wrong format: failed to merge target specific data of file rom_image
##
(old compiler said:compiled for a little endian system and target is little
endian)
##
ld.script.rd :
OUTPUT_FORMAT("elf32-littlemips")
OUTPUT_ARCH(mips)
SECTIONS
{
  .data :
  {
    __rd_start = .;
    *(.data)
    __rd_end = .;
  }
}