Subject: USB OHCI on 2.4.2 kernel using r4k processor

From: Wayne Gowcher <[email-masked]>
Date: Tue, 10 Jul 2001 12:45:26 -0700 (PDT)

Dear All,

Has anyone got USB OHCI running on a 2.4.2 kernel with
a mips r4k processor ?

I have successfully used the above with a r3k mips
processor but now after porting the same base code to
a r4k processor the kernel throws an OOPS.

I believe the problem may lay with the writeback cache
because when I disable the d cache on the r4k 2.4.2
kernel USB works fine !

I did some digging around and noted that the working
aic7xxx driver I have on the 2.4.2 r4k makes use of
pci_map_single to handle cache flushing ( ??? please
correct me if I am wrong ) and that this type of code
doesn't make it into the usb code until 2.4.4 of the
sgi linux kernel.

Does anyone have a "back patch" to apply to the 2.4.2
usb code ?

If not I am thinking of attempting this myself and
would welcome any comments / advice about doing this

TIA

Wayne

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: Pete Popov <[email-masked]>
Date: Tue, 10 Jul 2001 21:36:36 -0700

> Has anyone got USB OHCI running on a 2.4.2 kernel with

Yes, on a couple of different boards.  

 
 
> would welcome any comments / advice about doing this

Steve at MontaVista did the usb work for mips about six months ago on an 
ITE 8172 board. Since then we've also ported it to the Alchemy Au1000 
board, both running on 2.4.2.  He forwarded all patches to the usb 
maintainer but it looks like it took a bit of time for all the patches 
to be applied.  I don't know if we still have patches against the 2.4.2 
tree.  One thing you can do is next Monday check our ftp site (HHL2.0 
for mips should be released by early next week), grab the generic HHL2.0 
mips kernel, and diff all the usb code against the stock 2.4.2. I don't 
think it would be too bad of a job.

Pete