Subject: serial console startup problem

From: Barry Wu <[email-masked]>
Date: Fri, 27 Jul 2001 17:03:54 -0700 (PDT)

Hi,all,

When linux 2.4.3 startup, our serial console can not
work. I use another serial port to print some debug
messages, it likes following:

hda: 16841664 sectorsp: (8623 MB)p: w/512KiB Cachep:,
CHS=16708/16/63p:
Partition check:
hda:[PTBL] [1048/255/63] hda1 hda4
Serial driver version 5.05 (2000-12-13) with
MANY_PORTS SHARE_IRQ SERIAL_PCI e
nabled
ttyS00 at 0xb8000000 (irq = 2) is a 16550A
ttyS01 at 0xb8100000 (irq = 3) is a 16550A
VFS: Mounted root (ext2 filesystem) readonly.
Freeing prom memory: 1020kb freed
Freeing unused kernel memory: 52k freed

kernel BUG at page_alloc.c:191!
kernel BUG at page_alloc.c:191!
kernel BUG at page_alloc.c:191!

Do someone know what's problem it is?
If you know, please help me.

Thanks!

Barry

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

---

From: "machael thailer" <[email-masked]>
Date: Mon, 30 Jul 2001 15:17:42 +0800

Hello, all:
     Now I will plan to port linux on our custom mips-based board. Since
this will be the first time I use linux on mips CPU and I am a newbie for
mips RC32334, I have several questions to ask:

1 What's the current stable linux kernel version for mips that you are
using?Especially, which  version can support IDT mips RC32334 CPU now? If
linux can not support RC32334 for the time being,which familys of Mips
should I take as example and what modifications should I do?
2 What IDE tools for Mips are you using to debug linux kernel and  APPs ?
3  Are there any sample boot codes which can be burnt into BOOTROM and which
will  initialize the mip-based boards when power-on and then load the
linux-kernel to RAM via network or flash?
4 Is it possible to use RTLinux for mips now? If so, which rtlinux version
should I take?

Any suggestions will be highly appreciated.

Thank you very much.
machael thailer