Subject: about serial console problem

From: Barry Wu <[email-masked]>
Date: Sun, 22 Jul 2001 23:51:25 -0700 (PDT)

Hi, all,

I am porting linux 2.4.3 to our mipsel evaluation
board. Now I meet a problem. Because I use edown
to download the linux kernel to evaluation board.
I update the serial baud rate to 115200.
I use serial 0 as our console, and I can use
printk to print debug messages on serial port.
But after kernel call /sbin/init, I can not
see "INIT ...  ..." messages on serial port.
I suppose perhaps I make some mistakes. But when
I use 2.2.12 kernel, it ok.
If someone knows, please help me. Thanks!

Barry

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

---

From: Keith Owens <[email-masked]>
Date: Mon, 23 Jul 2001 17:11:38 +1000

On Sun, 22 Jul 2001 23:51:25 -0700 (PDT), 
>see "INIT ...  ..." messages on serial port.

Probably you did not code the console boot parameters correctly.  In
LILO, append="console=tty0 console=ttyS0,115200".  printk is written to
all consoles, init messages are only written to the last console
specified.

---

From: Marc Karasek <[email-masked]>
Date: 23 Jul 2001 10:29:20 -0400

This sounds like a problem I ran into on another processor/platform.
What are you using for a ramdisk?  Is it busybox?  There was a bug in
0.51 busybox that would not let it accept input from a console on a
serial port.  It had to do with the init for the serial port.  You can
check the patch file below to see the problem that was in busybox...

--- init.c.orig Sat Apr 21 17:46:57 2001
+++ init.c      Sat Apr 21 17:46:31 2001
@@ -276,7 +276,7 @@

        /* Make it be sane */
        tty.c_cflag &= CBAUD|CBAUDEX|CSIZE|CSTOPB|PARENB|PARODD;
-       tty.c_cflag |= HUPCL|CLOCAL;
+       tty.c_cflag |= CREAD|HUPCL|CLOCAL;

        /* input modes */
        tty.c_iflag = ICRNL | IXON | IXOFF;

--
/*************************
Marc Karasek
Sr. Firmware Engineer
iVivity Inc.
[email-masked]
(770) 986-8925
(770) 986-8926 Fax
*************************/

---

From: Dave Airlie <[email-masked]>
Date: Mon, 23 Jul 2001 20:56:56 +0100 (IST)

Cool, this patch fixed a problem we were seeing with busybox on the
Linux/VAX project, that I hadn't time to look at...

thanks

Dave.

-- 
David Airlie, Software Engineer
http://www.skynet.ie/~airlied / [email-masked]
pam_smb / Linux DecStation / Linux VAX / ILUG person