Subject: I2 R10K status?

From: Mike McDonald <[email-masked]>
Date: Fri, 20 Jul 2001 10:49:16 -0700

What's the status of linux for the I2 R10K? Any hope at all? I'm
well aware of the problems SGI had getting Irix to work on it. (I was
part of ISD then.)

  Mike McDonald
  [email-masked]

---

From: Thiemo Seufer <[email-masked]>
Date: Fri, 20 Jul 2001 22:01:55 +0200

> well aware of the problems SGI had getting Irix to work on it. (I was

A few days ago I posted about some success booting my ip28 AKA
Indigo2 R10000 Impact Ready. A updated version of the bootlog is
appended.

Used Tools:
- CVS binutils, hacked to allow assembly and linking of 64bit
  non-pic executables.
- GCC snapshot as of 2001-05-01 with some patch by Ralf to work
  better for R10000 and one more by myself.
- CVS linux from oss, patched to recognize an ip28 and to work
  in a real 64bit address space.

The Patches are available at
http://www.csv.ica.uni-stuttgart.de/homes/ths/linux-mips/src
The script I use to crosscompile is at
http://www.csv.ica.uni-stuttgart.de/homes/ths/linux-mips/edit

Current State:
The Kernel boots via bootp/tftp/nfs into an initshell, execution
of not too complex programs may or may not succeed, it's pretty at
random. /sbin/init itself seems to run, too, but all(?) spawned
processes crash due to unaligned access/illegal instruction in
kernel space. The serial console drops characters on high
throughput.

If you want to try it out, the kernel is available at
http://www.csv.ica.uni-stuttgart.de/homes/ths/linux-mips/mips64-linux-ip28-2001-07-20.tar.gz

Thiemo

-------------------------------------------------
>> bootp(): init=/bin/sash
Setting $netaddr to 10.0.0.5 (from server rembrandt)
Obtaining  from server rembrandt
1750384+278528+259632 entry: 0xa8000000201b4000
ARCH: SGI-IP28
PROMLIB: ARC firmware Version 64 Revision 0
Linux version 2.4.5-1 (ths@rembrandt) (gcc version 3.1 20010501 (experimental)) #78 Mon Jul 16 17:06:48 CEST 2001
Loading R10000 MMU routines.
CPU implementation 9, CPU revision 37
Primary instruction cache 32kb, linesize 64 bytes
Primary data cache 32kb, linesize 32 bytes
Secondary cache sized at 1024K, linesize 128
MC: SGI memory controller Revision 5
On node 0 totalpages: 262144
zone(0): 262144 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: init=/bin/sash
Entering 64-bit mode.
calculating r4koff... 000d5bea(875498)
Console: colour dummy device 80x25
zs0: console I/O
Console: ttyS0 (Zilog8530), 9600 baud
Calibrating delay loop... 174.89 BogoMIPS
Memory: 488192k/917500k available (1709k kernel code, 429308k reserved, 132k data, 88k init)
Dentry-cache hash table entries: 131072 (order: 9, 2097152 bytes)
Inode-cache hash table entries: 65536 (order: 8, 1048576 bytes)
Buffer-cache hash table entries: 65536 (order: 7, 524288 bytes)
Page-cache hash table entries: 262144 (order: 9, 2097152 bytes)
Checking for 'wait' instruction...  unavailable.
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd v1.8
initialize_kbd: Keyboard failed self test
pty: 256 Unix98 ptys configured
keyboard: Timeout - AT keyboard not present?
keyboard: Timeout - AT keyboard not present?
DS1286 Real Time Clock Driver v1.0
streamable misc devices registered (keyb:150, gfx:148)
block: queued sectors max/low 321560kB/190488kB, 960 slots per queue
sgiseeq.c: David S. Miller ([email-masked])
eth0: SGI Seeq8003 08:00:69:0b:35:da
SCSI subsystem driver Revision: 1.00
wd33c93-0: chip=WD33c93B/13 no_sync=0xff no_dma=0 debug_flags=0x00
           setup_args=,,,,,,,,,
           Version 1.25 - 09/Jul/1997, Compiled Jul 16 2001 at 02:37:07
wd33c93-1: chip=WD33c93B/13 no_sync=0xff no_dma=0 debug_flags=0x00
           setup_args=,,,,,,,,,
           Version 1.25 - 09/Jul/1997, Compiled Jul 16 2001 at 02:37:07
scsi0 : SGI WD93
scsi1 : SGI WD93
SGI Zilog8530 serial driver version 1.01
ttyS0 at 0xbfbd9830 (irq = 21) is a Zilog8530
ttyS1 at 0xbfbd9838 (irq = 21) is a Zilog8530
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 8192 buckets, 64Kbytes
TCP: Hash tables configured (established 262144 bind 65536)
Sending BOOTP requests . OK
IP-Config: Got BOOTP answer from 10.0.0.1, my address is 10.0.0.5
IP-Config: Complete:
      device=eth0, addr=10.0.0.5, mask=255.0.0.0, gw=10.0.0.1,
     host=10.0.0.5, domain=, nis-domain=(none),
     bootserver=10.0.0.1, rootserver=10.0.0.1, rootpath=/home/linux-mips
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Looking up port of RPC 100003/2 on 10.0.0.1
Looking up port of RPC 100005/2 on 10.0.0.1
VFS: Mounted root (nfs filesystem) readonly.
Freeing prom memory: 1024kb freed
Freeing unused kernel memory: 88k freed
Stand-alone shell (version 3.4)
> -ls
.
..
bin
boot
data.tar.gz
dev
etc
home
lib
lost+found
mipsroot-rh7.tar.bz2
mnt
opt
proc
root
sbin
tmp
usr
var
> ls
bin   data.tar.gz  etc   lib         mipsroot-rh7.tar.bz2  opt   root  tmp  var
boot  dev          home  lost+found  mnt                   proc  sbin  usr
> ls
pid 9: killed by signal 11

---

From: Klaus Naumann <[email-masked]>
Date: Fri, 20 Jul 2001 22:57:33 +0200 (CEST)

> kernel space. The serial console drops characters on high

This is not a IP28 specific problem. Esp. on Backspace and such things
the current serial console just f*cks up. Also a lot of data throughput
will make things worse.

[snip]

> Console: ttyS0 (Zilog8530), 9600 baud

Try using 38400, it helps a bit I think ...

> Page-cache hash table entries: 262144 (order: 9, 2097152 bytes)

[snap]

		CU, Klaus

-- 
Full Name   : Klaus Naumann     | (http://www.mgnet.de/) (Germany)
Nickname    : Spock             | Org.: Mad Guys Network
Phone / FAX : ++49/177/7862964  | E-Mail: ([email-masked])
PGP Key     : www.mgnet.de/keys/key_spock.txt

---

From: <[email-masked]>
Date: Fri, 20 Jul 2001 17:01:13 -0400 (EDT)

What bootimage are you useing?
	Thanks
		Nick

---

From: Thiemo Seufer <[email-masked]>
Date: Fri, 20 Jul 2001 23:33:16 +0200

Klaus Naumann wrote:
[snip]
> Try using 38400, it helps a bit I think ...

Thanks, I'll try it out.

> > Page-cache hash table entries: 262144 (order: 9, 2097152 bytes)

I forgot, there's something wrong here: My machine has 512MB RAM,
I don't know how these numbers were computed.

Thiemo

---

From: Florian Lohoff <[email-masked]>
Date: Sun, 22 Jul 2001 03:30:38 +0200

> kernel space. The serial console drops characters on high

This is true for all sgis IMHO - I have seen this before on the
Indy and Indigo2 - This is a bug in the sgiserial.c - I have tried
to find it before but havent been successfull. Another bug lets
the serial to freeze completely which prevents serial console
machines from reboot as the and print to the console blocks.

This has been fixed somewhere in the 2.4 area.

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?

---

From: Thiemo Seufer <[email-masked]>
Date: Sun, 22 Jul 2001 04:33:47 +0200

> > kernel space. The serial console drops characters on high

I've tested the serial console now with 38400 baud also,
the characteristics of the dropouts didn't change.

> to find it before but havent been successfull.

Well, then it's at least not a bug of mine. :-)

> Another bug lets

I haven't encountered this yet, so the fix seems to work for
64bit, too.

Thiemo

---

From: Klaus Naumann <[email-masked]>
Date: Sun, 22 Jul 2001 13:07:29 +0200 (CEST)

> the characteristics of the dropouts didn't change.

ok - when I have time next week I'll read through sgiserial.c 
and clean it up a bit ... maybe I find the bug ...

> Well, then it's at least not a bug of mine. :-)

No. :-)