Subject: Gdb quit problem on Linux/mips

From: "H . J . Lu" <[email-masked]>
Date: Fri, 13 Jul 2001 16:44:15 -0700

Did anyone see the quit problem on Linux/mips with gdb 2001-07-13-cvs?
I got

(gdb) b main
Breakpoint 1 at 0x400744: file x.c, line 3.
(gdb) r
Starting program: /tmp/./a.out 

Breakpoint 1, main () at x.c:3
3         printf ("Hello\n");
(gdb) q
The program is running.  Exit anyway? (y or n) y

It stops here. I get

 1540 pts/0    S      0:04 ./gdb ./a.out
 1550 pts/0    T      0:00 /tmp/./a.out

# strace -p 1540
wait4(-1,

It may be a kernel bug. I am running 2.4.3.

H.J.

---

From: Daniel Jacobowitz <[email-masked]>
Date: Fri, 13 Jul 2001 16:54:58 -0700

> It may be a kernel bug. I am running 2.4.3.

Yes, it's a kernel bug.  I believe this is fixed in the SGI tree; I
know it's fixed in ours (which will be available Monday or later
tonight).

-- 
Daniel Jacobowitz                           Carnegie Mellon University
MontaVista Software                         Debian GNU/Linux Developer