Subject: Probs running ntp on an indy

From: Robert Einsle <[email-masked]>
Date: Thu, 19 Jul 2001 19:26:14 +0200

Hy

Is it possible to run ntp on an indy??

while running ntpdate i got the error

ntpdate[621]: poll(): nfound = 0, error: Operation not permitted

the same thing happens while running ntpd

Thanks for your help

-- 
MFG

Robert Einsle
BNA Technik, Postmaster

>>Warum muss ich bei "Verwaltung von Problemloesungen
fuer eine EDV-Abteilung" an einen Waffenschrank denken?<<
(Robin S. Socha in de.comp.os.unix.linux.misc)

---

From: Klaus Naumann <[email-masked]>
Date: Thu, 19 Jul 2001 22:24:06 +0200 (CEST)

> the same thing happens while running ntpd

I know the problem but no solution. I suspect that it's a
problem of the poll function in Big Endian environments, because
I can reproduce this on my Indigo2 and on an Ultra 1 as well.

		CU, Klaus

-- 
Full Name   : Klaus Naumann     | (http://www.mgnet.de/) (Germany)
Nickname    : Spock             | Org.: Mad Guys Network
Phone / FAX : ++49/177/7862964  | E-Mail: ([email-masked])
PGP Key     : www.mgnet.de/keys/key_spock.txt

---

From: Florian Lohoff <[email-masked]>
Date: Thu, 19 Jul 2001 22:51:37 +0200

> I can reproduce this on my Indigo2 and on an Ultra 1 as well.

I remember seeing a patch concerning this problem - Something with
rtsignals - But i cant seem to find it anymore.

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?

---

From: Daniel Jacobowitz <[email-masked]>
Date: Thu, 19 Jul 2001 14:20:09 -0700

> rtsignals - But i cant seem to find it anymore.

That's probably this one.  I knew I'd let a patch slip.  Glibc folk, is
this OK?  The siginfo struct is different on MIPS.

-- 
Daniel Jacobowitz                           Carnegie Mellon University
MontaVista Software                         Debian GNU/Linux Developer

--- glibc-2.2.3/sysdeps/unix/sysv/linux/mips/bits/siginfo.h.orig	Thu May 24 15:35:42 2001
+++ glibc-2.2.3/sysdeps/unix/sysv/linux/mips/bits/siginfo.h	Thu May 24 15:35:49 2001
@@ -45,9 +45,9 @@
 typedef struct siginfo
   {
     int si_signo;		/* Signal number.  */
+    int si_code;		/* Signal code.  */
     int si_errno;		/* If non-zero, an errno value associated with
 				   this signal, as defined in <errno.h>.  */
-    int si_code;		/* Signal code.  */
 
     union
       {

---

From: Andreas Jaeger <[email-masked]>
Date: Fri, 20 Jul 2001 08:04:41 +0200

> this OK?  The siginfo struct is different on MIPS.

Yes, that's fine.

Thanks, I've committed it,
Andreas
-- 
 Andreas Jaeger
  SuSE Labs [email-masked]
   private [email-masked]
    http://www.suse.de/~aj