Subject: time_init() enables interrupt.

From: Atsushi Nemoto <[email-masked]>
Date: Mon, 23 Jul 2001 19:05:44 +0900

arch/mips/kernel/time.c:time_init() in current CVS contains following codes:

	/* setup xtime */
	write_lock_irq(&xtime_lock);
	xtime.tv_sec = rtc_get_time();
	xtime.tv_usec = 0;
	write_unlock_irq(&xtime_lock);

The write_unlock_irq() macro calls __sti(), but it is too early to
enable interrupts.

I think this write_lock_irq/write_unlock_irq pair should be removed
(or replaced with write_lock_irqsave/write_unlock_irqrestore pair).

---
Atsushi Nemoto

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 23 Jul 2001 16:49:16 +0200

> (or replaced with write_lock_irqsave/write_unlock_irqrestore pair).

There is no point in locking there.  This code is executed with interrupts
disabled on the boot cpu only.  I've removed the lock with no replacement.

  Ralf