Subject: Re: ksymoops changes for mips

From: Keith Owens <[email-masked]>
Date: Tue, 31 Jul 2001 13:57:45 +1000

On Thu, 28 Jun 2001 16:32:51 +0200, 
Thiemo Seufer <[email-masked]> wrote:
>Keith Owens wrote:
>[snip]
>> >The best option is for a mips64 kernel to indicate that it is 64 bit
>> >and its endianess.  Instead of printing
>
>The appended patch introduces the new format in mips64. Maybe this speeds
>up agreement about it. :-)

I am updating ksymoops now and need some information.  Could somebody
tell me what this produces on mips?

# objdump -h ksymoops | head -8
# objdump -h mips64-lsb-vmlinux | head -8
# objdump -h mips64-msb-vmlinux | head -8

where mips64-[lm]sb-vmlinux are kernels compiled for 64 bit with LSB
and MSB.

---

From: Keith Owens <[email-masked]>
Date: Tue, 31 Jul 2001 14:30:04 +1000

On Tue, 31 Jul 2001 13:57:45 +1000, 
>where mips64-[lm]sb-vmlinux are kernels compiled for 64 bit with LSB

Sorry, that should have been objdump -x, not objdump -h, I need the
architecture type as well as the file format.