Subject: about mipsel linux thread problem

From: Barry Wu <[email-masked]>
Date: Wed, 18 Jul 2001 20:01:36 -0700 (PDT)

Hi, all,

I just port mipsel linux 2.2.12 to our mips evaluation
board, and I use glibc-2.0.6-5l and linuxthread 0.7.
But when I run linuxthread application on it.
The application reports "Bus error".
I add some print information in linuxthreads source
code, and find that when call
linuxthreads/restart.h  suspend() function, the
application will Bus error.
I do not know which glibc and linuxthreads version
can support mips linux well. And I do not know what
the problem I meet is.
If someone knows, please help me!
Thanks!

Barry

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 19 Jul 2001 12:23:24 +0200

> can support mips linux well. And I do not know what

Please upgrade to glibc 2.2.x which will work much better.  Linuxthreads
is known to be broken with glibc 2.0 and nobody here intends to fix it as
glibc 2.0 is so old.

  Ralf