Subject: Re: Re: help on linux-mipsel frame buffer

From: Geert Uytterhoeven <[email-masked]>
Date: Wed, 18 Jul 2001 14:37:43 +0200 (MEST)

On Wed, 18 Jul 2001, Fuxin Zhang wrote:
> 2001-07-18 09:18:00£º
> >On Tue, 17 Jul 2001, James Simmons wrote:
> >> >   First I try the vga16 frame buffer driver,but i can only get
> >> > some black/white strips on the screen.(after made some changes
> >> > to the source,most important one is use pci to find and set the
> >> > vbase address).
> >>
> >> It is hardwired into the vga16fb driver the memory region (0xA000). This
> >> is very wrong on non intel platforms. So that drivers pretty much doesn't
> >> work on anything else.
> >
> >Does your firmware initialize the VGA card to VGA text mode? Vga16fb requires
> >this initialization, which is normally done by the VGA BIOS. An x86
> >BIOS-emulator may be your friend.
> Cound you give me a link to such a emulator?My firmware doesn't initialize VGA card.That seems the real problem.

I don't know whether it exists for Linux/MIPS yet.

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven ------------- Sony Software Development Center Europe (SDCE)
[email-masked] ------------------- Sint-Stevens-Woluwestraat 55
Voice +32-2-7248626 Fax +32-2-7262686 ---------------- B-1130 Brussels, Belgium

---

From: Jun Sun <[email-masked]>
Date: Fri, 20 Jul 2001 11:18:09 -0700

> I don't know whether it exists for Linux/MIPS yet.

FYI,  without the emulator, I have successfully run Matrox Millinium PCI card
from SGI CVS tree.  

With some patches, I have got MQ200 and Voodoo3 2000/3000 working as well.  I
don't know if any other cards work on MIPS.

For voodoo3 patch, look at http://www.medex.hu/~danthe/tdfx/.

Jun

---

From: Geert Uytterhoeven <[email-masked]>
Date: Sat, 21 Jul 2001 12:53:52 +0200 (MET DST)

> FYI,  without the emulator, I have successfully run Matrox Millinium PCI card

That's because matroxfb is one of the few frame buffer devices that know how to
initialize uninitialized cards.

Gr{oetje,eeting}s,

						Geert

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 21 Jul 2001 17:25:18 +0200

On Sat, Jul 21, 2001 at 12:53:52PM +0200, Geert Uytterhoeven wrote:

> That's because matroxfb is one of the few frame buffer devices that know how
> to initialize uninitialized cards.

Is that true for all of the Matrox PCI cards or which would be your
recommendation?

  Ralf

---

From: Geert Uytterhoeven <[email-masked]>
Date: Sun, 22 Jul 2001 11:55:25 +0200 (MET DST)

> Is that true for all of the Matrox PCI cards or which would be your

I think so.

I know not all features are supported for the latest Matrox cards, but these
are AGP only anyway.

Gr{oetje,eeting}s,

						Geert