Subject: Malta Board and PC Keyboard

From: [email-masked]
Date: Wed, 18 Jul 2001 19:05:54 +0200

Has somebody already used a PC Keyboard with the Malta development Board?
I have enabled the driver for the keyboard, but I get the bootmessage:
	initialize_kbd: Keyboard failed self test
	keyboard: Timeout - AT keyboard not present?

Maybe a problem with the mapping from Intel-IO to mmio?
I'm just starting development on MIPS and don't know where to search.

(My Kernel is 2.4.3-MIPS-01.00 from ftp.mips.com)

Thomas

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 19 Jul 2001 13:32:46 +0200

> (My Kernel is 2.4.3-MIPS-01.00 from ftp.mips.com)

Malta kernels don't have a complete keyboard driver.  The small bits that
are necessary to access the keyboard's I/O register are missing.  Please
try the (untested) patch below and tell me if it fixes kbd and PS/2 mouse
for you.

  Ralf

Index: arch/mips/mips-boards/malta/malta_setup.c
===================================================================
RCS file: /home/pub/cvs/linux/arch/mips/mips-boards/malta/malta_setup.c,v
retrieving revision 1.6
diff -u -r1.6 malta_setup.c
--- arch/mips/mips-boards/malta/malta_setup.c	2001/07/11 23:55:41	1.6
+++ arch/mips/mips-boards/malta/malta_setup.c	2001/07/19 11:28:22
@@ -49,13 +49,10 @@
 static int remote_debug = 0;
 #endif
 
-#ifdef CONFIG_BLK_DEV_IDE
 extern struct ide_ops std_ide_ops;
-#endif
-#ifdef CONFIG_BLK_DEV_FD
 extern struct fd_ops std_fd_ops;
-#endif
 extern struct rtc_ops malta_rtc_ops;
+extern struct kbd_ops std_kbd_ops;
 
 extern void mips_reboot_setup(void);
 
@@ -130,6 +127,9 @@
 #endif
 #ifdef CONFIG_BLK_DEV_FD
         fd_ops = &std_fd_ops;
+#endif
+#ifdef CONFIG_PC_KEYB
+	kbd_ops = &std_kbd_ops;
 #endif
 	mips_reboot_setup();
 }