Subject: Patch to ptrace.c

From: Jan-Benedict Glaw <[email-masked]>
Date: Fri, 13 Jul 2001 17:13:13 +0200

Hi!

Fixing a little typo preventing proper compiling... Ralf? Would you please
apply it?

Index: ptrace.c
===================================================================
RCS file: /cvs/linux/arch/mips/kernel/ptrace.c,v
retrieving revision 1.28
diff -u -r1.28 ptrace.c
--- ptrace.c	2001/07/12 00:16:53	1.28
+++ ptrace.c	2001/07/13 12:10:36
@@ -155,7 +155,7 @@
 				 * registers - unless we're using r2k_switch.S.
 				 */
 #ifdef CONFIG_CPU_R3000
-				if (mips_cpu_options & MIPS_CPU_FPU)
+				if (mips_cpu.options & MIPS_CPU_FPU)
 					tmp = *(unsigned long *)(fregs + addr);
 				else
 #endif
@@ -252,7 +252,7 @@
 			 * we're using r2k_switch.S.
 			 */
 #ifdef CONFIG_CPU_R3000
-			if (mips_cpu_options & MIPS_CPU_FPU)
+			if (mips_cpu.options & MIPS_CPU_FPU)
 				*(unsigned long *)(fregs + addr) = data;
 			else
 #endif

MfG, JBG

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 14 Jul 2001 12:54:21 +0200

> Fixing a little typo preventing proper compiling... Ralf? Would you please

Already fixed before your patch reached me ...

  Ralf