Subject: MIPS processor identification register

From: Narendra Sankar <[email-masked]>
Date: Tue, 17 Jul 2001 12:59:23 -0700

hi everyone
I could not find an answer to this question in the archives and hence am 
trying here -

Is there a complete list somewhere of the different PRID (CP0 register 15) 
values across the entire MIPS family - including all the different vendors?

Thanks
Naren
Clearwater Networks

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Tue, 17 Jul 2001 22:48:20 +0200

There is no list that is both public and complete.   MIPS issues
PRID values to MIPS licensees, but has no control over how,
when and whether the associated processors are commercialized,
and does not publish the full list of registered values.

            Kevin K.

---

From: "Oliver M . Bolzer" <[email-masked]>
Date: Tue, 17 Jul 2001 22:46:17 +0200

Hi!

On Tue, Jul 17, 2001 at 12:59:23PM -0700, Narendra Sankar <[email-masked]> wrote...
 
> values across the entire MIPS family - including all the different vendors?

Not that I know of any, but for reference, the PlayStation2's EmotionEngine
Processor (R5900) has a fixed Impl value of 0x2E.

[oliver@asuka tmp]$ cat /proc/cpuinfo 
cpu                     : MIPS
cpu model               : R5900 V1.4
system type             : EE PS2
BogoMIPS                : 392.40
byteorder               : little endian
unaligned accesses      : 0
wait instruction        : no
microsecond timers      : no
extra interrupt vector  : yes
hardware watchpoint     : no
VCED exceptions         : not available
VCEI exceptions         : not available

# If anybody is interested in poking around a PlayStation2 running Linux
# by SSH. send me a mail. I got a non-NDA fully GPL/LGPL compliant unit.
# It's running an 2.2.1 kernel that looks more like a 2.2.1{8,9} when
# looked under the hood. It was delivered that way by SCEI and somebody
# despeartely needs to update it. Unfortunatly I'm a userspace guy.
  
-- 
	Oliver M. Bolzer
	[email-masked]

GPG (PGP) Fingerprint = 621B 52F6 2AC1 36DB 8761  018F 8786 87AD EF50 D1FF