Subject: Continued MIPS kernel debugging symbols problem...

From: "Steven J. Hill" <[email-masked]>
Date: Thu, 13 Sep 2001 21:34:18 -0500

Greetings.

I have tried everything I can to get Linux kernel debugging
symbols to work properly. I apologize for posting to so
many lists too, but I really need to get this working. I
traded a few emails with HJ Lu and he referred me to the
following messages/threads:

   http://sources.redhat.com/ml/gdb/2001-08/msg00053.html
   http://sources.redhat.com/ml/gdb/2001-08/msg00079.html
   http://sources.redhat.com/ml/gdb/2001-08/msg00084.html

I did read them a few times and it appears that all the
necessary changes are in the current gdb and insight CVS
repositories. I checked out the latest sources a half
hour ago and compiled both gdb and insight using the
configuration line:

    configure --prefix=/opt/tools --target=mipsel-linux-elf

since my target is a NEC 5432 running in LE mode. I had
also tried 'mips-linux-elf' targets earlier in the day
with no difference. I am still getting the following
mismatch in symbols:

--------------------------------------------------------------------
(gdb) target remote /dev/ttyS1
Remote debugging using /dev/ttyS1
0x80012828 in breakinst () at af_packet.c:1879
1879            sock_unregister(PF_PACKET);
(gdb) bt
#0  0x80012828 in breakinst () at af_packet.c:1879
#1  0x8001a0d4 in sys_create_module (name_user=0x10001dc8 "cfi_probe",
    size=8176) at module.c:305
(gdb) c
Continuing.
--------------------------------------------------------------------

I compiled my kernel with a toolchain that used the following
versions of tools:

    binutils-2.11.90.0.31 (HJLu patches applied)
    gcc-3.0.1 (stock)
    glibc-2.2.3 (minor build patches)

Things are still not working and I would greatly appreciate some
direction. I've blown a whole day this and am a bit frazzled.
Thanks a bunch in advance.

-Steve

-- 
 Steven J. Hill - Embedded SW Engineer

---

From: Daniel Jacobowitz <[email-masked]>
Date: Fri, 14 Sep 2001 00:28:27 -0400

> with no difference. I am still getting the following

(Could you try building a mipsel-unknown-linux-gnu debugger/compiler
instead?  Does it make any difference?  I don't expect it to.)

>     glibc-2.2.3 (minor build patches)

If you'll post a binary that you're having trouble debugging, I'll try
to find time in the next couple of days to see what GDB is doing wrong.

-- 
Daniel Jacobowitz                           Carnegie Mellon University
MontaVista Software                         Debian GNU/Linux Developer

---

From: Andrew Cagney <[email-masked]>
Date: Fri, 14 Sep 2001 10:04:47 -0400

> to find time in the next couple of days to see what GDB is doing wrong.

PUT UP FOR FTP!

---

From: "H . J . Lu" <[email-masked]>
Date: Fri, 14 Sep 2001 08:07:12 -0700

>     configure --prefix=/opt/tools --target=mipsel-linux-elf
					     ^^^^^^^^^^^^^^^

I don't know if it will configure anything for Linux/mips. I use
mipsel-linux.

H.J.

---

From: "Amit S. Kale" <[email-masked]>
Date: Thu, 20 Sep 2001 17:38:01 +0530

Hi,

If you are debugging linux kernel modules, you may find
the loadmodule.sh script from http://kgdb.sourceforge.net/
useful to get a gdb script to load module object files.

-- 
Amit Kale
Veritas Software India ( http://www.veritasindia.com/ )