Subject: link error with ramdisk file

From: Gerald Champagne <[email-masked]>
Date: Fri, 28 Sep 2001 20:27:27 -0500

I'm getting the following error when creating a ramdisk on a big endian system:

$ mips-linux-ld -T ld.script -b binary -o ramdisk.o ramdisk.gz
mips-linux-ld: ramdisk.gz: compiled for a little endian system and target is big 
endian
File in wrong format: failed to merge target specific data of file ramdisk.gz

I get the same error regardless of what I use for the input file.  I don't 
understand how this linker error can occur when the input file format is binary.
Isn't the linker just ignoring the contents of the input file with the
"-b binary" option?

Thanks!

Gerald

---

From: Geoffrey Espin <[email-masked]>
Date: Fri, 28 Sep 2001 18:50:29 -0700

Gerald,

> File in wrong format: failed to merge target specific data of file ramdisk.gz

I recently had this mini-nightmare, too.  I don't recall exactly
what I did to eliminate it.  I'm now using:

    linux/arch/mips/philips/nino/ld.script

and my home-built linker:            :-)

    % mipsel-linux-ld -v
    GNU ld version 2.11.90 (with BFD 2.11.90)

I can't recall whether it was a bad linker, or wrong script, or something else.

What linker and script are you using?

At one stage I used:

    EXTRA_LDFLAGS = --no-warn-mismatch

as a work-around.  But now I've successfully disabled this.

Geoff
-- 
Geoffrey Espin [email-masked]