Subject: How to install the cross-compiler toolchain?

From: "kjlin" <[email-masked]>
Date: Wed, 5 Sep 2001 12:52:13 +0800

Hi 

My host is x86 running RedHat 7.1.
I downloaded the cross-compiler, toolchain-mips-20010810-1.i386.rpm, from the sgi ftp site and tried to install it.
But i found that GLIBC_2.2.3 is needed by toolchain-mips-20010810-1.
However, the system library of RedHat 7.1 is glibc-2.2.2 and the "failed dependencies" error message showed while installing.
Therefore, i downloaded the glibc-2.2.3-13.3.i386.rpm and installed.
But failed.
#rpm -ivh glibc-2.2.3-13.3.i386.rpm 
error: failed dependencies:
                glibc-common = 2.2.3-13.3 is needed by glibc-2.2.3-13.3
                glibc-devel < 2.2.3 conflicts with glibc-2.2.3-13.3
I also tried to install glibc-common-2.2.3-13.3.i386.rpm but still failed.
#rpm -ivh glibc-common-2.2.3-13.3.i386.rpm
error: failed dependencies:
                glibc < 2.2.3 conflicts with glibc-common-2.2.3-13.3

I am confused by the result.
Can anybody tell me how to install the toolchain-mips-20010810-1.i386.rpm successfully?

Thanks in advance.
KJ

---

From: Jean-Christophe ARNU <[email-masked]>
Date: 05 Sep 2001 09:27:40 -0400

> I am confused by the result.

	You should update and not install glibc.
	# rpm -uvh glibc-common-2.2.3.13.3.i386.rpm

-- 
Jean-Christophe ARNU
s/w developer 
Paratronic France

---

From: "kjlin" <[email-masked]>
Date: Wed, 5 Sep 2001 17:51:20 +0800

----- Original Message -----
Subject: Re: How to install the cross-compiler toolchain?

> # rpm -uvh glibc-common-2.2.3-13.3.i386.rpm

It is the same.
Just more error messages.
# rpm -Uvh glibc-common-2.2.3-13.3.i386.rpm
error: failed dependencies:
        glibc < 2.2.3 conflicts with glibc-common-2.2.3-13.3
        glibc-common = 2.2.2-10 is needed by glibc-2.2.2-10

# rpm -Uvh glibc-2.2.3-13.3.i386.rpm
error: failed dependencies:
        glibc-common = 2.2.3-13.3 is needed by glibc-2.2.3-13.3
        glibc-devel < 2.2.3 conflicts with glibc-2.2.3-13.3
        glibc > 2.2.2 conflicts with glibc-common-2.2.2-10
        glibc = 2.2.2 is needed by glibc-devel-2.2.2-10

# rpm -Uvh glibc-devel-2.2.3-13.3.i386.rpm
error: failed dependencies:
        glibc = 2.2.3 is needed by glibc-devel-2.2.3-13.3