Subject: RE: RE: _gp_disp

From: "Sun, Lei" <[email-masked]>
Date: Wed, 12 Sep 2001 12:48:57 -0400

Hi:
  Unfortunately, make clean didn't work, the linking problem still sit
there!

thanks
lei 

-----Original Message-----
From: Zhang Fuxin [mailto:[email-masked]]
Sent: Wednesday, September 12, 2001 12:38 PM
To: Sun, Lei
Cc: [email-masked]
Subject: Re: RE: _gp_disp

Sun, Lei，您好！

 I think a make clean will do.
 You got some .o lurking compiled without the flags

在 2001-09-12 11:57:00 您写道：
>Thanks for the kind response.
>after modified my Makefile according to Pete's suggestion, But I got the
>following erro when linking
>/opt/Embedix/tools/mipsel-linux/bin/ld: prism2dl.o: linking PIC files with
>non-P
>IC files
>/opt/Embedix/tools/mipsel-linux/bin/ld: prism2dl.o: uses different e_flags
>(0x100) fields than previous modules(0x0)
>Bad value: failed to merge target specific data of file prism2dl.o
>
>ANy more input?
>thank you!
>lei 
>
>-----Original Message-----
>From: Jun Sun [mailto:[email-masked]]
>Sent: Monday, September 10, 2001 7:18 PM
>To: Pete Popov
>Cc: Sun, Lei; Debian-Mips (E-mail)
>Subject: Re: _gp_disp
>
>
>Pete Popov wrote:
>> 
>> Sun, Lei wrote:
>> > Hi:
>> >   I was trying to port a wireless lan driver to MIPS based platform
(IDT
>> > 79S334), the compilation seems fine, But when I try to load the created
>> > module, it tells me "unresoved symbol _gp_disp".( I cross-compiled it
by
>> > mipsel-gcc compiler).
>> >   By doing a quick grep in the driver source, I didn't find the gp_disp
>> > symbol. My question is where did the _gp_disp come from and how I
should
>> > solve this problem?
>> >
>> > Appreciate your help!
>> 
>> You did not use the correct gcc options. Add these to your gcc flags and
>it
>> should work (replace -mcpu=<cpu> if you need to):
>> 
>> -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing
-G
>0
>> -mno-abicalls -fno-pic -mcpu=r4600 -mips2 -Wa,--trap -pipe -DMODULE
>-mlong-calls
>>    -DEXPORT_SYMTAB
>> 
>
>I think some of the options might not be necessary, but you definitely need
>"-DKERNEL"
>
>Jun
>
>
>-- 
>To UNSUBSCRIBE, email to [email-masked]
>with a subject of "unsubscribe". Trouble? Contact
[email-masked]

                    致
礼！

            Zhang Fuxin
            [email-masked]

---

From: "H . J . Lu" <[email-masked]>
Date: Wed, 12 Sep 2001 09:50:11 -0700

>   Unfortunately, make clean didn't work, the linking problem still sit

Please check the kernel source how to build the mips kernel modules.

# make modules

should give you a clue.

H.J.

---

From: Pete Popov <[email-masked]>
Date: Wed, 12 Sep 2001 10:00:54 -0700

>   Unfortunately, make clean didn't work, the linking problem still sit

Do you have a binary image that you're trying to link, such as a ramdisk?

Pete

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 13 Sep 2001 01:45:42 +0200

>   Unfortunately, make clean didn't work, the linking problem still sit

This is a linker bug which has been fixed several months ago.

  Ralf