Subject: RE: How to access kernel memory?

From: "Siders, Keith" <[email-masked]>
Date: Tue, 18 Sep 2001 09:59:07 -0500

I have just the opposite requirement. I need to allow any running process
and its threads to be "hot-patched" with executable code. I know you're
thinking "why?". I can't tell you that. I can only say  it's a firm
requirement, and I could use some helpful ideas.

Keith 

-> -----Original Message-----
-> From: Zhang Fuxin [mailto:[email-masked]]
-> Sent: Tuesday, September 18, 2001 9:53 AM
-> To: han han
-> Cc: [email-masked]
-> Subject: Re: How to access kernel memory?
-> 
-> 
-> hi,han han，
->    There are several ways.For example:
->    1.You can create a character device , implement its mmap function
-> to map the memory block you allcated.This can be done in a little
-> kernel module.There are some sample code before.
->    2.via /dev/mem,/dev/kmem etc
->    
-> 
-> 
-> 
-> 在 2001-09-18 07:35:00 you wrote：
-> >Hi, All,
-> >
-> >I allocated a block of memory in the kernel space. But
-> >I don't know how to directly access kernel space from
-> >user space. Anyone can help me?
-> >
-> >Thanks in advance.
-> >
-> >piggie
-> >
-> >
-> >__________________________________________________
-> >Terrorist Attacks on U.S. - How can you help?
-> >Donate cash, emergency relief information
-> >http://dailynews.yahoo.com/fc/US/Emergency_Information/
-> 
-> Regards
->             Zhang Fuxin
->             [email-masked]
->

---

From: Daniel Jacobowitz <[email-masked]>
Date: Tue, 18 Sep 2001 14:41:29 -0400

> requirement, and I could use some helpful ideas.

You can probably do all you need in this case with ptrace() - the
existing ptrace will not be quite adequate for large data sets,
especially if you need some atomicity, but it should have all the
sample kernel code you need.

-- 
Daniel Jacobowitz                           Carnegie Mellon University
MontaVista Software                         Debian GNU/Linux Developer