Subject: recent gdb add-symbol-file problem?

From: "renc stone" <[email-masked]>
Date: Mon, 24 Sep 2001 17:17:07 +0800

hi ,
 I use gdb 20010919 source form sources.redhat.com,
 target mipsel, host i386 box.

When I want to use this to debug some module of linux-mips kernel ,
trouble comes:

When I use the add-symbol-file command to add the symbols of module,

add-symbol-file mymodule.o 0xc001e060
gdb echos no problem,
but it seems to be confused:
the command
b my_func1
b my_func2
b my_func3

all show the same address, all the functions starts from ONE place?
I checked the address, it's the text section start address of this module.
Can't the gdb  correctly read the elf file of mipsel ?

 Any ideas?  Or anyone who have done this  please tell me how to get through
it .

---

From: Alexandre Oliva <[email-masked]>
Date: 27 Sep 2001 06:33:40 -0300

>  Any ideas?

You got the wrong mailing list.  gcc != gdb.

-- 
Alexandre Oliva   Enjoy Guarana', see http://www.ic.unicamp.br/~oliva/
Red Hat GCC Developer                  aoliva@{cygnus.com, redhat.com}
CS PhD student at IC-Unicamp        oliva@{lsd.ic.unicamp.br, gnu.org}
Free Software Evangelist    *Please* write to mailing lists, not to me