Subject: RE: Signal 11 on Process Termination - Update

From: Phil Thompson <[email-masked]>
Date: Wed, 5 Sep 2001 11:07:58 +0100

This fixed the problem - many thanks.

Ralf - is this patch going to be applied (the current CVS seems unusable
without it)?

Phil

> -----Original Message-----
> From: Atsushi Nemoto [mailto:[email-masked]]
> Sent: 05 September 2001 01:30
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Signal 11 on Process Termination - Update
> 
> 
> >>>>> On Tue, 4 Sep 2001 18:48:33 +0100 , Phil Thompson 
> <[email-masked]> said:
> Phil> The SIGSEGV is being raised because the access_ok() in
> Phil> setup_frame() in kernel/signal.c is failing when trying to
> Phil> deliver another signal (SIGALRM or SIGCHLD in my cases).
> 
> At setup_frame(), sp (regs->regs[29]) is in the kernel kernel stack,
> isn't it?
> 
> If so, please try a patch for entry.S I posted a couple days ago.
> 
> > Subject: Re: segfaults with 2.4.8
> 
> Hope this helps.
> ---
> Atsushi Nemoto
>

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 6 Sep 2001 02:24:49 +0200

> Ralf - is this patch going to be applied (the current CVS seems unusable

I've applied a different patch to CVS.

I've got other different problems with the current CVS; the 32-bit kernel
is very unreliable for me on 32-bit machines.

  Ralf

---

From: Pete Popov <[email-masked]>
Date: Wed, 05 Sep 2001 17:39:03 -0700

> is very unreliable for me on 32-bit machines.

That's my experience as well, just FYI.

Pete