Subject: RedHat 7.1/mips update

From: "H . J . Lu" <[email-masked]>
Date: Wed, 24 Oct 2001 12:16:46 -0700

I updated my RedHat 7.1/mips port. There are quite a few changes. Check it
out.

H.J.
-----
My mini-port of RedHat 7.1 is at

ftp://oss.sgi.com/pub/linux/mips/redhat/7.1/

you should be able to put a small RedHat 7.1 on the mips/mipsel box and
compile the rest of RedHat 7.1 yourselves.

Here are something you should know:

1. The cross compiler hosted on RedHat 7.1/ia32 is provided as a
toolchain rpm. The binary rpms for the mips and mipsel cross compilers
are included. You may need glibc 2.2.3-11 or above to use those
rpms. The glibc x86 binary rpms under RPMS/i386 should be ok.
2. You have to find a way to put those rpms on your machine. I use
network boot and NFS root to do it.
3. install.tar.bz2 has some scripts to prepare NFS root and install
RedHat 7.1 on a hard drive.
4. baseline.tar.bz2 contains the cross build tree.
5. Since everything is cross compiled from x86, which is little endian,
many data files for mips, which is big endian, are either missing or
wrong. To get those data files for mips, you have to rebuild/install
the folowing rpms:

cracklib
glibc

natively on Linux/mips.

Thanks.

H.J.

---

From: "Gleb O. Raiko" <[email-masked]>
Date: Thu, 25 Oct 2001 11:07:07 +0400

> I updated my RedHat 7.1/mips port. There are quite a few changes. Check it

Could you provide a changelog ?

Regards,
Gleb.

---

From: "H . J . Lu" <[email-masked]>
Date: Thu, 25 Oct 2001 00:13:59 -0700

> Could you provide a changelog ?

I don't have the time for it. Just do ls and compare it against what
you have. I updated quite a few rpms, most of them taken from RedHat
7.1 updates.

H.J.

---

From: Geoffrey Espin <[email-masked]>
Date: Thu, 25 Oct 2001 15:15:06 -0700

H.J.

> I updated my RedHat 7.1/mips port. There are quite a few changes. Check it

Thanks... works great, as did the last one, as far as I could tell.
Sadly, the only fix I wanted didn't make it in:

 mipsel-linux-gcc ...
 Assembler messages:  
 Warning: The -mcpu option is deprecated.  Please use -march and -mtune instead.
 Warning: The -march option is incompatible to -mipsN and therefore ignored.

Oh, well.  :-)

Geoff
-- 
Geoffrey Espin
[email-masked]

---

From: "H . J . Lu" <[email-masked]>
Date: Thu, 25 Oct 2001 15:25:32 -0700

>  Warning: The -march option is incompatible to -mipsN and therefore ignored.

It is intentional. Do what the message says. I only have to check my
arch/mips/Makefile from -mcpu=xxx to -mtune=xxx.

H.J.

---

From: Paul Kasper <[email-masked]>
Date: Wed, 31 Oct 2001 14:20:22 -0500

> ftp://oss.sgi.com/pub/linux/mips/redhat/7.1/
.....
> H.J.

I am trying to install from a SuSE 7.2 workstation. In an effort to get
findrpm to work, I updated my RPMs with 2 of yours and 2 from RedHat:
------------------------------
scooby:/opt/rh71_oss/install # rpm -Uhv  
../RPMS/i386/rpm-python-4.0.2-8.6.i386.rpm
../RPMS/i386/rpm-4.0.2-8.6.i386.rpm
/opt/download/RPMS/db1-1.85-7.i386.rpm
/opt/download/RPMS/patch-2.5.4-9.i386.rpm 
Preparing...                ###########################################
[100%]
package rpm-python-4.0.2-8.6 is already installed
package rpm-4.0.2-8.6 is already installed
package db1-1.85-7 is already installed
package patch-2.5.4-9 is already installed
scooby:/opt/rh71_oss/install # rpm -qa |grep python
python-imaging-1.1-68
python-tk-2.0-90
python-2.0-90
python-doc-2.0-90
python-devel-2.0-90
python-nothreads-2.0-90
python-demo-2.0-90
rpm-python-4.0.2-8.6
scooby:/opt/rh71_oss/install # rpm -qa |grep rpm   
rpm2html-1.5-16
rpmfind-1.6-62
autorpm-1.9.9-14
xrpm-2.2-333
rpm-4.0.2-8.6
rpm-python-4.0.2-8.6
scooby:/opt/rh71_oss/install # ./findrpm gcc
Traceback (most recent call last):
  File "./findrpm", line 5, in ?
    import rpm
ImportError: No module named rpm        <----- ??? -----
scooby:/opt/rh71_oss/install # 

------------------------------

Not being much of a python person, does anybody have any suggestions? 
Should I upgrade more of the python packages even though there are no
complaints regarding depenencies?

Any suggestions welcomed.

--
Paul Kasper
-- 
 /"\ . . . . . . . . . . . . . . . /"\
 \ /   ASCII Ribbon Campaign       \ /     Paul R. Kasper
  X    - NO HTML/RTF in e-mail      X      Patton Electronics Co.
 / \   - NO MSWord docs in e-mail  / \     301-975-1000 x173

---

From: "H . J . Lu" <[email-masked]>
Date: Wed, 31 Oct 2001 11:29:38 -0800

> findrpm to work, I updated my RPMs with 2 of yours and 2 from RedHat:

Only RedHat 7.1 is supported.

H.J.