Subject: other info about Toshiba TX3927 board boot problem.

From: 8route <[email-masked]>
Date: Mon, 29 Oct 2001 17:54:15 +0800

Dear Atsushi:
  Hi!
  I found the reset switch on the TX3927 board can work if you switch it
against the PCI interface when
==================================
  VFS: Mounted root (NFS filesystem).
  Freeing unused kernel memory: 44k freed 
========================================
,usually I switch it towards the PCI interface.

  And I have fixed the source code of process.c as you said.
>For TX3927, you must skip those two lines in exit_thread() and
>flush_thread().
>
>		set_cp0_status(ST0_CU1, ST0_CU1);
>		__asm__ __volatile__("cfc1\t$0,$31");
>
>
But the problem still exists.The serial console output will stop at
==================================
  VFS: Mounted root (NFS filesystem).
  Freeing unused kernel memory: 44k freed 
========================================

  I think that maybe the Linux system has booted up OK,but there is
something wrong with the serial console because serial ports are integrated
with TX3927.Do you agree?Please consider it in your latest patch.
>By the way, now I'm planning to send patches for TX CPU boards
>(including JMR3927) to oss.sgi.com.  If you can wait a while, you can
>try it.
Thank you very much.

8route
[email-masked]
10/29/2001

---

From: Alice Hennessy <[email-masked]>
Date: Mon, 29 Oct 2001 17:46:27 -0800

> against the PCI interface when

I have already submitted a patch to Ralf for the JMR3927 and am waiting for
his reply.
We should coordinate to make sure we don't overwrite each other.

Alice