Subject: Origin 200

From: Lukas Hejtmanek <[email-masked]>
Date: Wed, 24 Oct 2001 22:40:08 +0200

Is someone here who succesfully booted up an 1 processor Origin 200? I've tried
to boot some kernels -- result freeze without oops or oops result. Kernel 2.4.10
is configured with defconfig-ip27, with or without SMP support. Everything seems
to get the same result.

Is there any remote gdb howto? Especially for origin where serial port is used
as serial console. (I think gdb must connect to kernel before oops or freeze)

-- 
Lukáš Hejtmánek

---

From: <[email-masked]>
Date: Wed, 24 Oct 2001 16:48:13 -0400 (EDT)

I had very similar problems, where does it oops?  I lost access to the
origin that was haveing problems before tracking it down :(.
	Nick

On Wed, 24 Oct 2001, Lukas Hejtmanek wrote:

> Luká¹ Hejtmánek

---

From: Lukas Hejtmanek <[email-masked]>
Date: Wed, 24 Oct 2001 23:06:01 +0200

On Wed, Oct 24, 2001 at 04:48:13PM -0400, [email-masked] wrote:
> I had very similar problems, where does it oops?  I lost access to the origin
> that was haveing problems before tracking it down :(.  Nick

It seems to be at random place. I don't know what correct boot mesages look
like. Few times it freezed after amount memmory message, few times after message
about RT Link socket (or somewhat), sometimes after serial driver initialized.
Once it freezed after scsi driver loaded. I think it has nothing to do with any
driver because the same kernel freez or oops at different place.

Do you have any idea how to track it down?

-- 
Lukáš Hejtmánek

---

From: <[email-masked]>
Date: Wed, 24 Oct 2001 18:49:17 -0400 (EDT)

That's exactly the issues I was running into.  Talk to Ralf.  Erm, is it a
company system?
	Nick

---

From: Lukas Hejtmanek <[email-masked]>
Date: Thu, 25 Oct 2001 01:04:25 +0200

On Wed, Oct 24, 2001 at 06:49:17PM -0400, [email-masked] wrote:
> That's exactly the issues I was running into.  Talk to Ralf.  Erm, is it
> a company system?  

No, we have that box at school. Why? IRIX is normally running there but we have
forgotten root password ;-)

Also it is my diploma work to make it run in 64bit mode.

-- 
Lukáš Hejtmánek

---

From: <[email-masked]>
Date: Wed, 24 Oct 2001 20:23:00 -0400 (EDT)

Getting it running 64bit shouldn't be *too* bad, however there are some
revs of some chips on the MB which linux currently can't deal with, and
noone is quite sure 1. what revs, 2. why, or 3. anything
usefull. <Grin>.  Could you send a hinv -v from the prom?  Boot logs would
also be usefull (so I can tell if we are haveing the exact same problem,
or just similar ones)
	Thanks
		Nick

---

From: Lukas Hejtmanek <[email-masked]>
Date: Thu, 25 Oct 2001 10:33:33 +0200

>> hinv -v
IP27 Node Board, Module 1, Slot MotherBoard
    ASIC HUB Rev 3, 90 MHz, (nasid 0)
    Processor A: 180 MHz R10000, Rev 2.6, 1M  120MHz secondary cache, (cpu 0)
      R10000FPC  Rev 0
    Memory on board, 64 MBytes (Standard)
      Bank 0, 64 MBytes (Standard) <-- (Physical Bank 0)
BASEIO Origin 200 IO Board, Module 1, Slot MotherBoard
    ASIC BRIDGE Rev 3, (widget 8)
    adapter PCI-SCSI Rev 4, (pci id 0)
        peripheral SCSI DISK, ID 1, SGI IBM DORS-32160W
    adapter PCI-SCSI Rev 4, (pci id 1)
        peripheral SCSI CDROM, ID 6, TOSHIBA CD-ROM XM-5401TA
    adapter IOC3 Rev 1, (pci id 2)
        controller multi function SuperIO
        controller Ethernet Rev 1
    adapter PCI-SCSI Rev 5, (pci id 5)

-- 
Lukáš Hejtmánek

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 25 Oct 2001 12:14:50 +0200

>     ASIC HUB Rev 3, 90 MHz, (nasid 0)
[...]

Pretty much a standard Origin.  I suspect the problem might be related to
machines which only have a single physical CPU, that was the only common
thing between all the Origins on which Linux fails.  And indeed I don't
think we ever used such a small configuration for testing at SGI ...

Nick, did you observe any interesting differences to your failing Origin
configuration?

Btw, Origin UP kernel is definately broken ...

  Ralf

---

From: <[email-masked]>
Date: Thu, 25 Oct 2001 14:59:41 -0400 (EDT)

I didn't notice any huge differences.  My ASIC HUB ran at a different
speed, 120mhz IIRC.  I will try to aquire a single proc module for my
o200.  Lukas: Can I get a copy of your boot messages under linux?
	Thanks
		Nick

---

From: Lukas Hejtmanek <[email-masked]>
Date: Fri, 26 Oct 2001 13:02:12 +0200

> o200.  Lukas: Can I get a copy of your boot messages under linux?

Copy of boot messages are at www.fi.muni.cz/~xhejtman/mips

I've tried compile as small kernel as possible config is also at that web page
messages also. It seems it booted ok to the last message kernel panic no root
(that's ok nfsroot was not compiled in) But I tested it only once so mayby it is
just random behaviour.

-- 
Lukáš Hejtmánek

---

From: Lukas Hejtmanek <[email-masked]>
Date: Fri, 26 Oct 2001 16:31:17 +0200

> Btw, Origin UP kernel is definately broken ...

I think I've tracked down what makes freeze. If I use default config but
network card driver and scsi driver (seems to be generic PCI device) kernel
boots up to message I have no root (any time and not freezes I've changed little
bit sources to print '... waiting ...' every 2 seconds in infinite loop before
it does panic -- no root).

So I think there is some deadlock after some PCI device driver init that does
not occur in SMP mode.

-- 
Lukáš Hejtmánek

---

From: <[email-masked]>
Date: Fri, 26 Oct 2001 18:13:24 -0400 (EDT)

That was the same "fix" I came across.  I'm still not sure why though.
	Nick

---

From: Lukas Hejtmanek <[email-masked]>
Date: Sat, 27 Oct 2001 01:09:58 +0200

> That was the same "fix" I came across.  I'm still not sure why though.

However it should be found with gdb but I don't know how to setup remote
debugging, gdb always writes that it is unable to connect.
Is there any remote gdb how-to?

-- 
Lukáš Hejtmánek