Subject: First attempt to install Linux on my Indigo 2

From: Mat Withers <[email-masked]>
Date: Mon, 22 Oct 2001 13:06:59 +0100

Hi

I've been subscribed to the list for quite a while but am just about to try installing Linux on my Indigo2 (R4400SC / 128Mb RAM) for the first time.

I want to try H J Lu's port of Radhat 7.1. I've read the the howto at http://oss.sgi.com/mips/mips-howto.html, have set up a tftp server a bootp server an nfs server and have made up a working serial cable. Now having browsed ftp://oss.sgi.com/pub/linux/mips/redhat/7.1/ I am unsure what to do next. I assume I will need a kernel image and a root filing system to nfs mount but can't see anything resembling them on the ftp site.

I have a spare 4Gb scsi disk that I want to attempt the install on. I assume that once I have got the machine booted using an nfs root I can partion the hard disk - somehow install the RPMS on it and then use dvhtool to get my SGI to boot from the hard disk.

Is this all feasible ? has anyone got any hints or gottcha's ?

Thanks in advance for any help

Cheers

Mat

-- 

Mat Withers
[email-masked]
http://minus-9.com
phone/fax: +44 07092 375299
"a sarcasm detector, *that's* a real useful invention."

---

From: "H . J . Lu" <[email-masked]>
Date: Mon, 22 Oct 2001 12:19:19 -0700

> I want to try H J Lu's port of Radhat 7.1. I've read the the howto at http://oss.sgi.com/mips/mips-howto.html, have set up a tftp server a bootp server an nfs server and have made up a working seri…

1. You need to find a working kernel for your machine. I don't have
one.

2. In README:

3. install.tar.bz2 has some scripts to prepare NFS root and install
RedHat 7.1 on a hard drive.

>From README:

3. install.tar.bz2 has some scripts to prepare NFS root and install
RedHat 7.1 on a hard drive.

H.J.