Subject: Strange behavior of serial console under 2.4.9

From: "H . J . Lu" <[email-masked]>
Date: Thu, 18 Oct 2001 18:57:17 -0700

The serial console under 2.4.9 is very strange. It is very slow. I have
no such problem with 2.4.3/2.4.5. Telnet is fine.

H.J.

---

From: "Bradley D. LaRonde" <[email-masked]>
Date: Thu, 18 Oct 2001 22:11:18 -0400

I haven't noticed that.  I just ran top with 0 delay at 115200 and it seems
normally fast to me.

Regards,
Brad

---

From: "H . J . Lu" <[email-masked]>
Date: Thu, 18 Oct 2001 19:40:14 -0700

> I haven't noticed that.  I just ran top with 0 delay at 115200 and it seems

I am using 9600 buad. It used to be ok under 2.4.3/2.4.5. But under
2.4.9, the first 10 minutes after boot is very slow. After that, it
seems ok.

H.J.

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Fri, 19 Oct 2001 15:26:10 +0200 (MET DST)

> 2.4.9, the first 10 minutes after boot is very slow. After that, it

 That might be driver-specific.  I'm using drivers/tc/zs.c and it works
fine at 115200 bps.

-- 
+  Maciej W. Rozycki, Technical University of Gdansk, Poland   +
+--------------------------------------------------------------+
+        e-mail: [email-masked], PGP key available        +

---

From: "Bradley D. LaRonde" <[email-masked]>
Date: Fri, 19 Oct 2001 09:54:35 -0400

H.J., which serial driver are you using?

Regards,
Brad

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 19 Oct 2001 17:47:24 +0200

>  That might be driver-specific.  I'm using drivers/tc/zs.c and it works

I haven't noticed this problem ever on Origins which use the standard
16550 driver.

  Ralf

---

From: Jun Sun <[email-masked]>
Date: Fri, 19 Oct 2001 09:53:46 -0700

> no such problem with 2.4.3/2.4.5. Telnet is fine.

That is usually a symptom when the serial interrupts are not correctly
delivered.

Jun

---

From: "Bradley D. LaRonde" <[email-masked]>
Date: Fri, 19 Oct 2001 13:10:39 -0400

Let's try that again...

Agreed - I've seen it once where it spit 16 chars, long pause, 16 more
chars, etc.  This was due to the serial driver not getting interrupts.

Regards,
Brad

---

From: Wayne Gowcher <[email-masked]>
Date: Fri, 26 Oct 2001 09:12:59 -0700 (PDT)

Dear All,

I am having a problem with the backspace key on a
virtual terminal on a 2.4.2 kernel. If I hit backspace
when there is input at the command line - no problem
it deletes the character before the cursor.
But if I press backspace when there are no characters
at the command prompt, the kernel throws an oops. The
process causing the oops is Bash.
Note, on the Serial console, backspace works fine all
the time.

Has anyone ever seen anything like this ? If you have
how did you solve it ?

Does anyone know the program flow / program details of
what happens when backspace is pressed eg :

    Key In > Key passed to Routine X > Routine X
passes it to Routine Y etc > Bash receives key.

Or could someone point me to a doc that may explain
this ?

Thx

__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com

---

From: "Gleb O. Raiko" <[email-masked]>
Date: Fri, 26 Oct 2001 21:30:20 +0400

> Has anyone ever seen anything like this ? If you have

Guess 1: You've got PC UARTs and drivers/char/serial.c
Guess 2: TAB TAB in bash causes the oops too.
Guess 3: You didn't change famous beep function in the driver.

Regards,
Gleb.

---

From: Pete Popov <[email-masked]>
Date: Fri, 26 Oct 2001 11:05:42 -0700

> Note, on the Serial console, backspace works fine all

I'll make a guess.  With no input at the line, when you hit backspace,
the shell is probably generating a beep.  Your kernel is not handling
that.  I don't remember exactly where the "beep code" was but you can
probably find it pretty quickly.

Pete

---

From: James Simmons <[email-masked]>
Date: Fri, 26 Oct 2001 11:11:16 -0700 (PDT)

> probably find it pretty quickly.

linux/drivers/char/vt.c.

It is the functions kd_nosound and _kd_mksound.

---

From: Wayne Gowcher <[email-masked]>
Date: Fri, 26 Oct 2001 11:37:51 -0700 (PDT)

Gleb,

> Guess 3: You didn't change famous beep function in

Correct on all 3 counts. Thanks for pointing the way.

Also thanks to Pete Popov and James Simmons. In
particular to James for telling me to look at vt.c,
functions kd_nosound and _kd_mksound. I changed the
ifdef to be aware of my board and now the problem is
solved.

To All,

I am grateful that my problem was solved quickly. But
before I posted to the list I did a search on
"Backspace oops linux", "Backspace crash linux" and a
few other combinations to see if this was possibly a
known problem. But turned nothing up.
Is there any other list / repository I should be
looking at to pick up on bugs like this ?

Any tips / info would be greatly appreciated.

Wayne

---

From: "Gleb O. Raiko" <[email-masked]>
Date: Mon, 29 Oct 2001 11:26:48 +0300

> Correct on all 3 counts. Thanks for pointing the way.

In fact, guess 1 is irrelevant. :-)

> Any tips / info would be greatly appreciated.

This is a famous problem, just look at vt.c, you'll see a lot of ifdefs
around sound routines. Just every porting engineer who encounter this
problem solved it himself (and added own ifdef to vt.c). In my case, I
just got fault epc, found the address in objdump -D output and look at
the sources. For me it seems easier, than posting a message to a list.
<nothing personal, really>

Regards,
Gleb.

---

From: James Simmons <[email-masked]>
Date: Mon, 29 Oct 2001 10:21:22 -0800 (PST)

> <nothing personal, really>

I plan to have this problem removed in 2.5.X when the console system is
migrated to the input api :-)