Subject: RE: 1$ clobber bug

From: James Simmons <[email-masked]>
Date: Tue, 6 Nov 2001 11:44:20 -0800 (PST)

Sorry I got the patch backwards. It seems that the standard 2.4.14 tree
some how missed the $1 clobber fixes but it merged alot of other things.
Strange. 

I believe the ITE generic time code has a 1$ clobber bug in it. Here is a
patch to fix this.

--- time.c	Fri Oct  5 10:01:22 2001
+++ /usr/src/linux/arch/mips/ite-boards/generic/time.c	Tue Nov  6 11:38:00 2001
@@ -303,7 +303,8 @@
 			:"r" (timerhi),
 			 "m" (timerlo),
 			 "r" (tmp),
-			 "r" (USECS_PER_JIFFY));
+			 "r" (USECS_PER_JIFFY)
+			:"$1");
 		cached_quotient = quotient;
 	}

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 6 Nov 2001 13:05:31 -0800

> I believe the ITE generic time code has a 1$ clobber bug in it. Here is a

There is no point in a "$1" clobber.

  Ralf