Subject: Power MGMT on mips

From: "Han-Seong Kim" <[email-masked]>
Date: Mon, 12 Nov 2001 17:13:40 +0900

Hi, 

I want to ask about Power-Mnagement on mips.
1. Is it possible to use power mgnt (ex. apm,acpi) features of linux kernel?
2.If no, how can manage CPU and Bidge chips for power mgnt ?

Han-Seong

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 12 Nov 2001 23:30:31 +1100

> 1. Is it possible to use power mgnt (ex. apm,acpi) features of linux kernel?

Both are PC stuff, so no.

> 2.If no, how can manage CPU and Bidge chips for power mgnt ?

Right now Linux/MIPS will only use the CPU's power managment features, that
is the wait instruction or similar.

  Ralf

---

From: James Simmons <[email-masked]>
Date: Mon, 12 Nov 2001 13:50:28 -0800 (PST)

> is the wait instruction or similar.

What would be nice that I have been thinking about is making a cpu scale
api very similiar to what ARM has.

---

From: "Han-Seong Kim" <[email-masked]>
Date: Mon, 19 Nov 2001 21:13:08 +0900

Hi Ralf,

I reviewed the data sheet of Mips CPU - QED RM5231.
There is a wait instruction.
But when the SysAD bus goes to idle, the wait instruction is valid.
How can I SysAD bus make idle state?

Han-Seong

-----Original Message-----
From: Ralf Baechle [mailto:[email-masked]]
Sent: Monday, November 12, 2001 9:31 PM
To: Han-Seong Kim
Cc: [email-masked]; [email-masked]
Subject: Re: Power MGMT on mips

  Ralf