Subject: Re: do_ri( )

From: "Bradley D. LaRonde" <[email-masked]>
Date: Sun, 4 Nov 2001 23:33:10 -0500

I've seen the same thing but on a different processor (VR5432).  gcc 3.0.1,
glibc 2.2.3.  I suspect stack/register corruption.

Regards,
Brad

----- Original Message -----
From: Green
To: Linux-mips ; MipsMailList
Sent: Sunday, November 04, 2001 10:43 PM
Subject: do_ri( )

Dear all,

    I often get into trouble executing multithread application.
    Sometimes it will appear the message " Illegal instruction = 0xXXXX " in
    do_ri() function in /arch/mips/kernel/traps.c.
    It happened randomly.

    Up to now, I still didn't know how to fix bug.
    If any one know how to fix it, please reply me.
    Appreciate in sincerely.

    P.S  My mips bos is R3912.

~~
Green  [email-masked]

---

From: Waren Hardy <[email-masked]>
Date: Wed, 07 Nov 2001 16:50:46 -0800

I have a small prototype board with a mips 4kc on it and I have linux 
running. I have to megs of sram mapped how do i map in sdram ?

the memory map looks like

0000.0000 - 0001f.ffff 2M SRAM
0020.0000 - 0020.1fff 8K Embedded SRAM CPU
0020.2000 - 002f.fffff reserved
0030.0000 - 0030.ffff 64K Chip registers
0031.0000 - 00ff.ffff reserved
0100.0000 - 01ff.ffff 16M SDRAM
0200.0000 - 1fb0.ffff SDRAM
1fc0.0000 - 1fdf.ffff 2M ROM / FLASH
0060.0000 - ffff.ffff SDRAM

how do I get linux to read this 16M SDRAM @ 0100.000 - 01ff.ffff ? Then 
how do I get linux to read RAM @ 0200.000 - 1fb0.ffff and 0060.000 - 
ffff.ffff ?

We have our own load which is loading linux from ROM, and we can pass 
arg to linux, can the memory be set as an argument passed ?

Thanks for you help

Warren Hardy