Subject: [PATCH] NONCOHERENT_IO Decstation ?!

From: Florian Lohoff <[email-masked]>
Date: Tue, 27 Nov 2001 12:21:52 +0100

My Decstation /150 does not get the point 

SCSI subsystem driver Revision: 1.00
SCSI ID 7 Clk 25MHz CCF=5 TOut 167 NCR53C9x(esp236)
SCSI ID 7 Clk 12MHz CCF=3 TOut 139 NCR53C9x(esp236)
SCSI ID 7 Clk 12MHz CCF=3 TOut 139 NCR53C9x(esp236)
ESP: Total of 3 ESP hosts found, 3 actually in use.
scsi0 : ESP236 (NCR53C9x)
scsi1 : ESP236 (NCR53C9x)
scsi2 : ESP236 (NCR53C9x)
scsi: unknown type 17
  Vendor:           Model:     >   <   è½ .  Rev:     
  Type:   Unknown                            ANSI SCSI revision: 01
resize_dma_pool: unknown device type 17
resize_dma_pool: unknown device type 17

Without:

Index: arch/mips/config.in
===================================================================
RCS file: /cvs/linux/arch/mips/config.in,v
retrieving revision 1.151
diff -u -r1.151 config.in
--- arch/mips/config.in	2001/11/26 12:01:08	1.151
+++ arch/mips/config.in	2001/11/27 12:17:26
@@ -292,6 +292,10 @@
        define_bool CONFIG_PC_KEYB y
 fi                             
 
+if [ "$CONFIG_DECSTATION" = "y" ]; then
+       define_bool CONFIG_NONCOHERENT_IO y
+fi
+
 if [ "$CONFIG_ISA" != "y" ]; then
    define_bool CONFIG_ISA n
    define_bool CONFIG_EISA n

Now the current cvs boots until userspace but its not very happy.

-----------------------------------
/etc/init.d/rcS: line 28:    32 Illegal Instruction     grep -qs resync
/proc/mdstat
Starting portmap daemon: portmap.
/etc/init.d/rcS: line 57:    39 Illegal Instruction     ( trap - INT
QUIT TSTP; set start; . $i )

Setting the System Clock using the Hardware Clock as reference...
/etc/init.d/rcS: line 57:    40 Illegal Instruction     ( trap - INT
QUIT TSTP; set start; . $i )
Cleaning: /tmp /var/lock /var/run.
Initializing random number generator... done.
-----------------------------------

Ill dig into this later ...

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
Nine nineth on september the 9th              Welcome to the new billenium

---

From: James Simmons <[email-masked]>
Date: Tue, 27 Nov 2001 08:58:14 -0800 (PST)

> Index: arch/mips/config.in

We got nailed by this to. Ralph I like to suggest that we add 

set CONFIG_NONCOHERENT_IO 

to arch/mips/Config.in since most devices of this type don't support 
IO coherency.