Subject: [PATCH] arc_setup_console obsolete ?

From: Florian Lohoff <[email-masked]>
Date: Tue, 27 Nov 2001 00:32:28 +0100

This doesnt exist anywhere else - I would consider this history ?

diff -u -r1.9 init.c
--- arch/mips/arc/init.c	2001/01/27 04:34:10	1.9
+++ arch/mips/arc/init.c	2001/11/27 00:31:47
@@ -23,8 +23,6 @@
 
 extern void prom_testtree(void);
 
-extern void arc_setup_console(void);
-
 void __init prom_init(int argc, char **argv, char **envp, int *prom_vec)
 {
 	struct linux_promblock *pb;
@@ -35,19 +33,6 @@
 	prom_argv = argv;
 	prom_envp = envp;
 
-#if 0
-	/* arc_printf should not use prom_printf as soon as we free
-	 * the prom buffers - This horribly breaks on Indys with framebuffer
-	 * as it simply stops after initialising swap - On the Indigo2 serial
-	 * console you will get A LOT illegal instructions - Only enable
-	 * this for early init crashes - This also brings up artefacts of
-	 * printing everything twice on serial console and on GFX Console
-	 * this has the effect of having the prom printing everything
-	 * in the small rectangle and the kernel printing around.
-	 */
-
-	arc_setup_console();
-#endif
 	if (pb->magic != 0x53435241) {
 		prom_printf("Aieee, bad prom vector magic %08lx\n", pb->magic);
 		while(1)

-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
Nine nineth on september the 9th              Welcome to the new billenium

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 27 Nov 2001 17:34:16 +1100

> This doesnt exist anywhere else - I would consider this history ?

Correct, patch applied.

  Ralf