Subject: Which usrland packages should be built for swapon, hostname,and grep?

From: "Steven Liu" <[email-masked]>
Date: Fri, 9 Nov 2001 12:16:11 -0800

Hi All:

I am porting linux to mips r3000 now and need to build the following
files for the target board:
    /sbin/swapon,
   /bin/hostname,
   /bin/mount,
   /bin/grep.
Which usrland packages should I use for the above files?

Any help should be greatly appreciated.

Thank you.

Steven Liu

---

From: Geoffrey Espin <[email-masked]>
Date: Fri, 9 Nov 2001 12:30:01 -0800

> Which usrland packages should I use for the above files?

Go straight to http://busybox.lineo.com/ then search & join the mailing list.

Geoff
-- 
Geoffrey Espin
[email-masked]

---

From: Justin Carlson <[email-masked]>
Date: 09 Nov 2001 15:41:49 -0500

>    /bin/hostname,

In net-tools, here:

http://www.tazenda.demon.co.uk/phil/net-tools/

>     /sbin/swapon,

These are in util-linux, which can be found here:

ftp://ftp.win.tue.nl/pub/linux-local/utils/util-linux

>    /bin/grep.

This is a GNU utility, which can be found at any of the mirrors.  A good
one for the U.S. west coast is here:

ftp://gatekeeper.research.compaq.com/pub/GNU/grep

> Which usrland packages should I use for the above files?

In general, rpm -qf <program> on an rpm-based distro will often give you
a good idea as to what are the names of the source packages you want.
There's probably something similar for debian, but my debian-fu is weak.

-Justin

---

From: Florian Lohoff <[email-masked]>
Date: Fri, 9 Nov 2001 13:13:34 -0800

> Which usrland packages should I use for the above files?

A whole userland has been built with debian - You can get it on
the next debian mirror beeing found on www.debian.org.

One problem though might be that you need to fix "sysmips(MIPS_ATOMIC_SET)"
in the kernel to actually run the binarys (glibc 2.2).

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
Nine nineth on september the 9th              Welcome to the new billenium

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Mon, 12 Nov 2001 13:00:02 +0100 (MET)

> in the kernel to actually run the binarys (glibc 2.2).

 It seems to be fixed to the point of working.

-- 
+  Maciej W. Rozycki, Technical University of Gdansk, Poland   +
+--------------------------------------------------------------+
+        e-mail: [email-masked], PGP key available        +