Subject: emebedded ramdisk vs initrd

From: Guido Guenther <[email-masked]>
Date: Fri, 23 Nov 2001 13:55:18 +0100

Trying to link in arch/mips/ramdisk/ramdisk.o whenever
CONFIG_BLK_DEV_INITRD is defined is a bad idea, since there are other
ways to use a ramdisk (bootloader, addinitrd). I suggest to use
CONFIG_EMBEDDED_RAMDISK instead , since it's already used by sibyte/swarm. 
 -- Guido
--- arch/mips/Makefile.orig	Fri Nov 23 13:43:52 2001
+++ arch/mips/Makefile	Fri Nov 23 13:46:37 2001
@@ -111,7 +111,7 @@
 # You need a compressed ramdisk image, named ramdisk.gz in
 # arch/mips/ramdisk
 #
-ifdef CONFIG_BLK_DEV_INITRD
+ifdef CONFIG_EMBEDDED_RAMDISK
 CORE_FILES	+= arch/mips/ramdisk/ramdisk.o
 SUBDIRS		+= arch/mips/ramdisk
 endif

---

From: Guido Guenther <[email-masked]>
Date: Fri, 23 Nov 2001 14:22:10 +0100

> CONFIG_BLK_DEV_INITRD is defined is a bad idea, since there are other
...and therefore makes the compilation fail, I should add.
 -- Guido

---

From: Pete Popov <[email-masked]>
Date: Fri, 23 Nov 2001 11:41:17 -0800

> ...and therefore makes the compilation fail, I should add.

You need a ramdisk.gz in arch/mips/ramdisk. It shouldn't fail then. I
think you're right about the CONFIG_EMBEDDED_RAMDISK though.

Pete

---

From: Ralf Baechle <[email-masked]>
Date: Sun, 25 Nov 2001 12:43:16 +1100

> CONFIG_EMBEDDED_RAMDISK instead , since it's already used by sibyte/swarm. 

Good idea,

  Ralf